Author Topic: Web Shield is occasionally blocking internet traffic  (Read 20465 times)

Offline dougfunny64

  • Newbie
  • *
  • Posts: 5
    • Personal Message (Offline)
Web Shield is occasionally blocking internet traffic
« on: April 04, 2013, 03:23:08 PM »
Hi, everyone. I have avast! Free Antivirus installed on my laptop (every option is default, I have just reinstalled Windows and avast! after that), and Web Shield will occasionally block Internet connection: can't access any pages in browsers, can't use skype, can't use P2P software and can't even update avast!. Simply, Web Shield enabled means that in several occasions, there will be no connection. Everything is fine with my router, the DSL and Internet LEDs are on, meaning it's working as it should. Windows doesn't report any connectivity issues either, so I can assure you it's this avast! Shield which is blocking internet traffic.

When this issue happens, as soon as I turn Web Shield off, I get internet connection again. I disabled all Shields (only one each time), and Internet traffic was not blocked, except, obviously, for the Web Shield. This issue has been happening since avast! 7.x versions, with both Free and Internet Security (trial) flavours. Of course, I don't intend to access Internet with the main Shield turned off. What should I do to prevent Web Shield from blocking Internet traffic? Thanks in advance.

Info:

OS: Windows 7 Home Premium x64 SP1
avast! Free software version: 8.0.1483
virus definitions version: 130404-0
number of definitions: 4.264.713

P.S.: autoupdate is enabled
« Last Edit: April 05, 2013, 03:27:50 PM by dougfunny64 »

Offline Para-Noid

  • avast! Evangelist
  • Ultra Poster
  • ***
  • Posts: 4502
  • Gender: Male
    • Personal Message (Offline)
Re: Internet resident module is blocking internet traffic
« Reply #1 on: April 04, 2013, 03:55:40 PM »
Please explain the term "internet resident module"?  ???
Dell Inspiron, Win7x64 SP1, Pentium Dual-Core, 6 GB Ram, Avast Free 2014.9.0.2018, Comodo Firewall 5.12 w/D+, MalwareBytes Premium 2.0, MCShield, Super Anti-Spyware Free, SpywareBlaster, Bitdefender TrafficLight, OpenDNS Premium, Keyscrambler Personal,  PrivDog. CCleaner, Greenshot, Firefox (latest build) and, Google Chrome (latest build).

When you do something, do it with a purpose and do it on purpose.

Offline dougfunny64

  • Newbie
  • *
  • Posts: 5
    • Personal Message (Offline)
Re: Internet resident module is blocking internet traffic
« Reply #2 on: April 05, 2013, 03:20:30 PM »
It's one the avast! scanning shields (shield is translated as module in Brazilian Portuguese, the language I use avast! in). I have edited my post so where "Internet Module" was mentioned, it's "Web Shield" now. Also did another edit in the post in order to state this issue has been happening occasionally, not 100% of the time, but it's not so rare either.

In my case, the Web Shield occasionally blocks all Internet traffic. When this happens, I have to turn it off, otherwise I won't have any connectivity. On other hand, with the Web Shield turned, my laptop will be vulnerable to all virtual plagues existing on Internet. As stated in my previous post, all the options are default, and no connectivity issues in Windows. This happened a lot with avast! Internet Security (trial version) too, I even quit it before the expiration date due to this issue, believing it wouldn't happen anymore with the Free version. Would be grateful if someone helped me prevent Web Shield from blocking web traffic.
« Last Edit: April 05, 2013, 03:34:20 PM by dougfunny64 »

Offline arxxa

  • Newbie
  • *
  • Posts: 2
    • Personal Message (Offline)
Re: Web Shield is occasionally blocking internet traffic
« Reply #3 on: April 05, 2013, 08:06:21 PM »
Yes! This happens to me as well. When first starting Windows and/or opening IE 9 or 10 i cannot use the web for a good 2 minutes, if I disable avast web shield the problem goes away. Start Firefox after opening IE and it cannot connect to the web. Turn off avast all internet connections are fine.



I have been dealing with this problem for months its good someone else confirms it.

It seems AvastSvc cannot deal with alot of traffic.

Offline g0dsends

  • Jr. Member
  • **
  • Posts: 88
  • Gender: Male
    • Personal Message (Offline)
Re: Web Shield is occasionally blocking internet traffic
« Reply #4 on: April 05, 2013, 09:27:43 PM »
webshield is the issue  8)
Windows Xp Pro Service Pack 3  Avast Free 9.0
Super anti spyware Pro 5.6 
Malwarebytes Pro 1.75

Offline arxxa

  • Newbie
  • *
  • Posts: 2
    • Personal Message (Offline)
Re: Web Shield is occasionally blocking internet traffic
« Reply #5 on: April 06, 2013, 05:43:28 PM »
Updated to avast 8 last night and the problem still persists, its like if I open like three tabs at once avast cannot handle the load and all my internet connections stop working. 

Offline Barlin63

  • Newbie
  • *
  • Posts: 6
    • Personal Message (Offline)
Re: Web Shield is occasionally blocking internet traffic
« Reply #6 on: April 06, 2013, 10:30:08 PM »
Same here see also the post Slow,slow,slow http://forum.avast.com/index.php?topic=118354.0
By turning web shield off the internet connection speeds up (from 1Mbs to 30 mbs) and if I turn web shield on again it stays 30 Mbs).
Completely re-installed and deleted in safe mode with the appropriated tools bus that did not resolve the issue. I am thinking of abandoning Avast.

Offline dougfunny64

  • Newbie
  • *
  • Posts: 5
    • Personal Message (Offline)
Re: Web Shield is occasionally blocking internet traffic
« Reply #7 on: April 07, 2013, 12:49:46 PM »
I followed this suggestion found on this thread: http://forum.avast.com/index.php?topic=120600.0, and had the issue fixed. Do this:

avast! GUI -> Security -> Web Shield -> Settings -> Main Settings
Enable: Scan traffic from well-known browser processes only

Ater that, post here if this has prevented Web Shield from blocking connection in your PCs. ;)
Enabling this doesn't make avast! any less secure from what I've read.

Offline g0dsends

  • Jr. Member
  • **
  • Posts: 88
  • Gender: Male
    • Personal Message (Offline)
Re: Web Shield is occasionally blocking internet traffic
« Reply #8 on: April 07, 2013, 10:37:29 PM »
thanks doug im trying this fix too see if my internet drops out still
Windows Xp Pro Service Pack 3  Avast Free 9.0
Super anti spyware Pro 5.6 
Malwarebytes Pro 1.75

Offline Para-Noid

  • avast! Evangelist
  • Ultra Poster
  • ***
  • Posts: 4502
  • Gender: Male
    • Personal Message (Offline)
Re: Web Shield is occasionally blocking internet traffic
« Reply #9 on: April 07, 2013, 10:39:57 PM »
What other security software do you have or ever had?
If uninstalled how was it uninstalled?
Was this a "clean" install or was it done through the GUI?
Dell Inspiron, Win7x64 SP1, Pentium Dual-Core, 6 GB Ram, Avast Free 2014.9.0.2018, Comodo Firewall 5.12 w/D+, MalwareBytes Premium 2.0, MCShield, Super Anti-Spyware Free, SpywareBlaster, Bitdefender TrafficLight, OpenDNS Premium, Keyscrambler Personal,  PrivDog. CCleaner, Greenshot, Firefox (latest build) and, Google Chrome (latest build).

When you do something, do it with a purpose and do it on purpose.

Offline Barlin63

  • Newbie
  • *
  • Posts: 6
    • Personal Message (Offline)
Re: Web Shield is occasionally blocking internet traffic
« Reply #10 on: April 08, 2013, 08:33:47 AM »
Same for me. still not resolved.
I have a brand new machine which I completely installed myself and windows fire wall is the only other security product I use.

Offline achmadmulyadi

  • Newbie
  • *
  • Posts: 1
    • Personal Message (Offline)
Re: Web Shield is occasionally blocking internet traffic
« Reply #11 on: May 01, 2013, 06:08:59 AM »
I followed this suggestion found on this thread: http://forum.avast.com/index.php?topic=120600.0, and had the issue fixed. Do this:

avast! GUI -> Security -> Web Shield -> Settings -> Main Settings
Enable: Scan traffic from well-known browser processes only

Ater that, post here if this has prevented Web Shield from blocking connection in your PCs. ;)
Enabling this doesn't make avast! any less secure from what I've read.

This suggestion works for me.... Thanks.

Offline Zie016

  • Newbie
  • *
  • Posts: 1
    • Personal Message (Offline)
Re: Web Shield is occasionally blocking internet traffic
« Reply #12 on: May 14, 2013, 06:03:02 AM »
I followed this suggestion found on this thread: http://forum.avast.com/index.php?topic=120600.0, and had the issue fixed. Do this:

avast! GUI -> Security -> Web Shield -> Settings -> Main Settings
Enable: Scan traffic from well-known browser processes only

Ater that, post here if this has prevented Web Shield from blocking connection in your PCs. ;)
Enabling this doesn't make avast! any less secure from what I've read.

Thank you very much. It worked like a charm.

Offline akm

  • Jr. Member
  • **
  • Posts: 28
    • Personal Message (Offline)
Re: Web Shield is occasionally blocking internet traffic
« Reply #13 on: September 22, 2013, 07:23:06 AM »
The solution is not working today with version 8.0.1497 and Firefox and IE8.
Webshield is blocking all (when turn Webshield off, seems all is ok).
Reinstalled Avast Free and same problem.
Any other ideas ?
Says this thread is over 20dys old, and might not get reply, so might need to start new thread ?

I followed this suggestion found on this thread: http://forum.avast.com/index.php?topic=120600.0, and had the issue fixed. Do this:

avast! GUI -> Security -> Web Shield -> Settings -> Main Settings
Enable: Scan traffic from well-known browser processes only

Ater that, post here if this has prevented Web Shield from blocking connection in your PCs. ;)
Enabling this doesn't make avast! any less secure from what I've read.

Thank you very much. It worked like a charm.
Thanks again for your help ! akm (Dell Inspiron laptop changed from Wdos7 back to XPpro,SP3+IE7, Ofc2003, FireFox + OA,Avast,SAS,MBAM,all free vers)

Offline craigb

  • avast! √úberevangelist
  • Serious Graphoman
  • *****
  • Posts: 8068
  • Gender: Male
    • Personal Message (Offline)
Re: Web Shield is occasionally blocking internet traffic
« Reply #14 on: September 22, 2013, 07:48:19 AM »
Says this thread is over 20dys old, and might not get reply, so might need to start new thread ?
20 days! try 4 months.
Windows 8.1 Pro X64/ IE 11/ Avast 9.0.2018/ MBAM Premium 2

 

Google Chrome

AVAST recommends using the FREE Google Chrome™ browser.

Download Google Chrome Now