Author Topic: Concurrent connections limit in avast exceeded...?  (Read 15848 times)

Offline binggeli

  • Newbie
  • *
  • Posts: 6
  • I'm a llama!
    • Personal Message (Offline)
Concurrent connections limit in avast exceeded...?
« on: May 10, 2005, 04:09:12 PM »
Trying to troubleshoot why avast! v4.6 server edition (running on Windows Server 2003 Standard) is causing my ASP/IIS 6 web application to trigger the following error message:

421 concurrent connections limit in avast exceeded

We have several hundred people logged into our HR web application simultaneously, and we send out e-mail reminders, notifications, updates, etc. all day long.

I just installed avast! yesterday, and now several of my e-mail related functions (using Persits ASPMail) stopped working.

Can I disable something somewhere in avast?

I've looked through the INI file and the Settings but could not find any obvious e-mail related settings.



Any help, suggestions, links would be greatly appreciated!


Thanks much,
dpb


Offline binggeli

  • Newbie
  • *
  • Posts: 6
  • I'm a llama!
    • Personal Message (Offline)
Re: Concurrent connections limit in avast exceeded...?
« Reply #1 on: May 10, 2005, 04:42:13 PM »
OKAY,

So it takes me a bit longer than the average admin to figure out what's going on, but I think (and hope) I have resolved this issue.

1) Right-click the avast icon.
2) Turn off (Stop...) the Internet Mail provider to prevent avast! from scanning e-mail.


If anyone has any better suggestions, please let me know.

Thanks much,
dpb

Offline Tech

  • avast! team
  • Certainly Bot
  • *
  • Posts: 64873
  • Gender: Male
    • Personal Message (Offline)
Re: Concurrent connections limit in avast exceeded...?
« Reply #2 on: May 10, 2005, 05:55:49 PM »
Turn off (Stop...) the Internet Mail provider to prevent avast! from scanning e-mail.
If you browse 'Settings' in my signature you'll find in section [MailScanner] the option to increase the connections limit.  ;)
The best things in life are free.

Offline binggeli

  • Newbie
  • *
  • Posts: 6
  • I'm a llama!
    • Personal Message (Offline)
Re: Concurrent connections limit in avast exceeded...?
« Reply #3 on: May 10, 2005, 06:12:20 PM »
Where? How? What? Huh?

I have been up and down that SETTINGS dialog box, clicked every button, but for some reason, there is absolutely nothing that looks like "my signature" or MailScanner.

Please, help me figure this out!

Offline Tech

  • avast! team
  • Certainly Bot
  • *
  • Posts: 64873
  • Gender: Male
    • Personal Message (Offline)
Re: Concurrent connections limit in avast exceeded...?
« Reply #4 on: May 10, 2005, 07:55:37 PM »
Please, help me figure this out!

Do what I post: click 'Settings' in my signature...  ::)
It's not that difficult... http://forum.avast.com/index.php?topic=1647.msg10267#msg10267
The best things in life are free.

Offline binggeli

  • Newbie
  • *
  • Posts: 6
  • I'm a llama!
    • Personal Message (Offline)
Re: Concurrent connections limit in avast exceeded...?
« Reply #5 on: May 10, 2005, 08:11:09 PM »
Thank you!

Offline kunghung

  • Newbie
  • *
  • Posts: 2
  • Gender: Male
  • It's all in tha mind..
    • IT Experts, Expertise on demand !
    • Personal Message (Offline)
Re: Concurrent connections limit in avast exceeded...?
« Reply #6 on: July 29, 2005, 01:01:10 PM »
Hi ,

I have a similar problem on Windows 2003 Standard server with exchange 2003 installed.
After installing the exchange plugin, all mail is stuck in the queues, nothing leaves the organisation. I enabled loggin on the smtp servcie of exchange and found the same error message : "421+concurrent+connections+limit+in+avast+exceeded".

I allready added an entry in the avast.ini -> setting Maxconnections = 0 which would disable limits on connections (something i read in one of these threads).
I also tried adressing the problem fromin the exchange server itself by limiting outgoing smtp conenctions to 20. NO luck so far...

Disabling Avast mail scanner  service lets all mail flow out instantly...
It speaks for itself that this is not an option ...

Furthermore after a reboot i encouter several log entrys on the exchange server saying ..
VSAPI: Avast has not started yet. Will keep waiting...
Unable to start avast! Antivirus service, error 00000433 has occured 

On the AMS itself  after reboot i get this message...
Cannot connect Server lookup didn't find any AMS'! socket, WinSock error 0x00000000 has occurred.

I have had good experience with the avast client software and recommend it as much as i can ... but with the server version i've had nothing but issues, I hope i can get some help cuz this problem is chasing me for the entire week allready, any help would be appreciated.

Thanks in advance !!

Yves

Online Eddy

  • avast! Evangelist
  • Serious Graphoman
  • ***
  • Posts: 9867
  • Gender: Male
  • Watching (over?) you
    • Malware removal, Biljart and other things.
    • Personal Message (Online)
Re: Concurrent connections limit in avast exceeded...?
« Reply #7 on: July 29, 2005, 01:21:20 PM »
Could THIS be of any help?

Offline vojtech

  • avast! team
  • Advanced Poster
  • *
  • Posts: 911
  • Gender: Male
    • ALWIL Software
    • Personal Message (Offline)
Re: Concurrent connections limit in avast exceeded...?
« Reply #8 on: August 01, 2005, 01:19:52 PM »
You can get rid of the MaxConnections problem by stopping the Internet Mail resident provider, see http://forum.avast.com/index.php?topic=11698.msg101340#msg101340.

Offline Vlk

  • Global Moderator
  • Serious Graphoman
  • **
  • Posts: 11566
  • Gender: Male
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
    • Personal Message (Offline)
Re: Concurrent connections limit in avast exceeded...?
« Reply #9 on: August 03, 2005, 01:23:35 PM »
See here: http://forum.avast.com/index.php?topic=11698.0

In short, you MUST disable the "Internet Mail" provider if running on an Exchange server. Again, this should be done AUTOMATICALLY by the Server Deployment Wizard - the little app that started automatically just after you installed avast (and that can be run manually by click the appropriate icon in the avast antivirus group in Start menu).

Well, this sort of makes me think that we should actually programmatically BLOCK the Internet Mail provider if running on Exchange? ???
If at first you don't succeed, then skydiving's not for you.

 

Google Chrome

AVAST recommends using the FREE Google Chrome™ browser.

Download Google Chrome Now