Author Topic: Startup hang reported by Service Control Manager.  (Read 2071 times)

Offline JohnHC

  • Newbie
  • *
  • Posts: 8
    • Personal Message (Offline)
Startup hang reported by Service Control Manager.
« on: April 21, 2007, 06:43:21 PM »
I am getting a Service Control Manager (SCM) reported hang in my firewall at startup.  Avast! is up and running and the symptom is much worse since the latest update (to 4.7.986).  This first started some time ago and I was able to prevent it by clearing my Prefetch before shutting down.  But since the latest avast! update I get the hang on almost every boot even with the Prefetch folder cleared before boot.  The System log shows error 7022.  I disabled my Interconnect connection (cable modem) and did not get the hang (only one reboot).  I have delayed the check for avast! updates to 150 seconds via the avast4.ini file.  My system does recover from this hang and the firewall starts and runs normally.  I assume the SCM attempts to restart the FW after a time out.  The only real symptom is a long boot and an error in the System log.
I do not know what is causing this but I suspect it is an interaction between avast! and some other program.  I have stopped as many startup items as I can identify.
I hope someone can give me some suggestions.
Thanks....JohnHC

Windows XP Pro x64 Edition
avast! Home 4.7.986

Offline Vlk

  • Global Moderator
  • Serious Graphoman
  • **
  • Posts: 11566
  • Gender: Male
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
    • Personal Message (Offline)
Re: Startup hang reported by Service Control Manager.
« Reply #1 on: April 21, 2007, 07:07:41 PM »
Try going to avast settings, Troubleshooting page and check the "Delay loading of avast services" box. Chances are it will help.

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline JohnHC

  • Newbie
  • *
  • Posts: 8
    • Personal Message (Offline)
Re: Startup hang reported by Service Control Manager.
« Reply #2 on: April 22, 2007, 01:40:04 PM »
Thanks Vlk, That is a great suggestion and just the thing I think I have been looking for.
I do have some questions:
Will avast! be active before my Internet connection is open?
Have you or others seen similar problems that this delay has corrected?
Do you know the nature of the conflict?
Thanks much.....JohnHC

Offline Tech

  • avast! team
  • Certainly Bot
  • *
  • Posts: 64879
  • Gender: Male
    • Personal Message (Offline)
Re: Startup hang reported by Service Control Manager.
« Reply #3 on: April 22, 2007, 01:51:57 PM »
Will avast! be active before my Internet connection is open?
Sure.

Have you or others seen similar problems that this delay has corrected?
Yes. That is the reason of that 'delay', allowing other Microsoft services to load first and safe, as far I know.

Do you know the nature of the conflict?
I let this to him  ;D
The best things in life are free.

Offline JohnHC

  • Newbie
  • *
  • Posts: 8
    • Personal Message (Offline)
Re: Startup hang reported by Service Control Manager.
« Reply #4 on: April 22, 2007, 02:03:41 PM »
After one reboot, all went well.  Of course, this is a very small sample.  I will keep an eye on it and post again as needed.
Thanks much, Tech and Vlk!

Offline JohnHC

  • Newbie
  • *
  • Posts: 8
    • Personal Message (Offline)
Re: Startup hang reported by Service Control Manager.
« Reply #5 on: April 29, 2007, 02:42:34 PM »
After a number of boots, I have seen no SCM hangs.  I have been clearing my prefetch before I shutdown.  I will get brave enough to let the prefetch go one of these days.
Checking the option Vlk suggested prompts the obvious question:
What is the downside of this option?  If there is none, why is 'Delay loading....' not the default?
Thanks again to Vlk and Tech........JohnHC

Offline DavidR

  • avast! √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 69208
  • Gender: Male
  • No support PMs thanks
    • Personal Message (Offline)
Re: Startup hang reported by Service Control Manager.
« Reply #6 on: April 29, 2007, 02:47:14 PM »
The speeding up of avast loading is a new addition to the latest program updates, some however have experienced a problem with other services loading later. The Troubleshooting option effectively reverts to not speeding up the loading of avast services.

For the majority of people the speeding up of the loading of avast services isn't a problem.
« Last Edit: April 29, 2007, 02:48:54 PM by DavidR »
Core2Duo E8300/ 4GB Ram/ WinXP ProSP3/ avast! free 2014 9.0.2018/ Outpost Firewall Pro9.1/ Firefox 28.0, NoScript, RequestPolicy/ MailWasher Pro/ DropMyRights/ MalwareBytes AntiMalware Premium 2.0.1/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security

 

Google Chrome

AVAST recommends using the FREE Google Chrome™ browser.

Download Google Chrome Now