Author Topic: Internet Explorer of Firefox won't run after Avast update 28/11  (Read 3402 times)

Offline Gizmo555

  • Newbie
  • *
  • Posts: 11
    • Personal Message (Offline)
Internet Explorer of Firefox won't run after Avast update 28/11
« on: November 28, 2009, 05:54:54 PM »
Turn off the splash screen for the script blocker and everything will be ok

Looks like a bug in todays update

Offline Omega40

  • Full Member
  • ***
  • Posts: 137
  • Gender: Female
    • Personal Message (Offline)
Re: Internet Explorer of Firefox won't run after Avast update 28/11
« Reply #1 on: November 28, 2009, 06:03:08 PM »
You mean the IE addon for Firefox?

Online DavidR

  • avast! Überevangelist
  • Certainly Bot
  • *****
  • Posts: 69204
  • Gender: Male
  • No support PMs thanks
    • Personal Message (Online)
Re: Internet Explorer of Firefox won't run after Avast update 28/11
« Reply #2 on: November 28, 2009, 06:42:01 PM »
Sorry, but the splash screen is cosmetic the underlying provider (script blocker) would still be running, so I don't see how that could fix anything.

So this I feel is a happy coincidence unless you also disabled the script blocker.
Core2Duo E8300/ 4GB Ram/ WinXP ProSP3/ avast! free 2014 9.0.2016/ Outpost Firewall Pro9.1/ Firefox 28.0, NoScript, RequestPolicy/ MailWasher Pro/ DropMyRights/ MalwareBytes AntiMalware Premium 2.0.1/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security

Offline silvertones

  • Jr. Member
  • **
  • Posts: 42
    • Personal Message (Offline)
Re: Internet Explorer of Firefox won't run after Avast update 28/11
« Reply #3 on: November 28, 2009, 07:07:53 PM »
Works fine for me.
PC Tools Firewall Plus through up a popup after the update and asked if I still trust Avast and I said sure. That was it.
Great Firewall and it's totally free. No gimmicks.

Offline Gizmo555

  • Newbie
  • *
  • Posts: 11
    • Personal Message (Offline)
Re: Internet Explorer of Firefox won't run after Avast update 28/11
« Reply #4 on: November 28, 2009, 11:45:04 PM »
Using windows firewall and avast is listed as an exception.

Trust me if I turn off the splash screen then all is well time after time. If I turn it on then IE or Firefox often don't connect.
This happens repeatably so I'm confident this is the root cause.

It will be interesting if others reporting the same problem have the same solution.

All was well until todays upgrade. I use IE and Firefox without issue until todays update.
Nothing has changed on my Firewall.

Besides this this is an excellent package

Online DavidR

  • avast! Überevangelist
  • Certainly Bot
  • *****
  • Posts: 69204
  • Gender: Male
  • No support PMs thanks
    • Personal Message (Online)
Re: Internet Explorer of Firefox won't run after Avast update 28/11
« Reply #5 on: November 29, 2009, 12:20:21 AM »
I'm hearing an echo in here ;D
What version of windows are you using ?
XP's firewall provides zero outbound protection.

I didn't say I didn't trust what you said that simply the splash screen has no relevance as it isn't part of the protection, just a happy coincidence.

The avast Script Blocker only works with three browsers and firefox isn't one of them, so it shouldn't have any impact in that regard.
Core2Duo E8300/ 4GB Ram/ WinXP ProSP3/ avast! free 2014 9.0.2016/ Outpost Firewall Pro9.1/ Firefox 28.0, NoScript, RequestPolicy/ MailWasher Pro/ DropMyRights/ MalwareBytes AntiMalware Premium 2.0.1/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security

Offline Gizmo555

  • Newbie
  • *
  • Posts: 11
    • Personal Message (Offline)
Re: Internet Explorer of Firefox won't run after Avast update 28/11
« Reply #6 on: November 29, 2009, 09:09:34 AM »
Hi David

Windows XP
Really is confusing and I agree that the splash screen in itself is inocuous.

Think it must be a timing thing that interacts with something else
With the splash screen on IE opens maybe once every 20 attempts
With the splash screen off IE opens every time

Looking further this morning it appears to be an interaction with Trusteer Rapport which is a security plugin that my bank provides.
With Rapport off and avast splash screen on then IE is then ok

So now the question is which software has the problem ????
Problem only appeared after yesterdays avast application upgrade
Will run with the splash screen off for now

Regarding browsers isn't the Mozilla option for Firefox ?

Thanks

Mark

Online DavidR

  • avast! Überevangelist
  • Certainly Bot
  • *****
  • Posts: 69204
  • Gender: Male
  • No support PMs thanks
    • Personal Message (Online)
Re: Internet Explorer of Firefox won't run after Avast update 28/11
« Reply #7 on: November 29, 2009, 01:43:53 PM »
No, Mozilla relates to the old mozilla browser and not firefox.

Lets put it this way, this is the first time I have seen what you report with the splash screen in over five and a half years on the forums. So there are a myriad of different system settings and applications and no such report before.

Conflict happens, but again I have no idea why there would be a conflict with Rapport and an innocuous splash screen but not the underlying script blocker provider.
Core2Duo E8300/ 4GB Ram/ WinXP ProSP3/ avast! free 2014 9.0.2016/ Outpost Firewall Pro9.1/ Firefox 28.0, NoScript, RequestPolicy/ MailWasher Pro/ DropMyRights/ MalwareBytes AntiMalware Premium 2.0.1/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security

Offline YoKenny

  • Serious Graphoman
  • **
  • Posts: 8800
  • Gender: Male
    • Personal Message (Offline)
Re: Internet Explorer of Firefox won't run after Avast update 28/11
« Reply #8 on: November 29, 2009, 02:10:07 PM »
@Gizmo555

I don't have a problem with IE on my XP Pro system so it could be Trusteer Report:
http://www.trusteer.com

Its much easier and healthier for me to walk to the bank or do phone banking than trusting banking on-line.  8)
E5200 2.5GHZ, 4GB RAM, 320GB HD, Windows 7 Home Premium 64bit, avast! V9.0 Free, IE10
P4 2.8GHZ, 1.5GB RAM, 40GB HD, XP Pro SP3 32bit, avast! V9.0 Free, Google Chrome
with hpHosts, MVPS HOSTS files, SpeedFan, WinPatrol PLUS

Offline Trusteer Support

  • Newbie
  • *
  • Posts: 3
    • Personal Message (Offline)
Re: Internet Explorer of Firefox won't run after Avast update 28/11
« Reply #9 on: November 30, 2009, 08:58:23 AM »
Hello everyone,

There is a known conflict between Avast Script Blocker and Rapport. You were correct to notice the connection between the splash screen and the symptom.

We have fixed this problem in our latest version, which will be available soon through the public download links.
In the meantime, you can also get it from here (this is not a beta, but an official release):
http://download.trusteer.com/Gcur4Wtnu/RapportSetup.exe

Installing this version does not require uninstalling Rapport, but will require a system restart if a previous version is already installed.

For any issues regarding this version or otherwise, we recommend you contact us at support@trusteer.com where we will be happy to supply any help necessary.

Sincerely,
The Trusteer Technical Support Team

Online DavidR

  • avast! Überevangelist
  • Certainly Bot
  • *****
  • Posts: 69204
  • Gender: Male
  • No support PMs thanks
    • Personal Message (Online)
Re: Internet Explorer of Firefox won't run after Avast update 28/11
« Reply #10 on: November 30, 2009, 03:35:22 PM »
Welcome to the forums.

Thanks for the prompt resolution to the conflict.
Core2Duo E8300/ 4GB Ram/ WinXP ProSP3/ avast! free 2014 9.0.2016/ Outpost Firewall Pro9.1/ Firefox 28.0, NoScript, RequestPolicy/ MailWasher Pro/ DropMyRights/ MalwareBytes AntiMalware Premium 2.0.1/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security

Offline Gizmo555

  • Newbie
  • *
  • Posts: 11
    • Personal Message (Offline)
Re: Internet Explorer of Firefox won't run after Avast update 28/11
« Reply #11 on: November 30, 2009, 04:50:03 PM »
Wow - the power of the internet
Report what you think is an avast issue and the offending software company appears on this forum with a fix.

Trusteer - can you tell us what the conflict is ?

No offence intended but the problem I have downloading from the link is whether the download link is genuine. After all Rapport is there to stop identity theft.
Will wait for the upgrade through the normal channels.

Thanks all

Offline Trusteer Support

  • Newbie
  • *
  • Posts: 3
    • Personal Message (Offline)
Re: Internet Explorer of Firefox won't run after Avast update 28/11
« Reply #12 on: December 02, 2009, 06:23:46 AM »
Hello again,

Without going into technical detail, I can say there is a conflict in the simultaneous initialization of Rapport and the Script Blocker, resulting in a deadlock.

You can check and see that the host download.trusteer.com is the same one your bank's download link directs you to, but waiting for the normal channels is a fine choice.

All the best,
Trusteer Technical Support

 

Google Chrome

AVAST recommends using the FREE Google Chrome™ browser.

Download Google Chrome Now