Author Topic: avastui.exe application failed to start  (Read 41276 times)

Offline Tatsu333

  • Newbie
  • *
  • Posts: 1
    • Personal Message (Offline)
avastui.exe application failed to start
« on: February 19, 2010, 08:38:57 PM »
After numerous tries to install Avast 5 on a Dell laptop running Windows XP SP3, I have not been able to get around this.  The installation appears to go through fine, but I am not prompted to reboot after.  When I try to launch the Avast application (either from the desktop or Start menu), I get an error saying that the avastui.exe application failed to start because the application configuration is incorrect.

I have gone through removing and reinstalling numerous times, both from Safe Mode and not, using the aswclear5 utility and not, but no luck.  Any ideas?

I should note that the services do appear to be running just fine, I just can't launch the UI.

Online Tech

  • avast! team
  • Certainly Bot
  • *
  • Posts: 64879
  • Gender: Male
    • Personal Message (Online)
Re: avastui.exe application failed to start
« Reply #1 on: February 20, 2010, 06:17:28 PM »
Install and boot.
Try.

Any other antivirus before avast? How it was uninstalled?
The best things in life are free.

Offline pido

  • Newbie
  • *
  • Posts: 5
    • Personal Message (Offline)
Re: avastui.exe application failed to start
« Reply #2 on: February 21, 2010, 03:54:02 PM »
Hi,

I got the same issue.
OS: Vista 64bit Home
I upgraded from avast 4 home edition to avast 5 free edition following the steps provided.
AvastSvc is running, though I don't see any avast logo in the systray.
I rebooted, uninstalled, reinstalled, rebooted etc but the failure is persistent.
Seems like a bug to me.

Regards

Offline pido

  • Newbie
  • *
  • Posts: 5
    • Personal Message (Offline)
Re: avastui.exe application failed to start
« Reply #3 on: February 21, 2010, 03:59:56 PM »
Additional info from the eventlog:

Logboeknaam:   Application
Bron:          SideBySide
Datum:         21-2-2010 17:57:56
Gebeurtenis-id:33
Taakcategorie: Geen
Niveau:        Fout
Trefwoorden:   Klassiek
Gebruiker:     n.v.t.
Computer:      PLAYGROUND
Beschrijving:
Kan activeringscontext voor 'C:\Program Files\Alwil Software\Avast5\AvastUI.exe' niet maken. Kan afhankelijke assembly Microsoft.VC90.MFC,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8" niet vinden. Gebruik sxstrace.exe voor een gedetailleerde diagnose.
Gebeurtenis-XML:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="SideBySide" />
    <EventID Qualifiers="49409">33</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2010-02-21T16:57:56.000Z" />
    <EventRecordID>8059</EventRecordID>
    <Channel>Application</Channel>
    <Computer>PLAYGROUND</Computer>
    <Security />
  </System>
  <EventData>
    <Data>Microsoft.VC90.MFC,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8"</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>C:\Program Files\Alwil Software\Avast5\AvastUI.exe</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>

Offline Sebastian09

  • Newbie
  • *
  • Posts: 1
    • Personal Message (Offline)
Re: avastui.exe application failed to start
« Reply #4 on: March 01, 2010, 02:00:00 AM »
I ran into the same problem with an Acer laptop with WinXP SP3 that had previously had older Avast versions installed. I removed and installed the latest free version three times and every time I get the same error:

"C:\Program Files\Alwil Software\Avast5\AvastUI.exe
This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem."

This is very frustrating and I hope somebody can help. In light of this help I definitely won't try to buy a better version...

Offline olddog

  • Poster
  • *
  • Posts: 567
  • Gender: Male
    • Personal Message (Offline)
Re: avastui.exe application failed to start
« Reply #5 on: March 01, 2010, 03:08:56 AM »
Tatsu333, Sebastian09 and perhaps pido,

"This application has failed to start because the application configuration is incorrect" and "side by side" errors have been reported a number of times in the forum. I don't know whether this is applicable in your cases or not, but from memory Avast was not able to find the correct version of Microsofts Visual C++ run time library. I seem to recall a post indicating that the correct version was provided as part of the Avast installation, so it may be a case of determining whether it did not get installed for some reason.


   
3.4Ghz Intel i7, 8Gb Ram, GeForce GTX560, Win 7 Pro 64 bit, Dual 1920x1080 monitors, Avast 2014, Firefox 26, Malwarebytes Pro, Paragon 14

Offline pido

  • Newbie
  • *
  • Posts: 5
    • Personal Message (Offline)
Re: avastui.exe application failed to start
« Reply #6 on: March 02, 2010, 05:17:31 PM »
Hey olddog,

It seems like your the only one that pays attention to this problem, thanx.
If been searching my registry for clues on your tip.
Strange things I found:
ImagePath=\??\C:\Windows\system32\drivers\aswMonFlt.sys
DataFolder=\DosDevices\C:\ProgramData\Alwil Software\Avast5 (I got more of those prefixes)

I couldn't find any Avast key referring to any C++ runtime.
Can you give a hint?

Offline psw

  • Sr. Member
  • ****
  • Posts: 286
  • Gender: Male
    • Personal Message (Offline)
Re: avastui.exe application failed to start
« Reply #7 on: March 02, 2010, 06:21:04 PM »
I couldn't find any Avast key referring to any C++ runtime.
Can you give a hint?
C++ runtime should be installed in windows\winSxS directory during avast5 install. Probably you have troubles with this store. E.g. diagnosing SideBySide failures is described in http://blogs.msdn.com/junfeng/archive/2006/04/14/576314.aspx

Offline pido

  • Newbie
  • *
  • Posts: 5
    • Personal Message (Offline)
Re: avastui.exe application failed to start
« Reply #8 on: March 05, 2010, 05:24:32 PM »
Update:

So I checked the winsxs folder and there's lots of stuf there.
I also ran sxstrace but that resulted in a binary file that couldn't be parsed.

I used to be happy about avast but this going more-commercial and leave the home edition for rubbish.
Really make's me wonder

Since Avast has decreased it's protection through webpages (excluding Sandbox) and this problem isn't solved yet, I think I'm going for the alternative: Avira
« Last Edit: March 05, 2010, 05:34:23 PM by pido »

Offline Exciter

  • Newbie
  • *
  • Posts: 1
    • Personal Message (Offline)
Re: avastui.exe application failed to start
« Reply #9 on: March 11, 2010, 03:51:37 AM »
I have been having a hell of a time with this..
I tried installing net framework 3.5 and the 2008 redistribute.
Nothing worked.

However I did manage a work around by searching for vc90.crt on another xp computer. There were about 8 files in the windows\winSxS directory that I copied over to the problem computer.
Then the event log showed a side by side error for vc90.mfc.
I did the same thing, searched for vc90.mfc and found about 8 files again.. Copied to the problem computer and boom. Avast started up.

Hope this helps someone else.

Offline pido

  • Newbie
  • *
  • Posts: 5
    • Personal Message (Offline)
Re: avastui.exe application failed to start
« Reply #10 on: March 14, 2010, 11:29:56 AM »
Does anybody know how to fix WinSxs.
Avast totally messed up my computer with this.
Update nor other programs that require winsxs all fail.
This is like a nightmare and Avast isn't providing support.

Offline mikemason

  • Newbie
  • *
  • Posts: 1
    • Personal Message (Offline)
Re: avastui.exe application failed to start
« Reply #11 on: May 17, 2010, 06:30:18 PM »
Yea there is a way to fix all that avast ui.exe stuff.  forget all that 3.5 framework if MS want let it install and google Microsoft visual c++2010 express (it is free)  make sure to download all especially the VC 9.0 runtime and there you will see a 4 net framework you will need and other software but you can probably opt out of silverlight or go ahead and the disable what you don't need.  There are about 9 parts to this download so be patient but when you are through make sure all previous  av software is uninstalled and the install avast 5 and presto ui works and then you will see the orange avast ball in status bar.  NOTE THIS DOWNLOAD WILL TAKE QUITE A BIT OF TIME.

Offline mplsearl

  • Newbie
  • *
  • Posts: 1
    • Personal Message (Offline)
Re: avastui.exe application failed to start
« Reply #12 on: July 09, 2010, 05:48:41 PM »
Installing C++ Express and the rest of the programs worked perfectly. Thanks!

-Earl

Offline piqialex

  • Newbie
  • *
  • Posts: 1
    • Personal Message (Offline)
Re: avastui.exe application failed to start
« Reply #13 on: September 25, 2010, 09:22:28 AM »
I have the same problem with avast installation and at the end I have downloaded Visual c++. My problem is now solved!!! My avast is working excellent. Thank you everybody!!!  ;D

 

Google Chrome

AVAST recommends using the FREE Google Chrome™ browser.

Download Google Chrome Now