Author Topic: Safely Remove Hardware Icon Stopped Working  (Read 4881 times)

Offline David H

  • Newbie
  • *
  • Posts: 3
    • Personal Message (Offline)
Safely Remove Hardware Icon Stopped Working
« on: March 10, 2010, 07:25:07 PM »
I am using Windows 7 and the Safely Remove Hardware Icon has stopped responding.  I click on it and nothing happens.  It seems to have stopped working about the same time I upgraded to Avast version 5 from version 4, free version.
If I launch safely remove hardware from the Run box, "C:\WINDOWS\system32\rundll32.exe shell32.dll,Control_RunDLL hotplug.dll", it tells me the drive is not removeable.
Has anyone else experienced problems with Safely Remove Hardware, Windows 7, and Avast 5?

 

Offline Zyndstoff (aka Steven Gail)

  • avast! Evangelist
  • Massive Poster
  • ***
  • Posts: 2621
  • Gender: Male
  • I can resist anything except temptation.
    • tex62
    • Personal Message (Offline)
Re: Safely Remove Hardware Icon Stopped Working
« Reply #1 on: March 10, 2010, 07:28:28 PM »
Just checked it: no problems here. System Specs see my sig.

What drivetype are we talkin about? USB-stick, USB-HDD?
7 x64 SP1, FF 8a Aurora, TB6, 6.0.1203 Free
Free MBAM Clear

Offline David H

  • Newbie
  • *
  • Posts: 3
    • Personal Message (Offline)
Re: Safely Remove Hardware Icon Stopped Working
« Reply #2 on: March 10, 2010, 08:41:34 PM »
The drive is a USB External HD, Maxtor My Passport 500G.
If I dont hear anything in the next 24 hours, I am going to try uninstalling Avast, to see if this is the conflict.
« Last Edit: March 10, 2010, 08:45:43 PM by David H »

Offline news

  • Full Member
  • ***
  • Posts: 174
    • Personal Message (Offline)
Re: Safely Remove Hardware Icon Stopped Working
« Reply #3 on: March 10, 2010, 08:50:22 PM »
The drive is a USB External HD, Maxtor My Passort 500M.
If i dont hear anything in the next 24 hours, im going to try uninstalling Avast, to see if this is the conflict.

Hello David H....
You may also want to check and be sure any other new software, hardware, drivers..etc aren't the source of your problem as well.

Offline YoKenny

  • Serious Graphoman
  • **
  • Posts: 8800
  • Gender: Male
    • Personal Message (Offline)
Re: Safely Remove Hardware Icon Stopped Working
« Reply #4 on: March 10, 2010, 09:04:14 PM »
Absolutely no problem on my Windows 7 system with my 80G external.
E5200 2.5GHZ, 4GB RAM, 320GB HD, Windows 7 Home Premium 64bit, avast! V9.0 Free, IE10
P4 2.8GHZ, 1.5GB RAM, 40GB HD, XP Pro SP3 32bit, avast! V9.0 Free, Google Chrome
with hpHosts, MVPS HOSTS files, SpeedFan, WinPatrol PLUS

Offline Zyndstoff (aka Steven Gail)

  • avast! Evangelist
  • Massive Poster
  • ***
  • Posts: 2621
  • Gender: Male
  • I can resist anything except temptation.
    • tex62
    • Personal Message (Offline)
Re: Safely Remove Hardware Icon Stopped Working
« Reply #5 on: March 11, 2010, 06:00:18 AM »
You updated from 4.8 to 5. If you did not uninstall 4.8 prior to installation of new version, this might be a source of trouble.
So do this:

1. Download aswclear.exe and aswclear5.exe from link in my sig
2. Uninstall avast
3. Reboot to safe mode
4. In safe mode, run aswclear.exe and aswclear5.exe
5. Search for all remaining "*avast*" and "*alwil*" folders on c: and delete them (make sure that your explorer is set to show all hidden files and folders!)
6. Reboot to normal mode
7. Use Ccleaner or similar program to clean the registry
8. right click on avast5 setup and choose "run as administrator"
9. Reboot

Zyndstoff
« Last Edit: March 11, 2010, 06:41:12 AM by Zyndstoff »
7 x64 SP1, FF 8a Aurora, TB6, 6.0.1203 Free
Free MBAM Clear

Offline bong2x

  • Poster
  • *
  • Posts: 474
  • Gender: Male
  • My system Protector is avast
    • Personal Message (Offline)
Re: Safely Remove Hardware Icon Stopped Working
« Reply #6 on: March 11, 2010, 06:37:10 AM »
 ;) it happen to me 1 time
in my case i stored the avast in external hard drive,
then i install avast from external hard drive
after installing i set reboot later and try to safety removed hardware
it say that the drive cannot be removed because it is being used or not removable
so i did restart the comp even the external drive is attached
and after reboot its removable again. ;D
but if your case, you did reboot and still not removable, it is not the same case as i am experience :-X
Hardware
Intel Core 2 Duo @ 2.20GHz,3GB RAM.
Software
OS->WinXp-pro Sp3.
Protection->avast Free 6.0.1091,MBAM,SAS
Browser->Firefox 4.0,IE8,G-chrome
Emergency Interface->unlocker 1.8.9

Life is a continue process of learning

Offline bong2x

  • Poster
  • *
  • Posts: 474
  • Gender: Male
  • My system Protector is avast
    • Personal Message (Offline)
Re: Safely Remove Hardware Icon Stopped Working
« Reply #7 on: March 11, 2010, 07:43:39 AM »
 :) one option for this is to use unlocker,
you can removed your external drive even it is in used
just right click unlocker then set to unlock.
it will tell you what function is still running from it why it's not removable,
then when you unlock it, your screen may be blink.
and you can removed it. ;D
but be careful to use unlocker ;)
don't use unlocker to delete the thing you don't understand
it can damage your system :-X
Hardware
Intel Core 2 Duo @ 2.20GHz,3GB RAM.
Software
OS->WinXp-pro Sp3.
Protection->avast Free 6.0.1091,MBAM,SAS
Browser->Firefox 4.0,IE8,G-chrome
Emergency Interface->unlocker 1.8.9

Life is a continue process of learning

Offline David H

  • Newbie
  • *
  • Posts: 3
    • Personal Message (Offline)
Re: Safely Remove Hardware Icon Stopped Working
« Reply #8 on: March 12, 2010, 06:22:26 PM »
Thanks everyone for the responses.
I uninstalled Avast 5, and the Safely Remove Hardware is still unresponsive; so apparently it is NOT an Avast issue.
Thank you Zyndstoff for the unintall instructions.

Offline Zyndstoff (aka Steven Gail)

  • avast! Evangelist
  • Massive Poster
  • ***
  • Posts: 2621
  • Gender: Male
  • I can resist anything except temptation.
    • tex62
    • Personal Message (Offline)
Re: Safely Remove Hardware Icon Stopped Working
« Reply #9 on: March 12, 2010, 06:36:26 PM »
Will it work with any other USB device? A USB-stick?
Maybe it's the MyPassport HDD that refuses to work with it?
7 x64 SP1, FF 8a Aurora, TB6, 6.0.1203 Free
Free MBAM Clear

Offline cazoza

  • Full Member
  • ***
  • Posts: 140
  • Gender: Male
  • a pretty malwarefighter! dont u think?
    • Personal Message (Offline)
Re: Safely Remove Hardware Icon Stopped Working
« Reply #10 on: March 12, 2010, 09:09:51 PM »
Hi DavidH, maybe you need to try a repair of your windows or a system restore, why dont u try to do a system cleaning with CCleaner or Comodo System Cleaner. maybe something get fixed, and the icon too. Take care.
« Last Edit: March 12, 2010, 09:12:12 PM by cazoza »
Our actions define who we are

MoBo ASUS P5QC
ATI HD3650 1 Gb RAM PCI-E 2.0
Win 7 Ultimate x64
Quad Core q6600 2.4 GHz
8 Gb RAM DDR2 800 MHz
500 Gb HDD SATA2 32 Mb Buffer 7200 RPM

Avast 5.0.462 Free
Outpost Firewall Pro 2009 v6.7.3

 

Google Chrome

AVAST recommends using the FREE Google Chrome™ browser.

Download Google Chrome Now