Author Topic: Maintenance Tool Creates new Database - almost...  (Read 2993 times)

Offline noneya9

  • Newbie
  • *
  • Posts: 1
    • Personal Message (Offline)
Maintenance Tool Creates new Database - almost...
« on: March 10, 2010, 10:49:38 PM »
I've just reinstalled the ADNM console for the fifteenth time.  My setup:

SBS 2003 SP2
SQL Server 2005

Avast management services starts give me the following;

[3152] Could not locate entry in sysdatabases for database 'avast'. No entry found with that name. Make sure that the name is entered correctly.
[3152] Could not locate entry in sysdatabases for database 'avast'. No entry found with that name. Make sure that the name is entered correctly.
[3152] Could not locate entry in sysdatabases for database 'avast'. No entry found with that name. Make sure that the name is entered correctly.
[3152] Could not locate entry in sysdatabases for database 'avast'. No entry found with that name. Make sure that the name is entered correctly.
[3152] Could not locate entry in sysdatabases for database 'avast'. No entry found with that name. Make sure that the name is entered correctly.
[3152] Could not locate entry in sysdatabases for database 'avast'. No entry found with that name. Make sure that the name is entered correctly.
[3152] Could not locate entry in sysdatabases for database 'avast'. No entry found with that name. Make sure that the name is entered correctly.
[3152] Could not locate entry in sysdatabases for database 'avast'. No entry found with that name. Make sure that the name is entered correctly.
[3152] Could not locate entry in sysdatabases for database 'avast'. No entry found with that name. Make sure that the name is entered correctly.
[3152] Could not locate entry in sysdatabases for database 'avast'. No entry found with that name. Make sure that the name is entered correctly.
[3152] Could not locate entry in sysdatabases for database 'avast'. No entry found with that name. Make sure that the name is entered correctly.
[3152] *** ERR: cleaning up sqlInit() (err 80004005, thread 5912)...
[3152] sqlPurgeConnectionPool exit: total num = 0

and dies.  It can't find the avast database in my SQL, right...?  So I run the Create DB in the Maintenance Tool and get;

Database creation failed with 0x0000A410 errorr...
Going to create database of avast! on MS Sql server "XXXXXX", using user "sa"...
Cannot execute commnad for 0x00000066 resource, error 0x80040E14...
Cannot create "Object" table, error 0x0000A410...

and the log of;

[3996] DDL statement is not allowed.
[3996] Changed database context to 'avast'.

The database gets created in MS Sql and the .mdf & .ldf files are in the proper directory - but apparently they are not getting created in full.  The last line of the error says the tables cannot be created.  When I check the database - no tables exist.

I've tried all solutions that I've found on here.  I've deleted the .mdf & .ldf, i've changed the DBcreated to 1 from 0, I've been using the debug viewer to try to figure out the problem... i'm lost to any other solutions.

help...pullllease?


Offline wpn

  • avast! Evangelist
  • Super Poster
  • ***
  • Posts: 1443
  • Gender: Male
  • If it ain't broke, fix it! ;)
    • Bevolkingsonderzoek Zuid-West
    • Personal Message (Offline)
Re: Maintenance Tool Creates new Database - almost...
« Reply #1 on: March 11, 2010, 10:44:19 AM »
your using the correct SA account?

 

Google Chrome

AVAST recommends using the FREE Google Chrome™ browser.

Download Google Chrome Now