Author Topic: Webshield problem with Comodo Dragon browser  (Read 6870 times)

Offline JonahHex

  • Newbie
  • *
  • Posts: 18
    • Personal Message (Offline)
Webshield problem with Comodo Dragon browser
« on: March 28, 2010, 11:52:54 AM »
HI
Iam using comodo Dragon as my default browser and when i check my Avast settings i cant see any activity in the webshield. Comodo Dragon is a very new browser but it´s similar to Google Chrome.
But Avast scanner is scanning my networktraffic even if i use Comodo Dragon and when i´m switch to Internet Explorer8 everything work as it should.
I dont wont to be unprotected when i surf the web using comodo. Can you please give me an explanation?
Iam running Comodo Dragon and Avast with Windows 7 Ultimate x86

I´ve added a picture of my proxysettings
« Last Edit: March 28, 2010, 12:16:09 PM by satrew »

Offline spg SCOTT

  • Massive Poster
  • ****
  • Posts: 4138
  • Gender: Male
  • There is no magic, only lost physics
    • spg SCOTT
    • Personal Message (Offline)
Re: Webshield problem with Comodo Dragon browser
« Reply #1 on: March 28, 2010, 12:04:08 PM »
Hi satrew, welcome to the forum :)

I am guessing that dragon hasn't been added to the webshield defaults...

There are two options,

To add the localhost proxy in the proxy options:

Localhost   
12080

or

To add the executable for dragon into the webshield.ini

Which avast! version are you using, as the instructions are different for the ini...

-Scott-

EDIT: also what is the executable for dragon?
« Last Edit: March 28, 2010, 12:07:57 PM by spg SCOTT »
“There is a computer disease that anybody who works with computers knows about. It's a very serious disease and it interferes completely with the work. The trouble with computers is that you 'play' with them!”Richard Feynman

Offline JonahHex

  • Newbie
  • *
  • Posts: 18
    • Personal Message (Offline)
Re: Webshield problem with Comodo Dragon browser
« Reply #2 on: March 28, 2010, 12:09:58 PM »
Thanks for replying.
The version i am using are Avast free v.5.0.462.
If it is the proxy settings? How do i change it? I am not so god with computers.

Offline spg SCOTT

  • Massive Poster
  • ****
  • Posts: 4138
  • Gender: Male
  • There is no magic, only lost physics
    • spg SCOTT
    • Personal Message (Offline)
Re: Webshield problem with Comodo Dragon browser
« Reply #3 on: March 28, 2010, 12:15:43 PM »
For the proxy, you are going to add it to the comodo dragon settings, and I do not use it so I cannot direct you there....

IIRC, it is based on chrome isn't it?

If it is I may be able to find out how.

-Scott-
“There is a computer disease that anybody who works with computers knows about. It's a very serious disease and it interferes completely with the work. The trouble with computers is that you 'play' with them!”Richard Feynman

Offline JonahHex

  • Newbie
  • *
  • Posts: 18
    • Personal Message (Offline)
Re: Webshield problem with Comodo Dragon browser
« Reply #4 on: March 28, 2010, 12:18:29 PM »
I am so glad that you are helping me  ;). This is so annoying. I will check the settings in comodo dragon. I´ll be back.

Offline JonahHex

  • Newbie
  • *
  • Posts: 18
    • Personal Message (Offline)
Re: Webshield problem with Comodo Dragon browser
« Reply #5 on: March 28, 2010, 12:28:36 PM »
When i open up the proxysetting in Comodo a new window opens and my internet explorer settings for proxy opens. What should i do for changes there?

Offline spg SCOTT

  • Massive Poster
  • ****
  • Posts: 4138
  • Gender: Male
  • There is no magic, only lost physics
    • spg SCOTT
    • Personal Message (Offline)
Re: Webshield problem with Comodo Dragon browser
« Reply #6 on: March 28, 2010, 12:29:07 PM »
Ok, so I have discovered it is the same as chrome, so to add the proxy:

However, this may not be the way to go as it uses the pc proxy settings ???

-In the top right, click the spanner --> Options
-Click 'Under the bonnet'
-Click 'Change proxy settings' button
-Click 'LAN settings' button
-Tick the 'proxy server' option
-Enter localhost in 'address' and 12080 in 'port'

As I said, this changes the actual internet settings on the host pc, so I think this may not be the best option and it may be better with the ini option.

-Scott-

[EDIT] Oops, you already posted...Well, as I said, I am not too sure if it is the best option to change that, as I think that would change the IE settings as well...so the INI option would be better.
“There is a computer disease that anybody who works with computers knows about. It's a very serious disease and it interferes completely with the work. The trouble with computers is that you 'play' with them!”Richard Feynman

Offline JonahHex

  • Newbie
  • *
  • Posts: 18
    • Personal Message (Offline)
Re: Webshield problem with Comodo Dragon browser
« Reply #7 on: March 28, 2010, 12:39:17 PM »
Okay.
We are on the same level there. Now i wonder, if i want (and i do) change the webshield.ini file. How do i do that?

Offline logos

  • avast! Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 9456
  • Gender: Male
    • Personal Message (Offline)
Re: Webshield problem with Comodo Dragon browser
« Reply #8 on: March 28, 2010, 12:42:47 PM »
>>> get the original, no problem with it ;D http://www.google.com/chrome
w7 - ais7

Offline JonahHex

  • Newbie
  • *
  • Posts: 18
    • Personal Message (Offline)
Re: Webshield problem with Comodo Dragon browser
« Reply #9 on: March 28, 2010, 12:46:01 PM »
Haha! Okay but i want to use Comodo for its a darn good browser

Offline spg SCOTT

  • Massive Poster
  • ****
  • Posts: 4138
  • Gender: Male
  • There is no magic, only lost physics
    • spg SCOTT
    • Personal Message (Offline)
Re: Webshield problem with Comodo Dragon browser
« Reply #10 on: March 28, 2010, 12:46:23 PM »
OK, for Win 7

-Open in notepad C:\ProgramData\Alwil Software\Avast5\webshield.ini

The programdata folder is hidden so you may have to change the setting to shoe it.

-Under [WebScanner] enter:

OptinProcess=dragon.exe

-Save and close it. You will be prompted be avast! self defense about the modification (image) click yes.

-Restart the webshield.

-Scott-
“There is a computer disease that anybody who works with computers knows about. It's a very serious disease and it interferes completely with the work. The trouble with computers is that you 'play' with them!”Richard Feynman

Offline JonahHex

  • Newbie
  • *
  • Posts: 18
    • Personal Message (Offline)
Re: Webshield problem with Comodo Dragon browser
« Reply #11 on: March 28, 2010, 12:48:16 PM »

Offline spg SCOTT

  • Massive Poster
  • ****
  • Posts: 4138
  • Gender: Male
  • There is no magic, only lost physics
    • spg SCOTT
    • Personal Message (Offline)
Re: Webshield problem with Comodo Dragon browser
« Reply #12 on: March 28, 2010, 12:50:48 PM »
IIRC that was for IE in win2000 when the transparent proxy does not work...

In changing the proxy settings for dragon, it looks to have the same effect, which is why I thought it may mess up the IE connection...
“There is a computer disease that anybody who works with computers knows about. It's a very serious disease and it interferes completely with the work. The trouble with computers is that you 'play' with them!”Richard Feynman

Offline JonahHex

  • Newbie
  • *
  • Posts: 18
    • Personal Message (Offline)
Re: Webshield problem with Comodo Dragon browser
« Reply #13 on: March 28, 2010, 12:55:01 PM »
Okay.
Can it be solved or should i go back to Google Chrome or IE8 instead?
unfortunately i have to go but please try to slove this. If you need more information please mail me.

Offline spg SCOTT

  • Massive Poster
  • ****
  • Posts: 4138
  • Gender: Male
  • There is no magic, only lost physics
    • spg SCOTT
    • Personal Message (Offline)
Re: Webshield problem with Comodo Dragon browser
« Reply #14 on: March 28, 2010, 12:56:20 PM »
If you follow the instructions to 'optin' dragon into the webshield ini it should work. It is just that dragon is not on the default list to scan...

“There is a computer disease that anybody who works with computers knows about. It's a very serious disease and it interferes completely with the work. The trouble with computers is that you 'play' with them!”Richard Feynman

 

Google Chrome

AVAST recommends using the FREE Google Chrome™ browser.

Download Google Chrome Now