Author Topic: Avast firewall blocking my email  (Read 3883 times)

Offline dondi1

  • Newbie
  • *
  • Posts: 10
    • Personal Message (Offline)
Avast firewall blocking my email
« on: May 04, 2010, 11:51:51 PM »
You guys were great before, so here is my next problem--Hope you can help!  I have been running avast! on my new computer for a little over a month now.  I got my email up and running--which worked for a couple of weeks.....then suddenly I could receive, but I could not send email.  I get this error message :

 Failed to connect to the outgoing server 'mail.galaxynet.com'.  Please try again later.
 (then in the details section it says this:) 421 454 TLS missing certificate: error:02001002:system library:fopen:No such file or directory (#4.3.0).

 I've called my internet people several times.  They suggested it was a corrupted file in Incredimail, as the error code indicates that program. I have tried completely uninstalling and reinstalling Incredimail in case a file got corrupted, and no difference--except that now I have an inbound error similar to the outbound one.   I've made sure all my settings are correct in Incredimail --several times I've gone over all that. Their help center says this about (what is possibly) the problem:

Software firewalls are computer security applications that protect your computer by preventing unwanted intrusion from and to the Internet. If you have a firewall installed on your computer, you need to add the IncrediMail executable files to your firewall's 'Allowed Application' list, so that you are able to send and receive email with IncrediMail.

To learn how to configure Norton Internet Security 2004, click here.

To learn how to configure Norton Internet Security 2005, click here.

To learn how to configure McAfee, click here.

To learn how to configure ZoneAlarm, click here.

If your firewall does not appear on the above list, please follow these simple steps:

   1. Go to your firewall settings, and find the list of all the programs the firewall has detected.

   2. To enable IncrediMail to work with your firewall, allow the following IncrediMail files full access to the Internet:

         1. IMApp.exe
         2. ImNotfy.exe
         3. IncMail.exe
         4. ImpCnt.exe

   3. Your firewall is now correctly configured and you can continue to use your IncrediMail.



SO....I've disabled the avast! shields control (temporarily) and the problem goes away--that seems to indicate that it is avast! causing this to happen.  But I don't understand what I need to do to "allow Incredimail full access to the internet".  I'm not really THAT savvy.  I definitely don't want avast! disabled--what did I buy it for if I'm going to turn it off?  But I have looked all over the place and can't figure out what to do to get it to work.

The confusing thing is that it worked for a couple of weeks, just fine.  My email techs said that galaxynet (my email is galaxynet) switched servers at that time and during the switch is when this problem started.  But before that there was no such problem.  I sure hope you can help!

Two more things:  I even tried loading Mozilla Thunderbird in lieu of Incredimail (in case it was impossible to get Incredimail running properly again for some reason)--but it has issues too.  The error is not the same, but it is actually more cryptic and if I am going to struggle to get an email program running, I'd rather keep my incredimail.

Last:  in case you need this info, I am running Windows 7 Ult 64bit.  I have avast! Internet Security (the latest one I think) (yes, a paid license). 

Thanks
Dondi


doktornotor

  • Guest
Re: Avast firewall blocking my email
« Reply #1 on: May 04, 2010, 11:56:12 PM »
Code: [Select]
454 TLS missing certificate: error:02001002:system library:fopen:No such file or directory
If that is what you get from the server, then the morons have not installed SSL certificates on the mailservers when switching the HW. Nothing that Avast could solve for sure and you'll need to disable encryption for now.

Offline dondi1

  • Newbie
  • *
  • Posts: 10
    • Personal Message (Offline)
Re: Avast firewall blocking my email
« Reply #2 on: May 05, 2010, 12:54:48 AM »
...what's "HW"?  And my email folks said not to encrypt--no SSL.  They were pretty emphatic.

doktornotor

  • Guest
Re: Avast firewall blocking my email
« Reply #3 on: May 05, 2010, 01:19:53 AM »
...what's "HW"?  And my email folks said not to encrypt--no SSL.  They were pretty emphatic.

HW = the servers of the email provider. And "not to encrypt" is a wonderful "solution" indeed. Perhaps they should stop advertising SSL/TLS capabilities on their mailserver first which would prevent Avast from even trying to encrypt.  ::)

Offline vojtech

  • avast! team
  • Advanced Poster
  • *
  • Posts: 911
  • Gender: Male
    • ALWIL Software
    • Personal Message (Offline)
Re: Avast firewall blocking my email
« Reply #4 on: May 05, 2010, 08:23:37 AM »
Go to Real-Time Shields/Mail Shield/Expert Settings/SSL Accounts and set up the accounts as required by your mail provider (You probably need to set None encryption and ports 110 for POP3 and 25 for SMTP).

doktornotor

  • Guest
Re: Avast firewall blocking my email
« Reply #5 on: May 05, 2010, 08:59:36 AM »
For debugging similar stuff... If you go to mail shield and disable SMTP, POP3 and IMAP4 checking temporarily, you can diagnose the issue w/ their mailservers like this:

Code: [Select]
> telnet smtp.example.com 25
220 smtp.example.com ESMTP
EHLO localhost
250-smtp.example.com
250-PIPELINING
250-8BITMIME
250-SIZE 0
250-AUTH LOGIN PLAIN CRAM-MD5
250 STARTTLS
QUIT
221 smtp.example.com

Note the 250 STARTTLS part there.

Same for IMAP:

Code: [Select]
> telnet imap.example.com
* OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THRE
AD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION STARTTLS Courier-IMAP ready. Copyr
ight 1998-2005 Double Precision, Inc.  See COPYING for distribution information.
. logout
* BYE Courier-IMAP server shutting down
. OK LOGOUT completed

If they advertise anything like STARTTLS and don't have the server certificates installed (as shown in the output you've posted above), their server configuration is just plain broken.

P.S. Don't forget to re-enable the checking in Avast after testing.  ;)

Offline dondi1

  • Newbie
  • *
  • Posts: 10
    • Personal Message (Offline)
Re: Avast firewall blocking my email
« Reply #6 on: May 05, 2010, 12:52:00 PM »
Go to Real-Time Shields/Mail Shield/Expert Settings/SSL Accounts and set up the accounts as required by your mail provider (You probably need to set None encryption and ports 110 for POP3 and 25 for SMTP).


That's already done.   :-\

Offline vojtech

  • avast! team
  • Advanced Poster
  • *
  • Posts: 911
  • Gender: Male
    • ALWIL Software
    • Personal Message (Offline)
Re: Avast firewall blocking my email
« Reply #7 on: May 05, 2010, 01:30:46 PM »
And the mail server is still complaining about a certificate ?

Offline dondi1

  • Newbie
  • *
  • Posts: 10
    • Personal Message (Offline)
Re: Avast firewall blocking my email
« Reply #8 on: May 06, 2010, 12:50:08 AM »
Yes.  But if I disable all shields in Avast! it will send and receive email no problem.

doktornotor

  • Guest
Re: Avast firewall blocking my email
« Reply #9 on: May 06, 2010, 06:48:30 AM »
Delete the accounts in avast and after they get re-created, then disable the encryption there once again.

 

Google Chrome

AVAST recommends using the FREE Google Chrome™ browser.

Download Google Chrome Now