Author Topic: avast 6 caused problem with Outlook Express  (Read 4708 times)

Offline JohnnyBob

  • Full Member
  • ***
  • Posts: 199
  • Peace
    • Personal Message (Offline)
avast 6 caused problem with Outlook Express
« on: March 02, 2011, 02:45:29 AM »
I just updated to the new free avast 6 version and the result was the following problem with Outlook Express on Windows XP Home SP3. I then uninstalled avast 6 and the problem went away immediately, so that was definitely the cause.

I've been using avast antivirus for many years but I don't have time to troubleshoot such things, so I am installing Microsoft Security Essentials as the replacement protector for this computer.

Sorry, but adios amigos...
free avast! 9.0 installed without Email Shield (not needed). Web shield disabled. All other "extras" are not installed or disabled. It wanted server status access to the internet which I blocked permanently via ZA. I also killed AvastEmUpdate.exe by renaming it in Safe Mode. Windows XP Home SP3, ZoneAlarm 6.1.744.001, Firefox 25.0 & IE8, Outlook Express.

Offline JohnnyBob

  • Full Member
  • ***
  • Posts: 199
  • Peace
    • Personal Message (Offline)
Re: avast 6 caused problem with Outlook Express
« Reply #1 on: March 02, 2011, 04:23:22 AM »
It didn't take long to figure out that Microsoft Security Essentials was unsatisfactory, so I'm back to avast 6. Unfortunately the same script bug happens with Outlook Express whenever I open it, as described above. That's double confirmation that the cause is indeed avast 6. So how do I get rid of it?
free avast! 9.0 installed without Email Shield (not needed). Web shield disabled. All other "extras" are not installed or disabled. It wanted server status access to the internet which I blocked permanently via ZA. I also killed AvastEmUpdate.exe by renaming it in Safe Mode. Windows XP Home SP3, ZoneAlarm 6.1.744.001, Firefox 25.0 & IE8, Outlook Express.

Offline JohnnyBob

  • Full Member
  • ***
  • Posts: 199
  • Peace
    • Personal Message (Offline)
Re: avast 6 caused problem with Outlook Express
« Reply #2 on: March 02, 2011, 05:33:51 AM »
Turning off the avast script shield doesn't fix it, although I suspect that's the area where the bug resides. Somehow avast is interfering with proper operation of the script to read the opening page of Outlook Express ("frntpage.htm").

Proof: If I check the box in Outlook Express settings for "When Outlook Express starts, go directly to my Inbox", the script error doesn't happen.
free avast! 9.0 installed without Email Shield (not needed). Web shield disabled. All other "extras" are not installed or disabled. It wanted server status access to the internet which I blocked permanently via ZA. I also killed AvastEmUpdate.exe by renaming it in Safe Mode. Windows XP Home SP3, ZoneAlarm 6.1.744.001, Firefox 25.0 & IE8, Outlook Express.

Offline SafeSurf

  • avast! Evangelist
  • Ultra Poster
  • ***
  • Posts: 4926
    • Personal Message (Offline)
Re: avast 6 caused problem with Outlook Express
« Reply #3 on: March 02, 2011, 08:27:02 AM »
I don't have Outlook Express so I can only offer limited help.  You may want to contact Avast regarding this problem here http://www.avast.com/contact-form.php?loadStyles since no one has helped you in the forum as of yet.  Thank you.
iMac (Mavericks)/Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Prem)/ Avast Mobile Security with MBAM Pro/ iPad 4th gen.

Offline JohnnyBob

  • Full Member
  • ***
  • Posts: 199
  • Peace
    • Personal Message (Offline)
Re: avast 6 caused problem with Outlook Express
« Reply #4 on: March 02, 2011, 10:48:44 AM »
I don't have Outlook Express so I can only offer limited help.  You may want to contact Avast regarding this problem here http://www.avast.com/contact-form.php?loadStyles since no one has helped you in the forum as of yet.  Thank you.
OK, SafeSurf, I did as you suggest. It's now in their capable hands... :)
free avast! 9.0 installed without Email Shield (not needed). Web shield disabled. All other "extras" are not installed or disabled. It wanted server status access to the internet which I blocked permanently via ZA. I also killed AvastEmUpdate.exe by renaming it in Safe Mode. Windows XP Home SP3, ZoneAlarm 6.1.744.001, Firefox 25.0 & IE8, Outlook Express.

Offline VanguardLH

  • Jr. Member
  • **
  • Posts: 90
    • Personal Message (Offline)
Re: avast 6 caused problem with Outlook Express
« Reply #5 on: March 02, 2011, 11:47:33 AM »
There is no separate frntpage.htm file.  It is data defining that document within the msoeres.dll file; that is, the page gets extracted from that DLL file.

See http://windowsxp.mvps.org/oescript.htm for information (found just by Googling: http://www.google.com/search?q="frntpage.htm").  It certainly appears script blocking now added in v6 of Avast could be causing the problem but it also looks like you can undo the change it made to the Internet security zone settings.

UPDATE:
I just installed v6 and did the required reboot.  The "binary and script behaviors" option for Internet Options did not change from before.  It was Enabled and still is.  If this option got disabled, maybe you have some other security software that made the change.  I also started OE6 after the Avast v6 upgrade and reboot and it doesn't have the frntpage.htm error that you reported.
« Last Edit: March 02, 2011, 12:23:17 PM by VanguardLH »

Offline JohnnyBob

  • Full Member
  • ***
  • Posts: 199
  • Peace
    • Personal Message (Offline)
Re: avast 6 caused problem with Outlook Express
« Reply #6 on: March 02, 2011, 05:37:59 PM »
Thanks for the insights. It's now in the hands of the avast! tech crew complete with a hijackthis.log etc. This error message with Outlook Express goes back a long ways, 5-6 years at least, according to google searches. Fortunately I never encountered it before. As far as I know, nobody else has confirmed it happening with avast!6, so maybe I've got a weird computer!?
free avast! 9.0 installed without Email Shield (not needed). Web shield disabled. All other "extras" are not installed or disabled. It wanted server status access to the internet which I blocked permanently via ZA. I also killed AvastEmUpdate.exe by renaming it in Safe Mode. Windows XP Home SP3, ZoneAlarm 6.1.744.001, Firefox 25.0 & IE8, Outlook Express.

Offline JohnnyBob

  • Full Member
  • ***
  • Posts: 199
  • Peace
    • Personal Message (Offline)
Re: avast 6 caused problem with Outlook Express
« Reply #7 on: March 03, 2011, 10:57:35 PM »
I'm back to version 5.1.889 and the problem with Outlook Express disappeared. So version 6 is definitely the cause. This already greatly exceeds my interest. I don't want to have to spend so much time on antivirus software.
free avast! 9.0 installed without Email Shield (not needed). Web shield disabled. All other "extras" are not installed or disabled. It wanted server status access to the internet which I blocked permanently via ZA. I also killed AvastEmUpdate.exe by renaming it in Safe Mode. Windows XP Home SP3, ZoneAlarm 6.1.744.001, Firefox 25.0 & IE8, Outlook Express.

Offline Dch48

  • avast! Evangelist
  • Massive Poster
  • ***
  • Posts: 2786
  • Gender: Male
    • Personal Message (Offline)
Re: avast 6 caused problem with Outlook Express
« Reply #8 on: March 04, 2011, 04:10:22 AM »
Why not just leave OE set to go directly to the inbox? Mine has been set that way for years now.
HP6140 Laptop, AMD A8-3500M Quad Core APU, 6GB RAM, Windows 7 Home Premium 64 SP1, IE10 & Outlook 2007,  Comodo Internet Security 6.3, MBAM on demand
Google/Asus Nexus 7 tablet, Tegra 3 quad core 1.3ghz, 32GB storage, Android 4.4.2, Dolphin browser, TrustGo Mobile Security
HP 5215us laptop, AMD Turion64 single core CPU, 2GB RAM, Windows 8.1 pro 32 bit, IE11 & Outlook 2007, Comodo Internet Security 6.3--- All machines behind a NAT router

Offline JohnnyBob

  • Full Member
  • ***
  • Posts: 199
  • Peace
    • Personal Message (Offline)
Re: avast 6 caused problem with Outlook Express
« Reply #9 on: March 04, 2011, 04:43:28 AM »
Because if it causes this script error, it will probably cause other errors I haven't seen yet...so better to be rid of it. Also it's a 134 MB installation for the 5.1.889 version vs a 195 MB installation for v6. Etc. I just don't like v6.
free avast! 9.0 installed without Email Shield (not needed). Web shield disabled. All other "extras" are not installed or disabled. It wanted server status access to the internet which I blocked permanently via ZA. I also killed AvastEmUpdate.exe by renaming it in Safe Mode. Windows XP Home SP3, ZoneAlarm 6.1.744.001, Firefox 25.0 & IE8, Outlook Express.

Offline craigb

  • avast! √úberevangelist
  • Serious Graphoman
  • *****
  • Posts: 8068
  • Gender: Male
    • Personal Message (Offline)
Re: avast 6 caused problem with Outlook Express
« Reply #10 on: March 04, 2011, 04:50:49 AM »
Avast 6 is a 55 meg download and unpacks to 153 meg on harddrive.
Windows 8.1 Pro X64/ IE 11/ Avast 9.0.2018/ MBAM Premium 2

Offline JohnnyBob

  • Full Member
  • ***
  • Posts: 199
  • Peace
    • Personal Message (Offline)
Re: avast 6 caused problem with Outlook Express
« Reply #11 on: March 04, 2011, 07:12:03 AM »
My MB numbers are from the Add or Remove Programs list. The custom installation of v6 below comes to only 137 MB (vs 195 MB for the typical install).

As some others have suggested, and after some meditation and sleep, I decided to try a custom install of v6, omitting the WebCal thingie, the Mail Shield, the Scripts Shield, and then disabling the sandbox thingie. I don't need the Mail Shield because all of my email gets bounced through google (gmail) and they catch all of the bad stuff. The Scripts Shield is the probable cause of my Outlook Express opening script problem, although that isn't proven absolutely hereby. And I don't want any sandboxes nor the WebCal to interfere with proper operation of my computer.

Result: the script error when opening Outlook Express is gone.

I also note that avast5.ini remains even in v6 (why didn't they rename it avast6.ini?) so I can enter the further custom modifications I want thereby.

This makes v6 acceptable to me...
free avast! 9.0 installed without Email Shield (not needed). Web shield disabled. All other "extras" are not installed or disabled. It wanted server status access to the internet which I blocked permanently via ZA. I also killed AvastEmUpdate.exe by renaming it in Safe Mode. Windows XP Home SP3, ZoneAlarm 6.1.744.001, Firefox 25.0 & IE8, Outlook Express.

doktornotor

  • Guest
Re: avast 6 caused problem with Outlook Express
« Reply #12 on: March 04, 2011, 07:16:20 AM »
My MB numbers are from the Add or Remove Programs list.

Well, as a side note - this feature shows completely junk figures more often than the correct ones. For half of the SW installed here it shows no size at all. That includes stuff directly from MS, such as Office 2010.

Offline craigb

  • avast! √úberevangelist
  • Serious Graphoman
  • *****
  • Posts: 8068
  • Gender: Male
    • Personal Message (Offline)
Re: avast 6 caused problem with Outlook Express
« Reply #13 on: March 04, 2011, 07:29:38 AM »
No idea why you get that 195 meg reading as i have the full install of the free version and its 153 meg, if you place your curser over the avast program file that should give you the correct size. Did you do a clean install.
Windows 8.1 Pro X64/ IE 11/ Avast 9.0.2018/ MBAM Premium 2

Offline JohnnyBob

  • Full Member
  • ***
  • Posts: 199
  • Peace
    • Personal Message (Offline)
Re: avast 6 caused problem with Outlook Express
« Reply #14 on: March 04, 2011, 07:53:53 AM »
Did you do a clean install.
I think so. I scrubbed it with your uninstaller, as well as RevoUninstaller, and also looked for remnants manually.

A further note...

Updates are now speedy with my custom install of v6, only a few seconds. Previously with the typical install it took at least 3-11 minutes for them to process and recognize the simple fact that the program/engine/virus definitions were already up to date. So I suspect that your new Script Shield was interfering here too!?
free avast! 9.0 installed without Email Shield (not needed). Web shield disabled. All other "extras" are not installed or disabled. It wanted server status access to the internet which I blocked permanently via ZA. I also killed AvastEmUpdate.exe by renaming it in Safe Mode. Windows XP Home SP3, ZoneAlarm 6.1.744.001, Firefox 25.0 & IE8, Outlook Express.

 

Google Chrome

AVAST recommends using the FREE Google Chrome™ browser.

Download Google Chrome Now