Author Topic: Avast 6 to Avast 7 installed Chrome, destroys existing Chrome install  (Read 11703 times)

Offline Alievitan

  • Full Member
  • ***
  • Posts: 137
    • Personal Message (Offline)
I updated Avast 6 to Avast 7 via the GUI button for my Windows 7 64 bit machine.  I already have Chrome installed in the directory "C:\Users\______\AppData\Local\Google" which is the default installation directory of the official Chrome installation file from Google. 

However, for some reason, in the update from V6 to V7, Avast took it upon itself to install Chrome to another directory (programfiles).  As a result my chrome profile is messed up b/c chrome doesn't know where to go in regards to profile and exe resulting in errors when I try to use Chrome.  There are also conflicting Chrome tasks scheduled. 

Now I have to do the uninstall the Chrome (programfiles) that Avast arbitrarily installed and its trances in addition to uninstalling my original Chrome installation in the appdata directory to resolve the conflicts.  Finally I have to do a brand new clean install of Chrome and begin rebuilding my profile. 

I have nothing, but respect for the avast team, but this is a major screw up and a unnecessary waste of time.  I am very upset, b/c that Chrome profile had more than a years worth personal data and configurations which I now have to rebuild from scratch.  Avast should have detected that Chrome was already on my computer and not try to ram another Chrome installation down my throat. 

Offline BaconRules

  • Newbie
  • *
  • Posts: 5
    • Personal Message (Offline)
Re: Avast 6 to Avast 7 installed Chrome, destroys existing Chrome install
« Reply #1 on: February 24, 2012, 12:59:21 PM »
Glad I am not the only one.  I have been doing some major testing of the Chrome beta (v18), and Avast took it upon themselves to "upgrade" me down to v17, and the only way to fix it was to uninstall Chrome.  It even screwed up my canary install - which shouldn't be possible.

It seems like this release just wasn't fully baked yet, which is a bummer.  Avast has been very good to me, and I had a lot of faith in their products, but this release has knocked them down quite a few pegs.  It is going to take some really good PR to fix their reputation.

Offline murmatron

  • Newbie
  • *
  • Posts: 5
    • Personal Message (Offline)
Re: Avast 6 to Avast 7 installed Chrome, destroys existing Chrome install
« Reply #2 on: February 24, 2012, 06:13:47 PM »
Same thing happened to me.

After I calmed down, I un-installed Chrome, downloaded and installed it properly and then did a "Restore previous versions" on the Chrome directory in Appdata\Local\Google

Fortunately, that got me back to where I was with all my settings and extensions intact.

Installing stuff on my machine without asking me is not funny.

Installing something that's already there and making a complete mess of it in the process is beyond stupid.

A new emoticon is required for this topic because >:( really doesn't go far enough.

Offline Dch48

  • avast! Evangelist
  • Massive Poster
  • ***
  • Posts: 2786
  • Gender: Male
    • Personal Message (Offline)
Re: Avast 6 to Avast 7 installed Chrome, destroys existing Chrome install
« Reply #3 on: February 24, 2012, 06:49:03 PM »
It didn't happen here on our Vista Machine but it did ask about it on the final screen. Chrome never has been installed on that computer.
HP6140 Laptop, AMD A8-3500M Quad Core APU, 6GB RAM, Windows 7 Home Premium 64 SP1, IE10 & Outlook 2007,  Comodo Internet Security 6.3, MBAM on demand
Google/Asus Nexus 7 tablet, Tegra 3 quad core 1.3ghz, 32GB storage, Android 4.4.2, Dolphin browser, TrustGo Mobile Security
HP 5215us laptop, AMD Turion64 single core CPU, 2GB RAM, Windows 8.1 pro 32 bit, IE11 & Outlook 2007, Comodo Internet Security 6.3--- All machines behind a NAT router

Offline BlitzenZeus

  • Jr. Member
  • **
  • Posts: 54
  • Organized Chaos
    • Personal Message (Offline)
Re: Avast 6 to Avast 7 installed Chrome, destroys existing Chrome install
« Reply #4 on: February 24, 2012, 07:32:09 PM »
I had a similar problem, but I was not even allowed to uncheck the box to install Chrome.  All I saw was a flash of a Avast 7 screen, and soon after that a new chrome shortcut on my desktop as I always delete them.

The new installation of Chrome disabled my user installation, and reset the profile settings.  This is Google's fault, but again, Avast did stick this installation at the end, and again, I wasn't given a chance to uncheck it, but wasn't given that simple courtesy.  I have since removed the system wide installation, and reinstalled the user installation, however the damage to the profile is already done, along with your reputation Avast.

I have to call some other people, and warn them about this Avast Update.
Yesterday we obeyed kings, and bent our necks before emperors. But today we kneel only to the truth. -Kahlil Gibran

Offline hayc59

  • VoodØØ Child™
  • Sr. Member
  • ****
  • Posts: 310
  • I'm Your Huckleberry
    • Outpost Users Support Forum
    • Personal Message (Offline)

Offline AspieMum

  • Newbie
  • *
  • Posts: 3
    • Personal Message (Offline)
Re: Avast 6 to Avast 7 installed Chrome, destroys existing Chrome install
« Reply #6 on: February 24, 2012, 07:39:54 PM »
Not sure about the files (I haven't looked to see) but Chrome is working fine (I'm using it now). I haven't felt the need to check if the new Avast has changed my Chrome file as there is no noticeable change in use. I have Windows 7 64 bit and it is the latest stable release of Chrome. Mine is installed in "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" though.

Offline freddief

  • Newbie
  • *
  • Posts: 7
    • Personal Message (Offline)
Re: Avast 6 to Avast 7 installed Chrome, destroys existing Chrome install
« Reply #7 on: February 24, 2012, 07:43:37 PM »
I got a dialogue box after reboot, where I could uncheck Chrome.

Are you saying that your installs bypassed the "Finalize" dialogue box?

Offline BlitzenZeus

  • Jr. Member
  • **
  • Posts: 54
  • Organized Chaos
    • Personal Message (Offline)
Re: Avast 6 to Avast 7 installed Chrome, destroys existing Chrome install
« Reply #8 on: February 24, 2012, 07:52:23 PM »
Apparently I need to quote myself.

I had a similar problem, but I was not even allowed to uncheck the box to install Chrome.  All I saw was a flash of a Avast 7 screen, and soon after that a new chrome shortcut on my desktop as I always delete them.
Yesterday we obeyed kings, and bent our necks before emperors. But today we kneel only to the truth. -Kahlil Gibran

Offline murmatron

  • Newbie
  • *
  • Posts: 5
    • Personal Message (Offline)
Re: Avast 6 to Avast 7 installed Chrome, destroys existing Chrome install
« Reply #9 on: February 24, 2012, 08:49:50 PM »
I didn't see any mention of a Chrome install whatsoever during the upgrade or subsequent reboot. If it had been there, I would have seen it. The first thing I saw was a dialog stating that Chrome had been installed by an administrator (as if I'm not) and my installation needed to be converted (or something to that effect). This was followed by Chrome opening with a page informing me that I could "Browse safer with Chrome or some similar nonsense".

Just to reiterate:  For those who have had their Chrome install hosed by this on Vista/Seven ...

1. Uninstall Chrome
2. Download and install Chrome
3. Explore to SystemDrive\Users\YourUserName\Appdata\Local\Google
4. Right-click the Chrome folder
5. Select "Restore previous versions" on the context menu
6. Hope that your recovery settings are such that there are previous versions to restore
7. Restore the Chrome folder to a version before the Avast upgrade
8. Hurrah (hopefully)

Offline Gooob

  • Jr. Member
  • **
  • Posts: 40
    • Personal Message (Offline)
Re: Avast 6 to Avast 7 installed Chrome, destroys existing Chrome install
« Reply #10 on: February 24, 2012, 09:10:30 PM »
I am having a somewhat related problem where Avast AV Free 7 WebRep does not install in my Chrome Beta Channel browser.

Anyone have Web Rep Extension (v7 not v6) working with Chrome beta?

Offline BaconRules

  • Newbie
  • *
  • Posts: 5
    • Personal Message (Offline)
Re: Avast 6 to Avast 7 installed Chrome, destroys existing Chrome install
« Reply #11 on: February 24, 2012, 09:17:55 PM »
I am having a somewhat related problem where Avast AV Free 7 WebRep does not install in my Chrome Beta Channel browser.

Anyone have Web Rep Extension (v7 not v6) working with Chrome beta?

I'm tracking that issue in two related threads:
Chrome web rep not working - http://forum.avast.com/index.php?topic=93923.0
Firefox Webrep version - 6.0.1407 - http://forum.avast.com/index.php?topic=93884.0

WebRep is definitely hosed because of this Avast upgrade.

Offline Gooob

  • Jr. Member
  • **
  • Posts: 40
    • Personal Message (Offline)
Re: Avast 6 to Avast 7 installed Chrome, destroys existing Chrome install
« Reply #12 on: February 24, 2012, 09:28:48 PM »
+1
Thanks BaconRules, I will bookmark those threads.

OT:
Speaking of +1, does anyone find it odd that Avast is quite cozy with Chrome, offers to install Chrome, is used as the AV of choice by Google employees .... yet Avast only prompts social support on Facebook and Twitter ... but not Google+?

With so many Avast Chrome installs Avast is shooting itself in the foot by not supporting Google+ - Avast is missing some great free word of mouth....

Offline YoKenny

  • Serious Graphoman
  • **
  • Posts: 8800
  • Gender: Male
    • Personal Message (Offline)
Re: Avast 6 to Avast 7 installed Chrome, destroys existing Chrome install
« Reply #13 on: February 24, 2012, 09:40:36 PM »
I am having a somewhat related problem where Avast AV Free 7 WebRep does not install in my Chrome Beta Channel browser.

Anyone have Web Rep Extension (v7 not v6) working with Chrome beta?

I'm tracking that issue in two related threads:
Chrome web rep not working - http://forum.avast.com/index.php?topic=93923.0
Firefox Webrep version - 6.0.1407 - http://forum.avast.com/index.php?topic=93884.0

WebRep is definitely hosed because of this Avast upgrade.
Not a problem for me:
http://forum.avast.com/index.php?topic=93866.msg748260#msg748260
E5200 2.5GHZ, 4GB RAM, 320GB HD, Windows 7 Home Premium 64bit, avast! V9.0 Free, IE10
P4 2.8GHZ, 1.5GB RAM, 40GB HD, XP Pro SP3 32bit, avast! V9.0 Free, Google Chrome
with hpHosts, MVPS HOSTS files, SpeedFan, WinPatrol PLUS

Offline Gooob

  • Jr. Member
  • **
  • Posts: 40
    • Personal Message (Offline)
Re: Avast 6 to Avast 7 installed Chrome, destroys existing Chrome install
« Reply #14 on: February 24, 2012, 10:04:29 PM »

 
Quote
Not a problem for me:
http://forum.avast.com/index.php?topic=93866.msg748260#msg748260

You are using Chrome Beta Channel v18?

AFTER installing Avast 7 you have gone into Chrome Extension Page and have visually confirmed the WebRep Extension is version number 7.xxx not Extension version 6.xxx ?

 

Google Chrome

AVAST recommends using the FREE Google Chrome™ browser.

Download Google Chrome Now