Author Topic: avast! blocking email SMTP port 80 Redirector Settings  (Read 5982 times)

Offline avast@ advantage77.com

  • J.R. Guthrie - avast! Rising Star 2010
  • avast! reseller
  • Advanced Poster
  • *
  • Posts: 719
  • Gender: Male
  • avast! Distributor & Platinum Reseller
    • Advantage Micro Corporation
    • Personal Message (Offline)
avast! blocking email SMTP port 80 Redirector Settings
« on: March 06, 2012, 08:33:53 PM »
After an avast update, email would no longer send with SMTP on port 80.  This particular server "SMTPout.secureserver.net" is a relay server and used by several different hosting firms, including GoDaddy. I found this reference to the avast! Redirect Settings on Internet, but it would go against logic to clear all of these settings, as the author suggests.  What would be the repercussions of his actions?  What would be the correct Redirector Settings for SMTP on port 80?

This is the web article that I referenced above:

"It seems like a lot of people are having trouble with the latest version of Avast, the free virus checking software. Suddenly, Avast is blocking access to POP and IMAP email accounts.

If you're having this problem, here's the fix:

1. Open Avast

2. Click on 'Settings' (upper right corner of page)

3. Click on 'Troubleshooting'

4. Click on 'Redirect Settings'

5. Clear all the port #'s from each field

6. Check 'Ignore Local Communication'

7. Click 'OK'

8. Close Avast

Problem solved!

Wouldn't it be nice if all of life's problems were that easy to solve?"
Advantage Micro Corporation
http://www.advantage77.com
520-290-0595

Online lukor

  • avast! team
  • Super Poster
  • *
  • Posts: 1583
  • Gender: Male
    • AVAST Software
    • Personal Message (Online)
Re: avast! blocking email SMTP port 80 Redirector Settings
« Reply #1 on: March 06, 2012, 08:39:03 PM »
Disabling the redirected port in webshield is equivalent to turning webshield off. Will probably help in this case :-)

Better solution in such case, where SMTP is indeed running on HTTP port 80, is to add its ip address to the ignore list (in the same settings page). This will help as well - turns webshield off but only for the specified IP.

Online lukor

  • avast! team
  • Super Poster
  • *
  • Posts: 1583
  • Gender: Male
    • AVAST Software
    • Personal Message (Online)
Re: avast! blocking email SMTP port 80 Redirector Settings
« Reply #2 on: March 06, 2012, 08:40:40 PM »
On my system, the ip address for smtpout.secureserver.net is:

64.202.165.58

Offline avast@ advantage77.com

  • J.R. Guthrie - avast! Rising Star 2010
  • avast! reseller
  • Advanced Poster
  • *
  • Posts: 719
  • Gender: Male
  • avast! Distributor & Platinum Reseller
    • Advantage Micro Corporation
    • Personal Message (Offline)
Re: avast! blocking email SMTP port 80 Redirector Settings
« Reply #3 on: March 06, 2012, 08:45:42 PM »
Dear Lukor,

When using the IP exclusion, does this mean that the webshield would only be turned off for that IP address of the  SMTP server, where we would only be sending anyways.  That would then keep the protection intact for everything else.  OK that is clear, and that is a GREAT solution!
Advantage Micro Corporation
http://www.advantage77.com
520-290-0595

Offline chadneff

  • Newbie
  • *
  • Posts: 2
    • Personal Message (Offline)
Re: avast! blocking email SMTP port 80 Redirector Settings
« Reply #4 on: May 02, 2012, 05:23:06 PM »
Well great, except its the internet that runs on IP, people remember names.  The internet respects this.  So what happens whe smtp~.secureserver move to a different IP?  I don't want to get a bunch of calls from all the godady/avast computers I service 'cuase they can't send when smtp.secure is moved...   

Can't we use the Domains the way things were designed to work? _chad

Offline avast@ advantage77.com

  • J.R. Guthrie - avast! Rising Star 2010
  • avast! reseller
  • Advanced Poster
  • *
  • Posts: 719
  • Gender: Male
  • avast! Distributor & Platinum Reseller
    • Advantage Micro Corporation
    • Personal Message (Offline)
Re: avast! blocking email SMTP port 80 Redirector Settings
« Reply #5 on: May 02, 2012, 06:44:21 PM »
Dear Chad, it is hard to a client that has NO DNS issues.  This setting works, and keeps everyone protected.  Secureserver is a wierd configuration shared by many ISPs (not the norm)!

J.R. Guthrie
Advantage Micro Corporation
http://www.advantage77.com
520-290-0595

Offline chadneff

  • Newbie
  • *
  • Posts: 2
    • Personal Message (Offline)
Re: avast! blocking email SMTP port 80 Redirector Settings
« Reply #6 on: May 03, 2012, 03:45:47 AM »
I appreciate you overlooking, the somewhat aurgumentive tone of my last post.   I was really not trying to fault the effectiveness of your solution.  Just that it could generate unforseen future issuez.

Turns out there was another posting else where in these forums that went right at the heart of the matter.  I'm reposting that after solution at the end of this post.   I think as a long time user but only recent poster to these forums the fault here is becuse of Go Daddy's use of the normal Web port 80 for smtp... I believe this is also pointed out in the following repost.
*********************************************************************
tberman333:
Well... I did some more searching on Go Daddy's support page and they actually allow you to choose from Port 25, 80 and 3535 (but for some reason the client specific instructions on their site say it must be set to 80).

Anyway, I changed my email client SMTP port to 25 and the Web Shield HTTP redirect back to 80 and all is working.

So, Go Daddy is not really that strange to offer alternative Ports (I think they do it in case your ISP blocks 25), they should just update the client specific instructions to tell you that there are alternatives!

Anyway, if anyone else uses Go Daddy and has problems, hopefully this Topic will help them!
*********************************************************
So using 3535 for the smtpout.secureserver.net fixed the sending issue with no other changes for the accounts I was working with today.  but I have a further question.  I additionally added 3535 to the smtp redirection under setting/troubleshooting/  and I would appreciate knowing if this is a plus.  Or might that cause other problems further down the road?   Thanks again for your patience in responding to my first post. _c.

Offline avast@ advantage77.com

  • J.R. Guthrie - avast! Rising Star 2010
  • avast! reseller
  • Advanced Poster
  • *
  • Posts: 719
  • Gender: Male
  • avast! Distributor & Platinum Reseller
    • Advantage Micro Corporation
    • Personal Message (Offline)
Re: avast! blocking email SMTP port 80 Redirector Settings
« Reply #7 on: May 07, 2012, 10:55:48 PM »
Dear Chadneff,

Tested you findings.  You are correct!  easiest was changing SMTP port to 25, and NOT touching avast! redirector settings at all~!  KUDOS buddy!  J.R. Guthrie
Advantage Micro Corporation
http://www.advantage77.com
520-290-0595

 

Google Chrome

AVAST recommends using the FREE Google Chrome™ browser.

Download Google Chrome Now