Author Topic: avast! 4.1 + Win2000/XP Crash/Freeze  (Read 27792 times)

0 Members and 1 Guest are viewing this topic.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11655
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
avast! 4.1 + Win2000/XP Crash/Freeze
« on: September 14, 2003, 01:31:06 PM »
Guys, since there is a number of pending threads about this topic and it's quite strenuous to keep them all updated, I've decided to start yet another thread with the anticipation that we're close to the final solution.

My impression is that the problems are caused by a bug in the updater that sometimes fails to install the new driver files. That is, the updated drivers are correctly downloaded and unpacked, but are not installed to the system. Since other avast files are installed properly, there is a version-discrepancy problem (the program and driver versions do not match) that may eventually lead to disasters.

I'd need you to check if the drivers (i.e. the *.sys files) located in the <avast>\setup\inf directory are the same as these in \windows\system32\drivers (with respect to file sizes, timestamps etc.). They should be the same. If they're not, there is a problem and you should copy the <avast>\setup\inf versions to \windows\system32\drivers.

Please keep me informed - I would really like to know whether this is the real cause of these problems.

Thanks,
Vlk
If at first you don't succeed, then skydiving's not for you.

whocares

  • Guest
Re:avast! 4.1 + Win2000/XP Crash/Freeze
« Reply #1 on: September 14, 2003, 02:53:36 PM »
Hi VLK,

what are the exact dates and especially version numbers of the 3 sys files in system32\drivers supposed to be ?

I have 4.0.191.0  & 11.Sep.03 for all 3 files, as well as in avast's setup\inf
 ???

but this might be a special case & mea culpa if so .. ;)

 


Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11655
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:avast! 4.1 + Win2000/XP Crash/Freeze
« Reply #2 on: September 14, 2003, 02:59:47 PM »
September 11 sounds good. As for the version info I'm not sure but 191 is probably OK (although it's possible that it has not changed since 4.0.235 :-\)

Vlk
If at first you don't succeed, then skydiving's not for you.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67185
Re:avast! 4.1 + Win2000/XP Crash/Freeze
« Reply #3 on: September 14, 2003, 03:26:07 PM »
Hy Vlk. For both, Setup\Inf and System32\Drivers folders, I have:

Aavmker4.sys: 11-Sep-03 12:02:24 version 4.0.191.0
aswMon.sys: 11-Sep-03 06:06:36 version 4.0.191.0
aswMon2.sys: 11-Sep-03 06:06:24 version 4.0.191.0

They seem to work perfectly in XP.  ;)
The best things in life are free.

whocares

  • Guest
Re:avast! 4.1 + Win2000/XP Crash/Freeze
« Reply #4 on: September 14, 2003, 09:45:39 PM »
Thx  :)

Walker

  • Guest
Re:avast! 4.1 + Win2000/XP Crash/Freeze
« Reply #5 on: September 14, 2003, 11:14:10 PM »
My files are dated as follows.

C:\Program Files\Alwil Software\Avast4\Setup|Inf

   AavmKer4.inf   2KB   17/10/2002   18:06
   Aavmker4.sys   13KB   11/09/2003   17:02
   AswMon2.inf   2KB   16/10/2002   09:46
   aswMon2.sys   47KB   11/09/2003   11:06
   aswMon.sys   50KB   11/09/2003   11:06

C:\WINDOWS\system32\drivers

   aavmker.sys   13KB   03/07/2003   13:58
   aswmon2.sys   44KB   03/07/2003   14:01
   aswmon.sys   46KB   03/07/2003   14:01

I haven't noticed any problems (apart from Shadow copy backup mentioned elsewhere).
« Last Edit: September 14, 2003, 11:16:40 PM by Walker »

kubecj

  • Guest
Re:avast! 4.1 + Win2000/XP Crash/Freeze
« Reply #6 on: September 15, 2003, 12:03:21 AM »
Walker, could you, please, send me the file setup.log from avast4\setup directory. My email is: kubecj FUNNY_@_CHARACTER asw DOT cz
Thanks,

Walker

  • Guest
Re:avast! 4.1 + Win2000/XP Crash/Freeze
« Reply #7 on: September 15, 2003, 01:14:31 AM »
It's in the mail Kubecj
Why....... something wrong???


Sorry miss-spelled the name!

Any news????
« Last Edit: September 15, 2003, 01:01:16 PM by Walker »

Dave50

  • Guest
Re:avast! 4.1 + Win2000/XP Crash/Freeze
« Reply #8 on: September 15, 2003, 01:26:52 AM »
Vlk -- my files read the same as Technical's -- 9/11/03 date with all reading 4.0.191.0 in System32\Drivers as well as avast\setup\info.

As I reported on Saturday, after the program update downloaded on Thursday, P2P protection didn't work.  However, after the reboot with the iAVS update on Friday, avast! is working perfectly.  As you stated, the drivers probably installed properly with that reboot.

Keep up the good work.  You've got a great product!

Dave50

Dave50

  • Guest
Re:avast! 4.1 + Win2000/XP Crash/Freeze
« Reply #9 on: September 15, 2003, 01:39:28 AM »
Vlk -- just noticed something and I don't know if it's important.  As reported, the files in avast\setup\info and windows system32\drivers say version 4.0.191.0 with the September 11th date. However -- when checking the program version on avast! itself, it says 4.0.260 --

Dave50

tim

  • Guest
Re:avast! 4.1 + Win2000/XP Crash/Freeze
« Reply #10 on: September 15, 2003, 04:40:14 AM »
hi I have same  problem .My system Freeze if I use avast 4.1.,,no problem with  avast 4.0 ..and drivers seems like okey . :(

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67185
Re:avast! 4.1 + Win2000/XP Crash/Freeze
« Reply #11 on: September 15, 2003, 07:37:10 PM »
On the upgrade to 4.1.260 some "strange" things happen in Windows Installer:

1. If the user choose Change/Remove the application, the left side on the setup window does not show the components neither
to "Update" nor to "Change". The user could not choose what to update or change in the installation...  :'(

2. The file vpsupd.exe (update file) cannot be applied to version 4.1.260: Error: 0x00000008 (only works with previous version...  :'(

What´s happening Vlk?
The best things in life are free.

Offline MWassef

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1315
Re:avast! 4.1 + Win2000/XP Crash/Freeze
« Reply #12 on: September 16, 2003, 01:04:31 PM »

2. The file vpsupd.exe (update file) cannot be applied to version 4.1.260: Error: 0x00000008 (only works with previous version...  :'(

Kindly check http://www.avast.com/forum/index.php?board=2;action=display;threadid=1136
« Last Edit: September 16, 2003, 01:06:35 PM by minacross »
MW

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67185
The best things in life are free.

Walker

  • Guest
Re:avast! 4.1 + Win2000/XP Crash/Freeze
« Reply #14 on: September 17, 2003, 09:09:17 PM »
Walker, could you, please, send me the file setup.log from avast4\setup directory. My email is: kubecj FUNNY_@_CHARACTER asw DOT cz
Thanks,

Hi kubecj,

Can you tell me if there was anything interesting in the file I sent you.

I ask because I am getting some 'crashes', not necessarily caused by Avast, but  Avast files are mentioned in the Event Viewer log files!!!.

Wonering if I should re-install.

Thanks for any info.