Avast WEBforum

Avast Products => Non-english zone => Italiano => Topic started by: selen on September 18, 2012, 01:41:57 PM

Title: avast non riconosce google chrome come browser installato
Post by: selen on September 18, 2012, 01:41:57 PM
Ho urgente bisogno di aiuto, ho reinstallato google chrome sul pc ma avast non lo riconosce nella lista dei browser installati. Non posso abilitare il plug in webrep perchè secondo avast chrome non è istallato sul mio pc. Per favore aiutatemi!
Title: Re: avast non riconosce google chrome come browser installato
Post by: giogio on September 18, 2012, 03:49:18 PM
Ciao,
per favore non pubblicare 2 post uguali...  :(
http://forum.avast.com/index.php?topic=105864.0

come consigliato da bob3160 prova ad eseguire la riparazione di avast oppure disintalla avast e lo reinstalli.
Oppure aggiungi manualmente il web rep che si trova sotto la cartella di avast
C:\Programmi\AVAST Software\avast\WebRep\Chrome\AswWebRepChrome.crx e lo trascini all'interno del browser chrome
Title: Re: avast non riconosce google chrome come browser installato
Post by: selen on September 19, 2012, 02:27:19 PM
Ciao,
per favore non pubblicare 2 post uguali...  :(
http://forum.avast.com/index.php?topic=105864.0

come consigliato da bob3160 prova ad eseguire la riparazione di avast oppure disintalla avast e lo reinstalli.
Oppure aggiungi manualmente il web rep che si trova sotto la cartella di avast
C:\Programmi\AVAST Software\avast\WebRep\Chrome\AswWebRepChrome.crx e lo trascini all'interno del browser chrome

L'ho fatto, webrep funziona, ma avast non riconosce chrome lo stesso come browser installato alla voce protezione aggiuntiva/ protezione browser. Eppure il plug in appare chiaramente su chrome!
Title: Re: avast non riconosce google chrome come browser installato
Post by: giogio on September 19, 2012, 07:10:05 PM
Prova a reinstallare chrome, visto che il problema è iniziato da quando l'hai reinstallato (controlla ed elimina eventualmente quando hai disinstallato chrome residue prima di reinstallarlo).
Comuque se vedi le barre verdi del web-rep in chrome non hai motivo di preoccuparti del fatto che non sia presente nel programma sotto protezione browser (è solo una cosa puramente estetica a mio avviso..  ;))

ciao
Title: Re: avast non riconosce google chrome come browser installato
Post by: selen on September 20, 2012, 11:23:11 AM
Prova a reinstallare chrome, visto che il problema è iniziato da quando l'hai reinstallato (controlla ed elimina eventualmente quando hai disinstallato chrome residue prima di reinstallarlo).
Comuque se vedi le barre verdi del web-rep in chrome non hai motivo di preoccuparti del fatto che non sia presente nel programma sotto protezione browser (è solo una cosa puramente estetica a mio avviso..  ;))

ciao

L'ho reinstallato varie volte infatti, eliminando anche la chiave nel regedit...ogni volta che reinstallo chrome il webrep appare dopo qualche minuto, però poi andando a  guardare in avast il browser non risulta presente...è davvero strano, però se come dici tu non rappresenta un rischio sono più tranquilla
Title: Re: avast non riconosce google chrome come browser installato
Post by: giogio on September 20, 2012, 08:30:58 PM
Ciao,
curiosità prova a cercare il file avast5.ini (su xp dovrebbe essere sotto C:\Documents and Settings\All Users\Dati applicazioni\AVAST Software\avast), sotto la sezione
[Common]
mi dici che valori ci sono accanto a queste voci (si potrebbero trovare in ordine sparso)?
Code: [Select]
WebRepIEInstalled=
Browser1Installed=
WebRepFFInstalled=
Browser2Installed=
Browser3Installed=
Browser4Installed=
Browser5Installed=
WebRepChromeInstalled=
Title: Re: avast non riconosce google chrome come browser installato
Post by: selen on September 23, 2012, 03:10:43 PM
Ciao,
curiosità prova a cercare il file avast5.ini (su xp dovrebbe essere sotto C:\Documents and Settings\All Users\Dati applicazioni\AVAST Software\avast), sotto la sezione
[Common]
mi dici che valori ci sono accanto a queste voci (si potrebbero trovare in ordine sparso)?
Code: [Select]
WebRepIEInstalled=
Browser1Installed=
WebRepFFInstalled=
Browser2Installed=
Browser3Installed=
Browser4Installed=
Browser5Installed=
WebRepChromeInstalled=

allora il file che trovo si chiama avast5, non avast5.ini, è diverso il nome, però cercando all'interno di esso ho trovato la voce common di cui parli. Ti riporto qui di seguito i valori che mi hai chiesto:

WebRepIEInstalled=1
Browser1Installed=2
WebRepFFInstalled=1
Browser2Installed=2
Browser3Installed=0
Browser4Installed=0
Browser5Installed=0
WebRepChromeInstalled=1

da quanto mi pare di capire il problema è che avast alla voce browser3installed  ha valore zero, mentre non dovrebbe essere così, dato che sul pc ci sono 3 browser installati, ovvero IE, Firefox e chrome. Se infatti guardo sui miei altri due pc, a quella voce appare il numero 2 e infatti su questi pc avast riconosce normalmente chrome come browser installato. Il problema è dunque questo...si può fare qualcosa per risolverlo? Ho provato già la reinstallazione di avast e la funzione ripara, ma non è cambiato nulla.
Title: Re: avast non riconosce google chrome come browser installato
Post by: giogio on September 24, 2012, 08:12:35 AM
E' questo il punto, prova a riavviare il pc in modalità provvisoria (continuando a premere il pulsante F8 durante il boot) e quindi modificare il valore da
Browser3Installed=0
a
Browser3Installed=2
salvi il file e riavvi il pc normalmente.
Non sono sicuro che il problema si risolvi, ma vale la pena di tentare.

Ciao
Title: Re: avast non riconosce google chrome come browser installato
Post by: selen on September 24, 2012, 12:53:41 PM
E' questo il punto, prova a riavviare il pc in modalità provvisoria (continuando a premere il pulsante F8 durante il boot) e quindi modificare il valore da
Browser3Installed=0
a
Browser3Installed=3
salvi il file e riavvi il pc normalmente.
Non sono sicuro che il problema si risolvi, ma vale la pena di tentare.

Ciao

scusa se te lo chiedo, ma come valore non dovrei mettere 2 anzichè 3? Sugli altri pc ho notato che il valore è sempre 2, sia per chrome, che per gli altri browser installati
Title: Re: avast non riconosce google chrome come browser installato
Post by: giogio on September 24, 2012, 02:21:35 PM
E' questo il punto, prova a riavviare il pc in modalità provvisoria (continuando a premere il pulsante F8 durante il boot) e quindi modificare il valore da
Browser3Installed=0
a
Browser3Installed=3
salvi il file e riavvi il pc normalmente.
Non sono sicuro che il problema si risolvi, ma vale la pena di tentare.

Ciao

scusa se te lo chiedo, ma come valore non dovrei mettere 2 anzichè 3? Sugli altri pc ho notato che il valore è sempre 2, sia per chrome, che per gli altri browser installati

Scusa tu, hai ragione, è giusto 2
Ciao
Title: Re: avast non riconosce google chrome come browser installato
Post by: selen on September 24, 2012, 06:57:23 PM
E' questo il punto, prova a riavviare il pc in modalità provvisoria (continuando a premere il pulsante F8 durante il boot) e quindi modificare il valore da
Browser3Installed=0
a
Browser3Installed=3
salvi il file e riavvi il pc normalmente.
Non sono sicuro che il problema si risolvi, ma vale la pena di tentare.

Ciao

scusa se te lo chiedo, ma come valore non dovrei mettere 2 anzichè 3? Sugli altri pc ho notato che il valore è sempre 2, sia per chrome, che per gli altri browser installati

Scusa tu, hai ragione, è giusto 2
Ciao

Ho fatto la prova, ho cambiato il valore in modalità provvisoria, ma al riavvio del pc ho controllato e il valore da 2 è ripassato a zero, nonostante io avessi salvato la modifica al file. Secondo te è normale che succeda ciò? Eppure il plug in di avast funziona su chrome, quindi com'è possibile che da un momento all'altro l'antivirus non riconosca chrome come terzo browser installato?
Title: Re: avast non riconosce google chrome come browser installato
Post by: giogio on September 24, 2012, 09:40:01 PM
Bella domanda..
Quote
Ho fatto la prova, ho cambiato il valore in modalità provvisoria, ma al riavvio del pc ho controllato e il valore da 2 è ripassato a zero, nonostante io avessi salvato la modifica al file. Secondo te è normale che succeda ciò? Eppure il plug in di avast funziona su chrome, quindi com'è possibile che da un momento all'altro l'antivirus non riconosca chrome come terzo browser installato?
nulla è cosi scontato nell'informatica, e comunque non è successo casualmente, dicevi che avevi reinstallato chrome.. è successo qualcosa nel registro di sistema o da qualche altra parte.

L'ultimo consiglio che ti dispenso e di provare ad usare l'avast uninstall utility, e poi cercare ed eliminare eventuali cartelle rimaste di avast (ivi compresa questa
 C:\Documents and Settings\All Users\Dati applicazioni\AVAST Software\) e quindi provare a reinstallare avast.

Come ho detto comunque a livello di sicurezza non hai nulla da preoccuparti.

Ciao
Title: Re: avast non riconosce google chrome come browser installato
Post by: selen on September 25, 2012, 10:10:44 AM
Bella domanda..
Quote
Ho fatto la prova, ho cambiato il valore in modalità provvisoria, ma al riavvio del pc ho controllato e il valore da 2 è ripassato a zero, nonostante io avessi salvato la modifica al file. Secondo te è normale che succeda ciò? Eppure il plug in di avast funziona su chrome, quindi com'è possibile che da un momento all'altro l'antivirus non riconosca chrome come terzo browser installato?
nulla è cosi scontato nell'informatica, e comunque non è successo casualmente, dicevi che avevi reinstallato chrome.. è successo qualcosa nel registro di sistema o da qualche altra parte.

L'ultimo consiglio che ti dispenso e di provare ad usare l'avast uninstall utility, e poi cercare ed eliminare eventuali cartelle rimaste di avast (ivi compresa questa
 C:\Documents and Settings\All Users\Dati applicazioni\AVAST Software\) e quindi provare a reinstallare avast.

Come ho detto comunque a livello di sicurezza non hai nulla da preoccuparti.

Ciao

Io avevo già provato a disinstallate avast dal pannello di controllo, poi ho cancellato tutto ciò che era rimasto, ho fatto anche la pulizia del regedit con ccleaner e ho reinstallato. Il problema persiste, oltretutto ho fatto altre prove e credo di poter dire con sicurezza che la protezione comportamento e script di avast blocca google chrome. Sta avendo infatti problemi, da circa due settimane, con chrome, che non carica le pagine. Ho notato che se disabilito la protezione in tempo reale di avast il browser riprende ad andare. Tu sapresti darmi qualche consiglio per far si che avast smetta di causare problemi al mio browser?
Title: Re: avast non riconosce google chrome come browser installato
Post by: giogio on September 25, 2012, 07:05:02 PM
Una pulizia con ccleaner non risolve di certo il problema.
Prova come consigliato a eseguire l'avast uninstall utility, rimuovere eventuali cartelle rimaste cercando nei file nascosti e di sistema e dopo, se vuoi essere sicura di avere il registro pulito da voci di avast usa l'avast cleanup tool che trovi in questa pagina (https://skydrive.live.com/redir?resid=94A12102E5094675!920)

Ciao