Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: lesbanes on September 10, 2003, 12:35:28 AM

Title: No action on viruses
Post by: lesbanes on September 10, 2003, 12:35:28 AM
After an incoming email virus is caught I can take no action. If I try repair, delete, move to chest,etc I get the msg that Avast cannot process the file. What's wrong?
Title: Re:No action on viruses
Post by: Lisandro on September 10, 2003, 12:54:11 AM
Please, lesbarnes, give us more info: your OS, if you are using a firewall (which one...), proxy, what file(s) you cannot handle...
Title: Re:No action on viruses
Post by: lesbanes on September 10, 2003, 01:02:04 AM
My OS is Win98SE, no firewall, no proxy. Having trouble with BugBear (at least that is all I have rcvd).
Title: Re:No action on viruses
Post by: igor on September 10, 2003, 09:30:45 AM
What e-mail program do you use? What is the exact message avast! gives you - is there any reason (in the title bar of the messagebox or something like that)?
Title: Re:No action on viruses
Post by: lesbanes on September 10, 2003, 05:32:17 PM
I use OE6 for email. I don't remember a msg across top. The msg says "cannot process prog files,ALWIL,Avast,etc)"  & drills down to the folder & msg.
Title: Re:No action on viruses
Post by: sedina on September 10, 2003, 11:12:18 PM
Hi,

if you have that e-mail still on you computer, can you send it to sedina@asw.cz?

thanks,

pavels
Title: Re:No action on viruses
Post by: lesbanes on September 10, 2003, 11:41:03 PM
Sorry, I have to manually double delete. In other words to get rid of the Avast screen, I have to click OK. Then I double delete so it is removed from my delete mailbox. I'll save the next one!
Title: Re:No action on viruses
Post by: Lito on September 11, 2003, 09:32:22 PM
Hi, I had the same problem, and it was also with BugBear (the damaged version). I also use OE6 as email client; I'll send right now a copy of the infected message to that adress.

Cheers, Lito.

P.S: I tested today this email with the new version of Avast! and a I got the same result.
Title: Re:No action on viruses
Post by: lesbanes on September 11, 2003, 09:47:19 PM
Thanks, Lito :) At least I know I'm not completely insane
Title: Re:No action on viruses
Post by: ashley1978 on September 18, 2003, 08:48:16 AM
So how do get around this problem ? I'm experiencing it too.
Title: Re:No action on viruses
Post by: Lito on September 18, 2003, 02:20:34 PM
Great lesbarnes we are not alone ;D

ashley, I sent the infected email to pavels I think the Avast! Team is working on it to give us an answer ;)

Cheers, Lito.
Title: Re:No action on viruses
Post by: Vlk on September 18, 2003, 02:55:16 PM
Does it happen even in the latest version (avast 4.1)??

Vlk
Title: Re:No action on viruses
Post by: lesbanes on September 18, 2003, 05:19:03 PM
I have 4.1 but I have not had a virus since the report I filed. I will let you know if I get one.

Les
Title: Re:No action on viruses
Post by: whocares on September 18, 2003, 10:28:47 PM
you could try with the harmless testfile eicar.com from www.eicar.com
Title: Re:No action on viruses
Post by: lesbanes on September 18, 2003, 10:45:30 PM
OK. I d/l eicar.com Avast saw it immediately but again I could do nothing, not even delete it! I finally had to click OK and then go to the folder where it was and delete it.
Title: Re:No action on viruses
Post by: Lito on September 19, 2003, 01:10:30 AM
Does it happen even in the latest version (avast 4.1)??

Vlk

Hi Vlk, it happens to me with Avast 4.1 too :(. But it's not with every mail infected, I can delete an infected attachment with Mapson, Sobig or any other worm that I've recieved on these days, but the problematic sample is an email message infected with BugBear.B.dam ???

Best regards, Marcel.

P.S: sorry for my bad english :-[
Title: Re:No action on viruses
Post by: lesbanes on September 19, 2003, 01:24:14 AM
I'm using ver, 4.1.268 which I d/l today. Every error msg is "Avast:Access is denied" except for repair msg which is "Avast:Process is denied because"

Les
Title: Re:No action on viruses
Post by: Lito on September 19, 2003, 02:13:49 AM
I confirm that, I just tested it with this new update of Avast! and I received the same error message :'(
Title: Re:No action on viruses
Post by: lesbanes on September 19, 2003, 02:25:23 AM
Thanks, Lito!!
Title: Re:No action on viruses
Post by: Vlk on September 19, 2003, 08:15:42 AM
What happens if you save the message to a file on disk and scan it with avast (e.g. by right-clicking it in the Explorer and selecting Scan...)? Does it work?

Also, could you send me such a message?
This sounds like something that really shouldn't be hard to fix, if we only had the appropriate samples.

Please send the message untouched, i.e. as an eml attachment (don't just fwd the message).


Thanks,
Vlk
Title: Re:No action on viruses
Post by: lesbanes on September 19, 2003, 05:58:29 PM
Hi Vik,

You can d/l the file (a test virus file, not a real virus) from www.eicar.com. The file name is eicar.com.

Avast shows the proper path to get to the "virus" but says cannot process.

I drilled down to the file itself but Avast would not repair, says cannot process. It would delete though.

Les
Title: Re:No action on viruses
Post by: Lito on September 19, 2003, 09:22:02 PM
What happens if you save the message to a file on disk and scan it with avast (e.g. by right-clicking it in the Explorer and selecting Scan...)? Does it work?

Yes, that works, but it would be better if I could delete de infected attachment like always. Anyway, I just sent the message to your email address. I hope you can find a solution to this problem :D

Bye, Lito.
Title: Re:No action on viruses
Post by: lesbanes on September 19, 2003, 09:44:34 PM
Well it says I have to reply although I have nothing to reply to. Instead I'll ask why is that little doo-dad tell me I'm being watched and my ISP is attbi.com. My ISP is NOT attbi.com so evidently I'm not being watched too closely.

Les
Title: Re:No action on viruses
Post by: Lito on September 20, 2003, 01:04:24 PM
Instead I'll ask why is that little doo-dad tell me I'm being watched and my ISP is attbi.com. My ISP is NOT attbi.com so evidently I'm not being watched too closely.

Les

You're being paranoic ;D lol

Lito.
Title: Re:No action on viruses
Post by: lesbanes on September 20, 2003, 06:42:30 PM
You could be right, Lito!

Cheers,
Les
Title: Re:No action on viruses
Post by: sedina on September 22, 2003, 05:00:24 PM
Lito: there is a bug in avast! which causes for some specific attachment (specific name) problems with deleting in e-mails. Problem is currently
fixed and patch will be in the next program update. Sorry for this faul ;-( Thanks for co-operation...
I think that other problems decribed here have the same reason... Please try it after update (I don't know exactly when it will be, but I hope that soon) and if some problems, please contact me!
Title: Re:No action on viruses
Post by: Lito on September 22, 2003, 10:50:17 PM
Pavel, thanks to you for this great work. You and all the team make me love Avast! on my first month with your software (http://www.appzplanet.com/forum/html/emoticons/wub.gif)

Best regards, Lito.
Title: Re:No action on viruses
Post by: lesbanes on September 22, 2003, 11:29:54 PM
Thanks for the help everyone. Anxiously awaiting update.

Les
Title: Re:No action on viruses
Post by: judith on September 24, 2003, 11:10:13 AM
What happens if you save the message to a file on disk and scan it with avast (e.g. by right-clicking it in the Explorer and selecting Scan...)? Does it work?

Also, could you send me such a message?
This sounds like something that really shouldn't be hard to fix, if we only had the appropriate samples.

Please send the message untouched, i.e. as an eml attachment (don't just fwd the message).


Thanks,
Vlk

I received win32: Swen and saved it to my desktop (as virus.eml), scanned it, got the usual virus warning but unable to perform any action on the file.  No error message, just nothing happens. Can delete it manually, but Avast shoud be able to do it.  No problems with Eicar.  Do you want a sample, if so will I send it to support@...?
Title: Re:No action on viruses
Post by: Lito on September 24, 2003, 11:48:15 AM
Hi Judith, I think it would better to send it to vlk at avast dot com.

Cheers, Lito.
Title: Re:No action on mail-viruses and NO detection by RS !!!
Post by: whocares on September 29, 2003, 11:01:14 AM
Lito: there is a bug in avast! which causes for some specific attachment (specific name) problems with deleting in e-mails. Problem is currently
fixed and patch will be in the next program update. Sorry for this faul ;-( Thanks for co-operation...
I think that other problems decribed here have the same reason... Please try it after update (I don't know exactly when it will be, but I hope that soon) and if some problems, please contact me!

Hi Pavels,

here's another one...:

just got Swen.A = Gibe.C
twice per Email;

the RS of uptodate avast4.1home did pick up the saved .exe-attachment ok;
but nothing in the 2nd virus-mail, where the attachment is hidden in Netscape
-> I saved this email both as extensionless and as .EML-file (both 144 KB and quite clearly infected as told by other scanners including avast quick)

RS is set to standard plus scanning on opening and creating for the extension-list:
This is how it appears in the config-panel:
COM,EXE,DLL,SYS,SCR,OV?,VXD,386,BIN,BAT,CMD,DO?,XL?,PP?,HT*,HLP,CH?,{*},ASP,CLA*,CPL,CSS,INF,JS*,LNK,MS?,OCX,PDF,PIF,PO?,PRC,RTF,SHS,VB?,VSD,WS?,SWF,AD?,ASX,BAS,CRT,INS,ISP,MDB,MDE,PCD,PRF,REG,SCF,SCT,SHB,URL,EML,NWS)

you see -EML is in the list, but not working; do maybe " " spaces have to be there ??



the Quiscanner picks up the ext.free and the EML-file alright, but when told to delete, doesn't do anything, not even an error message..

RS-detection & actions on eicar.com ar as they should be..


(Netscape7.02 D on Win2k-all critical Updates)
???

P.S.: Mail protectiosn not set up (IMAP/SSL and don't need it anyway); only SS + P2P + IM running

Would you like any virus- or Setup-/log-files ? or is this included in the above bugfix ?

 ;)
Title: Re:No action on viruses
Post by: sedina on September 29, 2003, 08:51:52 PM
Hi,
send this e-mail to sedina@asw.cz. I will check it. thanks! If I understood it correctly, you have 2 problems:
1) RS doesn't catch 2nd attachment (with virus)
2) Quick doesn't allow any action with infected file (but catch both viruses)...

is it true?

thanks!
Title: Re:No action on viruses
Post by: whocares on September 30, 2003, 10:44:40 AM
Hi Pavel,

that's true (well, I didn't expect RS to pick up the extension-less file when I use the default extensionlist;
but for sure the .EML-File)

I'll send the files 2nite

and btw: how do I set the mask for extension-less files to be scanned in RS
on creating or reading ?
wasn't there a bug in 4.0 or something ?
or is it already included inherently ?