Avast WEBforum

Non-English Zone => Русский => Topic started by: Fnaq on March 02, 2013, 08:58:46 PM

Title: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: Fnaq on March 02, 2013, 08:58:46 PM
После обновления avast!Free до 8-й версии появилась возможность пользоваться расширением «avast! Ad Blocker».
Я решил попробовать, но не тут-то было.
Расширения установились, но не включаются.

(http://i.imgur.com/c33qNnu.png)

(http://i.imgur.com/hNiMyiq.png)

После простановки галки в Хроме и нажатия на кнопку в Firefox, галка моментально убирается сама собой, кнопка сама отжимается обратно.
Я не могу включить avast! Ad Blocker.
Браузеры последних версий.

Что я делаю не так?
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: George Yves on March 02, 2013, 09:09:42 PM
http://forum.avast.com/index.php?topic=116266.msg904010#msg904010

Всё это относится и к другим браузерам, использующим АВ+.
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: Fnaq on March 02, 2013, 09:12:43 PM
Quote
Аваст 8 использует блокировщик рекламы, основанный на AdBlock Plus (с подпиской EasyList). Поэтому вам нужно выбирать какой блокировщик использовать - в браузере или антивирусе. Оба одновременно они работать не могут - если один включён, то второй автоматически отключается.

Спасибо. Жаль, что об этом приходится узнавать таким образом.
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: George Yves on March 02, 2013, 09:30:08 PM
Сочувствую, но с другой стороны это великолепная реклама исходному АВ+. :)

В принципе, многие современные браузеры - Фаерфокс, Симанки, Хром (и его клоны) и Опера - уже давно используют АВ+ и его моды, так что Адблокер Аваста предназначен прежде всего для пользователей Интернет Эксплорера и других, редких браузеров. Кроме того, Адблокер, в отличие от АВ+, не имеет настроек и не может добавлять и изменять подписки.
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: Fnaq on March 02, 2013, 09:45:10 PM
Очистка браузеров от расширений и панелей:

(http://i.imgur.com/EomqGvQ.png)

Откуда берётся пользовательский рейтинг? Я не обнаружил возможности повлиять на него.
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: George Yves on March 02, 2013, 10:30:30 PM
Рейтинг берётся с сайтов по установке расширений типа АМО (для продуктов Мозиллы, например) и из Аваста его изменять невозможно.
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: Fnaq on March 02, 2013, 11:23:11 PM
Вижу явное несоответствие. Я даже пересчитал, получил 4,3.
(http://i.imgur.com/xt4g6gW.png)

На иллюстрации видно, что последний раз дополнение оценивалось аж 21 января 2013 (https://addons.mozilla.org/ru/firefox/addon/pagesaver/reviews/), т.е. трудно сослаться на немного устаревшие сведения.

Это, конечно, не претензия: просто заметка.
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: antrox on March 03, 2013, 07:32:21 AM
Автор, чтобы Avast AdBlock заработал - нужно отключить в ваших браузерах соплатформенный AdBlock Plus.

А у кого расширения Avast AdBlock вообще нету - идём в настройки > интеграция браузера > установить.

Фильтрует кстати очень достойно, на уровне папы AdBlock Plus.
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: George Yves on March 03, 2013, 07:37:31 AM
antrox
Адблокер Аваста, в отличие от "папы", работает только по одной подписке EasyList и не может быть перенастроен.
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: antrox on March 03, 2013, 07:51:12 AM
работает только по одной подписке EasyList
Я знаю, я уже писал Авастовцам предложение добавить возможность добавлять подписки на другие языки.
При небольшой доработке будет лучшее решение.

С другой стороны AdBlock Plus по умолчанию тоже лишь одну подписку устанавливает... Большая часть людей так и пользуется. В принципе хватает. По крайней мере для Эксплорера ничего лучше в природе нет.
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: George Yves on March 03, 2013, 08:00:32 AM
работает только по одной подписке EasyList
Я знаю, я уже писал Авастовцам предложение добавить возможность добавлять подписки на другие языки.
При небольшой доработке будет лучшее решение.
Тогда, во-первых, сильно усложнится код антивируса. А во-вторых, может обостриться проблема с лицензированием: АВ+ лицензируется как "ПО с открытым исходным кодом", а Аваст таковым не является. На форуме русской Мозиллы этим уже заинтересовались: http://forum.mozilla-russia.org/viewtopic.php?id=58245

Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: _George_ on May 08, 2013, 12:51:01 PM
А можно ли как-то заполучить файл расширения авастовского эдблока без установки аваста?
В т.ч. не только для IE, но и для других доступных браузеров?
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: _George_ on May 08, 2013, 02:56:12 PM
Просто странно, что adblock доступен в списках плагинов для браузеров, а авастовский нет.
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: George Yves on May 08, 2013, 04:37:27 PM
Авастовский Адблок - это элемент антивируса, а не браузера и отключать его можно только в самом антивирусе. Подписка в нём постоянная и неизменямая, так зачем тогда отображать его в списке плагинов браузера?
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: _George_ on May 09, 2013, 11:13:53 AM
Ага, а в первом посте этой темы не хром и огнелис? Скорей не элемент, а "входит в комплект поставки". Учитывая, что эдблок плюс покруче авастовского огрызка вообще странно, что не сделали отдельно как browser cleanup распространение плагинами для браузеров.
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: Andrey,pro on May 09, 2013, 11:37:43 AM
не вижу смысла делать Avast! Ad Blocker в виде отельного дополнения к браузерам
Учитывая, что эдблок плюс покруче авастовского огрызка
его просто никто не будет устанавливать, когда есть дополнение с большим функционалом и настройками, которых нет в Avast! Ad Blocker
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: afix on May 09, 2013, 07:21:00 PM
Ad blocker идёт отдельной программой в компьютере: когда даже я удалил аваст - адблокер продолжал функционировать самостоятельно. Преимущество его в том,что он пытается обслуживать ВСЕ браузеры на компе,а AdBlock+ к каждому браузеру нужно отдельно загружать плагин.
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: afix on May 15, 2013, 12:21:39 PM
Что-то этот Адблокер авастовский какой-то кривой,косой и недоделанный :-[ Вчера обновил Firefox до 21.0,адблокер аваста вообще исчез из браузера,а аваст пишет,что установлен. Я уже и удалял его,и снова включал - он в дополнениях Огнелиса даже не значится! :o Проверил Хром и IE- то же самое. Я в раздумьях... :-\
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: George Yves on May 15, 2013, 06:56:01 PM
Я не провидец, но пока бы поостерёгся винить во всём именно Аваст. Я не ставил авастовский Адблок, потому что предпочитаю АВР в Фаерфоксе, и не могу ничего утверждать, но обновление Фаерфокса до версии 21 какое-то странное в отношении дополнений и плагинов: из списка установленных пропали плагины медиаплееров (у меня - WMP QuickTime), при этом сами плееры нормально установлены в ОС.
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: afix on May 15, 2013, 07:23:30 PM
Я не провидец, но пока бы поостерёгся винить во всём именно Аваст. Я не ставил авастовский Адблок, потому что предпочитаю АВР в Фаерфоксе, и не могу ничего утверждать, но обновление Фаерфокса до версии 21 какое-то странное в отношении дополнений и плагинов: из списка установленных пропали плагины медиаплееров (у меня - WMP QuickTime), при этом сами плееры нормально установлены в ОС.
да,в этом обновлении я тоже заметил некоторые странности...
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: George Yves on May 15, 2013, 10:05:25 PM
afix
Офф-топ, но...

С плагинами вроде бы разобрался: https://forum.mozilla-russia.org/viewtopic.php?pid=612882#p612882  А второй способ мне разъяснили тут: https://forum.mozilla-russia.org/viewtopic.php?pid=612886#p612886

Попробуй какой-нибудь из этих способов, если пропали плагины. Может тогда и проблема с Адблок решится. Но не забудь бэкап Фаерфокса сделать сначала.
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: BlaCK_SOKOL on May 17, 2013, 12:51:48 PM
в последнюю версию мозиллы он не устанавливается, пишет ошибка.
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: afix on May 17, 2013, 12:56:20 PM
в последнюю версию мозиллы он не устанавливается, пишет ошибка.
А я забил на него и поставил старый добрый AdBlock+ - он устанавливается без ошибок  ;)
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: Nicholas@ on June 06, 2013, 07:52:04 AM
господа кто нибуть знает как включить это Ad Blocker
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: afix on June 06, 2013, 08:16:26 AM
господа кто нибуть знает как включить это Ad Blocker
оно Вам надо? ???
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: George Yves on June 06, 2013, 02:54:52 PM
господа кто нибуть знает как включить это Ad Blocker
1) Удалить АВР+ из Фаерфокса и его аналоги из других браузеров
2) Удалить сторонние программы типа AdMuncher
3) Заново переустановить Аваст, подключив этот модуль в кастомной установке
4) Разрешить его подключение в браузере, если браузер (как тот же Фаерфокс) спросит на это разрешение
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: Nicholas@ on June 07, 2013, 11:20:01 AM
оно Вам надо? ???
оно мне очень надо 8)
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: Nicholas@ on June 07, 2013, 11:21:56 AM
1) Удалить АВР+ из Фаерфокса и его аналоги из других браузеров
2) Удалить сторонние программы типа AdMuncher
3) Заново переустановить Аваст, подключив этот модуль в кастомной установке
4) Разрешить его подключение в браузере, если браузер (как тот же Фаерфокс) спросит на это разрешение
спасибо друг ;) только я переставил аваст и удалил свои AdMuncher и все получилось
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: amid525 on June 07, 2013, 12:24:19 PM
Зря. Ad muncher, по лучше гораздо. )
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: afix on June 08, 2013, 01:18:21 PM
Зря. Ad muncher, по лучше гораздо. )
Он-то получше,но за него платить надо,а активация кряками очень сложная и часто срывается ;)
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: Goga 525iA on June 08, 2013, 05:25:33 PM
Так, между прочим... Попробовал поюзать этот avast! Ad Blocker на деле в IE10... Буквально через 15 минут удалил его с компа (через настройки avast!).
Да, рекламу режет, но... Режет её так, что некоторые нужные мне сайты попросту не грузятся или грузятся будто кто-то сайт "ломанул" (или там сервак глючит) - например http://kinozal.tv/ .
Добавлять в исключения каждый неправильно отображающийся сайт не вижу смысла. Посему, пусть лучше будет с рекламой, зато показываться будет как положено.
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: amid525 on June 08, 2013, 05:30:56 PM
Посему, пусть лучше будет с рекламой, зато показываться будет как положено.
Тоже не выход, весь хлам загружать и смотреть.
Лучше-уж, пользоваться настраиваемыми браузерными блокерами (если проблема Ad muncher найти)
Для Опера - наилучший ContentBlockHelper.  И рекламу режет, и скрипты.
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: Goga 525iA on June 08, 2013, 06:11:58 PM
Тоже не выход, весь хлам загружать и смотреть.
Знаешь... Жил же я как-то без этой программы до этого, совершенно не зная о её существовании - и дальше буду.
Уж лучше пусть сайты будут с рекламой, зато на экране монитора будет виден корректно отображающийся контент, нежели "огрызки" после "работы" avast! Ad Blocker
"Такой хоккей нам не нужен!" © Николай Озеров ;)
Title: Re: avast! Ad Blocker 8.0 установился в браузеры, но не включается
Post by: amid525 on June 08, 2013, 06:25:27 PM

Знаешь... Жил же я как-то без этой программы до этого, совершенно не зная о её существовании - и дальше буду.

Ну да.. Разные грыжи и целлюлиты рассматривать.  Кайф.  ;D .  Я тоже раньше(года 3-4), всю эту ересь смотрел(когда не подозревал что есть вообще банерезки)
Quote
Уж лучше пусть сайты будут с рекламой, зато на экране монитора будет виден корректно отображающийся контент, нежели "огрызки" после "работы" avast! Ad Blocker
Так я и пишу - много других блокеров и без глюков..
Плюс, страницы быстрее грузятся, фильтруя ненужный мусор.