Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: Don Gray on March 07, 2013, 03:35:07 PM

Title: Fatal Error in GC
Post by: Don Gray on March 07, 2013, 03:35:07 PM
I get this error when running the Unity 3D Editor after about twenty minutes.
If I turn off Avast 8 it does not happen.
Title: Re: Fatal Error in GC
Post by: Asyn on March 07, 2013, 03:44:01 PM
Please update to V 8.0.1483
Title: Re: Fatal Error in GC
Post by: Don Gray on March 07, 2013, 03:59:44 PM
Ran the update, didn't it go back one digit from 1484 to 1483?
Will test.
Title: Re: Fatal Error in GC
Post by: Asyn on March 07, 2013, 04:02:04 PM
1. Ran the update, didn't it go back one digit from 1484 to 1483?
2. Will test.

1. No, last one was 1482.
2. OK
Title: Re: Fatal Error in GC
Post by: Don Gray on March 07, 2013, 04:40:11 PM
No, still crashed with the error after about 20 minutes, as before.
It also has been reported to the Unity developers and they are looking at it.
Title: Re: Fatal Error in GC
Post by: Asyn on March 07, 2013, 04:56:42 PM
It also has been reported to the Unity developers and they are looking at it.

Maybe they could contact avast!: http://www.avast.com/contact-form.php
Title: Re: Fatal Error in GC
Post by: Don Gray on March 07, 2013, 05:39:56 PM
If they find it is not something they can fix, I'm sure they will.
Title: Re: Fatal Error in GC
Post by: DoctorWhy on March 08, 2013, 12:36:57 AM
I am having this exact same issue. Is there a way to add Unity to some type of trusted software on my computer so I can make this not happen?  This is starting to effect my work. Also, since Unity's development cycle is rather long, it would be better fixed by the software that is causing the issue, AKA, Avast 8.
Title: Re: Fatal Error in GC
Post by: VirtualSUN on March 08, 2013, 04:31:13 AM
Same thing with "Unity 4"
Avast 8.0.1483
Title: Re: Fatal Error in GC
Post by: forgon on March 21, 2013, 01:24:53 PM
I am using Unity 4 and updated to Avast 8 and this problem started for me as well. It not only crashes the editor but it apperantly affects standalone unity games as well.
Title: Re: Fatal Error in GC
Post by: Helgor on June 12, 2013, 08:49:27 PM
Same here but with 2 Games using Unity Engine.
One crashes 1-5 seconds after start , the other crashes randomly.
Deactivate Avast donĀ“t help.Actuel Version installed.
Both Games runs fine before this issue started.


Something new on this thing?
Title: Re: Fatal Error in GC
Post by: Asyn on June 12, 2013, 08:53:23 PM
Uncheck: Settings -> Toubleshooting -> Enable hardware-assisted virtualization
Title: Re: Fatal Error in GC
Post by: Helgor on June 12, 2013, 09:20:11 PM
Uncheck: Settings -> Toubleshooting -> Enable hardware-assisted virtualization

Yeah , thx u very much , now the Games work.
Title: Re: Fatal Error in GC
Post by: Asyn on June 12, 2013, 09:26:34 PM
You're welcome.
Title: Re: Fatal Error in GC
Post by: Drejer on June 19, 2013, 05:48:58 PM
Uncheck: Settings -> Toubleshooting -> Enable hardware-assisted virtualization

Sorry to hop on board here, but is this safe? I need to disable it to run Scrolls, but should I be worried about having it unchecked?
Title: Re: Fatal Error in GC
Post by: Asyn on June 20, 2013, 07:10:01 AM
Uncheck: Settings -> Toubleshooting -> Enable hardware-assisted virtualization

Sorry to hop on board here, but is this safe? I need to disable it to run Scrolls, but should I be worried about having it unchecked?

It's safe, nothing to worry.
Title: Re: Fatal Error in GC
Post by: Drejer on June 21, 2013, 06:18:42 AM
Thanks for the response. :)
Title: Re: Fatal Error in GC
Post by: Asyn on June 21, 2013, 06:32:36 AM
You're welcome.
Title: Re: Fatal Error in GC
Post by: iTsMeNi on June 23, 2013, 08:12:14 PM
Today I had the same problem when I tried to play GT Legends.

BSOD PAGE_FAULT_IN_NONPAGED_AREA STOP 0x00000050 caused by ntoskrnl.exe.

I googled it and after a while I found this thread. I disabled the hardware-virtualisation feature as suggested and now I can play GT Legends without any hickups :-).

So thank you guys!