Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: AveryLuna on March 09, 2013, 01:04:03 AM

Title: Updating free issue
Post by: AveryLuna on March 09, 2013, 01:04:03 AM
So I got a code for the free Avast subscription for another year, the issue is the code I got isn't what I need.  I need a license file and it asks me to open a file, of course all I have is the code.
Title: Re: Updating free issue
Post by: DavidR on March 09, 2013, 01:13:59 AM
Are you sure that you are using the free version and not a trial version of pro/ais ?

If you are you are trying to enter it into the Upgrade option that is the only way you would be asked for a license file, e.g. you clicked the Insert license file ?

How much longer have you got to run on your existing registration period ?
Title: Re: Updating free issue
Post by: MrLewk on March 10, 2013, 12:45:31 PM
I have the same issue with the Free AV.

The registration email says:

Quote
To insert your license key, please follow the instructions below:

1. Highlight the license key above, then right click on it and select "Copy"
2. Open your avast Free Antivirus and select the Maintenance" tab on the left side. Then select "Registration"
3. Click the "Insert the license key" button at the bottom of the screen.
4. Right click in the empty Registration box then select "Paste"
5. Click "OK". Your license key is now inserted and the program can now be used free of charge for a further 12 months.


Yet the registration section only has this:
(http://www.dev.webbossuk.com/uploads/1.jpg)

Clicking on the "Register Now" button just gives this error:

(http://www.dev.webbossuk.com/uploads/2.jpg)


There is no option to copy/paste a license code, just a button to upload one and a broken register button.
Title: Re: Updating free issue
Post by: DavidR on March 10, 2013, 01:04:18 PM
I know what the email said, but you have to remember that when you use the on-line registration form, when they email the license they are going to send you instructions in how to enter it manually. Unfortunately it doesn't look like those instructions have caught up with avast 8.

The more important thing is the error message window.
This 'The AAVM subsystem detected an RPC error." has in the past been associated with another antivirus still installed or remnants of one.

Have (or did) you another Anti-Virus installed in this system, if so what was it and how did you get rid of it ?

####
You could try a repair of avast (though if the error is related to another AV, it is unlikely to work):
XP - Add Remove programs, select 'avast! Anti-Virus,' click the Change/Remove button and select Repair, click next and follow.

Vista, win7 - Control Panel, Programs & Features, uninstall a program, select 'avast! Anti-Virus,' click the Uninstall/Change and select Repair, click next and follow.

You may need to reboot after the repair.
Title: Re: Updating free issue
Post by: MrLewk on March 10, 2013, 01:20:12 PM
I know what the email said, but you have to remember that when you use the on-line registration form, when they email the license they are going to send you instructions in how to enter it manually. Unfortunately it doesn't look like those instructions have caught up with avast 8.

The more important thing is the error message window.
This 'The AAVM subsystem detected an RPC error." has in the past been associated with another antivirus still installed or remnants of one.

Have (or did) you another Anti-Virus installed in this system, if so what was it and how did you get rid of it ?

####
You could try a repair of avast (though if the error is related to another AV, it is unlikely to work):
XP - Add Remove programs, select 'avast! Anti-Virus,' click the Change/Remove button and select Repair, click next and follow.

Vista, win7 - Control Panel, Programs & Features, uninstall a program, select 'avast! Anti-Virus,' click the Uninstall/Change and select Repair, click next and follow.

You may need to reboot after the repair.


Hi DavidR, thanks for the info about the error. I only had Avast 7 and did the automatic update and then got these errors, plus my existing license vanished and after the initial update, it seemed to think I was on a trial period for the paid Avast (which I had not opted for)! I tried the repairs and uninstall/reinstall and still couldn't register.

BUT - thankfully now I've sorted it! I'll leave the details here for others to see in case your tips don't solve the issue:


(http://www.dev.webbossuk.com/uploads/3.jpg)

Sorted :)
Title: Re: Updating free issue
Post by: DavidR on March 10, 2013, 01:32:40 PM
You're welcome.

Yes, your installation must have been corrupted, as that Off-line option was previously there on earlier avast versions. That said because it seemed to think you started off with a trial version that off-line registration option wouldn't have been displayed.

The clean reinstall would have been the next step if the Repair hadn't worked, but I go for the less hassle route first ;D

Thanks for the image it may be helpful for others.

Glad that all is now as it should be.