Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: joanlui on March 06, 2003, 01:10:30 AM

Title: The Bat! Emailer
Post by: joanlui on March 06, 2003, 01:10:30 AM
Hi,

What about Avast!4 and The Bat! emailer? Are there a plugin?

Thanks,

Fabio (Italy)
Title: Re:The Bat! Emailer
Post by: Jirka on March 06, 2003, 05:17:09 AM
That would be great to know as I to am using The Bat!
Title: Re:The Bat! Emailer
Post by: Vlk on March 06, 2003, 09:33:59 AM
Hi,

basically, the answer is yes, you can use avast! with The Bat!. :)

However, you'll have to set it up manually because the Mail Protection Wizard has no direct support for it at the moment.

In short, all you have to do is slightly change the settings of your mail accounts in The Bat!, and add the names of your SMTP/POP3/IMAP server(s) to the file avast4.ini.

For detailed instructions, please refer to avast online help, page "Setting Up the Mail Protection" --> "Manual Setting of Mail Protection".

Hope this helps,
Vlk
Title: Re:The Bat! Emailer
Post by: joanlui on March 06, 2003, 03:36:07 PM
OK! I solved my problem.... ;)

bye!

FORZA ASCOLI!
Title: Re:The Bat! Emailer
Post by: Vlk on March 06, 2003, 04:12:39 PM
Good.  ;)

BTW who is Ascoli?  :D

Vlk
Title: Re:The Bat! Emailer
Post by: joanlui on March 06, 2003, 09:18:50 PM
Ascoli is my favourite football team... ;D

www.ascolicalcio.it

bye
Title: Re:The Bat! Emailer
Post by: Gu3 on May 26, 2003, 11:00:03 PM
VLK, I realize this is quite an old post, but thanks for the tip.  I was able to get Avast! and The Bat! working quite nicely together.  

Unfortunately, I'm one of those strange people that use multiple accounts within The Bat!  each with different SMTP and POP3 servers.  

Is there any intention to support mulitple accounts within the ini file format?  Or can I hijack one of the other services (like the Lookout Express or Internet mail providers) and use them for my purpose?

Right now I'm running my primary account on Avast! with no problems, however my secondary account is fully exposed!  

Any suggestions?

Thanks and regards.
Scott...
Title: Re:The Bat! Emailer
Post by: joanlui on May 26, 2003, 11:24:34 PM
Hi,
simply add all your accounts in the .ini file as pop or smtp!

Bye!
Title: Re:The Bat! Emailer
Post by: Gu3 on May 26, 2003, 11:42:14 PM
Joanlui,

Thanks for the reply, but I'm missing something here.  The only settings in the .ini file that I can manipulate seem (for this purpose) seem to be:

DefaultPopServer=mail.myserver.mycom
DefaultSmtpServer=smtp.myserver.mycom

I tried adding lines thus:
PopServer=othermail.myotherserver.mycom
SmtpServer=othersmtp.myotherserver.mycom

and the default is used instead.  How did you accomplish multiple accounts?

Regards and thanks
Scott
Title: Re:The Bat! Emailer
Post by: joanlui on May 27, 2003, 06:09:55 AM
Hi...

simply add all your accounts as DEFAULT accounts... ;)

For example...

DefaultPopServer=mail.tibernet.it
DefaultPopServer=pop.blu.it
DefaultSmtpServer=smtp.cheapweb.it
DefaultSmtpServer=smtp.blu.it

Fabio Monteverde, Italy
Title: Re:The Bat! Emailer
Post by: vojtech on May 27, 2003, 10:41:12 AM
It is not working this way. Duplicitous entries will be ignored.
For POP, avast takes the server address from the username in your mail account (username#server). If there is no '#' in the username, it takes DefaultPopServer.
For SMTP, avast takes always DefaultSmtpServer. Support for multiple SMTP servers will be added in the near future.
Title: Re:The Bat! Emailer
Post by: Gu3 on May 27, 2003, 07:58:00 PM
Thanks Fabio and Vojtech.

So, if I change my second account's User (login) info to point to 127.0.0.1, and then change my actual userid to say something like
mySID#mail.myaccount.com, it will GET mail from the correct POP server, but always try to SEND mail to the default SMTP server?

Hmmm.  I'm at work now, so I don't have a way to test this.  But when I get home I'll give it a try.  Thanks.

Fabio...yours works as you show it?  I might try that just to see what happens... thanks for the tip.

Scott...
Title: Re:The Bat! Emailer
Post by: Gu3 on May 28, 2003, 04:25:35 AM
Sweet!

Changing my user-id in the account properties to user#mail.server.com
and pointing The Bat! @ 127.0.0.1 for POP3 on my secondary account worked perfectly!  A little obtuse, but it works perfectly.  I'm not really all that concerned about outgoing email from that account anyway, as now everything is scanned on incoming, and AVAST! Seems to keep itself pretty well updated.

I look forward to the next release however with multiple SMTP support!  Thanks Vojtech and Fabio for your assistance with this.  This capability merely ensures that I will be a longtime AVAST! User.

Scott...