Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: rwishlaw on September 19, 2003, 10:17:30 AM

Title: Mozilla Email Password Problem
Post by: rwishlaw on September 19, 2003, 10:17:30 AM

Windows XP

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030916

Version 4.1-268
VPS 0309-1

The latest Avast program update (yesterday) has caused my Mozilla EMail password not to be recognized

when I try to send mail out

and I get a dialog titled

Mail Server Password Required.

which I fill in with the password but it pops up again.

I have reinstalled Avast and Mozilla several times and Mozilla is OK until I install Avast.

Title: Re:Mozilla Email Password Problem
Post by: vojtech on September 22, 2003, 04:15:48 PM
What username did avast set for outgoing mail (SMTP) in Mozilla Mail account settings?
Title: Re:Mozilla Email Password Problem
Post by: Amerk_5 on September 28, 2003, 01:12:25 AM
Using Mozilla Mail 1.5 RC2 (Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20030925) with Win98SE I had the same problem.

What I did to fix it was open avast4.ini & change UseDefaultSmtp=0 to UseDefaultSmtp=1. Then I terminated & restarted ashmaisv. I was then able send mail.
Title: Re:Mozilla Email Password Problem
Post by: Amerk_5 on September 28, 2003, 03:14:50 AM
I was able to get Mozilla Mail & avast to send & receive mail from my pop account & I was also able to get MM, avast, & YahooPops working but now I'm having some trouble.

As I said in my previous post, adding UseDefaultSmtp=1 to avast4.ini allowed me to send mail from my pop account. The problem is I can't send mail with YP. If I change UseDefaultSmtp=1 to UseDefaultSmtp=0 I can send with YP but not pop. Is there anything I can add/change in avast4.ini to be able send mail with both accounts?

Here's what I have setup for my pop account.
Incoming-
Server name: 127.0.0.1
Username: hitman00#pop3.frontiernet.net
Port: 110

Outgoing-
Server name: 127.0.0.1
Username: hitman00#mail.frontiernet.net
Port: 25
Use SSL: When available

Here's what I have for my yahoo account.
Incoming-
Server name: localhost
Username: kcchiefs_21#127.0.0.1:111
Port: 110

Outgoing-
Server name: localhost
Username: kcchiefs_21#127.0.0.1:26
Port: 25
Use SSL: When available
Title: Re:Mozilla Email Password Problem
Post by: Amerk_5 on September 29, 2003, 05:01:40 PM
Anybody have any ideas or should I just login to yahoo mail with my browser to reply to any email & have my pop account setup to send?
Title: Re:Mozilla Email Password Problem
Post by: vojtech on September 30, 2003, 04:15:09 PM
I think your setup is correct, it should work with UseDefaultSmtp=0. Does it work when you send from pop account without avast (i.e. Server name: mail.frontiernet.net, User name: hitman00) ?
Title: Re:Mozilla Email Password Problem
Post by: Amerk_5 on September 30, 2003, 05:26:03 PM
I think your setup is correct, it should work with UseDefaultSmtp=0. Does it work when you send from pop account without avast (i.e. Server name: mail.frontiernet.net, User name: hitman00) ?

It works just fine without avast. With avast & UseDefaultSmtp=0 Mozilla keeps prompting me for a password 2 seconds after I just entered it. And I know the password is right.

Setting use SSL to Never or When Available & Moz keeps prompting me for a password. Setting use SSL to Always & I get an error from Moz, "Sending of message failed. Unable to connect to SMTP server 127.0.0.1...." I also get this error after I hit cancel on the password prompt with use SSL at Never or When Available.
Title: Re:Mozilla Email Password Problem
Post by: vojtech on October 01, 2003, 11:21:14 AM
Could you plase send me the detailed log by mail, as described here: http://www.avast.com/forum/index.php?board=2;action=display;threadid=1195;start=msg6918#msg6918 (http://www.avast.com/forum/index.php?board=2;action=display;threadid=1195;start=msg6918#msg6918)
Title: Re:Mozilla Email Password Problem
Post by: Amerk_5 on October 01, 2003, 05:02:10 PM
Could you plase send me the detailed log by mail, as described here: http://www.avast.com/forum/index.php?board=2;action=display;threadid=1195;start=msg6918#msg6918 (http://www.avast.com/forum/index.php?board=2;action=display;threadid=1195;start=msg6918#msg6918)


Done. Email sent.
Title: Re:Mozilla Email Password Problem
Post by: vojtech on October 01, 2003, 05:19:45 PM
Please try this fix: http://www2.asw.cz/~peterka/test2/ashMaiSv.exe (http://www2.asw.cz/~peterka/test2/ashMaiSv.exe)
(Terminate process ashMaiSv.exe, copy the downloaded file to avast4 folder and start it.)
Title: Re:Mozilla Email Password Problem
Post by: Amerk_5 on October 01, 2003, 05:32:12 PM
Excellent!! I can send mail from both accounts now!

That was a quick fix. What's the difference between the 2 ashMaiSv.exe?
Title: Re:Mozilla Email Password Problem
Post by: vojtech on October 02, 2003, 10:17:20 AM
If the username is 'name#smtpserver' and the SMTP server doesn't support authentication, the first ashMaiSv.exe fails, which is fixed in the second one. If the username was '#smtpserver', it would work in both cases.