Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: tcw on May 08, 2013, 05:50:02 AM

Title: Avast 8 won't install on Vista SP2
Post by: tcw on May 08, 2013, 05:50:02 AM
Avast Free version 8 install fails. It had Avast on it a while ago, but the End User put a lot of other crap on this unit since the last time I touched it last year, including other antivirus and security crap which I cleaned out before trying to reinstall Avast.

The Avast install log mentions this:

26.04.201321:19:19Return code: 0x000036B1 [The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log for more detail.]

Event Log (Windows):

Log Name:      Application
Source:        SideBySide
Date:          4/26/2013 9:32:06 PM
Event ID:      59
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      xxxxxxxx
Description:
Activation context generation failed for "C:\Program Files\AVAST Software\Avast\ashBase.dll".Error in manifest or policy file "C:\Windows\WinSxS\manifests\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.6161_none_50934f2ebcb7eb57.manifest" on line 0. Invalid Xml syntax.


Did an sfc /scannow

Beginning system scan.  This process will take some time.

Beginning verification phase of system scan.
Verification 100% complete.
Windows Resource Protection found corrupt files but was unable to fix some of th
em.
Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For example
C:\Windows\Logs\CBS\CBS.log

The system file repair changes will take effect after the next reboot.


Any ideas how to fix this, short of a nuke and pave of the hard drive?

I've run the Avast cleaner, reinstalled all of the MS C++ packages to no avail...
Title: Re: Avast 8 won't install on Vista SP2
Post by: Eddy on May 08, 2013, 10:53:52 AM
It normally is a issue with visual c++.
Since (as you say) the user had a lot of crap on it and you "cleaned" the system....
It can be a lot (and really mean a lot!) of things causing the problem.
I would say, don't make it hard on yourself and just install Windows-7 (if the system can handle it)
If not, install Windows-XP (ofcourse with all available updates)
Title: Re: Avast 8 won't install on Vista SP2
Post by: Para-Noid on May 08, 2013, 07:19:29 PM
I would be wary of installing XP as support will end in less than a year.  :)
Title: Re: Avast 8 won't install on Vista SP2
Post by: DavidR on May 08, 2013, 07:41:37 PM
As mentioned the Side-By-Side Configuration is Incorrect Error in avast is usually related to C++ normally it means the required version isn't present - You need to install MS Visual C++ 2008 Redistributable.

You need 2008 SP1 - this is the one:
Microsoft Visual C++ 2008 SP1 Redistributable Package ATL Security Update (http://www.microsoft.com/downloads/en/details.aspx?FamilyID=2051a0c1-c9b5-4b0a-a8f5-770a549fd78c)
Note this link there are 64bit versions there (IA64, x64) ensure you get the correct one for your OS (x86 32bit OS, x64 64bit OS)