Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: is2see on September 28, 2003, 07:42:56 AM

Title: Avast Res. Won't Start After Upgrade
Post by: is2see on September 28, 2003, 07:42:56 AM
I recently upgraded my Avast.

Now Avast doesn't open on boot up. I get the red line showing no resident protection, on the Avast icon.

If I double click on the icon I get the message"The AAVM subsystem detected a RPC error"
The operation could not be completed.

If I right click the icon, the menu appears, but when I go into the Start Protection skin and choose the standard protection and close the skin, the Avast icon still shows the red line.

Previously this method of starting the protection would work.

I am running Win2K
I recently selected to have users press control alt delete to log on, but have now unchosen this option and rebooted.

I have also uninstalled Avast and reinstalled the prog with an updated registration #, Avast did a scan during bootup but failed to start the resident protection.
Title: Re:Avast Res. Won't Start After Upgrade
Post by: Vlk on September 28, 2003, 09:48:52 AM
Please go to the Control Panel, Administrative Tools, Services and try to start the "avast antivirus" service manually. Is this possible? If not, what error message are you getting?

If you're getting a message about dependency service, make sure that the Remote Procedure Call (RPC) service is running - avast has a dependency on this service and cannot operate without it.

Thanks,
Vlk
Title: Re:Avast Res. Won't Start After Upgrade
Post by: is2see on September 28, 2003, 05:50:38 PM
Tried starting Avast manually from control panel..
Title: Re:Avast Res. Won't Start After Upgrade
Post by: Vlk on September 28, 2003, 09:24:50 PM
What?? :o :o :o
Seems like the file is corrupted or something. Please try to do a repair of the installation: Control Panel, Add/Remove Programs, avast!, Change, Repair.

Thanks
Vlk
Title: Re:Avast Res. Won't Start After Upgrade
Post by: is2see on September 28, 2003, 11:47:32 PM
Well, the program couldn't repair itself, so I uninstalled deleted and redownloaded.

This time I tried the cz link for the file and reinstalled.

I have the same problem and the same response to the manual start.....
Title: Re:Avast Res. Won't Start After Upgrade
Post by: Lisandro on September 29, 2003, 03:19:18 AM
If you're getting a message about dependency service, make sure that the Remote Procedure Call (RPC) service is running - avast has a dependency on this service and cannot operate without it.
Thanks,
Vlk

Hey is2see, are you sure that RPC Service is running and starting automatically with Windows?
If it is, the behavior of your system is very strange like Vlk said  :o
Title: Re:Avast Res. Won't Start After Upgrade
Post by: is2see on September 30, 2003, 04:43:32 AM
Ya, thats just my luck...

There are two RPC progam type applications, both automatic, both started.

Same error.

I even uninstalled and went back to the older Avast version...it's doing the same thing.
Title: Re:Avast Res. Won't Start After Upgrade
Post by: Lisandro on October 01, 2003, 04:56:20 AM
Please, Vlk, come on! Help us as you usually does...  ;)