Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: MarkR on October 06, 2003, 10:36:33 PM

Title: Problem with Cirillic
Post by: MarkR on October 06, 2003, 10:36:33 PM
I am so distressed with these space gobbling bug that I completely forgot about my question I wanted to ask you since I updated to 4.1. So, here it is. I have question marks instead of names of folders. I name some folders in Russian. It does not impede on the performance, but would be interesting to know, why. I have XPpro MUI and everything else is fine.
Title: Re:Problem with Cirillic
Post by: Vlk on October 06, 2003, 10:39:25 PM
Maybe post a screenshot.

And version 4.0 was OK?? So the behavior changed between 4.0 and 4.1? :o
Title: Re:Problem with Cirillic
Post by: MarkR on October 06, 2003, 10:45:17 PM
So it seems.
Title: Re:Problem with Cirillic
Post by: kubecj on October 06, 2003, 11:35:24 PM
This occurs when there is a UNICODE (16bit) -> ANSI (8bit) conversion and some characters are missing in the ANSI table. Such are then replaced by special character, which is often a question mark.

My guess is that you're running on english NT based os, but without Russian (or whatever cyrillic nationality you may be) ANSI codepages installed as default language. Is that the case?

As Windows Exploder is an Unicode app, it has no problem, since no conversion occurs. Avast is ANSI application (it has to work on W9x which support Unicode only poorly), so it may have certain problems with displaying characters which don't fit into default ANSI codepage.

Title: Re:Problem with Cirillic
Post by: MarkR on October 07, 2003, 06:21:24 AM
I DO NOT KNOW WHAT TO SAY... I mentioned before - I am running Windows XP pro with MUI and Russian installed. My OS default language is Russian and interface is Russian. Where else do I look to correct the situation
Title: Re:Problem with Cirillic
Post by: Vlk on October 07, 2003, 02:26:47 PM
So in the Control Panel, Regional Settings, Advanced, what's in the first drop-down box ? (see the attached screenshot). Russian? I guess it should be Russian, in your case...
Title: Re:Problem with Cirillic
Post by: MarkR on October 07, 2003, 03:31:28 PM
You guessed right... ;D
Title: Re:Problem with Cirillic
Post by: MarkR on October 07, 2003, 03:32:07 PM
OOPS! Forgot the proof...
Title: Re:Problem with Cirillic
Post by: Vlk on October 07, 2003, 03:41:14 PM
Ok, try the following "hack":

Open the file <avast>\data\avast4.ini, and to the [Languages] section, add the following line:

0419=Russian

Also, change the line Engine=<some_number> to

Engine=1049

Now copy the contents of the <avast>\English folder to <avast>\Russian .
And then, start avast again.
That could help.

Vlk
Title: Re:Problem with Cirillic
Post by: igor on October 07, 2003, 03:46:58 PM
I guess you don't have to try - this will not work, unfortunatelly :(
Title: Re:Problem with Cirillic
Post by: MarkR on October 07, 2003, 04:27:19 PM
I did try and yes! - it did not work...
Version 4 did not have such problem, though...