Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Beta - Avast => Topic started by: gg41 on October 11, 2014, 09:07:34 AM

Title: BUG 2015 RC1 Exclusions URLs
Post by: gg41 on October 11, 2014, 09:07:34 AM
Hello,

Not taking account of the request for exclusions made by the user. Continues to block access despite the request of the user.

Example: http://www.zone-telechargement.com/  (no virus detected on this site)



Title: Re: BUG 2015 RC1 Exclusions URLs
Post by: lukor on October 11, 2014, 10:21:29 PM
Are you reporting that the programs ignores URL exlusions from its settings or that avast virus database hasn't been updated yet to remove this URL from blocked URLs list?

Title: Re: BUG 2015 RC1 Exclusions URLs
Post by: DavidR on October 11, 2014, 10:55:46 PM
There was an issue with Exclusions earlier when the web shield started scanning https traffic,  but it places an http: tag in front of the https url entered, just as it has for a very long time. Used the above url changed to https as an example.

Not wanting to too far off topic:
There are other issues with the Exclusions function - alerts on Hardened Mode (Aggressive), the Add to Exclusion... doesn't work (it doesn't add it). Manually adding it and OKing your way out doesn't work either, when you open the Exclusions again the entry you just copied into the Hardened Mode has gone.
Title: Re: BUG 2015 RC1 Exclusions URLs
Post by: gg41 on October 12, 2014, 08:22:58 AM
Are you reporting that the programs ignores URL exlusions from its settings or that avast virus database hasn't been updated yet to remove this URL from blocked URLs list?

Yes to both


There was an issue with Exclusions earlier when the web shield started scanning https traffic,  but it places an http: tag in front of the https url entered, just as it has for a very long time. Used the above url changed to https as an example.

it does not work, you can not access the site (I have to completely disable Avast, which is unfortunate)
Title: Re: BUG 2015 RC1 Exclusions URLs
Post by: DavidR on October 12, 2014, 04:00:55 PM
<snip quote>
There was an issue with Exclusions earlier when the web shield started scanning https traffic,  but it places an http: tag in front of the https url entered, just as it has for a very long time. Used the above url changed to https as an example.

it does not work, you can not access the site (I have to completely disable Avast, which is unfortunate)

My comment was more of an expansion to Lukor as there are other issues in the exclusions.

Don't completely disable avast, you would be completely unprotected. The web shield is what is looking after the web browsing side and no doubt alerting, so disabling that still leaves you the fall back of the file system shield.

I have visited the home page of the link you gave and no alert by avast, I'm using firefox 32.0.3, with noscript and requestpolicy. These would ordinarily protect against scripts on the site and third party scripts (on other sites).

I have selectively allowed permissions and I still don't get an alert -  can you attach a screenshot of the avast alert window.
Title: Re: BUG 2015 RC1 Exclusions URLs
Post by: Eddy on October 12, 2014, 04:41:00 PM
Website is opening fine with all shields enabled.
Title: Re: BUG 2015 RC1 Exclusions URLs
Post by: gg41 on October 12, 2014, 07:43:31 PM
Avast enabled: unable to access the site (this is the only site where I have a problem) as well with Chromium and IE browser.

Avast disabled (Web agent): no problem accessing the site.

With Avast 9: no problem
Title: Re: BUG 2015 RC1 Exclusions URLs
Post by: RejZoR on October 12, 2014, 09:37:15 PM
It seems that exclusions are entirely broken and non functional. File shield exclusions don't work for me, apparently web shield exclusions also don't work hm...
Title: Re: BUG 2015 RC1 Exclusions URLs
Post by: DavidR on October 12, 2014, 11:26:37 PM
It seems that exclusions are entirely broken and non functional. File shield exclusions don't work for me, apparently web shield exclusions also don't work hm...

Neither do the Hardened Mode exclusions, all in all a bit of a mess considering these were reported early on this beta testing session and her we are in an RC1 state ???

Something that I also noticed, exclusions previously present in the Hardened Mode exclusions were duplicated, one group, then a blank entry and then repetition. To resolve that I deleted all of the first group and the blank entry - now there are no entries in the Hardened Mode exclusions.
Title: Re: BUG 2015 RC1 Exclusions URLs
Post by: lukor on October 13, 2014, 12:52:40 AM
gg41, Rejzor, could you guys post screenshots with your exclusions set and the page that gets blocked (e.g. at least the virus name reported on the page).

Just tested it now nad url exclusions seem to work as they should for me.

thnks.
lukor
Title: Re: BUG 2015 RC1 Exclusions URLs
Post by: Charyb on October 13, 2014, 04:57:27 AM
I had a problem with hardened mode exclusions. I had AIS regular release installed then downloaded and installed the RC over the top. Hardened mode popup showed so I added the Release Candidate installation setup to exclusions. It still wouldn't run. I did it a second time and installer was still blocked from running. I ended up turning off all shields then was able to install it. It is also strange that in the exclusion list that there is an exclamation to the right and a blank line in between.


see attached.
Title: Re: BUG 2015 RC1 Exclusions URLs
Post by: gg41 on October 13, 2014, 01:36:01 PM
@lukor
gg41, could you guys post screenshots with your exclusions set and the page that gets blocked.

Example: http://www.zone-telechargement.com/  (no virus detected on this site)




Title: Re: BUG 2015 RC1 Exclusions URLs
Post by: jursa on October 13, 2014, 02:50:24 PM
@gg41:
- your issue is more related to FW/Network drivers - because of chrome err_network_access_denied exception. Webshield URL exclusions helps only for content scanning..
- it is happened only for http://www.zone-telechargement.com/ domain ? Other domains works ?

Could you please send us a support package ?
- download & run http://public.avast.com/supp/util/avastSupport.exe
- click to Generate now! and then post package ID (or send it directly to me; jursa(at)avast.com)

Thnx a lot,
David
Title: Re: BUG 2015 RC1 Exclusions URLs
Post by: gg41 on October 13, 2014, 04:27:32 PM
@jursa

I have sent directly to Jursa (at) avast.com.

Good reception.
Title: Re: BUG 2015 RC1 Exclusions URLs
Post by: RejZoR on October 14, 2014, 10:47:51 AM
Ok, so here we go. A systematic test of all exclusions and also Site Blocking...

Web Shield exclusions (URLs to exclude field):
http://www.eicar.org/download/eicar.com
https://secure.eicar.org/eicar.com

HTTP one gets a "Connection reset" in Firefox and no EICAR file is dropped to my Downloads folder. Also no avast! File System Shield detection popup!
HTTPS is excluded correctly and EICAR is detected by the File System Shield, however a 0 byte EICAR file remains in my Downloads folder.

Site Blocking
http://www.eicar.org/download/eicar.com
https://secure.eicar.org/eicar.com

Both links were blocked, however i only got a blocking message for HTTPS connection. For the HTTPS i only got a blank tab. Is that a bug or intended behavior? Shouldn't it display a webpage blocked by avast! message for both?

Global exclusions (URLs tab):
http://www.eicar.org/download/eicar.com
https://secure.eicar.org/eicar.com

HTTP one gets a "Connection reset" in Firefox and no EICAR file is dropped to my Downloads folder. Also no avast! File System Shield detection popup!
HTTPS is excluded correctly and EICAR is detected by the File System Shield, however a 0 byte EICAR file remains in my Downloads folder.
Title: Re: BUG 2015 RC1 Exclusions URLs
Post by: Roman Svihalek on October 14, 2014, 05:29:51 PM
I tried avast! IS with the settings you mentioned with the Firefox 32.0.3 on Win8.1 and found no problem.
Title: Re: BUG 2015 RC1 Exclusions URLs
Post by: Roman Svihalek on October 15, 2014, 10:57:45 AM
Both links were blocked, however i only got a blocking message for HTTPS connection. For the HTTPS i only got a blank tab. Is that a bug or intended behavior? Shouldn't it display a webpage blocked by avast! message for both?

In both first sentences you mentioned HTTPS - can I ask you to specify the case blocked page is shown to you? HTTP or HTTPS? Thank you
Title: Re: BUG 2015 RC1 Exclusions URLs
Post by: RejZoR on October 15, 2014, 11:40:42 AM
Yeah, sorry for that it was a typo. However, after re-testing this with RC2 just now, i now properly get message (Website blocked by avast!) for both HTTP and HTTPS so it seems all is fine now.
Title: Re: BUG 2015 RC1 Exclusions URLs
Post by: gg41 on October 18, 2014, 08:35:26 AM
Hello,

Still no communication from the "staff Avast" on Web exclusions that do not work?
Title: Re: BUG 2015 RC1 Exclusions URLs
Post by: CraigB on October 18, 2014, 08:38:28 AM
What do you call that 2 posts above your own ???
Title: Re: BUG 2015 RC1 Exclusions URLs
Post by: gg41 on October 18, 2014, 10:46:51 AM
What do you call that 2 posts above your own ???

It does not respond to my question or my problem, it's just an assertion.

Read my posts.
Title: Re: BUG 2015 RC1 Exclusions URLs
Post by: DavidR on October 18, 2014, 04:06:17 PM
The Hardened Mode (Aggressive) Add an exclusions... option (in the alert window) doesn't appear to be creating an exclusion.

However, I missed it first time round and used the 'Show last popup message' option on the avast tray icon - when that alert window was displayed again and I used the Add an exclusions... - I don't know if using in these circumstances (re-displaying the popup) the Add an exclusions... is active.

Slightly better news is that copying and pasting path into the Hardened Mode exclusions appears to remain after having closed down the UI. Will have to see if this stops the repetitive popup.