Avast WEBforum

Avast Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: redjak on March 07, 2015, 12:27:14 AM

Title: Latest AVAST update appears to block the FREAK attack
Post by: redjak on March 07, 2015, 12:27:14 AM
Saw something while reading the news about a new SSL/TLS vulnerability called the FREAK attack. Being curious, I tested my computers using the https://freakattack.com/ (https://freakattack.com/) test page. This page reported that both Firefox browser and Internet Explorer browser were vulnerable on my computers. I didn't expect the Firefox browser to fail, so I searched the Firefox forum and found a post saying an Avast update fixed this. Which sounded curious, but turned out to be true. Updating Avast program and virus definitions fixes the vulnerability for both Firefox and Internet Explorer on my computers. Thanks for the updated program (2015.10.2.2214)!
Title: Re: Latest AVAST update appears to block the FREAK attack
Post by: abruptum on March 07, 2015, 11:22:32 AM
I can confirm this. IE11 and FF 36.0.1 are not vulnerable with Avast 2015.10.2.2214.
Title: Re: Latest AVAST update appears to block the FREAK attack
Post by: Eddy on March 07, 2015, 11:24:38 AM
Opera 12.17
Windows XP sp3
All shields disabled
Not vulnerable  ;D
Title: Re: Latest AVAST update appears to block the FREAK attack
Post by: GrēætGrįëf on March 07, 2015, 12:57:17 PM
Nice!!   :D
Title: Re: Latest AVAST update appears to block the FREAK attack
Post by: Ѕeeкɘя on March 08, 2015, 08:35:10 PM
IE 11 (11.0.16) is vulnerable here with Avast 2015.10.2.2214. Maybe that's because I am not using HTTPS scanning by Avast

Firefox 37 beta and Chrome 41 are safe from the attack.
Title: Re: Latest AVAST update appears to block the FREAK attack
Post by: Techknow on March 08, 2015, 09:11:41 PM
Opera 12.17
Windows XP sp3
All shields disabled
Not vulnerable  ;D

Go Opera!  Works for me as well.
Title: Re: Latest AVAST update appears to block the FREAK attack
Post by: miels on March 12, 2015, 02:44:46 PM
Opera 12.17
Windows XP sp3
All shields disabled
Not vulnerable  ;D
What if you have enabled your shields?
You probably want to have real time scanning of files. But once your (or at least: MY) Avast is enabled I am vulnerable. Without shields I'm safe. Well, at least for FREAK. Not for files with virusses  :-\

Program version 2015.10.0.2208 (virus definitions 150312-0)
Title: Re: Latest AVAST update appears to block the FREAK attack
Post by: CraigB on March 12, 2015, 02:52:31 PM
Program version 2015.10.0.2208 (virus definitions 150312-0)
You should check the update thread at the top of the forum, latest version is 2015.10.2.2214 so you need to update https://forum.avast.com/index.php?topic=167184.0
Title: Re: Latest AVAST update appears to block the FREAK attack
Post by: miels on March 13, 2015, 08:37:41 AM
Thanks. Just when I noted my own version I thought "Hm, there might be a new version". Which there was indeed. And it fixed it.

Nevertheless, primarily wanted to point out that testing with shields disabled isn't enough. Enabling shields can make it worse (if you're not up to date, like I was  :-[)