Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: Tuscaneer on March 17, 2015, 02:29:00 PM

Title: Black Screen - Win7 x64 after upgrade to 2015.10.2.2214
Post by: Tuscaneer on March 17, 2015, 02:29:00 PM
Hi folks,

I just updated to 10.2.2214 (free) on reboot (Win 7 64bit) I get past the login prompt and then get a black screen with mouse cursor and there it stays.
If I rename :
c:\windows\system32\drivers\aswsp.sys
and set the avast service to manual
in safe mode, it will then boot correctly (although I don't know which change fixes it.)
albeit with no running avast.
I have uninstalled avast, then checked, everything is running on reboot
I have re-installed avast, then it fails to reboot cleanly again, once more staying on a black screen.

I have run various malware scan (Malwarebytes, Roguekiller, tdsskiller, etc.) all clear.

Any clues why Avast is hanging the windows boot before it shows explorer ?
Thanks and Best Regards
Title: Re: Black Screen - Win7 x64 after upgrade to 2105.10.2.2214
Post by: Alikhan on March 17, 2015, 02:31:16 PM
Do you have any other security software running than Avast?

I'd like you to perform a clean install a final time, please folllow each instruction.

You need to perform a clean install:

Note: It's important you used the stub online installer from the one I linked.. NOT the offline one.

Note: You need to be ONLINE during this install (online installer works in all cases whereas offline sometimes doesn't)

1.Download your version of avast! and the avastclear tool:
Avast Free Antivirus (https://www.avast.com/en-us/download-thank-you.php?product=FAV-TAG&locale=en-us&tag=dsFklWM1)
Avast Pro Antivirus (http://files.avast.com/iavs9x/avast_pro_antivirus_setup.exe)
Avast Internet Security (http://files.avast.com/iavs9x/avast_internet_security_setup.exe)
Avast Premier (http://files.avast.com/iavs9x/avast_premier_antivirus_setup.exe)
Download Avast Clear Tool (http://www.avast.com/en-gb/uninstall-utility)

2. Uninstall Avast by control panel  [If you don't have Avast in control Panel go to #3]
3. Uninstall in safe mode using Avastclear. [Running Avastclear is normal mode will give a prompt to go into Safe Mode]
Check : Once uninstalled check in device manager>view>show hidden devices if there is anything related to avast with a yellow triangle.. if so, uninstall it and reboot.
5. Install the version you downloaded.
6. Reboot.

Note : If you have a paid license, insert the license key/activation code after the reboot at stage 6.

If you have any questions, please don't hesitate to ask. It's better to ask than make a mistake and start over again with the process.
Title: Re: Black Screen - Win7 x64 after upgrade to 2105.10.2.2214
Post by: Tuscaneer on March 17, 2015, 02:35:08 PM
Thanks, as soon as the current ESET scan finishes I will go through this.
Title: Re: Black Screen - Win7 x64 after upgrade to 2105.10.2.2214
Post by: Alikhan on March 17, 2015, 02:36:50 PM
Thanks, as soon as the current ESET scan finishes I will go through this.

That is fine.

Though, there is a malware removal board where experts help to remove malware on your system (if any) on this forum too.

I'd recommend trying the clean install and if that doesn't work, I'll divert you for expert help for malware removal.
Title: Re: Black Screen - Win7 x64 after upgrade to 2105.10.2.2214
Post by: Tuscaneer on March 17, 2015, 03:39:50 PM
Hi,

ok I previously removed avast,  in safe mode, as stated above, on reboot, everything worked.
this time, in safe mode, I uninstalled avast, then ran the "Avast Clear Tool" in safe mode too.
I then removed the devices as advised.
now when I reboot, we're in the same black screen boat. what did the "Avast Clear Tool" actually do ?
Title: Re: Black Screen - Win7 x64 after upgrade to 2105.10.2.2214
Post by: Alikhan on March 17, 2015, 03:42:11 PM
Hi,

ok I previously removed avast,  in safe mode, as stated above, on reboot, everything worked.
this time, in safe mode, I uninstalled avast, then ran the "Avast Clear Tool" in safe mode too.
I then removed the devices as advised.
now when I reboot, we're in the same black screen boat. what did the "Avast Clear Tool" actually do ?

Avast clear tool is a tool from avast which removes avast completely from the system.

Did you uninstall from control panel, reboot and then use the clear tool?
Title: Re: Black Screen - Win7 x64 after upgrade to 2105.10.2.2214
Post by: Tuscaneer on March 17, 2015, 03:43:48 PM
Actually no, in safemode, I uninstalled from control panel, then ran the Avast Clear Tool then rebooted.
Title: Re: Black Screen - Win7 x64 after upgrade to 2105.10.2.2214
Post by: Alikhan on March 17, 2015, 03:44:47 PM
Reboot into safe mode again and re-run avast clear please.

Thanks.
Title: Re: Black Screen - Win7 x64 after upgrade to 2105.10.2.2214
Post by: Tuscaneer on March 17, 2015, 03:46:13 PM
ok, done..   rebooting back into full mode to test.
Title: Re: Black Screen - Win7 x64 after upgrade to 2105.10.2.2214
Post by: Tuscaneer on March 17, 2015, 03:57:25 PM
ok, rebooted in full mode after running the Avast Clear in safe mode.  went to black screen after login prompt accepted, but this time I waited.. after a few minutes a small white box with "please wait" came up on the screen, another few minutes later it booted into windows.
something definitely amiss !
Title: Re: Black Screen - Win7 x64 after upgrade to 2105.10.2.2214
Post by: Alikhan on March 17, 2015, 03:58:53 PM
Have you tried rebooting again?

Is there a delay?

Any other security software than avast?

Do you have many programs set to run at user logon?
Title: Re: Black Screen - Win7 x64 after upgrade to 2105.10.2.2214
Post by: Tuscaneer on March 17, 2015, 04:05:46 PM
no other active security products,

will try rebooting again now to see if it does the same.

just a couple of startup programs in the  "All Programs/ Startup" menu
Title: Re: Black Screen - Win7 x64 after upgrade to 2105.10.2.2214
Post by: bob3160 on March 17, 2015, 04:08:44 PM
The delay could also be from the recent patch Tuesday Windows Updates
if you haven't rebooted since that occurrence.
Title: Re: Black Screen - Win7 x64 after upgrade to 2105.10.2.2214
Post by: Tuscaneer on March 17, 2015, 04:17:37 PM
Ok, same delay, about 5 minutes of black screen after login .

the system has been booted a few times this week.

Title: Re: Black Screen - Win7 x64 after upgrade to 2105.10.2.2214
Post by: Rednose on March 17, 2015, 04:26:17 PM
Hi,

Can you look at this tutorial https://forum.avast.com/index.php?topic=53253.0

Scroll down to "Farbar Recovery Scan Tool" and follow the directions for that tool only.
Attach the FRST.txt and Additions.txt here in your next reply.

As soon as you have done that, I will notify Essexboy to help you  :)

Greetz, Red.
Title: Re: Black Screen - Win7 x64 after upgrade to 2105.10.2.2214
Post by: essexboy on March 17, 2015, 04:33:07 PM
Are you able to boot into safe mode or normal mode ?
Title: Re: Black Screen - Win7 x64 after upgrade to 2105.10.2.2214
Post by: Tuscaneer on March 17, 2015, 04:40:58 PM
Hi Rednose, here are the files:
Title: Re: Black Screen - Win7 x64 after upgrade to 2105.10.2.2214
Post by: Tuscaneer on March 17, 2015, 04:42:50 PM
Hi Essexboy, I boot into safemode cleanly, but I get black screen for about 5 or 6 minutes when going into normal mode after logon
Title: Re: Black Screen - Win7 x64 after upgrade to 2015.10.2.2214
Post by: essexboy on March 17, 2015, 06:51:52 PM
OK that gives me a good clue as to where the problem lies.  All that is showing on the logs are some old adware and orphans so we will clear those first.  Run this fix from safe mode, then reboot to safe mode for the next part

CAUTION :  This fix is only valid for this specific machine, using it on another may break your computer

Open notepad and copy/paste the text in the quotebox below into it:
 
Quote
HKU\S-1-5-18\...\RunOnce: [SpUninstallDeleteDir] => rmdir /s /q "\SearchProtect"
ShellIconOverlayIdentifiers: [00avast] -> {472083B0-C522-11CF-8763-00608CC02F24} =>  No File
SearchScopes: HKLM-x32 -> DefaultScope value is missing.
Toolbar: HKLM - No Name - {CC1A175A-E45B-41ED-A30C-C9B1D7A0C02F} -  No File
FF SearchEngineOrder.1: Secure Search
FF Plugin-x32: @mcafee.com/MVT -> C:\Program Files (x86)\McAfee\Supportability\MVT\NPMVTPlugin.dll [2013-02-05] (McAfee, Inc.)
FF SearchPlugin: C:\Program Files (x86)\mozilla firefox\browser\searchplugins\McSiteAdvisor.xml [2013-12-09]
2015-03-17 15:14 - 2013-10-22 18:49 - 00000000 ____D () C:\ProgramData\boost_interprocess
Task: {8082D92C-1DAD-4483-9441-D0F05DBFCB2B} - \BackgroundContainer Startup Task No Task File <==== ATTENTION
RemoveProxy:
EmptyTemp:
CMD: bitsadmin /reset /allusers

 
Save this as fixlist.txt, in the same location as FRST.exe
(https://dl.dropboxusercontent.com/u/73555776/FRSTfix.JPG)
Run FRST and press Fix
On completion a log will be generated please post that


THEN

In the search box type Msconfig and select the programme that appears at the top

1.In the System Configuration Utility dialog box, click Selective Startup on the General tab.
(https://dl.dropboxusercontent.com/u/73555776/Cleanboot1.JPG)
2.Click to clear the Load Startup Items check box.
NoteThe Use Original Boot.ini check box is unavailable.
3.Click the Services tab.
4.Click to select the Hide All Microsoft Services check box.
(https://dl.dropboxusercontent.com/u/73555776/cleanboot2.JPG)
5.Click Disable All, and then click OK.
6.When you are prompted, click Restart.
7.Reboot to normal mode and let me know how that goes
Title: Re: Black Screen - Win7 x64 after upgrade to 2015.10.2.2214
Post by: Tuscaneer on March 17, 2015, 08:18:05 PM
Thanks Essexboy,
so here is the fixlog.txt attached.

I disabled all but the microsoft services in msconfig, and the boot into normal is quick, no 6 minute delay on black screen.

Is the next step to re-introduce them  set at a time ?

Title: Re: Black Screen - Win7 x64 after upgrade to 2015.10.2.2214
Post by: essexboy on March 17, 2015, 08:37:55 PM
Unfortunately yes, one of the services is causing a conflict.  You could do them in groups and reboot in between.  That would make it a tad faster 
Title: Re: Black Screen - Win7 x64 after upgrade to 2015.10.2.2214
Post by: Tuscaneer on March 18, 2015, 12:45:53 AM
ok thanks.. I went through re-introducing the services in logical batches, with all enabled still booting properly.. so it must be one of the registry startup programs.. will run through them tomorrow..
thanks all for your help, I'll report back
Title: Re: Black Screen - Win7 x64 after upgrade to 2015.10.2.2214
Post by: jursa on March 18, 2015, 11:50:46 AM
Hi Tuscaneer, for proper analysis of your problem we need a complete memory dump (manually generated BSOD) when the black screen appears. Could you, please, provide it for us ?

Before test, you need a little bit set up your system:
1.) Download BellaVista - http://www.zezula.net/en/fstools/bellavista.html
2.) In SafeMode launch BellaVista.exe and in the "Crash Dump" tab click to "Full Dump" and reboot the computer
3.) When the black screen appears hold the right CTRL key and press "Scroll Lock" twice - bluescreen your system
4.) Boot into SafeMode with networking and there will be MEMORY.DMP in the "C:\Windows" folder.
5.) Launch avast support tool (http://public.avast.com/supp/util/avastsupport.exe) navigate to "advanced" tab and check "Full dumps" then click to "Generate Now!"
(or just compress the MEMORY.DMP file (using zip/rar) with some password and upload it on some share services like mega.co.nz/googledrive and send me a link. )

If you need additional assistance contact me please directly at jursa@avast.com.

Thanks and sorry for your troubles,
David
Title: [FIXED] : Black Screen - Win7 x64 after upgrade to 2015.10.2.2214
Post by: Tuscaneer on March 18, 2015, 07:25:55 PM
No need Jursa.

Thanks Essexboy, for pointing me back to basics :-)
I've re-enabled all the services, and re-added the registry startups I actually need running.
rebooted and all good.
I've now re-installed Avast 10.2.2214, and rebooted.. all good.

Cheers.
Title: Re: Black Screen - Win7 x64 after upgrade to 2015.10.2.2214
Post by: essexboy on March 18, 2015, 07:33:28 PM
Glad all is now well :)
Title: Re: Black Screen - Win7 x64 after upgrade to 2015.10.2.2214
Post by: Tuscaneer on March 19, 2015, 03:10:37 PM
I spoke too soon.. back to black screen on start up... 
Title: Re: Black Screen - Win7 x64 after upgrade to 2015.10.2.2214
Post by: Alikhan on March 19, 2015, 03:12:21 PM
I spoke too soon.. back to black screen on start up...

Could you submit your memory dump to Jursa?

I don't think this issue is related to avast! but rather to a conflicting startup entry.

By sending Jursa the dump, it will be easier for avast! to spot the issue (if any).
Title: Re: Black Screen - Win7 x64 after upgrade to 2015.10.2.2214
Post by: Tuscaneer on March 19, 2015, 04:49:35 PM
I've nailed it..

IBM Trusteer Endpoint Protection was updated at around the sametime as Avast. 
Removed that and re-installed avast again... 6 reboots in a row now clean.

Cheers
Title: Re: Black Screen - Win7 x64 after upgrade to 2015.10.2.2214
Post by: essexboy on March 19, 2015, 06:38:50 PM
That uses low level drivers just like Avast
Title: Re: Black Screen - Win7 x64 after upgrade to 2015.10.2.2214
Post by: bob3160 on March 19, 2015, 06:44:14 PM
Just curious as to which program was installed first. Avast or Trusteer ???
It is quite possible that the order in which these programs are installed determines if they compliment or destroy each other ???