Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: hectic-mmv on March 23, 2015, 06:21:59 PM

Title: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: hectic-mmv on March 23, 2015, 06:21:59 PM
Hi all,

we have just released update of Avast 2015 R2 SP1(build number 2015.10.2.2215).

Build contains these fixes:
-          Unable to insert Avast SecureLine license
-          Failed to load language dll [1033\UILangRes.dll] error after update
-          Mail Shield blocked Windows Live Mail connection
-          BCU problems with removing addons in silent mode

And some minor internal fixes for BSODs


How to install:

1. If you have installed some version before you can update it to this latest version via Settings->Update->Program.

2. Or you can download and install from here:

http://files.avast.com/iavs9x/avast_free_antivirus_setup.exe
http://files.avast.com/iavs9x/avast_pro_antivirus_setup.exe
http://files.avast.com/iavs9x/avast_internet_security_setup.exe
http://files.avast.com/iavs9x/avast_premier_antivirus_setup.exe

Avast cleaner:
http://files.avast.com/iavs9x/avastclear.exe

It should be possible to install this version on top of your existing avast! installation (all settings should be preserved).

To report BSODs, crashes or any other none trivial problems please use new SupportPackage generating tool.
- http://utils.support.tools.avast.com/tools/support/utils/avastsupport.exe

Instructions how to use it can be easily found:
- https://www.avast.com/en-us/faq.php?article=AVKB33#artTitle


Thank you and enjoy new version,
Avast team
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: abumalek_2013 on March 23, 2015, 06:26:30 PM
hi  and thanks alot
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: DavidR on March 23, 2015, 06:39:56 PM
Are we sure that this topic Title is the correct build 2015.10.2.2215, as we already have build 2015.10.2.2215 ?


Manual update reports already up to date ?
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: hectic-mmv on March 23, 2015, 06:44:33 PM
Are we sure that this topic Title is the correct build 2015.10.2.2215, as we already have build 2015.10.2.2215 ?


Manual update reports already up to date ?

You are on the beta channel. See beta9x in the server name. Now the same binaries have been released to release channel.

Both channels, beta and release are the same.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: DavidR on March 23, 2015, 06:51:37 PM
Are we sure that this topic Title is the correct build 2015.10.2.2215, as we already have build 2015.10.2.2215 ?


Manual update reports already up to date ?

You are on the beta channel. See beta9x in the server name. Now the same binaries have been released to release channel.

Both channels, beta and release are the same.

Thanks, doesn't take much to confuse me ;D
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: abruptum on March 23, 2015, 06:58:39 PM
Updated through the GUI and everything is fine except NG or whatever it is called now was installed,
although I didn't have it installed before. This happens when I don't follow my rule to manually update things.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: DavidR on March 23, 2015, 07:06:26 PM
Updated through the GUI and everything is fine except NG or whatever it is called now was installed,
although I didn't have it installed before. This happens when I don't follow my rule to manually update things.


You can remove it in the normal way - control panel - programs & features - avast - Change. The new name for NG is 'Secure Virtual Machines' somewhat different to NG.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: EmoHobo on March 23, 2015, 07:25:18 PM
I see avast is back down to only running a single AvastUI.exe by default.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: abruptum on March 23, 2015, 07:31:25 PM
Updated through the GUI and everything is fine except NG or whatever it is called now was installed,
although I didn't have it installed before. This happens when I don't follow my rule to manually update things.


You can remove it in the normal way - control panel - programs & features - avast - Change. The new name for NG is 'Secure Virtual Machines' somewhat different to NG.
Already did that. I agree that new name - Secure Virtual Machines is somewhat different to NG,but I didn't know how to translate it from Croatian.So,now I know - Secure Virtual Machines.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: lucD on March 23, 2015, 07:50:22 PM
Installed fine via GUI ... streaming updates still playing up though!
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: Lyon :)) on March 23, 2015, 07:53:49 PM
Updating now .. :)

Thanks avast!
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: DavidR on March 23, 2015, 07:55:39 PM
Installed fine via GUI ... streaming updates still playing up though!

Streaming updates are outside of program versions - so that wouldn't change on the program update if you were having problems previously.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: lucD on March 23, 2015, 08:04:18 PM
Quote
Streaming updates are outside of program versions - so that wouldn't change on the program update if you were having problems previously.
I know ... it was just a cheeky off-topic attempt to get a comment from Avast on the streaming update issue.   ;)
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: Rednose on March 23, 2015, 08:26:23 PM
Are we sure that this topic Title is the correct build 2015.10.2.2215, as we already have build 2015.10.2.2215 ?


Manual update reports already up to date ?

You are on the beta channel. See beta9x in the server name. Now the same binaries have been released to release channel.

Both channels, beta and release are the same.

Thanks, doesn't take much to confuse me ;D

You are not alone. I was also trying to update  ;D

Greetz, Red.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: iroc9555 on March 23, 2015, 09:03:35 PM
Installed through UI and rebooted. Everything seems fine, but when running Smart Scan Windows alert me of Avast UI error and must close it but it does not. It keeps scanning.

Aplication with errores: avastui.exe, version: 10.2.2215.880, module with error: libcef.dll, version 3.2171.1929.0, address with error 0x01cf3006.

Will wait for another reboot or repair. If error still shows. I will try a clean install.

Update: It seems that a repair got rid of the UI error.

Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: Staticguy on March 23, 2015, 09:13:47 PM
To Avast Team,

I have updated successfully to this new version via Avast GUI, but this bug still exits https://forum.avast.com/index.php?topic=167408.0. Couple of weeks ago when I had the previous version of avast, I have sent a support package to Avast via the avastsupport.exe

File ID: SDFUN

Last time I heard that it's in the QA Department.

Any updates on this? When will this bug get fixed?
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: iroc9555 on March 23, 2015, 10:02:53 PM
To Avast Team,

I have updated successfully to this new version via Avast GUI, but this bug still exits https://forum.avast.com/index.php?topic=167408.0. Couple of weeks ago when I had the previous version of avast, I have sent a support package to Avast via the avastsupport.exe

File ID: SDFUN

Last time I heard that it's in the QA Department.

Any updates on this? When will this bug get fixed?

Yeap!! It is still happening. Red my Network security but it is installed and active according to Avast Security information in my account.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: Alikhan on March 23, 2015, 10:17:57 PM
Update went fine on 3 machines.

No issues to report.

Thanks.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: Staticguy on March 23, 2015, 10:53:22 PM
To Avast Team,

I have updated successfully to this new version via Avast GUI, but this bug still exits https://forum.avast.com/index.php?topic=167408.0. Couple of weeks ago when I had the previous version of avast, I have sent a support package to Avast via the avastsupport.exe

File ID: SDFUN

Last time I heard that it's in the QA Department.

Any updates on this? When will this bug get fixed?

Yeap!! It is still happening. Red my Network security but it is installed and active according to Avast Security information in my account.

Glad that I am not the only person facing this bug. On the security tab it has a tick on mail shield. I don't even have mail shield installed. Only web and file shield, software updater, and home network security.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: mchain on March 24, 2015, 07:17:45 AM
Clean install of 10.2.2215 AIS.  Uninstalled old version 10.0.2208 using Programs and Features and aswclear.exe.  Full offline installer run.
Other noticed behavior listed below in attachments:

Third attachment likely has nothing to do with avast; Flash Player plug-in for Firefox remains running after FF is closed or suddenly appears after FF is closed and hangs until manually closed in Task Manager if FF is run unsandboxed.  But these (2) Flash Player processes cause Avast Sandbox to hang either way for at least 20 seconds or more until the sandbox is able to terminate FP plugin processes.  Same exact behavior seen in Sandboxie. 

5 Flash Player plugins running in Task Manager window below likely is the result of opening and closing FF three times in normal unsandboxed mode and none of the earlier processes were terminated prior even tho FF appeared to close normally each time.

Possible conflict/hang with Malware Anti-Exploit noted in running Avast Sandbox and Firefox.  May be the root cause of the black window seen in attachment # 1.

Much better version than 10.2.2214 just previous.   Https works in sandboxed mode.  Good job.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: Ѕeeкɘя on March 24, 2015, 01:48:39 PM
I have to ask this: Doesn't avast know what components are installed on a user's system and update only those components? Why does it install the component named Secure Virtual Machine (NG) then even when the previous version opted out of it? I don't understand your reason for doing so. There is a reason why some of us just don't want some features and chose not to install but then you have to screw it on the next update?
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: abruptum on March 24, 2015, 02:36:39 PM
I have to ask this: Doesn't avast know what components are installed on a user's system and update only those components? Why does it install the component named Secure Virtual Machine (NG) then even when the previous version opted out of it? I don't understand your reason for doing so. There is a reason why some of us just don't want some features and chose not to install but then you have to screw it on the next update?

I uninstalled Secure Virtual Machines,but then I decided to install it again since now it should work with Windows 7 x86.
How to test if it is working ?
I also have this warning after installation of SVM :

http://oi62.tinypic.com/28sog0g.jpg
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: AshevilleHawker on March 24, 2015, 05:37:45 PM
I am still having the BSOD issues on first boot with Avast Pro 2015.10.2.2215 that I had with 2015.10.2.2214 (but not 2015.10.0.2208)
avastsupportR2.exe used - report #X2SMC. I will start a new thread regarding this issue.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: Avq2315 on March 24, 2015, 09:04:59 PM
Having just updated on Windows 8.1 I noticed that Windows Defender had been reactivated after restart and had to be deactivated manually.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: -Genesis- on March 25, 2015, 06:21:55 AM
It seems this build fixed the sandboxie but i noticed my system slows by this update.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: DavidR on March 25, 2015, 05:13:27 PM
Updated through the GUI and everything is fine except NG or whatever it is called now was installed,
although I didn't have it installed before. This happens when I don't follow my rule to manually update things.


You can remove it in the normal way - control panel - programs & features - avast - Change. The new name for NG is 'Secure Virtual Machines' somewhat different to NG.

Confirmed, I had previously uninstalled this module in my win7 netbook, and an update from the UI didn't honour the existing modules.

To be honest it should never have been installed first time round as the netbook is so under powered it was crippled by NG. Someone really has to look at the required resources for NG and above all if it isn't installed on a previous version it shouldn't be installed on an update from the UI, when you don't get the opportunity to do a custom update.

Acer Aspire One, Win7 Starter (32bit) 10.1", 1024X600 screen, 2GB DDR3 RAM, Intel Atom N255 (1.5GHz dual core) CPU and 250GB HDD.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: avaster78 on March 25, 2015, 06:51:22 PM
AvastUI.exe again down to 1 after 2015.10.2.2215 update. Is this correct?
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: DavidR on March 25, 2015, 09:47:59 PM
AvastUI.exe again down to 1 after 2015.10.2.2215 update. Is this correct?

No my XP Pro system it was always one, but would rise when the UI was opened and if other data was being downloaded for displaying stats, etc.

My win7 netbook, previously had two, but now has one, opening the UI doesn't increase but also will generate another instance if data is to be downloaded, as the instance above.

For now it looks like it is back down to one.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: aztony on March 25, 2015, 09:59:57 PM
After reading thru this thread I have a partial understanding of the issue I experienced. When I installed .2214 a couple weeks back I elected to custom install thereby selecting what I wanted installed. Among what I unchecked was 'Secure Virtual Machines'. When I update to .2215 thru the GUI, based on what others have posted, the update included 'Secure Virtual Machines.' It shouldn't have, and that led to my BSOD problem. When I did a clean install hoping it would solve the problem, unwittingly I did select 'Secure Virtual Machines.' And it took me right back to square one, BSOD. Still awaiting word on just why NG was crashing my system.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: MikeBCda on March 26, 2015, 10:36:24 PM
No problems updating through the UI.  Interestingly, this time I did get the Chrome opt-out screen after rebooting, so maybe they're headed in the right direction.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: Foola on March 29, 2015, 12:54:00 AM
Avast services crash when I typing exclusions Path contain (*) wildcard

At Deep Scan Exclusions, I typing
ie.
?:\Windows\servicing\TrustedInstaller.exe
?:\Windows\WinSxS\amd64_microsoft-windows-servicingstack_*\TiWorker.exe
and click OK to close the settings window.

move mouse over the Asast systay icon say "You are unprotected"
right-click on Avast icon, Avast shields control, re-enble All shields
Avast main window show"You are unprotected and avast services not working"
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: CheckMate on March 29, 2015, 10:05:20 PM
is it final version or not?
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: Staticguy on March 29, 2015, 10:13:35 PM
is it final version or not?

Yes it is.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: jursa on March 30, 2015, 09:42:35 AM
Avast services crash when I typing exclusions Path contain (*) wildcard

At Deep Scan Exclusions, I typing
ie.
?:\Windows\servicing\TrustedInstaller.exe
?:\Windows\WinSxS\amd64_microsoft-windows-servicingstack_*\TiWorker.exe
and click OK to close the settings window.

move mouse over the Asast systay icon say "You are unprotected"
right-click on Avast icon, Avast shields control, re-enble All shields
Avast main window show"You are unprotected and avast services not working"

Hi,
can you generate support package and send it to us? Please, don't forget to mark down it's ID and post it here.
Using this tool http://public.avast.com/supp/util/avastsupportR2.exe

Thank you,
David
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: -midnight on March 30, 2015, 08:50:22 PM
Just updated on my Window's 8.1 with no problems.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: mchain on March 31, 2015, 06:56:35 PM
Running AIS 2015.10.2.2215 SP1.

Problems with avast sandbox continues:  (See attached below, also https://forum.avast.com/index.php?topic=168376.msg1197205#msg1197205 (https://forum.avast.com/index.php?topic=168376.msg1197205#msg1197205))

No audio in flash when run, same symptoms as in link above, final total of 19 instances of flash running in sandbox, FP processes will not automatically terminate on close of FF browser, must use 'Terminate all' to force close of browser process and flash.  Running FF in Sandboxie has no issues as above except FP will cause hang on close for an additional 20 seconds as it waits for up to 4 instances of FP to be terminated.  Do not see as many multiple FP processes in Sandboxie as in avast sandbox.

When additional FP processes come in, FF reports a 'Not Responding' hang in avast sandbox every time.  This is reproducible.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: Rompin Raider on April 02, 2015, 06:40:01 AM
Updated on Win 7x64...smooth...thanks Avast! 8)
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: fritz_brown on April 03, 2015, 09:56:28 AM
After updating to this build, I immediately began experiencing problems with "Plugin container for Firefox has stopped working" messages. It appears to primarily be Flash Player that triggers it. The only solution seems to be to turn off "Scan for browser add-ons" under Smart Scan.

I am running Vista x64 and Firefox 36.0.4. (BTW, this totally kills the Opera browser - stops it dead.)

The only thing that changed between status of "working browser" and "non-functioning browser" was the update of my Avast version. What can be done?
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: rymnd6c28 on April 11, 2015, 12:09:45 AM
HTTPS scanning makes most website have privacy error. Im using Chrome Win 8.1, alongside with Malwarebytes. This just came out of nowhere since i already updated Avast weeks ago yet the problem only occurs now.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: mikaelrask on April 11, 2015, 08:42:00 AM
update went fine here. keep up the good work avast team  :)
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: Jaap Ton on April 12, 2015, 02:55:33 PM
I sent this file with AvastSupport.exe:

File 20150412_1239_PYS54_2124420770.zip" was successfully uploaded to server
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: Coolmario88 on April 13, 2015, 06:47:24 AM
I really probably should be asking this in my own topic but.. I am wondering anybody else getting such ads from avast free alerting about avast free business edition now?
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: Asyn on April 13, 2015, 07:04:28 AM
I am wondering anybody else getting such ads from avast free alerting about avast free business edition now?
Yes, others reported it as well.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: DavidR on April 13, 2015, 11:55:49 AM
I really probably should be asking this in my own topic but.. I am wondering anybody else getting such ads from avast free alerting about avast free business edition now?

Yes many others including myself have got this, what possessed them to stick an image to an already disliked series of popups, is beyond me.

Whist I generally have no problem with the small toaster popups, my screen resolution 1920x1200 means it is less obtrusive. Those on small low resolution screens, like my 10.1" 1024x600 win7 netbook, see it eat up a massive screen area.

For me they aren't that frequent on my win7 netbook as it isn't in use 24/7, but on my desktop system I now have that on silent/gaming mode, but there downsides on doing that.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: boe323 on April 13, 2015, 04:10:39 PM
I know this isn't the place to ask this question, but its only 1 question so theres no point in starting a topic, just want to know if I can install premier on a laptop that's been given to me and use my single licence for both desktop and laptop?
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: DJBone on April 13, 2015, 04:21:34 PM
I know this isn't the place to ask this question, but its only 1 question so theres no point in starting a topic, just want to know if I can install premier on a laptop that's been given to me and use my single licence for both desktop and laptop?
No, you must buy a second license.

DJBone
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: boe323 on April 13, 2015, 05:38:01 PM
Thanks
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: DJBone on April 13, 2015, 05:41:36 PM
You're welcome.

DJBone
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: aztony on April 13, 2015, 10:13:45 PM
Well I reinstalled Avast  2015.10.2.2215, opting out of 'Secure Virtual Machines' on my Win 7 pc. Its been up and running (2) days now without incident. Also installed it on my XP pc ('Secure Virtual Machines' was not given as an option there) after having eschewed Avast for some time due to stability issues. It, too, has been stable over the past couple of days.   
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: DavidR on April 13, 2015, 11:37:34 PM
Well I reinstalled Avast  2015.10.2.2215, opting out of 'Secure Virtual Machines' on my Win 7 pc. Its been up and running (2) days now without incident. Also installed it on my XP pc ('Secure Virtual Machines' was not given as an option there) after having eschewed Avast for some time due to stability issues. It, too, has been stable over the past couple of days.   

XP and Vista aren't currently able to run the NG 'Secure Virtual Machines' (possibly in the future, but for now it doesn't appear as an option in custom install.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: skinnypops on April 14, 2015, 03:25:16 PM
hello

actually, secure virtual machines runs just fine in vista.  find newest avast ais very easy on resources even with sec
ure virtual machines running. remains to be seen what happens when it sandboxes something though, as i'm very careful in my surfing.

a good day to all,

skinnypops
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: heikwith on April 16, 2015, 06:44:59 PM
Help,
Alle my downloads never ends in my dutch Windows 8.1 (both in 32bit and 64bit)
This happens in all the browsers, but also with online updates in applications.
When  I disable Avast all this problems are gone.
When there is a percentage displayed it happens always at 99% or 100%, so it must something be in the end of the download or direct after it.
A repair of avast and a remove + reïnstall was not the solution.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: bob3160 on April 16, 2015, 06:49:36 PM
Help,
Alle my downloads never ends in my dutch Windows 8.1 (both in 32bit and 64bit)
This happens in all the browsers, but also with online updates in applications.
When  I disable Avast all this problems are gone.
When there is a percentage displayed it happens always at 99% or 100%, so it must something be in the end of the download or direct after it.
A repair of avast and a remove + reïnstall was not the solution.
The following took care of this problem for me:
https://forum.avast.com/index.php?topic=169047.msg1201632#msg1201632 (https://forum.avast.com/index.php?topic=169047.msg1201632#msg1201632)
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: bodnarl65 on April 18, 2015, 09:48:29 AM
Hi everybody,

My problem is that, when I installed the last two versions of avast (2214 & 2215), they started to write into the
c:\System Volume Information\
folder a big file, which getting bigger and bigger, now it is some GB.

I did it on two different machine one with Win7 64bit, the another with Vista 32 bit, and all the same happened. When I went back to the older version of Avast, the extra file disappeared, when reinstalled it appeared again, so I'm sure that the extra file is written by Avast.
What can I do because with SSD every bit counts. :)

And sorry for my English! :)
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: heikwith on April 18, 2015, 04:55:44 PM
Help,
Alle my downloads never ends in my dutch Windows 8.1 (both in 32bit and 64bit)
This happens in all the browsers, but also with online updates in applications.
When  I disable Avast all this problems are gone.
When there is a percentage displayed it happens always at 99% or 100%, so it must something be in the end of the download or direct after it.
A repair of avast and a remove + reïnstall was not the solution.
The following took care of this problem for me:
https://forum.avast.com/index.php?topic=169047.msg1201632#msg1201632 (https://forum.avast.com/index.php?topic=169047.msg1201632#msg1201632)

Hello bob3160,
I followed your advice to do avastclear in safe mode and then a clean install of 2015.10.2.2215.
But my download probems are not solved.
Even the downloads that Avast needs to get the last updates after the clean install have DL problems.
So to get all the online updates I had to disable Avast itself.
AS you can see in the attachment that avast was "already up to date (current version 150323-0).
Right after that  I clicked the avast program icon but that request never ends because of the download problems.
In this 32-bit windows8.1 system (because of this "bug") even Firefox and Chrome do not there automatic updates.


Edit: Avast Team please help me to solve this.
In the meantime I wil test these download problems in Windows 10PV with Avast 2015.10.2.2217 beta2
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: bob3160 on April 18, 2015, 10:33:38 PM
Help,
Alle my downloads never ends in my dutch Windows 8.1 (both in 32bit and 64bit)
This happens in all the browsers, but also with online updates in applications.
When  I disable Avast all this problems are gone.
When there is a percentage displayed it happens always at 99% or 100%, so it must something be in the end of the download or direct after it.
A repair of avast and a remove + reïnstall was not the solution.
The following took care of this problem for me:
https://forum.avast.com/index.php?topic=169047.msg1201632#msg1201632 (https://forum.avast.com/index.php?topic=169047.msg1201632#msg1201632)

Hello bob3160,
I followed your advice to do avastclear in safe mode and then a clean install of 2015.10.2.2215.
But my download probems are not solved.
Even the downloads that Avast needs to get the last updates after the clean install have DL problems.
So to get all the online updates I had to disable Avast itself.
AS you can see in the attachment that avast was "already up to date (current version 150323-0).
Right after that  I clicked the avast program icon but that request never ends because of the download problems.
In this 32-bit windows8.1 system (because of this "bug") even Firefox and Chrome do not there automatic updates.


Edit: Avast Team please help me to solve this.
In the meantime I wil test these download problems in Windows 10PV with Avast 2015.10.2.2217 beta2
Did you first remove Avast through Programs and Features ???
I also stated that this worked for me. My system even if it's windows 8.1 may not be the same as yours and there may be other things that need to be addressed.
If you've done everything possible and still have a problem, try the following:
Submit a support ticket via  https://support.avast.com/Tickets/Submit (https://support.avast.com/Tickets/Submit)
If that still doesn't solve your problem, totally remove Avast, (you'll still have protection for Microsoft's Defender), and see if your downloads now work.
You may also want to explore the following:
https://forum.avast.com/index.php?topic=53253.0 (https://forum.avast.com/index.php?topic=53253.0)
Let us know what else we can do to help and/or, what finally solves your problem.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: heikwith on April 18, 2015, 11:26:17 PM
Help,
Alle my downloads never ends in my dutch Windows 8.1 (both in 32bit and 64bit)
This happens in all the browsers, but also with online updates in applications.
When  I disable Avast all this problems are gone.
When there is a percentage displayed it happens always at 99% or 100%, so it must something be in the end of the download or direct after it.
A repair of avast and a remove + reïnstall was not the solution.
The following took care of this problem for me:
https://forum.avast.com/index.php?topic=169047.msg1201632#msg1201632 (https://forum.avast.com/index.php?topic=169047.msg1201632#msg1201632)

Hello bob3160,
I followed your advice to do avastclear in safe mode and then a clean install of 2015.10.2.2215.
But my download probems are not solved.
Even the downloads that Avast needs to get the last updates after the clean install have DL problems.
So to get all the online updates I had to disable Avast itself.
AS you can see in the attachment that avast was "already up to date (current version 150323-0).
Right after that  I clicked the avast program icon but that request never ends because of the download problems.
In this 32-bit windows8.1 system (because of this "bug") even Firefox and Chrome do not there automatic updates.


Edit: Avast Team please help me to solve this.
In the meantime I wil test these download problems in Windows 10PV with Avast 2015.10.2.2217 beta2
Did you first remove Avast through Programs and Features ???
I also stated that this worked for me. My system even if it's windows 8.1 may not be the same as yours and there may be other things that need to be addressed.
If you've done everything possible and still have a problem, try the following:
Submit a support ticket via  https://support.avast.com/Tickets/Submit (https://support.avast.com/Tickets/Submit)
If that still doesn't solve your problem, totally remove Avast, (you'll still have protection for Microsoft's Defender), and see if your downloads now work.
You may also want to explore the following:
https://forum.avast.com/index.php?topic=53253.0 (https://forum.avast.com/index.php?topic=53253.0)
Let us know what else we can do to help and/or, what finally solves your problem.

No I did not first remove Avast through Programs and Features. Is there a difference ?
So I will try again the clean install on next Monday.
No download problems in W10PV, win7 and Vista until now.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: bob3160 on April 19, 2015, 03:28:36 PM
@ heikwith,
So you followed only a part on my advice given in the link I posted. :)
Totally removing Avast is always a two part operation.

The following took care of this problem for me:
https://forum.avast.com/index.php?topic=169047.msg1201632#msg1201632 (https://forum.avast.com/index.php?topic=169047.msg1201632#msg1201632)
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: heikwith on April 20, 2015, 08:29:45 PM
@ heikwith,
So you followed only a part on my advice given in the link I posted. :)
Totally removing Avast is always a two part operation.

The following took care of this problem for me:
https://forum.avast.com/index.php?topic=169047.msg1201632#msg1201632 (https://forum.avast.com/index.php?topic=169047.msg1201632#msg1201632)

Download problems still NOT solved.
This is what I did:
1. normal startup of my dutch windows 8.1 32bit with Avast 2215 final
2. remove Avast through Programs and Features
3. reboot in safe mode
4. avastclear in this safe mode
5. reboot normal
6. test downloads (so without Avast)
7. no download problems
8. reïnstall avast
9. Download problems again
10. disable Avast
11. no download problems
12. reboot normal
13. still Download problems
14. disable Avast
15. no download problems

Bob, I hope I still did something wrong, but I do not think so
By the way scanning of Avast, HitmanPro and HitmanPro Alert and MalwareBytes found nothing.

Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: bob3160 on April 20, 2015, 09:33:52 PM
"2. remove Avast through Programs and Features
3. reboot in safe mode
4. avastclear in this safe mode"
3 should be reboot.
4 should be run avastclear in regular mode, choose which version it is to remove and then allow it to boot into safemode to do it's job.
5 Once done, it will give you the option to boot back into regular mode.
At that time, you should be able to do a clean install. Use the custom install so you can uncheck anything you don't want.
A video to guide you through all these step is available at:
https://forum.avast.com/index.php?topic=93544.msg1201631#msg1201631 (https://forum.avast.com/index.php?topic=93544.msg1201631#msg1201631)

I have no idea if  making these changes in the procedure make a difference.
I can tell you that this is what worked for me - and, is still working for me. :)
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: heikwith on April 20, 2015, 11:50:07 PM
"2. remove Avast through Programs and Features
3. reboot in safe mode
4. avastclear in this safe mode"
3 should be reboot.
4 should be run avastclear in regular mode, choose which version it is to remove and then allow it to boot into safemode to do it's job.
5 Once done, it will give you the option to boot back into regular mode.
At that time, you should be able to do a clean install. Use the custom install so you can uncheck anything you don't want.
A video to guide you through all these step is available at:
https://forum.avast.com/index.php?topic=93544.msg1201631#msg1201631 (https://forum.avast.com/index.php?topic=93544.msg1201631#msg1201631)

I have no idea if  making these changes in the procedure make a difference.
I can tell you that this is what worked for me - and, is still working for me. :)

Sorry, still not solved.
I followed your sequence and everything happened as you said.
But no success.

Again it happened that Avast said after the clean install there were no updates after 150323-0.
That is also a download problem in Avast itself.
See the attachment (with name "no update available after clean install 2215.jpg") in one of my previous entries.
Immediately after disabling Avast the automatic update to 150419-1 was done.

Tomorrow I will submit a support ticket via  https://support.avast.com/Tickets/Submit
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: bob3160 on April 21, 2015, 12:17:05 AM
It would be interesting to find out what Avast finally finds that's causing your problem.
My VPS and streaming updates also have no problems. ??? ???
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: mchain on April 21, 2015, 06:52:55 AM
"2. remove Avast through Programs and Features
3. reboot in safe mode
4. avastclear in this safe mode"
3 should be reboot.
4 should be run avastclear in regular mode, choose which version it is to remove and then allow it to boot into safemode to do it's job.
5 Once done, it will give you the option to boot back into regular mode.
At that time, you should be able to do a clean install. Use the custom install so you can uncheck anything you don't want.
A video to guide you through all these step is available at:
https://forum.avast.com/index.php?topic=93544.msg1201631#msg1201631 (https://forum.avast.com/index.php?topic=93544.msg1201631#msg1201631)

I have no idea if  making these changes in the procedure make a difference.
I can tell you that this is what worked for me - and, is still working for me. :)

Sorry, still not solved.
I followed your sequence and everything happened as you said.
But no success.

Again it happened that Avast said after the clean install there were no updates after 150323-0.
That is also a download problem in Avast itself.
See the attachment (with name "no update available after clean install 2215.jpg") in one of my previous entries.
Immediately after disabling Avast the automatic update to 150419-1 was done.

Tomorrow I will submit a support ticket via  https://support.avast.com/Tickets/Submit
Actually, I think you can also consider checking for unusual files and/or abnormal settings on your system.

Whilst we're not saying you've got malware of any kind on your system, something is not right (see above) and it won't hurt to have a certified malware expert have a look-see via logs you submit, while you are waiting for a reply to your support ticket.

To do that, go here:  https://forum.avast.com/index.php?topic=53253.0 (https://forum.avast.com/index.php?topic=53253.0)

Start a 'New Topic' (you must be logged on to avast! forums to see this link) and run the first three programs and attach the logs resulting from running them.  Someone will assist you once you start your topic and attach.

There is nothing more exasperating than having a system running the way yours seems to be, and would at least want to have the peace of mind to know whether it is clean or not.  Besides, help here is free for all who ask.

Best possible outcome would be to have your issue with avast fixed and the fix(es) only will be specific and personlised just for your system.
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: heikwith on April 21, 2015, 09:30:54 AM
Just created a 'New Topic' about this download problem:
https://forum.avast.com/index.php?topic=169856.0
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: bruce_b on April 21, 2015, 07:23:10 PM
Can't say if the download issues are with Avast or Firefox (28) or the Firefox Download Manager
I find that just recently, say last 2 months or so, that if I change the Download File Name, it errors out and can not download it. So I have to save it as it is and then rename it how I like it.
 
Title: Re: Avast 2015 R2 SP1(build number 2015.10.2.2215)
Post by: heikwith on April 22, 2015, 06:37:53 PM
Just created a 'New Topic' about this download problem:
https://forum.avast.com/index.php?topic=169856.0

Download problems solved by the update to 2015 R2SP2 (2015_10_2_2218)
Thanks your help guys.