Avast WEBforum

Avast Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Beta - Avast => Topic started by: Asyn on August 29, 2015, 06:17:41 PM

Title: [2227/2228 BUG - Fixed] Strange behaviour with manual VPS update
Post by: Asyn on August 29, 2015, 06:17:41 PM
Condition: Manual VPS update with build 2227/2228

I tested this several times and always get the same result.
Avast goes from green to yellow to red, back to yellow and green again. :-\

Edit: Updated to bug status.
Edit: Bug is fixed.
Title: Re: [2227] Strange behaviour with manual VPS update
Post by: DavidR on August 29, 2015, 06:32:39 PM
Confirmed, manual update check - in my case there was no update 'Already up to date.'

Effectively no update done, but the main UI home page flip flopped back and forth through Green to RED (Unprotected) in my case, to Yellow and eventually back to Green. This was with the main UI open and the Update window.

I tried it again going from the tray icon - about avast - from the window  that opened I clicked the Update tab and update VPS. Since I didn't have the main UI window open no cycling through the colours, but the Virus Definitions section had some errors, Connection not established and no date of Last update received.

A short time later these fields returned to normal.

EDIT: Typo
Title: Re: [2227 BUG] Strange behaviour with manual VPS update
Post by: Asyn on August 29, 2015, 06:39:07 PM
Thanks for the confirmation Dave. Guess, we can call it a bug then.
Title: Re: [2227 BUG] Strange behaviour with manual VPS update
Post by: Zeniit on August 29, 2015, 08:58:02 PM
For me it's working fine.
Title: Re: [2227 BUG] Strange behaviour with manual VPS update
Post by: NON on August 30, 2015, 06:48:36 AM
Working fine here too, could be a XP only bug.
Title: Re: [2227 BUG] Strange behaviour with manual VPS update
Post by: DavidR on August 30, 2015, 03:24:57 PM
Working fine here too, could be a XP only bug.

We won't know until others actually try a manual update, I don't think many do unless they feel auto update isn't doing its job (but we're two for two right now).
Title: Re: [2227 BUG] Strange behaviour with manual VPS update
Post by: Patrick2 on August 31, 2015, 08:42:31 PM
Confirms issue on my XP Sp3 Laptop, been meaning to get beta build on Windows 10 Pro 64bit Desktop, but haven't had a chance yet today,  Went from Red, Yellow and back to green on Manual VPS update, despite was already up to date.     


Will be installing 2227 on Windows 10 Pro 64bit Desktop sometime today,  been dealing with numerous RL things, and other things lately though. 

Title: Re: [2227 BUG] Strange behaviour with manual VPS update
Post by: bob3160 on August 31, 2015, 08:54:32 PM
(http://www.screencast-o-matic.com/screenshots/u/Lh/1441050782813-52479.png)
No problem on latest build of Windows 10
Title: Re: [2227 BUG] Strange behaviour with manual VPS update
Post by: dbrisendine on September 01, 2015, 06:13:36 AM
No problem on Win10 or Win 7.
Title: Re: [2227 BUG] Strange behaviour with manual VPS update
Post by: Zeniit on September 04, 2015, 10:49:34 AM
@Asyn and @DavidR

Guys, I tested this build on Windows Xp in virtualbox, and I can confirm this is a bug. On Windows 7 it's working fine.
Title: Re: [2227/2228 BUG] Strange behaviour with manual VPS update
Post by: Asyn on September 04, 2015, 09:52:08 PM
Note: Not fixed in build 2228.
Title: Re: [2227/2228 BUG] Strange behaviour with manual VPS update
Post by: DavidR on September 04, 2015, 10:48:40 PM
Note: Not fixed in build 2228.

Nor is it resolved in 2229, which as an XP SP3 user I shouldn't even have.

Strange thing the Manual Program update in 2228 or 2229 experienced this problem.
Title: Re: [2227/2228 BUG] Strange behaviour with manual VPS update
Post by: Peter ZoŇ°iak on September 08, 2015, 08:24:45 AM
Condition: Manual VPS update with build 2227/2228

I tested this several times and always get the same result.
Avast goes from green to yellow to red, back to yellow and green again. :-\

Edit: Updated to bug status.

Hi. Bug is confirmed and we are working on fix right now. Thank you for your report.
Title: Re: [2227/2228 BUG - Fixed] Strange behaviour with manual VPS update
Post by: Asyn on September 20, 2015, 07:55:41 AM
Note: Bug is fixed in the latest build.
Title: Re: [2227/2228 BUG - Fixed] Strange behaviour with manual VPS update
Post by: DavidR on September 20, 2015, 03:57:04 PM
Also confirmed.