Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: glnz on November 04, 2015, 01:23:37 PM

Title: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: glnz on November 04, 2015, 01:23:37 PM
Have problems with the new Avast 2016 Free on my Win 7 Pro SP1 64-bit machine.  (It's a Dell Optiplex 7010 with 16GB RAM and an Intel Core i5 3470 with 4 cores, and with hardware virtualization turned ON in my BIOS.)

First, after the reboot, the new (to me) process aswFe.exe runs for a LONG time and consumes 25%± of my CPU.  At least an hour. 

Second, following other posts here, I checked how (or whether) NG was actually running.  See the attached screenshot of my attempts in cmd to check - lots of error messages.  You can see I tried to start it although I don't know these commands and was just "pushing buttons".  But lots of ERRORS.  Please open the attachment jpg.  (It's formatted for legal size paper, which was a clearer image.)

So what is happening with NG and this aggressive process aswFe.exe?  Is NG even running on my machine?  Am I getting the benefit of Avast's virtualization features?  Are the Avast sandbox features running at all?  How do I check?

Thanks.
Title: Re: aswFE.exe and NG problems in new Avast 2016 - Win 7 64-bit with virtualization
Post by: glnz on November 05, 2015, 12:50:25 AM
I just re-checked my post above from a different computer (not logged in), and the attachment above had disappeared.  But now viewing from my original posting PC (logged in), it's here now.

My thread is pointless without the attachment.  It's here now, but is it missing for anyone else?

And any thoughts on my thread above?

Thanks.
Title: Re: aswFE.exe and NG problems in new Avast 2016 - Win 7 64-bit with virtualization
Post by: Asyn on November 05, 2015, 06:28:24 AM
Note: You need to be logged in to see attachments.
Title: Re: aswFE.exe and NG problems in new Avast 2016 - Win 7 64-bit with virtualization
Post by: glnz on November 05, 2015, 07:00:16 AM
Asyn - thanks.  Any thoughts about the errors in the attachment and questions re NG?
Title: Re: aswFE.exe and NG problems in new Avast 2016 - Win 7 64-bit with virtualization
Post by: Asyn on November 05, 2015, 07:03:53 AM
Asyn - thanks.  Any thoughts about the errors in the attachment and questions re NG?
You're welcome.
Nope, wait for one of the devs and/or submit a ticket: https://support.avast.com/support/tickets/new
Title: Re: aswFE.exe and NG problems in new Avast 2016 - Win 7 64-bit with virtualization
Post by: glnz on November 05, 2015, 01:57:36 PM
Asyn - Submitted a ticket, but that will take a while, and I doubt the front-line tech team will know anything about my attachment above.

Would much appreciate this forum's advice - how do I test whether NG is running in this new Avast?  Or whether any of the sandbox features are working?  (What does NG do anyway?)

Thanks.
Title: Re: aswFE.exe and NG problems in new Avast 2016 - Win 7 64-bit with virtualization
Post by: glnz on November 06, 2015, 01:55:00 PM
Man - I'm feeling lonely - no one even wants to tell me what NG does!!

And what about those commands in my cmd screenshot above?  What are they anyway?  Does Avast publish a guide to them?
Title: Re: aswFE.exe and NG problems in new Avast 2016 - Win 7 64-bit with virtualization
Post by: Asyn on November 07, 2015, 06:56:24 AM
Man - I'm feeling lonely - no one even wants to tell me what NG does!!
Basic info: https://forum.avast.com/index.php?topic=154857.msg1125734#msg1125734
Title: Re: aswFE.exe and NG problems in new Avast 2016 - Win 7 64-bit with virtualization
Post by: GaAs on November 07, 2015, 10:50:23 AM

Here, instead, ngtool.exe, mftutil.exe, aswFe.exe, every time that the operating system start, cpu usage 36% (on average), again and again, again, again, again, again, again, again, again, again , again, a nuisance monstrous !!!!
30 minutes of hard drive and CPU every time !!!!!!!!!!!
In previous versions, the three tool, were initiated only the installation of avast or a new update of the program.
Please solve !!!
Bye to all. :o :o ::)
Title: Re: aswFE.exe and NG problems in new Avast 2016 - Win 7 64-bit with virtualization
Post by: glnz on November 07, 2015, 12:04:46 PM
Asyn - thanks for info.  But from your link to pk's description, it seems that the "errors" in my cmd screenshot above mean that Avast NG is NOT ABLE to create the VirtualBox VMs on my PC that are part of NG.  But my PC definitely has hardware virtualization.  I have run the Win 7 machine in XP Mode a few times just for fun.  And I have just re-run MS's havdetectiontool, and it reports that "This computer is configured with hardware-assisted virtualization".

Also, in Settings for my 2016 Avast, "Enable DeepScreen" and "Use secure virtual machines" are both checked.

So what do we do?  How do I test further to determine why there are "errors" in my cmd screenshot above, or to see whether NG is working on my machine?

I have not heard from Avast Support.  Thanks.
Title: Re: aswFE.exe and NG problems in new Avast 2016 - Win 7 64-bit with virtualization
Post by: Asyn on November 07, 2015, 12:08:45 PM
1. Asyn - thanks for info.
2. I have not heard from Avast Support.  Thanks.
1. You're welcome.
2. Be patient, it can take up to 7 (business) days.
Title: Re: aswFE.exe and NG problems in new Avast 2016 - Win 7 64-bit with virtualization
Post by: glnz on November 07, 2015, 04:29:33 PM
By the way, aswFE.exe does not seem to re-run on bootups.  However, the problem continues with ngtools and the above indications (and cmd results) that NG is not running correctly because Avast is failing to make the needed virtual machines.

Just to add some detail --

In the BIOS for my Optiplex 7010, these are the settings under the caption "Virtualization Support":
-  Virtualization - Enable Intel Virtualization Technology is CHECKED
-  VT for Direct I/O - Enable VT for Direct I/O is CHECKED
-  Trusted Execution - Trusted Execution is UNchecked.

I have also attached the more detailed hav log file from this morning's run of MS's havdetectiontool.  Looks good to me.

So how do I test the NG sandbox?  Doesn't Avast have a web link with a fake bad page that would put it to the test?

Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: glnz on November 08, 2015, 03:22:07 AM
 
And, before anyone asks, in Avast - Settings - Troubleshooting, "Enable hardware-assisted virtualization" is CHECKED.

Any thoughts, anyone?
Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: glnz on November 08, 2015, 07:20:30 PM
 
Doesn't ANYONE know how to test the NG feature, which I understand is some type of sandboxing?  Thanks.
Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: NON on November 09, 2015, 01:08:53 PM
Old good autosandboxme2.exe still triggers DeepScreen aka NG.
http://public.avast.com/dev/autosandboxme2.exe

And yes, NG is a kind of sandbox, mainly to determine the file is malicious or not.


BTW, this is my personal opinion: internal tools (ngtool.exe for example) should only be executed by avast itself, not by user's intention, even if there is built-in help text.

You don't know what they perform or what is needed to properly execute these tools.
Playing with these tools might be fun (I can understand it), but it should be done at your own risk using your own knowledge.
Expecting official support for your playing is just not good.

Just my opinion.
Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: glnz on November 09, 2015, 08:24:30 PM
 
NON - thanks for that link.  Unfortunately, Firefox blocks the page and gives me a warning before Avast does anything.  No reaction from Avast.  So I still have no idea whether NG is running or doing anything.

My purpose was to test whether NG and some kind of sandboxing are working on my PC, not only to have fun.  And the idea to try to run the stuff in CMD was from a diferent Avast thread.
Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: RejZoR on November 09, 2015, 10:58:03 PM
For me, the test file doesn't trigger DeepScreen.
Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: NON on November 10, 2015, 11:32:32 AM
For me, the test file doesn't trigger DeepScreen.

Well, for me it triggers DeepScreen. What is the difference ???
Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: glnz on November 10, 2015, 12:11:37 PM
RejZoR and NON -- NON's question directly above is a good one, and maybe we're starting to get somewhere. 

Each of you, please run an elevated cmd and then run the ngtool isready test shown in my attachment at the top of this thread, and post here the results.  From what I can see, the ngtool isready command is just a test to see whether NG is working on your PC.  In my case, the result is an error message that my NG virtual machines aren't ready.  Very curious to see what it tells each of you.

I think you might get there using  cd C:\Program Files\AVAST Software\Avast\ng
then type    ngtool isready
Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: glnz on November 11, 2015, 05:34:12 PM
 
Asyn and all - attached is the response from Avast customer support.  Read from bottom up.  No help at all.  NG looks like a defective product.

Have you all had a chance to run the ngtools isready test?  Still curious to know what's happening, although Avast itself hasn't a clue.

Thanks.
Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: davexnet on November 11, 2015, 06:01:02 PM
Seems as if NG is some developers proof of concept, rather than a usable, reliable product.  Sadly, other parts of avast feel like this also,
such as the SSL scanning in XP.  How well did that work?
Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: glnz on November 11, 2015, 06:22:15 PM
davexnet - join the party.  But, if you want a drink, please first try running the ngtools.exe isready test in my attachment at the top of this thread.

What results do you get?
Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: davexnet on November 11, 2015, 06:53:53 PM
I no longer have it installed.  I reinstalled, did a custom setup and chose the shields only.
Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: glnz on November 11, 2015, 07:30:27 PM

davexnet - how does one do that?  Please point to a link if that's easy.  Thanks.
Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: davexnet on November 11, 2015, 07:42:44 PM
To alter your active system,
control panel/programs and features/avast/change.
Deselect everything except the shields.

For a fresh install, uninstall and reboot.  Open the avast installer package and on the very first screen that comes up,
(in a very small font) choose the custom install.  In the middle column you'll see all the bloatware value-added extras.
Choose what you like from here .  Select your language on the right, then choose next.  From then on it's pretty much
the same as the basic install.
Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: glnz on November 12, 2015, 05:06:04 PM
davexnet - thanks.  Really dumb question - where do I get the installer, as my current install was through my prior Avast's program update.

Everyone - I got another email from Avast support, this time from a "Technical support engineer" asking that I run a diagnostic tool from https://www.avast.com/faq.php?article=AVKB33#artTitle (https://www.avast.com/faq.php?article=AVKB33#artTitle)

I did that, but (a) it showed my Win 7 Pro 64-bit system is clean and compatible, and (b) it would NOT upload the detailed information to Avast itself - its effort to do so generated error message.  See the TWO attached jpgs.

Avast is spending a bit too much on marketing and annoying pop-up messages and a bit too little on the tech side.
Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: davexnet on November 12, 2015, 07:12:50 PM
https://forum.avast.com/index.php?topic=178580.0
Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: glnz on November 13, 2015, 05:04:45 AM
davexnet and others here --

Well, I have now uninstalled and cleared Avast 2016 and reinstalled it, and I followed davexnet's excellent instructions for unchecking the bloatware in the middle column.  I DID check the box on the right for working with virtual machines.  I went through the Avast settings to make sure that Enable Hardware Virtualization is checked.

I GET THE SAME ERROR FOR NGTOOL ISREADY AS IN MY FIRST POST ABOVE.

Avast 2016 DOES NOT WORK.
Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: glnz on November 15, 2015, 06:23:35 PM
 
Avast - do have nothing to add here?  You have also gone radio silent on my support ticket with you.

If NG doesn't work, please tell us.

What do the error codes (in my first post above) mean?

What's your response to this?
Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: glnz on November 18, 2015, 03:52:03 AM
Still no response from my support ticket.  Avast 2016 is still defective.
Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: glnz on November 27, 2015, 05:11:28 PM
Ten days later, this is STILL not fixed.  I have avast version 11.1.2241.

NG and Avast 2016 are not working.
Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: glnz on November 29, 2015, 02:13:00 PM
I uninstalled and reinstalled the new Avast (from a new download), with the correct settings for virtualization, and I continue to get the error message about ngtool (first post above).  Still broken.

Has anyone else run the ngtool isready test?
Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: glnz on December 05, 2015, 01:18:53 PM
 
Still not fixed, and Avast wants to close my separate support ticket.

In the meantime, the newest sub-version of Avast eliminates the ngtool isready test.  (In response to this thread?)  The command is no longer available.  So, the problem continues, but Avast doesn't want us to test for it anymore.

NG remains broken.

Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: glnz on January 10, 2016, 04:42:41 PM
Still no news on this from Avast.
Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: glnz on January 13, 2016, 02:35:28 PM

NG still does not work.
Title: Re: NG problems in new Avast 2016 - on Win 7 64-bit with virtualization
Post by: glnz on January 29, 2016, 02:42:00 PM
Just for the hell of it, I went to Programs and Features, went to "Change" Avast and hit "Modify" to see if by magic the old references to virtual or NG had returned.  No.

So I did a Repair of Avast, went back to Programs and Features, and the Change options for Avast still do NOT show virtual anything or NG anything.

NG still does not work, in a really great, modern Dell desktop with tested hardware virtualization capacity.