Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: dale42 on September 24, 2016, 01:00:50 AM

Title: Extensions not being installed / added to Chrome
Post by: dale42 on September 24, 2016, 01:00:50 AM
Hi.

Just installed Avast! Free Edition on a new and clean install of Windows 7 Pro 64bit.  However: none of the Avast! extensions are being added to Chrome by the installer.  Specifically: neither the "Security browser extension" nor the "Safeprice browser extension" are being added to Chrome by the installer (and I've tried both the online and offline installer as well as tried the repair option).  The only way to add the extensions to Chrome is via the Chrome Web Store.  Has something changed very recently insofar as the installation of Avast! Free Edition is concerned that I'm not aware of i.e. I've been using Avast! Free Edition for many years and I don't ever recall having to visit the Chrome Web Store to add Avast! extensions to Chrome as they were always added by the installer.  What's also very odd is that both extensions are showing in the Components tab and both offer the Uninstall Component option (so I have to assume that they are indeed installed but nevertheless neither extension was added to Chrome by the installer).

Very, very, confused and, of course, wondering if this new / clean install is indeed protected.

P.S.

I'm not sure if this means anything but I just took a look in the \Avast Software\Avast folder.  There is a folder called "Webrep" and inside that folder are two folders name "FF" (Firefox???) and "IE" (Internet Explorer???).  In other words: I don't see a seperate folder for "Chrome" (for example)???

Regards,

Dale.
Title: Re: Extensions not being installed / added to Chrome
Post by: Be Secure on September 24, 2016, 02:31:06 AM
Yes the Security browser extension or AOS load very slowly to the Google Chrome(After few restart of Chrome).Avast! team has to solve this problem quickly. :)
Title: Re: Extensions not being installed / added to Chrome
Post by: dale42 on September 24, 2016, 09:13:32 AM
Hi.

Thanks for the response but that's not the problem.  The extensions are not being added to Chrome by either of the installers and have to be added manually via the Chrome Web Store.  Using this method is of great concern i.e. how can one even be sure that the extensions added via the Chrome Web Store are a) indeed from Avast! and b) the correct / updated versions???  At present: Avast! Free Edition version on this PC is 12.3.2280 while the version of the Security browser extension (from the Chrome Web Store) is 11.1.0.955.  Not sure if the version numbers should be the same or not but just an observation.

Regards,

Dale.
Title: Re: Extensions not being installed / added to Chrome
Post by: Eddy on September 24, 2016, 09:48:17 AM
Version numbers are just for that part of avast, so yes they can differ.
CleanUp, Secureline etc. also have their own version numbers.

You can be sure that things in the Chrome store are from the mentioned developer.
Google is checking that and in this case avast also.

As the add-on installs without a problem on other systems, the issue seems to be specific to yours.
Webrep is from a old(er) avast version and has been replaced by AOS.

It seems to me your system is (a bit) messy.
I suggest to remove avast and Chrome completely and install them new.
Title: Re: Extensions not being installed / added to Chrome
Post by: dale42 on September 24, 2016, 02:04:20 PM
Hey Eddy.

Thanks for the input.

I'm not entirely sure that I agree that my system is "messy" i.e. this is a (very!!!) clean install of Windows 7 Pro 64bit with nothing other than Chrome and Avast! Free Edition installed (I've not even begun to install software) (and have ensured, after many many many hours thanks to MS, that all MS updates are installed).

The above being said and following your advice:

Uninstalled Avast! Free Edition, uninstalled Chrome, downloaded offline installers for both (yet again to ensure that both were up-to-date), re-installed Chrome, re-installed Avast! Free Edition, no change at all unfortunately i.e. no Avast! Free Edition extensions appearing in Chrome at all (but according to Avast! Free Edition components tab they are indeed all installed as there is an uninstall option presented for all).

No surprise here of course but after uninstalling both there sure is a lot of stuff "left over".  After I re-installed Chrome but before re-installing Avast Free! Edition again Avast's Security browser extension was still present from my manual adding of it prior to all of this (I removed it before re-installing Avast! Free Edition again but just saying).  Yeh I know: one could use something like Revo Uninstaller (to clear ALL "left overs" after uninstalling software) but this got me into some "deep water" three weeks ago when removing software (and if the truth be told it's but one of the reasons why I ended up re-installing Windows 7 Pro etc. etc. etc.).

One thing that "gives me hope" here is this:

https://forum.avast.com/index.php?topic=189836.0

That's a link to the "NEW August versions: 12.3.2279 + 2280" thread.  In the thread the following is listed as "fixed": "+ SafePrice browser extension component is not installed during update when Browser extension was not installed in the previous version".  This tells me that quite possibly this is not as "fixed" as Avast would like to think i.e. neither the SafePrice browser extension nor the Security browser extension are being installed / added to Chrome upon a new and clean install.  In other words: MAYBE if an older installer was used to install these components then they would be fine and present but the very latest installer is not installing them correctly.  No idea really but this would make sense (to me anyway).

Oh well.  Not quite sure where to from here.  As I noted: I'm loathe to install extensions especially when such extensions are supposed to be being installed by the installers themselves.  So I guess I'll just leave them out for now and see if something gets resolved in some or the other new updated / installer release (unless of course somebody out there has more ideas as to why this is happening / not happening).

Regards,

Dale.

P.S.  Does Avast! Support ever check these forums???  No idea i.e. never had a problem or issue with Avast! for year up until now so have never had to request support / input.
Title: Re: Extensions not being installed / added to Chrome
Post by: Eddy on September 24, 2016, 04:03:05 PM
Did you perform a custom installation of avast ?
Title: Re: Extensions not being installed / added to Chrome
Post by: dale42 on September 24, 2016, 04:39:48 PM
Hello.

Funny that you should ask that question!!!  8)!!!

Matter of fact: yesterday upon my initial install I performed a custom install and ensured that all options were selected or ticked.  Today: I simply clicked on the big "INSTALL" button (wondering if it would make a difference) (which it didn't).

As a matter of interest:

When you perform a custom web install: not all of the options are selected or ticked.  But when you perform an offline custom install then all options are selected or ticked (but this is not serious I don't think).

Judging by what Avast! Free Edition is showing me: the offline default install does indeed install everything anyway.

I'm guessing this is all working fine.  Just hate it when things happen or don't happen that I don't have explanations for.

I'm wondering actually if this has something to do with the latest version / update of Chrome.  My reason for saying this is because I did experience a problem with the extension for Internet Download Manager (and this is sure one very stable application and never had issues with it ever but then I can say the same about Avast! Free Edition too i.e. up until now I've never ever had an issue) and this is definitely an issue with Chrome (and have resolved the issue).

For fun: I opened Internet Explorer 11 and all Avast! Free Edition extensions (or plug-ins as they are called in IE) are indeed installed and working no problem.

For more fun: I searched for all *.CRX files (Chrome extensions).  Oddly enough there are many Avast Chrome extension files but they're all residing in the Safezone Brower folder.

I'm still of the opinion now that the installers are simply not installing the Chrome extensions where they should be.  Who knows.  And I'm not about to start "dropping" extensions into Chrome from the Sarfezone Browser folder either.

I really cannot think of anything else that's "out of the ordinary" here.  The only possible other thing was that I had MS Security Essentials installed initially and then Avast! Free Edition after that.  I then decided to uninstall MS Security Essentials (because of the "old story" that one should not have two AV packages running on the same PC but it should be said that I was not experiencing any issues with both being installed at the same time either).  This all works as it should i.e. the moment Avast! Free Edition is installed then Windows Defender is disabled automatically and once Avast! Free Edition is uninstalled then Windows Defender is enabled again.  So no issues here.  And I cannot see how simply uninstalling Avast! Free Edition, then uninstalling MS Security Essentials, and then re-installing Avast! Free Edition could result in my issues (and I for sure ain't wiping this Windows 7 Pro installation out and starting again just to prove a point).

And thanks.  I have to say I'm a little bit more comfortable installing extensions from the Chrome Web Store.  After your post and some checking: it certainly does seem that both the software vendors and Google spend some time doing their best to ensure that extensions being offered via the store are legit) (although I'd still prefer that the installers were installing what they're supposed to be installing).

Any other ideas???  Welcome.

Regards,

Dale.
Title: Re: Extensions not being installed / added to Chrome
Post by: Eddy on September 24, 2016, 04:45:28 PM
Quote
For more fun: I searched for all *.CRX files (Chrome extensions).  Oddly enough there are many Avast Chrome extension files but they're all residing in the Safezone Brower folder.
.CRX are not Chrome extensions, but extensions for Chromium based browsers (which the SafeZone Browser is).

They are actually just renamed .ZIP files.
Title: Re: Extensions not being installed / added to Chrome
Post by: MartinZ on September 29, 2016, 12:21:10 PM
Hi Dale,

did you install Avast with Chrome or Chrome was already installed on the machine before Avast installation?
Title: Re: Extensions not being installed / added to Chrome
Post by: Be Secure on September 29, 2016, 12:34:21 PM
Hi Dale,

did you install Avast with Chrome or Chrome was already installed on the machine before Avast installation?
Yes.For my system:Chrome was already installed on the machine before Avast installation.
Title: Re: Extensions not being installed / added to Chrome
Post by: MartinZ on September 29, 2016, 03:46:51 PM
The installation of plugin is delayed for 12 hours and we don't use crx anymore. It's installed via registry key, that points to Chrome web store
Title: Re: Extensions not being installed / added to Chrome
Post by: bob3160 on September 29, 2016, 03:56:00 PM
The installation of plugin is delayed for 12 hours and we don't use crx anymore. It's installed via registry key, that points to Chrome web store
Is a direct link to the App available at the Google Store ??? 
Title: Re: Extensions not being installed / added to Chrome
Post by: IvanM on October 06, 2016, 05:15:53 PM
The installation of plugin is delayed for 12 hours and we don't use crx anymore. It's installed via registry key, that points to Chrome web store
Is a direct link to the App available at the Google Store ???

Sure,

AOS: https://chrome.google.com/webstore/detail/avast-online-security/gomekmidlodglbbmalcneegieacbdmki
SP: https://chrome.google.com/webstore/detail/avast-safeprice/eofcbnmajmjmplflapaojjnihcjkigck
Title: Re: Extensions not being installed / added to Chrome
Post by: bob3160 on October 06, 2016, 11:43:04 PM
The installation of plugin is delayed for 12 hours and we don't use crx anymore. It's installed via registry key, that points to Chrome web store
Is a direct link to the App available at the Google Store ???

Sure,

AOS: https://chrome.google.com/webstore/detail/avast-online-security/gomekmidlodglbbmalcneegieacbdmki (https://chrome.google.com/webstore/detail/avast-online-security/gomekmidlodglbbmalcneegieacbdmki)
SP: https://chrome.google.com/webstore/detail/avast-safeprice/eofcbnmajmjmplflapaojjnihcjkigck (https://chrome.google.com/webstore/detail/avast-safeprice/eofcbnmajmjmplflapaojjnihcjkigck)
Thank you. Much appreciated. :)
Title: Re: Extensions not being installed / added to Chrome
Post by: shootfire on November 04, 2017, 07:41:42 AM
FWIW, I have been having this issue myself for a month now. I even got a personal e-mail contact from Steven at Avast Support, who says I must be doing something wrong like disabling the component or running another AV product simultaneously. No. I'm not doing anything wrong. After he insisted I was doing something wrong, I became a snobby difficult customer revealing I was a PC Technician for 5 years doing malware removal on home user and small biz PCs with a A+ and a MCITP cert. I'm following the exact steps as the OP here, and having the same issue.

Installed Avast Internet Security, offline installer, custom install, enabling the security browser extension. Chrome, FF & IE were already installed; this was not a new/clean Windows install, but I ran the appropriate uninstall/removal tool for my prior AV product.  In this case, the Avast browser extension for FF & IE showed up and worked fine, but not Chrome.

After getting the support guy's response today, I was ticked off, so I did a complete clean install of Windows 10 x64, Version 1709, build 16299.19. Chrome Version 62.0.3202.75 Official Build.  And Avast Free Version 17.7.2314 (Build 17.7.3660.244).  I installed Chrome, then Avast Free using the online installer, full installation (not custom) and this time there was no security browser extension for IE OR Chrome.

Yes, I can install the Chrome extension manually (thank you IvanM for the link!) but that doesn't address the actual issue at hand. And I'm pretty certain that if the OP and myself are/were having this issue, there are probably many other less technically-inclined users having the same thing go wrong. 

If anyone from Avast is on here, I'll be happy to forward you the emails going back and forth between myself and Steven in the support dept.  I apologize in advance for being difficult with him, but don't just blow off your customer assuming they have no idea what they're doing. I'm not trying to make your jobs more difficult; I'm trying to help you solve a problem because I'm a geek and happy to share my expertise with you!  *exhale* ;)