Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: Ishamael on May 04, 2017, 09:00:59 AM

Title: Overwatch wont launch with Avast 17.4.2294
Post by: Ishamael on May 04, 2017, 09:00:59 AM
Having problems launching Overwatch with this new update (17.4.2294). It was working fine earlier today on the previous version.

Pressing play on the Blizzard launcher causes nothing to happen except for the Overwatch process to pop up in task manager. If i disable File System Shield, the game immediately launches no problem. 

I tried adding the Overwatch folder and battle.net folder to exclusions, but that did not work.

I have tried running a repair and also uninstall/reinstall but that did nothing either.

I am using Avast Free Antivirus 17.4.2294 on Windows 10 64-Bit Pro 1703.
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: Alikhan on May 04, 2017, 10:20:08 AM
I've escalated this issue to the Avast devs.
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: JoeyChicago on May 04, 2017, 09:40:07 PM
I had this issue as well. The problem started yesterday for me, and it would usually take upwards of 5 minutes for the game to finally launch. Once it did, it would freeze while loading a new map, but during an actual match, it seemed to work fine. It was when a match ended that the problems began.

What worked for me was to go to Settings > Components > click Customize on File System Shield > Exclusions, and adding the folder where Overwatch is installed, as well as the folder for Battle.net.

For me it was "C:\Program Files (x86)\Overwatch\" and "C:\Program Files (x86)\Battle.net\". I also added the folder for Overwatch Test (the PTR), but not everyone uses that, so I'm not sure if that had any effect~
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: Ishamael on May 05, 2017, 02:22:47 AM
I've escalated this issue to the Avast devs.

Great! Thank you.

I had this issue as well. The problem started yesterday for me, and it would usually take upwards of 5 minutes for the game to finally launch. Once it did, it would freeze while loading a new map, but during an actual match, it seemed to work fine. It was when a match ended that the problems began.

What worked for me was to go to Settings > Components > click Customize on File System Shield > Exclusions, and adding the folder where Overwatch is installed, as well as the folder for Battle.net.

For me it was "C:\Program Files (x86)\Overwatch\" and "C:\Program Files (x86)\Battle.net\". I also added the folder for Overwatch Test (the PTR), but not everyone uses that, so I'm not sure if that had any effect~

That is so strange! So I ended up trying to add both folders you mentioned back to the exclusions list, and its now working for me. When I added them before it did nothing, so I'm guessing when I did a full uninstall and reinstall of Avast, that fixed my exclusion list as it wasn't successfully excluding the folders prior.

Thanks
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: JoeyChicago on May 05, 2017, 07:46:00 PM
Just when I thought that had cleared up the issue. It's back to doing it again. It has to be due to the new virus definitions that were downloaded, because disabling the File System Shield makes the game work fine again.

I might have to check out some other antivirus programs until this gets sorted out for good...
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: Eddy on May 05, 2017, 07:49:31 PM
No, it is not the VPS that is the problem.
It is the micro fix that avast has rolled out.
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: asdfasdfasdfasdf on May 05, 2017, 08:34:24 PM
I have the same issue with Avast. It has been going on for like 3 days now. When I try to launch Overwatch nothing happens, even though battle.net client says that the game is running and its process is active in task manager. When I disable Avast shields the game launches normally. I've tried to enable Avast after the game had been launched but then I couldn't load a map, the game stopped responding. It's definitely an issue with the last Avast update. Also excluding battle.net and overwatch folders didn't help. I hope this can be resolved soon cos I like this antivirus and it would suck to have to switch to something else. :/

I'm using version 17.4.2294 (build 17.4.3482.0)
Virus library 170505-0
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: Justin0018 on May 05, 2017, 10:25:37 PM
I've been having the same problem as above, it wont load anything, map nor game. but sometimes it works..... Im so confused! I just want to play OW and I have to deal with this

PLEASE FIX. seems to be the case with all online (realtime) games
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: Ishamael on May 06, 2017, 12:41:20 PM
Looks like im having problems again with overwatch, even with both folders added to exclusion. Only way to play atm is to disable File Shield while playing the game =/

Hope this gets fixed asap!
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: family_ITguy on May 06, 2017, 02:02:10 PM
same here, just with terrible mouse stutter when it started. although the latter i had in multiple other games too after the update. had to deinstall avast and default to defender, since the stutter wouldnt have gone away, even after clean install and restart. after deinstalling - stutter was gone as it had come. corded mouse btw.

i wonder how something like this even happens. in 5 years never had my pcs normal operation hampered like that by avast :( really sad to see. anyway, keeping avast off my pc is my only option - and hoping they hear us and act. Preferably not in some months, since i trusted avast again this year by buying the license.

please avast, prove to us that you care. overwatch is a game played by millions and millions and i can't be the only one having issues in other games.
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: John Dean on May 06, 2017, 04:21:39 PM
I am also having the same problem with avast conflicting with Overwatch.
Adding Overwatch to the exclusions doesn't change anything, but disabling the shields allows Overwatch to work properly.
Please sort this out because many other people are reporting this conflict with avast on Blizzard's Overwatch forum too: https://eu.battle.net/forums/en/overwatch/search?q=avast&forum=19369429 (https://eu.battle.net/forums/en/overwatch/search?q=avast&forum=19369429)
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: i.dezotti on May 06, 2017, 05:47:53 PM
Hello,
I also have the same issue when launching Overwatch: The game takes up to 3 minutes to launch when it should only take 5 seconds. The problem disappears when I disable the anti-virus file system shield agent.
Thanks for your support.
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: Justin0018 on May 06, 2017, 11:55:48 PM
Avast adds the gaming mode when they dont even let you play games XD......plz help us. Any Online game is hindered by Avast shutting it down and restricting its disk recall speed to literally 0. Disabling the shields (Behavior and File) make the games work properly. I really like avast, but if they dont fix this soon, bye bye
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: nebulamask81 on May 07, 2017, 06:40:18 AM
Same problem here.  Overwatch wouldn't launch at all when avast shields were enabled.  Even after disabling them there were issues with the game.  Came here to look for a solution.  I'm forced to uninstall until this is resolved.
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: avast-user-01 on May 07, 2017, 09:36:08 AM
Guys, try this and see if it fixes your issue. I don't have overwatch, but my IDM and virtualbox had similar issues.

https://forum.avast.com/index.php?topic=201729.msg1391933#msg1391933
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: seebach on May 07, 2017, 07:41:01 PM
Additionally someone on Reddit found out it was the File System Shield after talking to a blizzard rep.

https://www.reddit.com/r/Overwatch/comments/69nw9y/fix_overwatch_taking_ages_to_start_up_freezes_lag/
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: hyde_v on May 08, 2017, 09:52:46 PM
Same issue.  Avast is preventing the game Overwatch from playing.  I have had to uninstall the Avast software to bring the game back.

Sorry.  I liked Avast.  But when your updates block my games, your software has to go.
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: vls519 on May 09, 2017, 03:35:45 AM
I've used avast for 10+ years and I had to uninstall it. this is pretty big fuck up by avast. there are millions of overwatch players and your anti virus is blocking it. I'm sticking to window defender for now.
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: Adam310 on May 09, 2017, 03:38:22 AM
10+ year user here. I had the same problem, OW wouldn't open. Disabling the file system shield in the components appears to work for now. It was also giving me issues playing League (lobby was loading very slowly). Please fix asap since I don't want to be running on partial security!
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: youwereout on May 09, 2017, 06:42:56 AM
I'm having issues playing overwatch as well. I've disabled the file system shield as mentioned and now the games plays. However after some time (within a match or two my whole system freezes. Cursor still moves and can still hear game sounds. I have to reset to be able to use my pc again.
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: Alikhan on May 09, 2017, 03:37:49 PM
This issue should be fixed in the next VPS update.
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: Alikhan on May 09, 2017, 10:18:46 PM
Fixed in the latest virus definition update VPS 170509-4
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: Justin0018 on May 09, 2017, 11:13:54 PM
I would just like to thank the team on the fix! Glad they seen it and squashed it as soon as they could! Thanks!
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: Ishamael on May 10, 2017, 06:33:33 AM
Thanks for the fix! glad to see that the discord problem was fixed also. Good work!
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: Bacontoast84 on August 06, 2017, 11:39:09 PM
I've been getting randomly tabbed out while playing Overwatch with Avast game mode on. Tried disabling seems to work for now.  :-\
Title: Re: Overwatch wont launch with Avast 17.4.2294
Post by: Martin Vlcek on August 08, 2017, 12:02:57 PM
I've been getting randomly tabbed out while playing Overwatch with Avast game mode on. Tried disabling seems to work for now.  :-\

Hi,

what edition and version of Avast AV did you had when you experienced the problem (both program and virus def) ?

Thank you,

M