Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Beta - Avast => Topic started by: Karel Šťavík on December 07, 2017, 01:56:46 PM

Title: New Beta version 17.9.2320
Post by: Karel Šťavík on December 07, 2017, 01:56:46 PM
Hi everyone,

new beta version 17.9.2320 (build 17.9.3748.0) is released.

Changes / Fixed Bugs

Known Issues

Download links:
https://forum.avast.com/index.php?topic=179943.0

Enjoy this beta!
We are looking forward to your feedback.

AVAST Team
Title: Re: New Beta version 17.9.2320
Post by: NON on December 07, 2017, 03:36:05 PM
Thanks for the new beta :)
Title: Re: New Beta version 17.9.2320
Post by: bob3160 on December 07, 2017, 04:03:52 PM
Thanks for the new beta and all the fixes.
This is still a problem:
(http://screencast-o-matic.com/screenshots/u/Lh/1512658965119-88878.png)
It's what greeted me after the initial requested reboot.
Title: Re: New Beta version 17.9.2320
Post by: bob3160 on December 07, 2017, 10:55:16 PM
(http://screencast-o-matic.com/screenshots/u/Lh/1512683602303-1973.png) (https://youtu.be/TXy3VST2dkw)
https://youtu.be/TXy3VST2dkw
Title: Re: New Beta version 17.9.2320
Post by: bob3160 on December 08, 2017, 12:03:47 AM
(http://screencast-o-matic.com/screenshots/u/Lh/1512687107653-89162.png)
Why isn't this module shown when doing a custom install ???
Or, an option to not install this since it appears to be a free standing program ???
(http://screencast-o-matic.com/screenshots/u/Lh/1512687661749-13247.png)
The only way to get rid of it is to go to Programs and Features and uninstall it. It's a separate program that's installed.  :(
Title: Re: New Beta version 17.9.2320
Post by: SpeedyPC on December 08, 2017, 12:26:08 AM
Has SafeZone browser been included in this beta release, and will be ready soon when the final stage comes out soon??
Title: Re: New Beta version 17.9.2320
Post by: bob3160 on December 08, 2017, 12:30:06 AM
Has SafeZone browser been included in this beta release, and will be ready soon when the final stage comes out soon??
No, not included. I've been beta testing but there are still things missing which, IMHO, make it not ready for prime time.
It's called Avast Secure Browser. :)
Title: Re: New Beta version 17.9.2320
Post by: Asyn on December 08, 2017, 08:23:28 AM
Thanks Karel, testing...
Title: Re: New Beta version 17.9.2320
Post by: Asyn on December 08, 2017, 08:47:49 AM
Regarding Smart-Scan, same as reported in a prior beta.
-> https://forum.avast.com/index.php?msg=1429560
Title: Re: New Beta version 17.9.2320
Post by: petr.kolacek on December 08, 2017, 09:08:07 AM
Thanks for the new beta and all the fixes.
This is still a problem: Behavioral shield not turned on after update and reboot.
It's what greeted me after the initial requested reboot.

Hi Bob, regarding this issue with Behavioral shield, as we did not induce the issue here, could you please provide us more information about it?
1. First of all, did you try the "Turn on" button? If yes, what happened?
2. Could you please upload logs (in archive) from ProgramData folder to our ftp (ftp.avast.com/incoming) and let me know the name of the archive?
3. Could you also look into the application event log and filter error messages if there are any related to the time of the issue and the Avast client (if so, could you please make an export of it and attach to the archive with logs)?

Thank you for your beta testing and report! P.
Title: Re: New Beta version 17.9.2320
Post by: petr.kolacek on December 08, 2017, 09:12:20 AM

Why isn't this module shown when doing a custom install ???
Or, an option to not install this since it appears to be a free standing program ???

The only way to get rid of it is to go to Programs and Features and uninstall it. It's a separate program that's installed.  :(

Bob, the Driver Updater program is actually not installed itself during installation of the AV product. You need to open this component and install it via a button (Install Now). However, what I see on your screenshots is that it is already installed. So, probably stupid question, but did you install it anytime before or do you claim it was installed "automatically" during installation of the AV client? Could you please look for the setup.log and update.log situated in "c:\ProgramData\AVAST Software\Persistent Data\Avast\Logs\" and send it to me for further analysis? Thank you!
Title: Re: New Beta version 17.9.2320
Post by: SpeedyPC on December 08, 2017, 10:52:54 AM
No, not included. I've been beta testing but there are still things missing which, IMHO, make it not ready for prime time.
It's called Avast Secure Browser. :)

Thanks Bob really appreciate the feedback ;)

Title: Re: New Beta version 17.9.2320
Post by: Asyn on December 08, 2017, 11:06:40 AM
Not fixed: The tray icon doesn't animate anymore.
Title: Re: New Beta version 17.9.2320
Post by: bob3160 on December 08, 2017, 04:10:16 PM

Why isn't this module shown when doing a custom install ???
Or, an option to not install this since it appears to be a free standing program ???

The only way to get rid of it is to go to Programs and Features and uninstall it. It's a separate program that's installed.  :(

Bob, the Driver Updater program is actually not installed itself during installation of the AV product. You need to open this component and install it via a button (Install Now). However, what I see on your screenshots is that it is already installed. So, probably stupid question, but did you install it anytime before or do you claim it was installed "automatically" during installation of the AV client? Could you please look for the setup.log and update.log situated in "c:\ProgramData\AVAST Software\Persistent Data\Avast\Logs\" and send it to me for further analysis? Thank you!
It was a clean install of the latest beta. I discovered it when I looked at the performance tab.
Since this is beta, I thought it might have been a new feature for us to play with.
I'll send you the logs via the Slack channel.

Title: Re: New Beta version 17.9.2320
Post by: bob3160 on December 08, 2017, 05:21:11 PM
Anyone else having a problem with Avast Password ???
(http://screencast-o-matic.com/screenshots/u/Lh/1512749925147-24914.png)
Since doing a clean install of this beta, my password isn't working. ???

Title: Re: New Beta version 17.9.2320
Post by: RejZoR on December 09, 2017, 10:54:45 AM
Ok, what the hell is wrong with the damn avast! installer? It's now taking freaking forever to install. Installs are now taking over 15 minutes. It's ridiculous. And AVG has the exact same problem. It's sitting at 2mm of progress bar above taskbar for 5 minutes now and it's barely moving anywhere. No AV including avast! ever took this long to install, not even Norton in its worst days.

And what's worse, it's IMPOSSIBLE to cancel installation. I now have to sit through half an hour of waiting for the stupid installer to complete. If lucky.

EDIT:
30 minutes have passed and the progress bar is still sitting at 1/3 of the progress... This is just absolutely absurd.

EDIT 2:
It finished in exactly 40 minutes. WHAT!? Started the install at 10:50 and it finished at 11:30. This is just ridiculous.

EDIT 3:
Oh no, it hasn't actually finished. It's now doing a progress bar thingie in its main interface. Stuck at 33% just like the last time...
Title: Re: New Beta version 17.9.2320
Post by: bob3160 on December 09, 2017, 02:32:50 PM
To add to what RejZoR said,
When the system starts, it takes a long time for the Avast icon to appear on the System tray.
If you happen to run the VPN, that takes another 40 seconds before it appears.
(The slowness of the VPN module isn't new.)
Title: Re: New Beta version 17.9.2320
Post by: nero59 on December 09, 2017, 07:38:17 PM
When the system starts, it takes a long time for the Avast icon to appear on the System tray.

I've actually reported this problem here on the forum for a previous stable version and everyone dismissed it as "not a big deal".
Title: Re: New Beta version 17.9.2320
Post by: Alikhan on December 09, 2017, 08:03:31 PM
When the system starts, it takes a long time for the Avast icon to appear on the System tray.
If you happen to run the VPN, that takes another 40 seconds before it appears.
(The slowness of the VPN module isn't new.)

That's actually intentional - to minimize the effect on Windows startup (i.e. on other programs you may want to launch or be launched early), the start of the Avast UI has been delayed - which includes the tray icon.
However, it doesn't mean that your machine is not protected till then - the main service (AvastSvc.exe) is launched earlier and it doesn't need the UI to be running to scan and block infected files. So the real time protection is running, you just don't know about it for a while.

I want it to load up considerably faster too but doubt they will change it.
Title: Re: New Beta version 17.9.2320
Post by: bob3160 on December 10, 2017, 04:14:34 AM
I was talking about the Avast VPN Service. Please don't quote out of context.
Title: Re: New Beta version 17.9.2320
Post by: Alikhan on December 10, 2017, 07:58:10 AM
I was talking about the Avast VPN Service. Please don't quote out of context.

The VPN trqy icon loading is also delayed.
Title: Re: New Beta version 17.9.2320
Post by: bob3160 on December 10, 2017, 03:35:05 PM
I was talking about the Avast VPN Service. Please don't quote out of context.

The VPN trqy icon loading is also delayed.
Obviously you don't understand.
It takes a long time for the Avast tray icon to become visible. (OK, this is by design.)
Now you wait another 45 sec. or longer for the VPN tray icon to come up. - This is not acceptable.
Title: Re: New Beta version 17.9.2320
Post by: bob3160 on December 10, 2017, 03:56:29 PM
This mornings boot revealed the following:
(http://screencast-o-matic.com/screenshots/u/Lh/1512917610905-2306.png)
The Restart Service doesn't fix the problem.
I've just finished doing a repair. Hopefully the problem will be fixed once I reboot.  :'(


Windows Defender still states that I'm protected by Avast. ???
Title: Re: New Beta version 17.9.2320
Post by: bob3160 on December 10, 2017, 04:19:48 PM
A repair and reboot accomplished nothing.
Title: Re: New Beta version 17.9.2320
Post by: Patrick2 on December 10, 2017, 05:43:06 PM
Same on my Crappy Test Machine Intel Atom with 2gb of Ram, Windows 7 SP1 32bit,  UI Failing to Load for Avast,  Restart service so far does nothing, trying a repair shortly
Title: Re: New Beta version 17.9.2320
Post by: bob3160 on December 10, 2017, 05:45:16 PM
A repair and reboot accomplished nothing.
A clean install solved the problem. :)

Clean Install of Avast:
https://goo.gl/4Ptzkf
If you need additional help with the Clean Install, watch this:
https://youtu.be/p-h3myRD51A
Title: Re: New Beta version 17.9.2320
Post by: Patrick2 on December 10, 2017, 05:46:14 PM
Ok will get clean install done shortly on that little system
Title: Re: New Beta version 17.9.2320
Post by: RejZoR on December 10, 2017, 08:06:19 PM
Interestingly enough I never experienced Behavior Shield service shutting down or GUI failing to load. Quite a lot of people seem to have this problem here.
Title: Re: New Beta version 17.9.2320
Post by: Patrick2 on December 11, 2017, 01:08:53 AM
Well got it fixed on that system,  weird how it always happens on that one system,  GUI Failing to load or Behavior shield issues, and yes it was a clean install in the past, perhaps I switched to MSE/Avast too much on that system, who really knows for sure,  Definitely staying with Avast now though lol, too much hassle redoing all the exclusions for a game, and such.