Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Beta - Avast => Topic started by: petr.kolacek on May 24, 2018, 02:08:18 PM

Title: New Beta version 18.5.2339
Post by: petr.kolacek on May 24, 2018, 02:08:18 PM
Hi everyone,

new beta version 18.5.2339 (build 18.5.3907) is released.

What's new:

What was fixed:

Download links:
https://forum.avast.com/index.php?topic=179943.0

Enjoy this beta!
We are looking forward to your feedback.

AVAST Team.
Title: Re: New Beta version 18.5.2339
Post by: Asyn on May 24, 2018, 03:22:23 PM
Thanks Petr, testing...
Title: Re: New Beta version 18.5.2339
Post by: NON on May 24, 2018, 03:35:43 PM
Thanks for the new beta!

What's new:
  • Added "restore as" option to virus chest
Finally! 8)
Title: Re: New Beta version 18.5.2339
Post by: schmidthouse on May 24, 2018, 04:43:24 PM
Update fine.
THanks   :)
Title: Re: New Beta version 18.5.2339
Post by: Asyn on May 24, 2018, 05:29:11 PM
Please see https://forum.avast.com/index.php?topic=218426.0, else the beta is running smooth here.
Title: Re: New Beta version 18.5.2339
Post by: RejZoR on May 24, 2018, 06:01:31 PM
Working fine so far. Firewall registration with Security Center is fixed.
Title: Re: New Beta version 18.5.2339
Post by: lanshark4972 on May 24, 2018, 11:11:18 PM
Using XP SP3 up-to-date, uninstalling with Avast Clear between versions:
NB: I have never had the problem of avastui not loading. What I am seeing with the beta is two instances of avastui running: one apparently displays the UI and uses very little cpu when active; the other is the one now using 94%-97% cpu continuously. I can't kill the processes unless I first disable the self-protection.

Any questions?
Title: Re: New Beta version 18.5.2339
Post by: westk on May 27, 2018, 06:24:28 PM
What´s the new "offline mode" that appears in the main context menu?
Title: Re: New Beta version 18.5.2339
Post by: Csicso on May 28, 2018, 03:22:11 AM
Using XP SP3 up-to-date, uninstalling with Avast Clear between versions:
  • 18.3.3860.316 issue is avastui.exe keeping my cpu @ 91%-94%
  • 18.4.2338: no change
  • Hacked back to 18.3.2333: no change
  • Beta 18.5.2339: no change
NB: I have never had the problem of avastui not loading. What I am seeing with the beta is two instances of avastui running: one apparently displays the UI and uses very little cpu when active; the other is the one now using 94%-97% cpu continuously. I can't kill the processes unless I first disable the self-protection.

Any questions?

Windows XP?? 17(!) years old operation system. why do you use it? I do not even understand why it is a supported operating system by Avast.I'm sorry I did not want to be a troll
Title: Re: New Beta version 18.5.2339
Post by: MartinZ on May 28, 2018, 11:36:24 AM
yeah...we will soon announce end of support of these OS..
Title: Re: New Beta version 18.5.2339
Post by: Asyn on May 28, 2018, 12:53:12 PM
yeah...we will soon announce end of support of these OS..
Hi Martin, good to know. Any given timeframe..? Cheers
Title: Re: New Beta version 18.5.2339
Post by: MartinZ on May 28, 2018, 02:09:20 PM
we will announce the final date by the end of June.
Title: Re: New Beta version 18.5.2339
Post by: Asyn on May 28, 2018, 02:18:54 PM
we will announce the final date by the end of June.
OK, thanks.
Title: Re: New Beta version 18.5.2339
Post by: aharris2 on May 28, 2018, 04:12:19 PM
yeah...we will soon announce end of support of these OS..

Large numbers of Avast users use XP -see other forums. https://forum.avast.com/index.php?board=2.0.. We use it precisely to avoid all the bizarre issues that show up on later versions of Windows (maybe not Win7). Personally, I use it as a VM on my Mac, running flawlessly under Parallels, for all non-internet work, but need antivirus since XP files are accessible when shared with the Mac OS. The 18.4 version of the Avast Free Antivirus program introduced something that does not work with most installations of XP.  I reverted to the 18.3 version, which works fine. Presumably we will still be able to use updated virus definitions, running on 18.3  Nevertheless it would be nice if Avast would fix the problem introduced in 18.4  I have not tried the new beta, and will not until someone posts that it fixes the problem.
Title: Re: New Beta version 18.5.2339
Post by: schmidthouse on May 28, 2018, 04:54:36 PM
I still use my XP OS for in house tasks. Certainly not situations that require 'constant' internet connection.
XP is not a secure OS for a huge number of reasons beyond Anti Virus protection.
Anyway, nothing lasts forever, eventually all XP systems will cease to exist. :-\
Title: Re: New Beta version 18.5.2339
Post by: Csicso on May 28, 2018, 04:56:21 PM
yeah...we will soon announce end of support of these OS..

Large numbers of Avast users use XP -see other forums. https://forum.avast.com/index.php?board=2.0.. We use it precisely to avoid all the bizarre issues that show up on later versions of Windows (maybe not Win7). Personally, I use it as a VM on my Mac, running flawlessly under Parallels, for all non-internet work, but need antivirus since XP files are accessible when shared with the Mac OS. The 18.4 version of the Avast Free Antivirus program introduced something that does not work with most installations of XP.  I reverted to the 18.3 version, which works fine. Presumably we will still be able to use updated virus definitions, running on 18.3  Nevertheless it would be nice if Avast would fix the problem introduced in 18.4  I have not tried the new beta, and will not until someone posts that it fixes the problem.


compatibility with Xp can hinder development. Makes development difficult. I belive.
Title: Re: New Beta version 18.5.2339
Post by: Csicso on May 28, 2018, 05:00:36 PM
I still use my XP OS for in house tasks. Certainly not situations that require 'constant' internet connection.
XP is not a secure OS for a huge number of reasons beyond Anti Virus protection.
Anyway, nothing lasts forever, eventually all XP systems will cease to exist. :-\

Use it Windows 95,  they do not even write a vírus. I do not really understand what people think Will support be up to the end of time?


USE   L I N U X!
Title: Re: New Beta version 18.5.2339
Post by: bruce_b on May 29, 2018, 01:45:46 PM
A lot of us still use XP .. I use XP PRO SP3 on my old Dell Dimension 8200 P4 1.8Ghz 2GB RAM machine. It is a fully legit version of XP that is installed. As to Avast discontinuing support of XP, I use only the basics from Avast Free (File Shield, Web Shield, Behavior Shield) .. It has the latest stable release on it and is working fine. I would like to know how long we will still be able to auto update virus definitions after support for XP ends. Will the entire Avast Free stop installing on XP or only certain components of it, that a lot of us do not use ? ? ? What about AVG ? ? ? Will that work on XP ? ? ? Or does anyone have a good replacement that does not hog or slow down the computer if it is needed ? ? ?
Title: Re: New Beta version 18.5.2339
Post by: Asyn on May 29, 2018, 01:54:09 PM
Guys, the XP discussion is OT in this beta thread..!!
-> https://forum.avast.com/index.php?topic=219361.0
Title: Re: New Beta version 18.5.2339
Post by: aharris2 on May 29, 2018, 04:48:29 PM
Guys, the XP discussion is OT in this beta thread..!!
-> https://forum.avast.com/index.php?topic=219361.0

OK, I will make it on topic. This beta is supposed to fix the UI not loading problem on many/most XP machines. Can anyone tell me if this beta 18.5 fixes the problem - that is, if 18.4 had the problem on your machine, does 18.5 beta fix it?
Title: Re: New Beta version 18.5.2339
Post by: bruce_b on May 29, 2018, 04:51:32 PM
The current stable release works fine on my old Dell Dimension 8200 with a P4 at 1.8Ghz and 2GB RAM .. it is running XP PRO SP3 ... I do not know why some have issues and some do not. Sometimes a clean install of the antivirus is best. Also clear out your temporary files and run disk defragmenter.
Title: Re: New Beta version 18.5.2339
Post by: Csicso on May 29, 2018, 05:19:12 PM
A lot of us still use XP .. I use XP PRO SP3 on my old Dell Dimension 8200 P4 1.8Ghz 2GB RAM machine. It is a fully legit version of XP that is installed. As to Avast discontinuing support of XP, I use only the basics from Avast Free (File Shield, Web Shield, Behavior Shield) .. It has the latest stable release on it and is working fine. I would like to know how long we will still be able to auto update virus definitions after support for XP ends. Will the entire Avast Free stop installing on XP or only certain components of it, that a lot of us do not use ? ? ? What about AVG ? ? ? Will that work on XP ? ? ? Or does anyone have a good replacement that does not hog or slow down the computer if it is needed ? ? ?

A lot of us still use XP - changed windows 10 or LINUX.  DELL Dimension 8200 15 years old machine (i found it) Wonder how it works


Sorry for lots OFF.
Title: Re: New Beta version 18.5.2339
Post by: bruce_b on May 29, 2018, 05:35:32 PM
For it's age what I use it for (mainly Firefox 52.8.0ESR) and Office XP (word, excel) it does fine. It did need a new Nvidia Video card about 3 years ago when the one I ordered it with called it quits (my Dell (sony style) CRT monitor died about 3 weeks after the video card (that was replaced with a Dell S2340M monitor for $130) 
Title: Re: New Beta version 18.5.2339
Post by: bob3160 on May 29, 2018, 09:24:51 PM
Time to get back on topic. :)
Title: Re: New Beta version 18.5.2339
Post by: av20 on May 30, 2018, 08:13:23 PM
Another XP user here and the beta is working OK.
Title: Re: New Beta version 18.5.2339
Post by: aharris2 on May 30, 2018, 08:18:53 PM
thanks -  was 18.4 not working for you?
Title: Re: New Beta version 18.5.2339
Post by: av20 on May 30, 2018, 08:59:37 PM
thanks -  was 18.4 not working for you?

I remember reporting a bug in one of the betas that was related to a change in WiFi inspector.  It was fixed shortly afterward.
Title: Re: New Beta version 18.5.2339 not working on my XP
Post by: andy_wa on June 01, 2018, 03:29:10 PM
Hi,
The Beta version has the same problems as 18.4 version on my Windows XP SP3:

- when starting UI -> error "UI Failed to load"
- when starting definitions/program update -> error "RPC server not available"
- Avast Antivirus service not starting automatically,
            when trying to start it -> error 1053 "service does not replay to signal..."

Windows system services seem to work OK.
What else can I check?
Title: Re: New Beta version 18.5.2339
Post by: bruce_b on June 01, 2018, 03:34:49 PM
That sure sounds like a corrupt install. I would run Avast Clear to uninstall Avast (first backup your exclusions list), then be sure all program folders from Avast (including in the Docs & Settings folders) are removed. You may want to run a Registry Cleaner to be sure all old Avast Registry keys are gone. Then reboot and run the Full Off Line Installer of Avast  .. reboot again and see if all is good.
Title: Re: New Beta version 18.5.2339
Post by: aharris2 on June 01, 2018, 03:58:04 PM

I did all those things and more for 18.4 without effect (see previous posts).

"Using XP SP3 - no problems for many years with Avast Free Antivirus until this latest - UI does not load. Some postings indicate that fixes have been made, at least for Win10. However, on XP (SP3), version 18.4.3895.0 still has the problem. I have uninstalled, reinstalled, rebooted, and repaired. I have made all the suggested tweaks to "Services" (background intelligent transfer service; terminal services; remote desktop service), but the problem remains."

My XP works flawlessly in all other programs, and has worked on all previous versions of Avast through 18.3.

This is seems to be an issue introduced with 18.4 and has not been addressed in the beta 18.5. As others have noted, it apparently does not occur in some XP installations, but affects others. Probably some minor registry setting?

Title: Re: New Beta version 18.5.2339
Post by: bruce_b on June 01, 2018, 04:13:56 PM
That is why I suggested a full removal using the removal tool and a registry cleaner to get rid of any unwanted reg keys that may still be in the system.
Title: Re: New Beta version 18.5.2339
Post by: aharris2 on June 01, 2018, 04:15:33 PM
yep, did that too.
Title: Re: New Beta version 18.5.2339 not working on my XP
Post by: av20 on June 01, 2018, 09:28:25 PM
Hi,
The Beta version has the same problems as 18.4 version on my Windows XP SP3:

- when starting UI -> error "UI Failed to load"
- when starting definitions/program update -> error "RPC server not available"
- Avast Antivirus service not starting automatically,
            when trying to start it -> error 1053 "service does not replay to signal..."

Windows system services seem to work OK.
What else can I check?

Perhaps try a custom install with only file system shield enabled.  If that works, enable one thing at a time.  Use Avastclear from safemode prior to this install as well.  Another thought is that there is a XP service disabled that Avast is depending on, search the net for default XP service startups.
Title: Re: New Beta version 18.5.2339
Post by: NeverOnSunday on June 03, 2018, 05:26:02 AM
yep, did that too.

Aharris2,

Thank you for letting us know that whatever error the May 17th download introduced, it has not been fixed by this Beta download.  What all these helpful posters with their helpful suggestions do not appreciate is that nothing suddenly went wrong with all of our systems.  The error was introduced by Avast.  The error is not with our XP systems.
Title: Re: New Beta version 18.5.2339
Post by: Vitdom on June 06, 2018, 08:44:38 PM
I experienced a serious error in this Beta today. Avast logs: https://www.dropbox.com/s/bbobjo7r5m5kgmx/avastreport.zip?dl=1

After having scanned a folder through the Explorer context entry, Avast reported the Scan as Complete and No issues found!
Seconds later, an alert appeared from Avast that a file I scanned, had been identified as Win64:Malware-gen and has been moved to the Virus Chest.

I highly suspect this file is a false positive so I clicked "Report as false positive" but nothing happened, so I opened the Virus Chest and it was empty.
The file is gone and I can't find it.

Until this issue is fixed, I am disabling Avast Beta Shields and only use Windows Defender. I can't risk losing data. Fortunately the file that disappeared wasn't important and I can download it again as part of a software bundle.