Avast WEBforum

Consumer Products => Avast Passwords => Avast Passwords for Mac => Topic started by: me45 on December 02, 2018, 10:20:44 PM

Title: Firefox Issue
Post by: me45 on December 02, 2018, 10:20:44 PM
Hey there. Just made the switch from Chrome to Firefox.

The extension worked great on Chrome, but doesn't seem to work on Firefox.
I'm running the latest versions of both Firefox and Passwords.

Avast Passwords > Preferences > Browser > "Install Extension" (Firefox)
It brings me to the install page, where I install it. It just shows the icon with the exclamation point.

Going back to the install URL says:
"Sorry, something went wrong

Please make sure you have the latest Avast Passwords desktop app installed and try again."

Even though I am using the latest versions. Google Chrome switches "Install" to "Reinstall" but it still shows as "Install" for Firefox, so it's like it isn't registering that it's installed on Firefox, even though it is. I've tried deleting and re-installing the extension to no avail.

Any help would be appreciated.
Title: Re: Firefox Issue
Post by: David Mokos on December 17, 2018, 02:49:50 PM
Hello,
there has been a release of version 2.6.1 of Avast Passwords for Mac that should fix your problem. Could you please try updating the application?

Best regards,
David
Title: Re: Firefox Issue
Post by: me45 on December 18, 2018, 11:54:38 PM
Still need help.
Title: Re: Firefox Issue
Post by: me45 on December 18, 2018, 11:56:05 PM
Hello,
there has been a release of version 2.6.1 of Avast Passwords for Mac that should fix your problem. Could you please try updating the application?

Best regards,
David
Updated to the latest version, no fix.
Title: Re: Firefox Issue
Post by: me45 on December 19, 2018, 12:28:35 AM
Clicking the Firefox extension icon now says:

"Hmm... Something's not right

Avast Passwords requires Avast antivirus to work. Make sure Avast antivirus is running and try again. Don't have it? Download it for free here"
(Clicking used to do nothing, latest update shows that).

I have Avast Security installed, and running. As well as the extension.
Title: Re: Firefox Issue
Post by: David Mokos on December 20, 2018, 12:16:40 PM
Hello again,

Thank you for the provided error message. The error message is actually wrong and should say that the extension requires Avast Passwords to be running. So please make sure that Avast Passwords application is running. The problem with wrong error message is a problem on our side and will fix it as soon as possible. Thanks for reporting.

If Avast Passwords application is running and the problem still persists, I would advise to try once again removing the extension from Firefox (at about:addons (http://about:addons)), restarting Avast Passwords (from the top menu > Passwords icon > Quit) and reopen and installing it again using the button in Avast Passwords > Preferences > Browser > "Install Extension" (Firefox).

Other thing that comes to my mind that could potentially solve the issue is to close all other browsers and restart the Avast Passwords application.

Please let us know whether any of those advices has solved the problem. In the meantime we will further investigate what could go wrong in your setup.

Thank you for your patience.

Best regards,
David
Title: Re: Firefox Issue
Post by: me45 on December 20, 2018, 10:12:33 PM
Hello again,

Thank you for the provided error message. The error message is actually wrong and should say that the extension requires Avast Passwords to be running. So please make sure that Avast Passwords application is running. The problem with wrong error message is a problem on our side and will fix it as soon as possible. Thanks for reporting.

If Avast Passwords application is running and the problem still persists, I would advise to try once again removing the extension from Firefox (at about:addons (http://about:addons)), restarting Avast Passwords (from the top menu > Passwords icon > Quit) and reopen and installing it again using the button in Avast Passwords > Preferences > Browser > "Install Extension" (Firefox).

Other thing that comes to my mind that could potentially solve the issue is to close all other browsers and restart the Avast Passwords application.

Please let us know whether any of those advices has solved the problem. In the meantime we will further investigate what could go wrong in your setup.

Thank you for your patience.

Best regards,
David

Resolved the issue. Not entirely sure what changed, as I had tried restarting Avast Passwords before, but I guess a computer restart and opening the application fixed the issue.
Title: Re: Firefox Issue
Post by: David Mokos on December 27, 2018, 10:53:32 PM
Hi,

thanks for letting me know! I'm glad you were able to resolve the issue.

Best regards,
David
Title: Re: Firefox Issue
Post by: me45 on January 21, 2019, 09:13:05 PM
Hi,

thanks for letting me know! I'm glad you were able to resolve the issue.

Best regards,
David
Issue is reoccuring again.
Repeated the steps, and it's still disabled.