Avast WEBforum

Avast Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: kenrbnsn on September 16, 2019, 02:03:05 AM

Title: Excessive Memory Usage
Post by: kenrbnsn on September 16, 2019, 02:03:05 AM
Windows 7 (laptop) Lastest Microsoft updates applied
8Gb memory
1 TB internal disk (170 Gb free)
2 TB external disk

Since the last version 19.7.2388 was installed on September 9th, Avast has been using way too much memory.
See the jpg at the following URL:
https://kenrbnsn_general_files.s3.amazonaws.com/Avast%20Problem.jpg (https://kenrbnsn_general_files.s3.amazonaws.com/Avast%20Problem.jpg)

I've rebooted a few times. Normally after a reboot, my machine is at about 40% memory utilization, now after a reboot it's at close to 80%. I can hardly start up Chrome. It's also using between 25% & 50% of my CPU, which is also unusual.

I have the paid version.

What can I do to remedy this situation?

Thanks in advance,
Ken Robinson
Title: Re: Excessive Memory Usage
Post by: Asyn on September 16, 2019, 08:04:09 AM
Repair Avast:
1. Avast GUI -> Settings -> Troubleshooting
2. Click on 'REPAIR APP'.
3. Follow instructions.
4. Reboot.
Title: Re: Excessive Memory Usage
Post by: rocksteady on September 16, 2019, 02:50:17 PM
Ken,
FYI, people on here can be reluctant to click on 3rd party links to view your screenshot photos.
It is easy to upload photo as attachment to your post, just click on "Attachments and other options" below the text box.
Title: Re: Excessive Memory Usage
Post by: kenrbnsn on September 17, 2019, 04:35:21 AM
I did the repair as instructed. It's better, but Avast still seems to be taking up more memory than it did a few weeks ago. See attached image.

Sorry about posting the URL to my pic, but it was unclear that clicking on the link below would let me attach images. Most forums I've delt with allow embedded images.

Also, please replace the captcha with a better one.
Title: Re: Excessive Memory Usage
Post by: Asyn on September 17, 2019, 07:38:27 AM
- Other security related software installed..?
- Which AV(s) did you use before Avast..?

PS: Captcha is only needed for your first 3 posts. (Spam protection)
Title: Re: Excessive Memory Usage
Post by: kenrbnsn on September 17, 2019, 01:40:56 PM
I have used Avast on this machine for as long as I've had it -- over 2 years. It has been the only one I've ever run.

I also run SpyBot and have for years.

One thing I noticed last night and fixed this morning -- the windows icon cache was corrupted, and after following the directions on Microsoft to delete it and reboot, Avast seems to be behaving itself again. So that may have been the root of my problem all along, not Avast.

Re: captcha -- even though it's only displayed for the first 3 posts, you really should try to replace it with re-captcha. The style you use is extremely hard to use -- the first time I saw it, I got it wrong multiple times.

Title: Re: Excessive Memory Usage
Post by: Asyn on September 17, 2019, 01:49:09 PM
One thing I noticed last night and fixed this morning -- the windows icon cache was corrupted, and after following the directions on Microsoft to delete it and reboot, Avast seems to be behaving itself again. So that may have been the root of my problem all along, not Avast.
Sounds good, thanks for the feedback.
Title: Re: Excessive Memory Usage
Post by: igor on September 17, 2019, 02:37:32 PM
That's quite interesting if it's connected (could also be a coincidence)...
You don't happen to have a backup of the corrupted cache file, do you?