Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: wizzlbang on November 20, 2019, 11:40:45 PM

Title: Avast Pro Antivirus not working, "You are Unprotected"
Post by: wizzlbang on November 20, 2019, 11:40:45 PM
I got an alert last night that avast needed to restart my computer, with no further details given.
After doing so I noticed the avast icon in my system tray had a little red x on it, alerting me that I am unprotected, trying to open avast to investigate the problem, I'm greeted with the loading screen, telling me "this shouldn't take long", but it appears to be stuck on this screen indefinitely.
I've already tried right clicking and clicking "open avast user interface", and according to avast shield control "all shields are on"

Restarting has also not solved the problem
Title: Re: Avast Pro Antivirus not working, "You are Unprotected"
Post by: wizzlbang on November 20, 2019, 11:43:04 PM
I've also just noticed that my Avast Online Security plugin has also disappeared from my browser, though its still listed under my installed plugins
Title: Re: Avast Pro Antivirus not working, "You are Unprotected"
Post by: DavidR on November 21, 2019, 12:20:03 AM
What windows version are you using ?
Also what does the Windows Security Center report on security software running ?

Since the User Interface doesn't open according to your attached image, you could try running an Avast Repair from the Control Panel > Programs > Uninstall a program  > Avast Antivirus > Change - here you should find a Repair option.
Title: Re: Avast Pro Antivirus not working, "You are Unprotected"
Post by: wizzlbang on November 21, 2019, 01:04:10 AM
windows 7
I've used the repair tool from the uninstall options, it completed but I'm still having the same issue
Title: Re: Avast Pro Antivirus not working, "You are Unprotected"
Post by: DavidR on November 21, 2019, 01:38:29 AM
windows 7
I've used the repair tool from the uninstall options, it completed but I'm still having the same issue

What version and build number of avast are you using ?

Did you reboot after the Repair (it may be required) ?
Title: Re: Avast Pro Antivirus not working, "You are Unprotected"
Post by: wizzlbang on November 21, 2019, 01:59:56 AM
I did reboot, Avast Pro
I don't know how to check build number when it's in this state
I've noticed another thread up with many people with the same problem though, this extra thread is probably unnecessary
Title: Re: Avast Pro Antivirus not working, "You are Unprotected"
Post by: r@vast on November 21, 2019, 09:39:09 AM
Hi,

Have you tried this? https://forum.avast.com/index.php?topic=230502.msg1525984#msg1525984
and
https://forum.avast.com/index.php?topic=230502.msg1525996#msg1525996 (if you wish to back up and restore customized settings)

https://support.avast.com/en-ww/article/Backup-Antivirus-settings (Guide in English)
Title: Re: Avast Pro Antivirus not working, "You are Unprotected"
Post by: DavidR on November 21, 2019, 09:53:58 AM
<snip>
I don't know how to check build number when it's in this state

I've noticed another thread up with many people with the same problem though, this extra thread is probably unnecessary

If you use windows explorer open the C:\Program Files\AVAST Software\Avast folder and check the file properties of of one of the Avast executable files, or just hover your mouse over it it should give enough information on the file version.

Whilst it would be worth monitoring the other topic, it would be more relevant if you were using the same avast version.
Title: Re: Avast Pro Antivirus not working, "You are Unprotected"
Post by: Jakub Dubovic on November 21, 2019, 11:22:46 AM
I did reboot, Avast Pro
I don't know how to check build number when it's in this state
I've noticed another thread up with many people with the same problem though, this extra thread is probably unnecessary

Hello, thank you for reporting the issue. Do you mean this thread? https://forum.avast.com/index.php?topic=230412.0

It would help to determine if the cause of the problem is the same if you could
also generate the support package as described in the linked thread. We're working on fixing the issue.
Title: Re: Avast Pro Antivirus not working, "You are Unprotected"
Post by: wizzlbang on November 21, 2019, 12:07:12 PM
that thread, yes
I'll do so as soon as I can