Avast WEBforum

Consumer Products => Avast Mac Security => Topic started by: lukas.hasik on September 29, 2020, 11:31:04 AM

Title: BETA version 14.6 with support for BigSur
Post by: lukas.hasik on September 29, 2020, 11:31:04 AM
There is new version 14.6 of Avast Security for Mac available for Beta users. You can install it from links bellow.
 
What's new?

While the list may seems short we really had to rewrite the whole approach to real time protection aka shields. If you face any issues with browsing internet, playing videos or anytime when you have a feeling that something is wrong please let us know.

Download it from direct link - http://mac-av.u.avcdn.net/mac-av/10_10/beta/AAFM/avast_security_online.dmg
Technical change log - http://mac-av.u.avcdn.net/mac-av/10_10/beta/AAFM/changelog.html
Title: Re: BETA version 14.6 with support for BigSur
Post by: DarylW on September 30, 2020, 11:09:51 PM
Cannot login to my account or activate with this version, otherwise seems to have shields up.
Title: Re: BETA version 14.6 with support for BigSur
Post by: DarylW on September 30, 2020, 11:12:26 PM
Also, running Smart Scan causes app to crash.
Title: Re: BETA version 14.6 with support for BigSur
Post by: lukas.hasik on October 01, 2020, 10:58:42 AM
Cannot login to my account or activate with this version, otherwise seems to have shields up.
Any error message? Afair, there were no changes in this area of functionality...
Title: Re: BETA version 14.6 with support for BigSur
Post by: tomerV on October 16, 2020, 02:11:20 PM
Hi, When I had avast after I updated to bigsur, it didn't work, so I deleted it.
But now when I try to install avast, it says that I already have Avast Installed (But I don').
I'll add screenshots...

Thanks in advance, Tomer.
Title: Re: BETA version 14.6 with support for BigSur
Post by: lukas.hasik on October 16, 2020, 02:46:17 PM
Hi, When I had avast after I updated to bigsur, it didn't work, so I deleted it.
But now when I try to install avast, it says that I already have Avast Installed (But I don').
I'll add screenshots...

Thanks in advance, Tomer.
there must be some remnants of Avast. Please follow Jakub's recommendations at https://forum.avast.com/index.php?topic=221972.msg1480656#msg1480656
Let us know if it helps.
Title: Re: BETA version 14.6 with support for BigSur
Post by: lukas.hasik on October 16, 2020, 03:04:29 PM
FYI - 14.6 is available as regular version now https://forum.avast.com/index.php?topic=210570.0
Please note that it's not available at Avast's website yet (next week).
Title: Re: BETA version 14.6 with support for BigSur
Post by: Asyn on October 16, 2020, 03:12:56 PM
Nice, thanks Lukas. :)
Title: Re: BETA version 14.6 with support for BigSur
Post by: tomerV on October 16, 2020, 03:17:48 PM
Hi, When I had avast after I updated to bigsur, it didn't work, so I deleted it.
But now when I try to install avast, it says that I already have Avast Installed (But I don').
I'll add screenshots...

Thanks in advance, Tomer.
there must be some remnants of Avast. Please follow Jakub's recommendations at https://forum.avast.com/index.php?topic=221972.msg1480656#msg1480656
Let us know if it helps.

Hi, Thanks! It worked!
Title: Re: BETA version 14.6 with support for BigSur
Post by: happygerbster on October 16, 2020, 05:45:04 PM
So I just installed this today and it crashes my macbook completely:
- everything becomes unresponsive
- the macbook turns itself off instantly
- after boot i first get a message that the computer shut itself down because of an error (apple logo) before it proceeds to boot
- after boot the same as above repeats
- removing avast fixed the issue, i suspect its the kext files

Good to know, i also have a couple of other kexts installed; one is from Tripmode, and another one is from VirtualBox
Title: Re: BETA version 14.6 with support for BigSur
Post by: lukas.hasik on October 20, 2020, 01:47:46 PM
Hi happygerbster,
my bet is that there is some incompatibility between Tripmode and our web shield. I doubt that there is any issue with VirtualBox as we are using it as well ;)
Would you mind to help to prove it? However it would require you to install Avast again after you uninstall Tripmode. If everything works fine than there is probably some hiccup between these two products :(
One more question - did the issue appeared on BigSur or older macosx?

Thank you for sharing your experience with us!
Lukas


So I just installed this today and it crashes my macbook completely:
- everything becomes unresponsive
- the macbook turns itself off instantly
- after boot i first get a message that the computer shut itself down because of an error (apple logo) before it proceeds to boot
- after boot the same as above repeats
- removing avast fixed the issue, i suspect its the kext files

Good to know, i also have a couple of other kexts installed; one is from Tripmode, and another one is from VirtualBox
Title: Re: BETA version 14.6 with support for BigSur
Post by: colin.bray on October 28, 2020, 01:11:24 PM
Hi !

Avast 14.6 (9745695992b3) Free version doesn't run correctly on my Macbook (Mojave).
All previous versions I used were fine.

I have a warning for all core shields (File/Web/Email) stating :
We're sorry. There is some
problem on our side. We'll fix it
as soon as possible.


After a few days, this is still not fixed...
Can someone give me an update or explain if I need to do something?
I have already tried uninstalling and reinstalling, to no avail.

Thanks.
Title: Re: BETA version 14.6 with support for BigSur
Post by: lquinta on October 28, 2020, 02:10:24 PM
Hi !

Avast 14.6 (9745695992b3) Free version doesn't run correctly on my Macbook (Mojave).
All previous versions I used were fine.

I have a warning for all core shields (File/Web/Email) stating :
We're sorry. There is some
problem on our side. We'll fix it
as soon as possible.


After a few days, this is still not fixed...
Can someone give me an update or explain if I need to do something?
I have already tried uninstalling and reinstalling, to no avail.

Thanks.

It's not 14.6.  It's every version of Avast and every version of AVG.  Avast's service has been down for a week and they've done nothing to fix it.
Title: Re: BETA version 14.6 with support for BigSur
Post by: colin.bray on October 28, 2020, 02:21:29 PM
Thanks, that's good to know.

I wasted quite some time trying different things to fix the problem.  >:(

It reminds me of Garmin during the summer, when things weren't working correctly on their servers.
They kept quiet and then stalled : Later we heard that Garmin had been hacked and was the victim of a ransom demand. But, then probably Garmin wasn't using Avast  :D
Title: Re: BETA version 14.6 with support for BigSur
Post by: colin.bray on October 30, 2020, 04:15:54 PM
It's not 14.6.  It's every version of Avast and every version of AVG.  Avast's service has been down for a week and they've done nothing to fix it.
Where did you see this information - have they a message ?
I ask because on my old Mac with OSX 10.9.5, Avast still appears to start Core Shields.
Thanks.
Title: Re: BETA version 14.6 with support for BigSur
Post by: Thomas812 on November 16, 2020, 05:11:27 PM
Today is November 17, above described issues have not been solved.
Title: Re: BETA version 14.6 with support for BigSur
Post by: keithmac on November 19, 2020, 07:56:17 PM
Just upgraded my MacBook Pro to Big Sur. Running Avast 14.6 (sorry don’t have exact release number). Noticed in the Network settings on the Mac there are multiple instances of the Avast VPN Service. Appears that a new instance of the service is created every time the Macbook / Avast is restarted. If I manually disconnect and reconnect the VPN the same service instance is re-used but if I manually disconnect it and allow Avast to automatically reconnect it when I browse, a new instance is created, as opposed to the existing one being re-used. Each restart of the Mac is resulting a new service instance. Anyone else seeing this?

Thanks
Keith

Title: Re: BETA version 14.6 with support for BigSur
Post by: krahulik on November 20, 2020, 03:13:16 PM
Hello,
this behaviour has showed an historical version of Avast SecureLine, approx. a year ago in a combination with macOS 10.15 and newer. Could you please check that you are using the latest product version (4.1.1)?

Best Regards,
Martin
Title: Re: BETA version 14.6 with support for BigSur
Post by: keithmac on November 20, 2020, 06:38:13 PM
Hello - I have not deliberately separately installed Secure Line. When I installed the Free version of Avast Security I followed the prompts and it configured the VPN as result of the installation process. There is a step in the installation in which it prompts to configure Proxies and I accepted this prompt. I have attached a screenshot of the Avast Security version.
Thanks
Title: Re: BETA version 14.6 with support for BigSur
Post by: ray181 on November 24, 2020, 10:08:50 AM
We have an issue of avast automatically configuring VPNs in MacOS Big Sur. The unwanted VPNs automatically connect themselves and when deleted in network preferences they come back.

How can we stop these VPNs from connecting, or more to the point creating in the first place.

See this image showing avast prompting to install the VPNs during avast install process on Big Sur:

https://drive.google.com/file/d/1IDojd0X9bzzMA7jK_ziPYA3IaUL_-6Gt/view?usp=sharing (https://drive.google.com/file/d/1IDojd0X9bzzMA7jK_ziPYA3IaUL_-6Gt/view?usp=sharing)
Title: Re: BETA version 14.6 with support for BigSur
Post by: ondrej.kolacek on November 24, 2020, 10:45:50 AM
We have an issue of avast automatically configuring VPNs in MacOS Big Sur. The unwanted VPNs automatically connect themselves and when deleted in network preferences they come back.

How can we stop these VPNs from connecting, or more to the point creating in the first place.

See this image showing avast prompting to install the VPNs during avast install process on Big Sur:

https://drive.google.com/file/d/1IDojd0X9bzzMA7jK_ziPYA3IaUL_-6Gt/view?usp=sharing (https://drive.google.com/file/d/1IDojd0X9bzzMA7jK_ziPYA3IaUL_-6Gt/view?usp=sharing)
Hello,

Avast Antivirus does not configure any VPN. With Catalina, Apple has introduced Network Extension framework (https://developer.apple.com/documentation/networkextension?language=objc) for intercepting network traffic (which our Web Shield and Mail Shield need to do) instead of the old way (via Kernel Extension). This framework was AFAIK originally used on MacOS only to implement VPN, however on iOS it has also already contained the network traffic interception. This functionality was ported and expanded to MacOS in Catalina, although in an immature state. With Big Sur, Apple has discontinued kernel extensions, so we had to switch to this new technology.

Unfortunately despite the fact we are not using the VPN part of Network Extension (our system extension which uses Transparent Proxy and Dns Proxy for our Pro version), it shows as VPN in Networks in Preferences. This is probably an artifact of the fact that originally Network Extension was used for VPN; we have already reported other place where VPN term was erroneously used in messaging and Apple has fixed it, however we have not reported this yet. We will do so now, hopefully they will rename the records to better reflect what is actually being done (they have already done something similar with one other part of Network Extension functionality).

So please rest assured, unless you buy our VPN product, there is no VPN active.

Kind regards,
Ondrej Kolacek
Title: Re: BETA version 14.6 with support for BigSur
Post by: keithmac on December 12, 2020, 08:44:57 PM
Thanks Ondrej. Although the Proxy connection still falsely shows as a VPN connection when running release 14.7 on Big Sur (still expected for the reasons you provided), I can report that the multiple 'VPN connections' issue I reported previously has been resolved in 14.7. Thanks to the Avast Team for fixing this.

Regards
Keith