Avast WEBforum

Avast Products => Avast Free Antivirus / Pro Antivirus / Internet Security/ Premier => Topic started by: tri.bassett on January 13, 2007, 06:55:50 PM

Title: Avast install on 64 bit vista
Post by: tri.bassett on January 13, 2007, 06:55:50 PM
I just installed Avast 4.7 on 64 bit vista and find some odd behavio.  when Avast is in On Access Protection control, I cannot access task manager (Windows cannot access the specified device, path or file.  You may not have appropriate permissions to access the item).  Other applications (control panel, command prompt) result in the same error. 

Any clues? ???
Title: Re: Avast install on 64 bit vista
Post by: al968 on January 13, 2007, 07:07:26 PM
Welcome to the Forum  ;)
This is a known issue it will be fixed tonight or earlier according to this post :

http://forum.avast.com/index.php?topic=25697.135

Al968
Title: Re: Avast install on 64 bit vista
Post by: PheeniX on January 13, 2007, 08:42:38 PM
 :-[ i am having the same problems.. i have to shutdown avast in order to access or run many vista tools or programs. getting access denied all over windows vista 64 ultimate
Title: Re: Avast install on 64 bit vista
Post by: paesan on January 13, 2007, 08:53:21 PM
Just updated on vista 64 bit and I am getting the same access denied messages. System is acting very weird now with the new update. Sidebar won't even load. I had to diasble on access protection. Hope this is fixed soon.
Title: Re: Avast install on 64 bit vista
Post by: al968 on January 13, 2007, 09:27:35 PM
Paesan, PheeniX,

Did you read my previous post ??  :(
It's going to be fixed tonight  :)

Al968
Title: Re: Avast install on 64 bit vista
Post by: paesan on January 13, 2007, 09:32:16 PM
Yes al968, I did read it. What is wrong with me contributing some more info. What is the point of this forum if one can't contribute their issues with the program. Lighten up a little!!!
Title: Re: Avast install on 64 bit vista
Post by: al968 on January 13, 2007, 09:37:40 PM
Yes al968, I did read it. What is wrong with me contributing some more info. What is the point of this forum if one can't contribute their issues with the program. Lighten up a little!!!
All I am saying is that Vlk said that there was no need for additional posts about those issues as they have been fixed are will be released in a few hours  :)

Al968
Title: Re: Avast install on 64 bit vista
Post by: FlyBye88 on January 14, 2007, 08:51:32 AM
Yes al968, I did read it. What is wrong with me contributing some more info. What is the point of this forum if one can't contribute their issues with the program. Lighten up a little!!!
All I am saying is that Vlk said that there was no need for additional posts about those issues as they have been fixed are will be released in a few hours  :)

Al968

How do we know when it has been fixed and the new build is available? When it is available where will one find it - and can one see the build number before downloading?

 ::)
Title: Re: Avast install on 64 bit vista
Post by: alanrf on January 14, 2007, 09:04:24 AM
All that information will be posted in this forum by one of the moderators - as it always is.
Title: Re: Avast install on 64 bit vista
Post by: DavidR on January 14, 2007, 02:47:16 PM
How do we know when it has been fixed and the new build is available? When it is available where will one find it - and can one see the build number before downloading?

You can also check http://www.avast.com/index.html the build number, the bit after 4.7, e.g. .936 under latest updates, see image.
Title: Re: Avast install on 64 bit vista
Post by: FlyBye88 on January 15, 2007, 09:26:21 AM
How do we know when it has been fixed and the new build is available? When it is available where will one find it - and can one see the build number before downloading?

You can also check http://www.avast.com/index.html the build number, the bit after 4.7, e.g. .936 under latest updates, see image.

Thanks, I understand this - but the update to cure the problems with Vista 64+ that was apparently originally expected for a couple of days ago does not seem to be actually available for d-load allthough there is some talk here on the forum of an update being around?

- and yes one is impressed by the generally responsive support situation.

Now it will just be real nice when the goods are there too!  :o
Title: Re: Avast install on 64 bit vista
Post by: alanrf on January 15, 2007, 09:37:06 AM
This post explains that there may be a delay in updating the main current product information.

http://forum.avast.com/index.php?topic=25697.msg212558#msg212558

However, as many of us have found, the update promised on Jan 14th was provided as version 4.7.938 and may be downloaded by selecting the Program Update of the avast menu.

(Right click avast tray icon > Updating > Program Update)   
Title: Re: Avast install on 64 bit vista
Post by: sanelson on January 15, 2007, 09:48:44 AM
4.7.938 does not fix the problem with Vista x64.  At least, not for me.  I can't even log into Windows with it installed.  I'm running Vista x64 RC1, and have been running avast since I installed Vista several months ago.  The 4.7.936 update totally hosed my system after I rebooted as it did everybody else.  I did a system restore to fix the problem, and didn't find out it was avast until after I got everything back up and running and avast installed again.  When my system finally crashed a few minutes ago, and I had to reboot, I did an update to 4.7.938 from safe mode and the problem still exists.  I get to the login screen, click on my name, and enter my password, then Windows says "Logging OFF" and my monitor goes into sleep mode as if it's not getting a video signal.  I then have to hard-reboot my computer and log in in safe mode (where I'm writing this from).  I tried uninstalling 4.7.938, then reinstalling 4.7.936 from the website and updating to 4.7.938 before I reboot the computer.  The same thing still happens.  I can log-in to Windows normally as long as avast is not installed, but if either 4.7.936 or 4.7.938 is installed, I cannot log in at all except through safe mode.
Title: Re: Avast install on 64 bit vista
Post by: chinga69 on January 15, 2007, 10:18:16 AM
after a lot of playing around i have found that i have to customize the standard shield and untick scan executed progs and scan dynamic libraries  to be able to get access back for net and system .
Title: Re: Avast install on 64 bit vista
Post by: igor on January 15, 2007, 10:20:35 AM
Chinga, what build of avast! are you running?
Is the problem still present in 4.7.938?
Thanks.
Title: Re: Avast install on 64 bit vista
Post by: chinga69 on January 15, 2007, 10:24:01 AM
updated from 36 today to


 Program: Already up to date
  (current version 4.7.938)
- Vps: Already up to date
  (current version 000703-0)

Server: download76.avast.com (75.126.38.78)
Downloaded files: 3 (0.03 KB)
Download time: 2 s
Title: Re: Avast install on 64 bit vista
Post by: igor on January 15, 2007, 10:24:51 AM
And the problem (that applications cannot be started if Standard Shield is active) is still present there?
Title: Re: Avast install on 64 bit vista
Post by: chinga69 on January 15, 2007, 10:26:33 AM
im hoping i am still protected enough to keep me safe till the fix is released

Title: Re: Avast install on 64 bit vista
Post by: igor on January 15, 2007, 10:27:10 AM
Please, is the bug still present in 938 (i.e. if you reenable scanning of executed programs, does the problem appear again)?
Title: Re: Avast install on 64 bit vista
Post by: chinga69 on January 15, 2007, 10:28:04 AM
not if you untick 
untick scan executed progs and scan dynamic libraries


you get all acess back
Title: Re: Avast install on 64 bit vista
Post by: igor on January 15, 2007, 10:29:22 AM
Yes, I understand that - but if the option is selected, the problem is still there, right?
Title: Re: Avast install on 64 bit vista
Post by: chinga69 on January 15, 2007, 10:31:50 AM
yes until the fix is released

which should be soon the avast guys are very GOOD
Title: Re: Avast install on 64 bit vista
Post by: chinga69 on January 15, 2007, 10:39:08 AM
the problem is there as far as i cant get on the net or access some of my system but i can still log on when i reboot

Title: Re: Avast install on 64 bit vista
Post by: chinga69 on January 15, 2007, 10:40:44 AM
can some one tell me why i get kicked out of the thread when i post a reply
Title: Re: Avast install on 64 bit vista
Post by: paesan on January 15, 2007, 03:20:11 PM
Newest update to the update still not working properly. Time to go back to 892 version until things get fixed.
Title: Re: Avast install on 64 bit vista
Post by: Lisandro on January 15, 2007, 03:27:41 PM
Newest update to the update still not working properly. Time to go back to 892 version until things get fixed.
Which is the error?
Please, post the last 50-100 files of avast log files:
C:\Program Files\Alwil Software\Avast4\DATA\log\Setup.log
C:\Program Files\Alwil Software\Avast4\Setup\setup.log
Title: Re: Avast install on 64 bit vista
Post by: paesan on January 15, 2007, 03:48:49 PM
On windows startup I keep getting all these windows .exe error notifications. Also, internet connection will not work when avast is enabled.
Title: Re: Avast install on 64 bit vista
Post by: Lisandro on January 15, 2007, 03:51:31 PM
On windows startup I keep getting all these windows .exe error notifications.
Can you post a screenshot?
To know how to post a screenshot, see http://forum.avast.com/index.php?topic=8982.0
You can use WinSnap to get a screenshot (http://www.ntwind.com/software/winsnap.html).

Also, internet connection will not work when avast is enabled.
Which firewall do you use?
Into the firewall settings, the following programs should be allowed to connect:

C:\Program Files\Alwil Software\Avast4\ashWebSv.exe (avast! Web Scanner)
C:\Program Files\Alwil Software\Avast4\ashMaiSv.exe (avast! e-Mail Scanner Service)
C:\Program Files\Alwil Software\Avast4\Setup\avast.setup (avast! Update executable). This is a temporary file that just appears when an update (check) is about to launch, and disappears again afterwards.

Don't need rights to connect:
C:\Program Files\Alwil Software\Avast4\ashServ.exe (avast! antivirus service)
C:\Program Files\Alwil Software\Avast4\aswUpdSv.exe (avast! Update Service)
Title: Re: Avast install on 64 bit vista
Post by: chadderbox on January 15, 2007, 04:31:30 PM
I can't even see if I'm having that problem because with either .936 or .938 installed as soon as I try to logon to Vista, the screen almost immediately says Logging Off and goes dark.  I have to reboot in safe mode in order to get back into my system.  Is this a new problem or a known one?  Or possibly just a problem with my system? I am running Vista x64 on a Core2Duo CPU with 4GB's of memory if that helps.
Title: Re: Avast install on 64 bit vista
Post by: paesan on January 15, 2007, 04:57:17 PM
Well I am sticking with version 892. After uninstall of 938 and reinstall to 892 everything works fine. I then updated again to 938 and upon reboot I get message that all my recycle bins are corrupted, click ok and system never completely finshes booting up. Icons are there but i get access denied meesage when I try to access control panel , my computer, etc.  I had to boot into safe mode to get access to the control panel to remove avast and install with 892. Everything is fine with this version and I have spent enough time with this.
Title: Re: Avast install on 64 bit vista
Post by: Lisandro on January 15, 2007, 05:33:09 PM
Everything is fine with this version and I have spent enough time with this.
You can make it...
Anyway, I think there are some scheduled improvements for Vista 64bits
http://forum.avast.com/index.php?topic=26021.msg212665#msg212665
Title: Re: Avast install on 64 bit vista
Post by: PheeniX on January 15, 2007, 07:37:24 PM
I updated to 4.7.938 and started my avast services and immediately could not access any windows programs again. stopped the avast services and back to normal ???
Title: Re: Avast install on 64 bit vista
Post by: DavidR on January 15, 2007, 07:52:42 PM
What programs couldn't you access ?

What errors were displayed ?
Title: Re: Avast install on 64 bit vista
Post by: igor on January 15, 2007, 09:19:58 PM
Regarding 64bit Vista - please see here (http://forum.avast.com/index.php?topic=25697.msg212717#msg212717).
Title: Re: Avast install on 64 bit vista
Post by: paesan on January 15, 2007, 09:30:35 PM
Great work all. The 941 build seems to have fixed the vista 64bit issues. So far everything seems to be working fine. Thanks................
Title: Re: Avast install on 64 bit vista
Post by: chinga69 on January 16, 2007, 05:01:50 AM
yes all working here great job thanks muchly  ;D