Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: a good boy on April 15, 2007, 08:06:00 PM

Title: need help
Post by: a good boy on April 15, 2007, 08:06:00 PM
hi to everyone. ;D i have a problem. when i install avast and i open it says: Couldn't found ashAvast.exe :-\ :'( i install it 5 times but i don't know the problem. please answer.Thank You :D
Title: Re: need help
Post by: DavidR on April 15, 2007, 08:40:10 PM
Have (or did) you another AV installed in this system, if so what was it and how did you get rid of it ?
What is your firewall ?

Were you infected before you installed avast ?
I suspect you may have been, by a variant of the bagle virus which kills Anti-Virus applications and is hidden by a rootkit.

See http://forum.avast.com/index.php?topic=26554.0 (http://forum.avast.com/index.php?topic=26554.0)
http://forum.avast.com/index.php?topic=25941.0 (http://forum.avast.com/index.php?topic=25941.0)

http://research.pandasoftware.com/blogs/research/archive/2006/12/14/Rootkit-cleaner.aspx (http://research.pandasoftware.com/blogs/research/archive/2006/12/14/Rootkit-cleaner.aspx)
http://www.f-secure.com/blacklight/try_blacklight.html (http://www.f-secure.com/blacklight/try_blacklight.html)


The above is speculation, but one that has been in the forums, first try these options:
Try a repair of avast. Add Remove programs, select 'avast! Anti-Virus,' click the Change/Remove button and scroll down to Repair, click next and follow. You need to be on-line to do this.
If that doesn't work try, uninstall, reboot, install, reboot.

If neither of these work the above speculative suggestion may be correct.
Title: Re: need help
Post by: Lisandro on April 15, 2007, 08:52:13 PM
If you run ashSimp2.exe from avast folder, will the antivirus skinless version load?
Which Windows are you using?
Title: Re: need help
Post by: a good boy on April 15, 2007, 11:41:44 PM
thaks to all i've made it (i use Windows XP home edition)

i used a online scanner (i've had 200 viruses :o :o!!!) and i repair all the files. the i install avast and it works! thx to all
Title: Re: need help
Post by: Lisandro on April 16, 2007, 01:06:28 AM
thaks to all i've made it (i use Windows XP home edition)

i used a online scanner (i've had 200 viruses :o :o!!!) and i repair all the files. the i install avast and it works! thx to all
Don't forget to run avast at boot time to be sure you're clean.
Also, it will be good if you download, install, update and run trojan removers like a-squared and AVGantispyware.
Title: Re: need help
Post by: DavidR on April 16, 2007, 01:32:05 AM
thaks to all i've made it (i use Windows XP home edition)

i used a online scanner (i've had 200 viruses :o :o!!!) and i repair all the files. the i install avast and it works! thx to all

Well I thought you had some problems but 200 viruses.

Glad we could help, welcome to the forums.

You didn't answer the question about a firewall as I suspect you either don't have one or you have the XP firewall (assuming your XP home is up to date SP2), which doesn't provide any outbound protection.

Whilst the windows XP firewall is usually good at keeping your ports stealthed (hidden) it provides no outbound protection and you should consider a third party firewall.

Any malware that manages to get past your defences will have free reign to connect to the internet to either download more of the same, pass your personal data (sensitive or otherwise, user names, passwords, keylogger retrieved data, etc.) or open a backdoor to your computer, so outbound protection is essential. Otherwise keeping your system clean will be a continuing battle.