Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: zombieman on April 23, 2007, 06:45:56 PM

Title: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: zombieman on April 23, 2007, 06:45:56 PM
According to task manager, AshWebSv.exe is constantly using about 225,000K of memory, even with no web applications running. I'm using Windows XP. Avast is fully updated, and I've tried adjusting the sensitivity of the scanner, but to no avail. Does anyone know what might be causing this, and what I can do to fix it?
Thanks.
Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: DavidR on April 23, 2007, 08:14:18 PM
Mine is currently at Men Usage of 24,156K, Peak Usage of 38,664 with a VM size of 100,00K by all accounts (avast team) the VM Size is a more accurate guide.

The amount of usage will fluctuate in use and I wouldn't be unduly concerned unless the CPU % is also elevated and not 00% when idle ?

Have you recently downloaded anything ?
You could Terminate the web shield and start it again, I just did and now my figures are, Mem Usage 2,288K, Peak Usage of 14,336K and VM Size of 8,956K
Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: zombieman on April 23, 2007, 08:23:48 PM
Terminating and restarting the web shield sorted it, I don't know why I didn't think of that myself! Thanks for the help.
Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: DavidR on April 23, 2007, 08:43:29 PM
No problem, welcome to the forums.

Stick around and browse the forums, especially the sticky topics at the top of each of the forums, not to mention the avast help file. They provide a wealth of information to help you get the best from avast.
Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: zombieman on April 23, 2007, 08:48:36 PM
No problem, welcome to the forums.

Stick around and browse the forums, especially the sticky topics at the top of each of the forums, not to mention the avast help file. They provide a wealth of information to help you get the best from avast.

Don't worry, I plan to! I didn't even realise that there were any support forums until I had this bijou problem, and I decided to check out the support section of the website. :)
Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: DavidR on April 23, 2007, 08:55:23 PM
That is one of the strengths of avast a responsive and friendly support forum.
Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: Turboff on August 02, 2007, 06:25:34 AM
I have this issue with a fully updated avast 4.7 home edition, and terminating and restarting Web Shield did not help. My memory usage of Ashwebsv occasionally jumps to between 125,000 and 250,000k, thus making my 3.0GHz processor usage go from 1 to 50%, and increasing the CPU temperature from 48 to 62 degrees C. Only terminating the process stops it.

Please help, otherwise I will need to uninstall Avast and search for a different antivirus software.
Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: DavidR on August 02, 2007, 02:56:04 PM
What are you doing during the time the memory and CPU usage is high ?

The memory and CPU using will peek whilst scanning but should quickly drop, though I don't see this high memory usage in system. Currently my ashWebSv.exe shows a VM Size 10,280Kb, Mem Usage 26,924Kb and a Peak Usage of 45,804Kb.

Are you using any P2P applications ?
Have (or did) you another AV installed in this system, if so what was it and how did you get rid of it ?
Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: lukor on August 02, 2007, 04:25:34 PM
In these situations, if we should be of any help we must either know a way to reproduce the problem or at least have a current memory snapshot of that process. Otherwise, all what can be done is restarting, reinstalling etc.

You can easily create a memory dump of the WebShield process and then upload it to our servers.

For it, please download this tool:

http://www2.asw.cz/~rypacek/userdump.exe

Try to reproduce the problem and when Web Shield starts eating the RAM please execute it with the following command-line:

userdump ashwebsv.exe

This will create application memory dump, which might help us in identifying the problem. The dump will be created in the current directory with the name:

ashWebSv.dmp

You can upload this file (zipped) to our anonymous FTP server at:

ftp://ftp.asw.cz/incoming

and post the filename here (together with the problem description).

Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: Turboff on August 03, 2007, 09:58:18 PM
DavidR,

When this happens I am surfing the internet on Firefox, not doing anything out of the ordinary. No P2P applications are running. I used to have Norton AV but I uninstalled it via Control Panel>Add or Remove Programs prior to installing Avast.

lukor,

Today I was surfing on Firefox as usual when I heard the CPU fan get louder. I checked my processes and ashWebSv was running at around 50,000k and CPU usage was around 50%. I than ran the userdump. After the userdump was finished, I went back to terminate it and it was at 90,000k. After termination, CPU went back to 0-1%.

I have uploaded the zipped userdump. It is called 6073ashWebSv.zip

I hope this will help.
Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: DavidR on August 03, 2007, 10:54:04 PM
I would say you need to take another step to ensure NAV is completely gone.

A link worth looking at, which is a program removal tool that can remove the remnants of a number of different Norton Programs:
Removing your Norton program using SymNRT (http://service1.symantec.com/SUPPORT/tsgeninfo.nsf/docid/2005033108162039)
Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: Turboff on August 03, 2007, 11:05:12 PM
I ran the removal program. I'll wait and see now.

I actually had the problem occur again just a few minutes ago. It's weird, because previously it went up to 225,000k, but now the CPU usage jumps when it gets to 50,000k, which is a completely normal amount of memory. Firefox sometimes gets up to 60,000k and many programs that I have use up to 200,000k, so the CPU usage seems to be unrelated to the memory usage.
Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: DavidR on August 03, 2007, 11:09:33 PM
Have you rebooted after the SymNRT tool, I don't know if it would make a difference or not. It may well be worth reinstalling avast (uninstall, reboot, install, reboot) after having run SymNRT.
Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: Lisandro on August 03, 2007, 11:49:53 PM
I ran the removal program. I'll wait and see now.
Please, consider full SymNRT info:

1. Download and save these three files to the Windows desktop:
   a) ftp://ftp.symantec.com/public/english_us_canada/linked_files/tsgen/MSIFIX.bat
   b) ftp://ftp.symantec.com/public/english_us_canada/linked_files/tsgen/SymNRT.exe
   c) ftp://ftp.symantec.com/public/english_us_canada/linked_files/tsgen/SYMMSICLEANUP.reg

2. Run the three files that you just downloaded
   a) On the Windows desktop, double-click the MSIFIX icon.
      Click Run.
      A black window may appear very briefly.
   b) On the Windows desktop, double-click the SymNRT icon.
      Click Run.
      Click Next.
      Click I accept the License Agreement, and click Next.
      Type the letters and numbers that you see in the white box, and then click Next.
      Click Yes or OK at each prompt.
      You may need to click more than once. Your computer may be restarted for you more than once.
      You may be asked to repeat some steps after the computer restarts.
   c) On the Windows desktop, double-click the SYMMSICLEANUP icon.
      Click Run, and then click Yes.
      Click OK.

3. Boot.
Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: Turboff on August 04, 2007, 03:53:08 AM
DavidR, I did reboot after the removal tool, but the CPU jump happened again about 10 minutes ago.

Tech,

I ran the three files. I probably won't find out if it helped or not until tomorrow, however, because I'm done with the computer for today.
Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: Turboff on August 04, 2007, 07:24:37 PM
It did it again. I'll try reinstalling it.
Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: Turboff on August 04, 2007, 09:23:19 PM
Reinstalling didn't help. It did it again just now.

Before someones tries to ask how I reinstalled.
1. Uninstalled via Control Panel
2. Restart
3. Avast uninstall tool
4. Restart
5. Install
6. Restart

I'll be uninstalling it again and I guess I'll have to look for something else unless someone is able to provide a fix by the end of this weekend.
Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: Lisandro on August 04, 2007, 10:04:57 PM
I'll have to look for something else unless someone is able to provide a fix by the end of this weekend.
Well... you could post a list of the running programs and applications... something is conflicting or bringing trouble to WebShield. It's strange... and worse, it's difficult to troubleshoot...
Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: Turboff on August 04, 2007, 10:16:06 PM
Only Firefox is running.

Processes:

aawservice
AdskScSrv
alg
ashDisp
ashMaiSv
ashServ
ashWebSv
aswUpdSv
ati2evxx
csrss
ctfmon
EM_EXEC
explorer
firefox
gnotify
GoogleToolbarNotifier
iTouch
lsass   Edit: I don't know if this starts with an L or I
mDNSResponder
MsPMSPSv
raysat_3dsmax9_32server
services
smss
soundman
spoolsv
svchost (there are 6)
System
System Idle Process
Tablet
TabUserW
taskmgr
usnsvc
wdfmgr
winlogon
Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: Turboff on August 06, 2007, 03:24:39 AM
Any luck with the userdump, lukor? I like avast when it works, so I'd like to keep it. I've also ordered a new laptop which has Vista, and I plan to put avast on there as well. Hopefully I have no problems on it as it is a completely different system.
Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: Vlk on August 06, 2007, 10:33:50 AM
Hi Turboff,

I took a look at your dump, and I think the problem is related to a rogue Winsock LSP called xfire_lsp_8742.dll, that's somehow installed on your machine.
Could you please try to remove it see if it resolves the issue?

The step-by-step instructions on how to remove it are here: http://www.techspot.com/vb/topic18355.html

Thanks
Vlk
Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: Turboff on August 06, 2007, 06:10:41 PM
Alright, I've done it, Vlk. Now the waiting begins again.
Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: Turboff on August 08, 2007, 04:04:01 PM
It looks like it worked, Vlk! It's been two days now and no problems, whereas before it messed up every couple of hours. Thank you.
Title: Re: Avast 4.7 Home - Large Memory Usage in Ashwebsv.exe
Post by: Vlk on August 08, 2007, 05:45:45 PM
Sounds good. Thanks for taking your time and posting back.

Cheers :)
Vlk