Avast WEBforum

Consumer Products => Avast Mac Security => Topic started by: cein on June 12, 2021, 11:54:45 PM

Title: Avast VPN blocking certain website
Post by: cein on June 12, 2021, 11:54:45 PM

I'm currently on macOS Big Sur 11.4, Avast Security 14.9 (Free). It's a fairly new iMac.

Recently, I found it somewhat troublesome to connect to a certain website (Adorama.com), couldn't figure out why.
Safari cannot connect to a site, tried installing Chrome but didn't help anything. Meanwhile, I still can connect to Adorama on my iPhone. Then I tried on MacBook and it works fine at there as well.
So I checked bunch of stuffs like proxy and DNS to see if there's any issue (I found that some softwares change the setting without me knowing it somehow) but it doesn't seem likely. Only thing I found was that Use Passive FTP Mode (PASV) is checked. I tried to connect a website while unchecking it, but still the same.
Then I noticed that on the left side of Network Settings window, there's Avast Security is also appearing connected. So Avast Security was running VPN for my privacy; which was plus, but this is the one blocking me from connecting Adorama. I disconnected it and give it a shot, and the web page opened.

So I have a few question here :

1. Can I tweak the setting somehow so that I can connect to Adorama without disconnecting a VPN every single minute? (VPN automatically reconnected after a certain time disconnected)
2. Is it Adorama who blocked the all VPN connection somehow? (If anyone with Avast Security or VPN running test and leave me an update it would be much appreciated!!)

I'm pretty new to Avast, I just didn't expect VPN feature comes in a free version so I'm in mixed emotions now that half glad to have it but other half annoyed by blocking the website I frequently visit.

Thank you for your help in advance!

Title: Re: Avast VPN blocking certain website
Post by: ondrej.kolacek on June 15, 2021, 06:02:32 PM

Unfortunately we do not run VPN for your privacy; rather you are hitting a visual bug in MacOS Big Sur. Starting with Big Sur, Avast Web Shield has ceased using System Extensions (as these were discontinued in Big Sur) and has started using Network Extension framework instead. Unfortunately, even though we are using Network Extension in Transparent Proxy mode to scan web traffic, it shows in Networks as a "VPN". We have reported this nearly 2 years ago, and we do not think it will ever be fixed. It is causing us a constant headache as it is really confusing for our users.

What is happening instead is that Avast Web Shield is breaking adorama.com due to our bug. You disconnecting the "VPN" turns off Avast Web Shield for a minute, so it fixes the issue temporarily in the browser, then we detect the shutdown and restart tne Transparent Proxy.

I have just reproduced your issue it on my machine; our http2 code does not handle a specific kind of traffic correctly. I am now working on a fix; we will probably have to hotfix Avast 14.10 which is right now being released. Hopefully we will get a fix out at worst within a week or two.

Thank you a lot for reporting this issue; while our tests are pretty throughout, it is nearly impossible to find all these corner cases without people like you helping us by reporting such issues.

We appologise for the inconvenience.

Kind regards,

Ondrej Kolacek
Title: Re: Avast VPN blocking certain website
Post by: ondrej.kolacek on June 17, 2021, 12:45:38 PM
NOTE: the issue has been fixed in a repack of Avast 14.10 released yesterday (16.6.2021).
Title: Re: Avast VPN blocking certain website
Post by: Matej48 on October 11, 2021, 04:35:46 PM
Sorry but I am still experiencing the same issue on macOS Big Sur 11.6 with  Avast Premium Security 15.0.

As soon as I turn off the so called VPN I get access to these web sites and all works for that session but when I close the tab and try again it blocks the site. This happens on multiple random web sites.
Title: Re: Avast VPN blocking certain website
Post by: Matej48 on October 11, 2021, 04:51:34 PM
I just turned off the "Real Sites" and it looks like that is the issue. Looks like the DNS proxy configuration is messing things up.