Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: casey on April 12, 2004, 05:18:23 AM

Title: Timeout makes it unusable
Post by: casey on April 12, 2004, 05:18:23 AM
I have installed the newest Home version of "home" product. My configuration is:
 
Windows XP PRO Service Pack 1
Incredimail  Build 2501.361 (preferred)
Outlook Express 6 (also used to test all of bellow)
 
I have gone through the steps in your FAQ and all the threads dealing with this. I have started all over again specifying only 1 email account. I tried both with and without an attachement. I have increased the timeout in avast to 600 seconds!!!!

I am still having problem sending email. See messages bellow.

I have access to the mail server so I monitor the syslog messages. I don't see any activity and I don't see any activity on my DSL modem and/or router. When I disable the outgoing scan, the message goes in 1 or 2 seconds.


Email client stays in sending mode (email client says 100%), smtp icon is active for a while and then I get a message avast!: Connection timeout Internet connection timeout elapsed. Contnue waiting ?[ Server 'smtp1.sympatico.ca'. Port 25]  ...
 
When I press OK, my client gives the following message
 
421 tomts25-srv.bellnexxia.net Lost connection to [64.229.132.218]
 
In order to send this message, I had to turn the outgoing scan off.
 
Can you help ?
 
Lanny Rosicky
Toronto
 
   
 
Title: Re:Timeout makes it unusable
Post by: shgoh on April 12, 2004, 05:24:20 AM
did you enable smtp authentication?
Title: Re:Timeout makes it unusable
Post by: casey on April 12, 2004, 05:38:38 AM
The smtp authentication is checked (at the time I deplyed the mail wizard) - that is I did not change it from what the wizard set it at. When I look at the settings it says:

Login information for server 127.0.0.1

x logon using #smtp1.sympatico.ca
password nothing/empty
Title: Re:Timeout makes it unusable
Post by: shgoh on April 12, 2004, 05:49:55 AM
is your login info is yourusername#smtp1.sympatico.ca?

if it is...then that should be fine...make sure you didn't enable any TLS or SSL

try to run the mail wizard again to re-setup the protection
Title: Re:Timeout makes it unusable
Post by: jonzsie on April 12, 2004, 12:01:33 PM
I have been having the same problem, everything appears to be correct according to the help files. Can you please tell me where in avast you set the time out....I will check that. I am running foxmail.
Title: Re:Timeout makes it unusable
Post by: shgoh on April 12, 2004, 12:47:35 PM
I have been having the same problem, everything appears to be correct according to the help files. Can you please tell me where in avast you set the time out....I will check that. I am running foxmail.

click on the avast icon in your system tray...choose internet mail...customize...advanced...
Title: Re:Timeout makes it unusable
Post by: casey on April 12, 2004, 02:56:39 PM
is your login info is yourusername#smtp1.sympatico.ca?

if it is...then that should be fine...make sure you didn't enable any TLS or SSL

try to run the mail wizard again to re-setup the protection

Yes it is. The password is emptu, thoug. I rerun and rerun si I am out of breath now. Perhaps I will have to return to the other AV.
Title: Re:Timeout makes it unusable
Post by: techie101returns on April 12, 2004, 06:11:35 PM
Casey

The Avast timeout will have minimal effect on the STMP server conncection.

However, those of you using OE6 will have difficulty if the Timer Connection setting is not sufficient to allow sending of large files.  This setting is located in the Properties tab of the mail account settings found in OE.

Try this first.  Also, zipping large files instead of trying to send them in their original format helps since the file/s are compressed and take less time to transmit. (This can be a headache if the person on the other end doesn't know or have use of a Zip/Unzip program)


Techie
Title: Re:Timeout makes it unusable
Post by: casey on April 12, 2004, 06:28:38 PM
Casey

The Avast timeout will have minimal effect on the STMP server conncection.

However, those of you using OE6 will have difficulty if the Timer Connection setting is not sufficient to allow sending of large files.  This setting is located in the Properties tab of the mail account settings found in OE.

Try this first.  Also, zipping large files instead of trying to send them in their original format helps since the file/s are compressed and take less time to transmit. (This can be a headache if the person on the other end doesn't know or have use of a Zip/Unzip program)


Techie

As I tried to describe in my post, it happens even for a one sentence, no attachement email.
Title: Re:Timeout makes it unusable
Post by: jonzsie on April 13, 2004, 01:05:19 AM
Thanks I found the settings and changed them in avast and outlook express to the maximum and it still timed out. What if I changed them both to 0.....would that mean there was no time out?
Title: Re:Timeout makes it unusable
Post by: techie101returns on April 13, 2004, 01:48:05 AM
jonzie,

Yes, if you lower the timeout towards zero, it approaches no timeout.

At this point, I am nor sure what the cause of the problem could be.  
It seems as though the computer is waiting for an SMTP connection but does not see one and disconnects.

Have you reviewed the Help file on manual configuration of Avast? Let me know while I do some more research.

IMPORTANTAlso, how long ....from the time you attempt to send an email to the time you get the "timeout" alert?

Techie
Title: Re:Timeout makes it unusable
Post by: casey on April 13, 2004, 02:06:36 AM
As there is obviously no solution to this problem, I am going back to my AVG.  Thanks everybody for your help.

Title: Re:Timeout makes it unusable
Post by: jonzsie on April 13, 2004, 02:59:44 AM
I have just timed it. Sending an attachment about 470kb it timed out after 3mins. In the past it sometimes takes awhile to send attachments depending on their size but my program has never timed out. (this was before I installed Avast) It is only attachments I have the problem with. The progress bar for sending is completed staight away (and it should take awhile to complete) then it is just suspended then I get the time out message. If I send a smaller attachment of about 250kb it works. I am puzzled.  I will try changing the setting in Avast to 0 and keep the setting in Outlook at 6mins. I dont use outlook I use foxmail.....but it does the same in both programs.
Title: Re:Timeout makes it unusable
Post by: techie101returns on April 13, 2004, 04:11:48 AM
jonzie,

The 3 minute timeout does not conform to any of the times in Avast.  I was hoping to link it to something.

This is a long shot, but do you use a firewall?

Can it be that the FW is blocking the transfer of the attachments?

Maybe a call to your ISP might help.

Techie
Title: Re:Timeout makes it unusable
Post by: jonzsie on April 13, 2004, 04:27:28 AM
Thank you for all your help......I do use a firewall sygate but have had no probs with any other email clients. I WILL NOT GIVE UP.......I want to use Avast becasue it picked up a virus the first time I used the program when avg had missed it and so had trend online scan. This is what I came across in the help.

 Known problems
 

If the internet connection is too slow or the message being sent is too long, it is possible that the period your mail programs waits for the response, expires. A mail program that automatically disconnects after the times elapsed is not able to send such a message. This error will not be corrected, due to the characteristics of the SMTP protocol. It is necessary to set the interval to the highest possible value. When downloading a long message from a POP3 server, messages about timeout expiration should be eliminated. But it is still recommended to set this interval to the highest possible value, too.

That applies to Outlook but should not effect Foxmail as there has never been a time out period with foxmail.

Title: Re:Timeout makes it unusable
Post by: techie101returns on April 13, 2004, 05:07:31 AM
jonzie,

I don't give up either.  I came across this article which might help:

"Certain ISPs (as Netcom, Earthlink, AOL and others) will not let you send email via smtp-roam. They will silently force you to use their own SMTP server. This prevents you from being able to send email. If your connection times out, or otherwise fails when you attempt to send email , you may need to make a small tweak to your email program. Most programs let you switch from port 25, through which your ISP can hijack your SMTP server, to port 465, which will prevent this from happening"

It is worth trying

Also, I would like you to go into the Internet Mail module of the On Access Protection.  Go to Customize and disable "Scan outgoing mail under the SMTP tab.

Try to send email again.  I want to try and localize the problem area if it is indeed Avast.

Techie
Title: Re:Timeout makes it unusable
Post by: jonzsie on April 13, 2004, 07:47:47 AM
GOOD NEWS.....I have it working. I have set the avast email program to 0....and found a time out setting in foxmail which i thought was just to do with the dial up connection..set that 2000. And when I used the email wizard I only had one program high lighted not all programs.....I had select all before.....when I had select all it seemed to select the same procedure for both email programs.

I am happy.....thank you for all your input.
Title: Re:Timeout makes it unusable
Post by: shgoh on April 13, 2004, 01:12:10 PM
well done jonzsie...and welcome to avast
Title: Re:Timeout makes it unusable
Post by: techie101returns on April 13, 2004, 04:06:41 PM
jonzie,

Great!  At least I know we were right at the doorstep of the solution.

You learned a big lesson......never assume and never take for granted......especially computer settings!  ;D

Remember that we are here on the other end of the line and rely totally on the answers you provide to questions.  Timer settings were mentioned quite often in the post.
See how easy it is to overlook the "solution".

Glad you joined the forum and I hope you stop by again.

Techie

Title: Re:Timeout makes it unusable
Post by: casey on April 13, 2004, 04:22:52 PM
I am glad you can congratulate each other but mine is not working, unless I turn of the scanning of the output.

None of the suggestions in this post, in the help or FAQ seem to work.

Title: Re:Timeout makes it unusable
Post by: shgoh on April 13, 2004, 04:26:05 PM
I am glad you can congratulate each other but mine is not working, unless I turn of the scanning of the output.

None of the suggestions in this post, in the help or FAQ seem to work.



please be a little patient casey....we all tried our best to help...we are not god that can solve any problems...we too are still learning... :)
Title: Re:Timeout makes it unusable
Post by: casey on April 13, 2004, 04:31:51 PM
I am not impatient and do appreciate this community support - I just want to do my part --- perhaps I can do some trace or something. I do have access to the mail server (Unix sendmail) and I have the basic knowledge of the protocols.  I don't have access to my ISP (for the client email smtp).

So, if there is anything I can do to help in soving this, I'll do it.
Title: Re:Timeout makes it unusable GOT IT!
Post by: casey on April 13, 2004, 06:21:13 PM
I have turned off the insertion of the notification test and set the time out for AVAST to 0 (zero).  It now works perfectly!


See my new post on insert messages
Title: Re:Timeout makes it unusable
Post by: jonzsie on April 14, 2004, 12:09:00 AM
Casey I'm so glad you have it working too...it's totally frustrating and like techie said we have to persevere..there usually is an answer.

Techie thanks for taking the time to help out, your help has been greatly appreciated. I don't know what I would do without sites like this. A very big Thank you.

Jonzsie
Title: Re:Timeout makes it unusable
Post by: CharleyO on April 14, 2004, 03:00:52 AM
Well, Techie & everyone, I guess I can concider myself lucky since I use Earthlink email and have not yet had a problem sending email. In fact, I've not had any problems with avast! since first using it back in February.    ;D  

Also, I've not made any changes to the settings in my email account nor to avast! in order to be able to send out email. It all works perfectly for me. With avast!, I must be the fortunate son!    :D  


Title: Re:Timeout makes it unusable
Post by: techie101returns on April 14, 2004, 07:34:16 AM
Casey,
Please try not to "jump the gun" next time.  The solution was the same as the one we were "congratulating" each other on.
I guess you did not take the time to read Jonzie's post.

Jonzie,
Thank you for the kind words.

CharleyO,
Apparently, Foxmail is more prone to the "timeout" problem which requires Avast Timer to be set down to zero.

Each program does have their parculiarities and it takes us here on the forum a bit of time to get things sorted out.

Take Care,
Techie
Title: Re:Timeout makes it unusable
Post by: goa103 on January 29, 2005, 12:41:02 PM
IMPORTANTAlso, how long ....from the time you attempt to send an email to the time you get the "timeout" alert?

I read two topics about this timeout problem and can't understand how to solve it. You said to set a timeout to 0 in Avast!, but where is it ? I can't find anything in the preferences not was able to find the internet mail option right-clicking the system tray icon.

My problem is that I don't even try to send a mail. Avast! just pops up a timeout connection dialog some time to time.
Title: Re:Timeout makes it unusable
Post by: Lisandro on January 29, 2005, 01:30:53 PM
You said to set a timeout to 0 in Avast!

No... Please, timeout must be at least 120 seconds not zero... This is why you try to send an email and avast! just pops up a timeout connection dialog...

but where is it ? I can't find anything in the preferences not was able to find the internet mail option right-clicking the system tray icon.

Try to increase both timeouts (of avast into the Advanced tab of Internet Mail provider settings and of your email account, in Properties of the account, Advanced tab too). You can set both to 600, for instance. If you're on a DSL connection (not dial-up) it shouldn't be necessary a so long timeout anyway...
Title: Re:Timeout makes it unusable
Post by: goa103 on January 31, 2005, 09:32:53 AM
Try to increase both timeouts (of avast into the Advanced tab of Internet Mail provider settings and of your email account, in Properties of the account, Advanced tab too). You can set both to 600, for instance. If you're on a DSL connection (not dial-up) it shouldn't be necessary a so long timeout anyway...

I'm sorry but I can't find the timeout option you mention, I only have a SMTP tab in the preferences dialog, and other tabs but none related to internet mail. I use the Home version of Avast!, not Pro.

What happened since 4.0 because I never got trouble with 4.0, now that I upgraded to 4.5... This annoying pop up :(.
Title: Re:Timeout makes it unusable
Post by: Lisandro on January 31, 2005, 01:46:51 PM
I'm sorry but I can't find the timeout option you mention, I only have a SMTP tab in the preferences dialog, and other tabs but none related to internet mail. I use the Home version of Avast!, not Pro.

You're on the avast Settings...
You must start the On-line protection window: LEFT click the 'a' blue icon.
Choose Internet Mail provider.
Click on Customize
Go to Advanced tab...
Title: Re:Timeout makes it unusable
Post by: goa103 on February 02, 2005, 09:16:48 AM
You're on the avast Settings...
You must start the On-line protection window: LEFT click the 'a' blue icon.
Choose Internet Mail provider.
Click on Customize
Go to Advanced tab...

I was lost because I thought this option was in the Program Settings. Left clicking the A blue icon displayed the avast! On-Access Scanner dialog. Then I add to click the Details button to find the Internet Mail tab.

Thanks I was able to set the Timeout for Internet communication to 600, I will try 0 later if the Connection timeout dialog keeps popping up.

Just a suggestion but I think you should rename the Details button to Advanced (Settings).

Thanks.
Title: Re: Timeout makes it unusable
Post by: goa103 on February 17, 2005, 05:31:26 PM
So I set the timeout to 0 and it worked for some days... Today I tried to check my mail using my anti-spam software and got the following error message :

Quote
Failed connecting to POP3 source!

concurrent connections limit in avast exceeeded

I set the timeout back to 600 and about 15 timeout windows popped up ! I said no to each of them and now I don't know what to do. Searching for concurrent connections topics I found four topics but none of them give a clear solution : http://forum.avast.com/index.php?topic=10210.0 http://forum.avast.com/index.php?topic=9478.0 http://forum.avast.com/index.php?topic=9560.0 and http://forum.avast.com/index.php?topic=10189.0

Note that I use Sygate Personal Firewall as a firewall, ChoiceMail One as an anti-spam tool and Outlook as a mail client. However these softwares have been installed since 2 to 3 years now and since I upgraded to Avast! 4.5... I got into trouble : timeout, not I can't receive my mails.

What should I do ?
Title: Re: Timeout makes it unusable
Post by: vojtech on February 18, 2005, 12:26:44 PM
Is there a program name and server address in the timeout message ?