Avast WEBforum

Avast Products => Avast Free Antivirus / Pro Antivirus / Internet Security/ Premier => Topic started by: pwebonline on April 16, 2004, 10:56:22 PM

Title: The AAVM subsystem detected an RPC error!
Post by: pwebonline on April 16, 2004, 10:56:22 PM
Hi everyone. I don't know why but for some reason I can't make the resident protector to work on my W2k pro.
I am getting this error message: "The AAVM subsystem detected an RPC error!"
I tried to stop the service and run it manually but still doesn't work.
Any ideas?
Title: Re:The AAVM subsystem detected an RPC error!
Post by: Lisandro on April 17, 2004, 03:55:26 AM
Hi everyone. I don't know why but for some reason I can't make the resident protector to work on my W2k pro.
I am getting this error message: "The AAVM subsystem detected an RPC error!"
I tried to stop the service and run it manually but still doesn't work.
Any ideas?

Did you try the 'Repair' function (Control Panel > Add/Remove programs > avast > Change > choose the Repair option when a window pop-up)?

If this do not work, try uninstalling/boot/installing/boot...?
Did you change your shutdown properties in Windows 2k?
The two avast! services must be running automatically when Windows starts...  ::)
Title: Re:The AAVM subsystem detected an RPC error!
Post by: pwebonline on April 17, 2004, 08:02:15 PM
What do you mean change your shutdown properties in Windows 2k?
Title: Re:The AAVM subsystem detected an RPC error!
Post by: CharleyO on April 18, 2004, 12:19:56 AM
Yikes! While reading this very post a few mins ago, I encountered this same error!       :o  

The monitor went black with exception of the error message in seperate and narrow black bar across the top of the screen. Pressing Ctrl+Alt+Delete at the same time did nothing ... nor did the Esc key. So, I used the reset button to restart my computer.    >:(  

The reset made me go through the scandisk function, of course. But, the computer came up normal after that. Everything seems to be funtioning correctly now.    :)  

I have no idea why that occurred and had no way of getting a screen shot of the error message.    :(  

Title: Re:The AAVM subsystem detected an RPC error!
Post by: pwebonline on April 18, 2004, 02:34:18 AM
I did you try the 'Repair' function and it didn't work so I uninstaled/boot/instaled/boot again but right after windows starts there´s a red circle on avast! a-ball icon in system tray and when I click on it, the error message appears saying "the AAVM subsystem detected a RPC error" just like before. I enter the lincense code but the error persist. I check the services and the 2 avast's services are running in automaticly and so is the Remote Procedure Call (RPC).
I don't know what you mean by "change the shutdown properties in Windows 2k" though.
Title: Re:The AAVM subsystem detected an RPC error!
Post by: Lisandro on April 19, 2004, 04:59:11 AM
Sorry, I mismatch the topic with 'shutdown' problems. Maybe I thought in the 'service' properties. Sorry.

Usually, the uninstall/boot/install/boot process correct the RPC errors.
Do you have any other antivirus application running in your system?
Did you install any (even in the past)?

Title: Re:The AAVM subsystem detected an RPC error!
Post by: pwebonline on April 19, 2004, 03:09:36 PM
Just Avast in my system. I did try to install older versions and the last version over because of the repair the RPC error.
When uninstalling I tried to remove every record in the registry related to avast or alwil but it wouldn't let me:
LEGACY_AAVMKER4
LEGACY_ASWMON
LEGACY_ASWUPDSV
LEGACY_AVAST!_ANTIVIRUS
Title: Re:The AAVM subsystem detected an RPC error!
Post by: pwebonline on April 20, 2004, 03:34:56 AM
Anybody can help me??? I am loosing my mind here. I am starting to feel like I should try another antivirus  :'(
Title: Re:The AAVM subsystem detected an RPC error!
Post by: Lisandro on April 20, 2004, 04:08:55 AM
Generally, you're not allowed to delete LEGACY keys in the Windows Registry.
The problem are access rights (the LEGACY was already loaded).

Sometime in the past, I have to do it and use Registrar Lite (http://www.resplendence.com/docs/). The application has a feature to get control over right access (take the ownership) of the LEGACY.

But believe me. This happens (AAVM / RPC error) when you have a 'second' antivirus application in your system. Or you did not uninstall it correctly prior avast installation.

Can you say something about this?
You do not have to delete LEGACY keys if you uninstall the previous antivirus application, I suppose  ::)
Title: Re:The AAVM subsystem detected an RPC error!
Post by: Vlk on April 20, 2004, 08:09:08 AM
Is the "avast Antivirus" service running? (Control Panel -> Administrative Tools -> Services). If not, can you try to start it manually? Does it start? If not, what error messages do you get?

Thanks
Vlk
Title: Re:The AAVM subsystem detected an RPC error!
Post by: pwebonline on April 20, 2004, 03:27:39 PM
For of them are running automaticaly... I did try to run them manually though just in case. I made a fresh new instalation of w2k in this PC just a few days ago so I know for sure that it didn't have another antivirus installed. I did install avast a few times though. How do I fix this?
Title: Re:The AAVM subsystem detected an RPC error!
Post by: Vlk on April 20, 2004, 05:46:21 PM
Also check the Windows event log (Control Panel -> Administrative Tools -> Event Viewer), Antivirus category. Are there any "red" entries?

Thanks
Vlk
Title: Re:The AAVM subsystem detected an RPC error!
Post by: pwebonline on April 20, 2004, 06:10:33 PM
There's nothing at all in there.

Thanks,
Julio
Title: Re:The AAVM subsystem detected an RPC error!
Post by: Vlk on April 20, 2004, 06:12:36 PM
Is "ashServ.exe" in the process list (in the Task Manager)?
How much memory does it take?

Thanks
Vlk
Title: Re:The AAVM subsystem detected an RPC error!
Post by: pwebonline on April 20, 2004, 06:21:28 PM
Yes. There's ashServ.exe, ashMailSv.exe and a ashDisp.exe
Title: Re:The AAVM subsystem detected an RPC error!
Post by: pwebonline on April 20, 2004, 06:22:42 PM
ashServ.exe 4.536KB
ashMailSv.exe 940KB
ashDisp.exe 1.272KB
Title: Re:The AAVM subsystem detected an RPC error!
Post by: Vlk on April 20, 2004, 06:25:35 PM
Do you have the latest version of avast? (4.1.357)

4.5MB for ashServ is suspiciously little. There must be a problem in loading of the process. How many threads does it have? (you have to explicitly enable this column in the Task Manager's settings)

Thanks
Title: Re:The AAVM subsystem detected an RPC error!
Post by: pwebonline on April 20, 2004, 07:52:01 PM
ashServ.exe has 16 threads and 39488 page errors
Title: Re:The AAVM subsystem detected an RPC error!
Post by: pwebonline on April 20, 2004, 07:57:09 PM
and yes, I have the last version 4.1.357
Title: Re:The AAVM subsystem detected an RPC error!
Post by: Vlk on April 20, 2004, 09:39:39 PM
Thank.
And aren't there any entries in any of the categories of the avast! log viewer? (to access the viewer, e.g. right-click the avast tray icon). What matters are the categories Warning and higher...

Thanks
Vlk
Title: Re:The AAVM subsystem detected an RPC error!
Post by: pwebonline on April 20, 2004, 09:56:30 PM
Not even one  :'(
Title: Re:The AAVM subsystem detected an RPC error!
Post by: Lisandro on April 21, 2004, 04:00:53 PM
Not even one  :'(

Can you put the slider on the bottom position (debugger) and let it there?
Maybe next time something will be stored in the 'higher' categories...
Title: Re:The AAVM subsystem detected an RPC error!
Post by: Vlk on April 21, 2004, 11:23:23 PM
Any change in the latest version (4.1.389)?
Title: Re:The AAVM subsystem detected an RPC error!
Post by: pwebonline on April 22, 2004, 12:47:39 AM
I uninstalled the old version and installed the latest to see if it fix my problem but for some reason after rebooting w2k now does not start correctly, after logging in as Administrator it doesn't show any icon or anything, just the blue light wallpaper
Title: Re:The AAVM subsystem detected an RPC error!
Post by: pwebonline on April 22, 2004, 01:11:27 AM
I booted my w2k in secure mode and uninstalled avast and everything is back to normal.
Title: Re:The AAVM subsystem detected an RPC error!
Post by: Vlk on April 22, 2004, 08:11:08 AM
Did you remove your previous AV software before installing avast?
Title: Re:The AAVM subsystem detected an RPC error!
Post by: quickslam on April 23, 2004, 05:36:14 AM
I am having the same problem running Windows XP pro - SP1

My event viewer shows the following:

Event Type:   Error
Event Source:   avast!
Event Category:   Client
Event ID:   90
Date:      4/21/2004
Time:      12:46:41 AM
User:      NT AUTHORITY\SYSTEM
Computer:   SERVER
Description:
AAVM - scanning error: x_AavmCheckBootDirectEx: avscanScanReal of *BOOTA failed, 00000005.  

This problem has been occuring off and on Since February - sometimes I can log off and then back on and the problem will go away - some times I have to reboot several times - lately nothing will fix it.

Any help is greatly appreciated   ;D
Title: Re:The AAVM subsystem detected an RPC error!
Post by: Vegeta on April 27, 2004, 02:44:49 PM
Hi,

I have the same problem here. Some days ago I got DSL and I bought an Ethernet Card 10/100 from Realtek.
If I disable the Card via the Win-Manager the problem is gone after the next reboot.

Is there any way to fix this problem? It's very annoying to wait two minutes until avast running after a reboot (click on tray icon says: The AAVM subsystem detected an RPC error!).

I'm running Windows XP SP1 German with the latest patches.
There are no entries in the avast log and the two services (avast Antivirus/avast Controll Service) running automatically.
Avast Home Edition: 4.1.396

Greetings,
Vegeta
Title: Re:The AAVM subsystem detected an RPC error!
Post by: thenewking on May 04, 2004, 01:29:39 AM
hi i just installed avast and i did once have another AV on my PC which since have been unistalled


i am runnin zonealarm at start and thats it

OS is winxp
the def and program are upto date
splash cannot execute the following program
i get the error 0x000000c1 when i start avast c:\...\ashsimpl.exe

any ideas on what i can do to fix this
Title: Re:The AAVM subsystem detected an RPC error!
Post by: pk on May 04, 2004, 01:38:57 AM
0xC1 == ERROR_BAD_EXE_FORMAT (193) and means EXE file is not a valid Win32 application, maybe it's corrupted - try to repair avast.
Title: Re:The AAVM subsystem detected an RPC error!
Post by: thenewking on May 04, 2004, 04:09:15 AM
i did the repair thing and still the same error

should i reinstall

Title: Re:The AAVM subsystem detected an RPC error!
Post by: ZiP on May 04, 2004, 07:39:47 PM
I have this problem too. It started when I installed avast. I had this error for some time and then(I didn't do anything - as I know) it disapeard. It'd worked fine for some time and then again. I re-installed, changed the "Database" key of "data\avast4.ini" file from "ODBC" to "XML",
checked the Windows event log and there is a lot of errors, ashServ.exe is not in the process list, I have the latest version, in the avast log viewer there are 4 errors - one of them is - During the parsing of C:........DATA\avast4.xml XML document, following error occurred: C., I had some antivirus programs before but i uninstalled them correctly I think. I have ad-aware 6 an zone alarm installed. What's wrong?
Title: Re:The AAVM subsystem detected an RPC error!
Post by: ZiP on May 05, 2004, 08:54:57 AM
Anyone?
Title: Re:The AAVM subsystem detected an RPC error!
Post by: Vlk on May 05, 2004, 09:11:27 AM
Please send me the file avast4.xml (via email). Then you may try to delete it and restart the "avast antivirus" service...
Title: Re:The AAVM subsystem detected an RPC error!
Post by: DoctorO on May 06, 2004, 02:19:44 AM
Hey there.. I was having the same problem here and after much frustration, I found this and it solved the problem!!  (for me at least)

CAUSE
This issue occurs when one or both of the following conditions are true:
There is a file named Program in your SystemDrive folder.
There is a file named Common, SharePoint, or SharePoint Portal in your ProgramFiles folder.

RESOLUTION
To resolve this issue, rename, move, or delete the respective files from the SystemDrive folder or the ProgramFiles folder

You can find the full article here:
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q325680 (http://support.microsoft.com/default.aspx?scid=kb;en-us;Q325680)

Happy virus hunting!  ;)

Doc
Title: Re:The AAVM subsystem detected an RPC error!
Post by: ZiP on May 06, 2004, 04:16:55 PM
OMG!!! That's it. I deleted the file and now it's working. Thanks God.
Title: Re:The AAVM subsystem detected an RPC error!
Post by: CharleyO on May 07, 2004, 06:59:45 AM

Welcome to the forums, DoctorO! And thanks for the info that helped ZiP. I am sure others may find this useful also!    :)    


Title: Re: The AAVM subsystem detected an RPC error!
Post by: wpcoe on May 12, 2007, 05:58:10 PM
OK, now *I* am getting the dreaded avast "AAVM subsystem detected a RPC error'" message.

This is on my notebook computer that I only use on the road, and haven't been on the road for a while, so not sure when it started, but going to the error logs, I find that on 4/20/07 I started getting Program path "e:\programs\Avast" is invalid.  Correct it or rinstall the program.  I *do* have the program installed to that directory, with the only exception that "programs" actually is "Programs" when I view the directory tree in Windows Explorer.

I manually updated the program to "Build: May2007 (4.7.1001)" and also ran the Repair option from Control Panel > Add/Remove Programs.

Doctor O's MSKB suggestion does not apply ... I do not have files or folders thusly named in either my C:\ or E:\ drives.

I made sure the RPC and RPC Locator services are started.

The only avast processes showing in Windows Task Manager are ashDisp.exe (6480k) and aswUpdSv.exe (248k).

Do you suppose that it's the capitalization of the "programs" directory?

I *can* start avast! Antivirus to conduct a scan, I just cannot start "On-Access Protection"
Title: Re: The AAVM subsystem detected an RPC error!
Post by: Lisandro on May 14, 2007, 07:39:18 PM
The only avast processes showing in Windows Task Manager are ashDisp.exe (6480k) and aswUpdSv.exe (248k).
If ashServ.exe is not running, you're antivirus is disabled. Generally, will also being running ashMaiSv.exe and ashWebSv.exe.

Do you suppose that it's the capitalization of the "programs" directory?
No. avast should be able to run from any folder.
Does the path contain non-ASCII (or accented) characters?

Can you try?

1. Uninstall avast from Control Panel first.
2. Boot.
3. Use Avast Uninstall (http://www.avast.com/eng/avast-uninstall-utility.html) for complete uninstallation.
4. Boot.
5. Install again.
6. Boot.

By the way, any other antivirus installed (even in the past) in this computer?
Title: Re: The AAVM subsystem detected an RPC error!
Post by: wpcoe on May 15, 2007, 11:34:28 PM
Sorry for the delayed reply.  Life "on the road" has taken its toll and I've not been online as much as usual.

I did un- and re-install Avast and all is well now, revolving spheer in the system tray and all.

Not sure just what was the problem, but the re-installation fixed whatever it was.

Thanks for the help!
Title: Re: The AAVM subsystem detected an RPC error!
Post by: Lisandro on May 15, 2007, 11:47:12 PM
Not sure just what was the problem, but the re-installation fixed whatever it was.
Probably folder access rights... The reinstallation generally solves this...
Welcome to avast forums 8)
Title: Re: The AAVM subsystem detected an RPC error!
Post by: lwainer on September 22, 2008, 05:43:48 PM
I had the same problem, and here is the solution that worked for me.  If you uninstalled Avast in the past through the add/remove programs, you probably did not uninstall it correctly (as was the case for me). 
Avast has a program to uninstall it correctly on their website.  Here is the link that will remove the software completely from the computer.  Then you can reinstall.
http://www.avast.com/eng/avast-uninstall-utility.html
For some reason, if you uninstall any other way, there are things left in the registry that will conflict with a reinstall.  After removing it this way, reinstalling it works perfectly.
Title: Re: The AAVM subsystem detected an RPC error!
Post by: cipix on February 24, 2009, 04:53:33 PM
People, if all above fails, then RPC ERROR IS A  R A M ERROR.

Try upgrade your bios, or adjust ram frequency to lowest/safest.

If this still fails, change your RAM.


Title: Re: The AAVM subsystem detected an RPC error!
Post by: Lisandro on February 24, 2009, 06:43:16 PM
RPC ERROR IS A  R A M ERROR.
Well... why are you saying that? I think RPC error won't be related to hardware problems or RAM...
Title: Re: The AAVM subsystem detected an RPC error!
Post by: DavidR on February 24, 2009, 07:26:49 PM
RPC ERROR IS A  R A M ERROR.
Well... why are you saying that? I think RPC error won't be related to hardware problems or RAM...

Snap, this is I believe software and not hardware related, so I would appreciate where you found this theory/analysis.
Title: Re: The AAVM subsystem detected an RPC error!
Post by: wabbaloo on February 25, 2009, 07:33:04 PM
I'm also now dealing with this problem. I used to have either Norton or Mcafee a long time ago (at least 2 years), but then switched to Avast.  What do I need to do to rid my computer of any remnants of these programs?

I'm also running Windows Defender, Spycatcher, and Ad-Aware.  Using Windows Firewall because of some kind of problem with Zone Alarm, but it was some time ago and forget what it was.  IIRC, Zone Alarm had some kind of anti-virus capability as well. How much will any of this affect Avast?  Thanks!!!

The only avast processes showing in Windows Task Manager are ashDisp.exe (6480k) and aswUpdSv.exe (248k).
If ashServ.exe is not running, you're antivirus is disabled. Generally, will also being running ashMaiSv.exe and ashWebSv.exe.

Do you suppose that it's the capitalization of the "programs" directory?
No. avast should be able to run from any folder.
Does the path contain non-ASCII (or accented) characters?

Can you try?

1. Uninstall avast from Control Panel first.
2. Boot.
3. Use Avast Uninstall (http://www.avast.com/eng/avast-uninstall-utility.html) for complete uninstallation.
4. Boot.
5. Install again.
6. Boot.

By the way, any other antivirus installed (even in the past) in this computer?
Title: Re: The AAVM subsystem detected an RPC error!
Post by: DavidR on February 25, 2009, 07:34:45 PM
A link worth looking at, which is a program removal tool that can remove the remnants of a number of different Norton Programs:
Removing your Norton program using SymNRT (http://service1.symantec.com/SUPPORT/tsgeninfo.nsf/docid/2005033108162039)

McAfee has an uninstall tool that you could run to ensure any possible remnants are removed.
http://download.mcafee.com/products/licensed/cust_support_patches/VSCleanupTool.exe (http://download.mcafee.com/products/licensed/cust_support_patches/VSCleanupTool.exe) Or http://majorgeeks.com/McAfee_Consumer_Product_Removal_Tool_d5420.html (http://majorgeeks.com/McAfee_Consumer_Product_Removal_Tool_d5420.html)
2007 version - http://download.mcafee.com/products/licensed/cust_support_patches/MCPR.exe (http://download.mcafee.com/products/licensed/cust_support_patches/MCPR.exe)
Also see - How do I uninstall SecurityCenter? http://ts.mcafeehelp.com/faq3.asp?docid=71525 (http://ts.mcafeehelp.com/faq3.asp?docid=71525)
Title: Re: The AAVM subsystem detected an RPC error!
Post by: punitr1 on June 12, 2009, 04:00:22 PM
hi i am also having the same problem. when i switch my computer the  avast icon has a red circle on it and when i click on it says
'The AAVM subsystem detected an RPC error'.
I am also trying get rid of avast from my computer when i try to remove the software it, it says
Avast!
a setiface error has occurred: 536870929
Try to reinstal or contact support, please.

i am really confused  ??? what to do so could you please help..
Title: Re: The AAVM subsystem detected an RPC error!
Post by: .: L' arc :. on June 12, 2009, 04:03:48 PM
hi i am also having the same problem. when i switch my computer the  avast icon has a red circle on it and when i click on it says
'The AAVM subsystem detected an RPC error'.
I am also trying get rid of avast from my computer when i try to remove the software it, it says
Avast!
a setiface error has occurred: 536870929
Try to reinstal or contact support, please.

i am really confused  ??? what to do so could you please help..

-= Try Repairing avast installation via Add or Remove Programs --> Avast antivirus --> Change/Remove --> Scroll down to see the repair function..

-= *yawn* its already 12:00.. I guess its time for me to sleep.. Good night to everyone..
Title: Re: The AAVM subsystem detected an RPC error!
Post by: DavidR on June 12, 2009, 04:19:25 PM
hi i am also having the same problem. when i switch my computer the  avast icon has a red circle on it and when i click on it says
'The AAVM subsystem detected an RPC error'.
I am also trying get rid of avast from my computer when i try to remove the software it, it says
Avast!
a setiface error has occurred: 536870929
<snip>

You could start by answering this question - Have (or did) you another AV installed in this system, if so what was it and how did you get rid of it ?

This is by far the most common reason for this problem.

Or if no other AV installed now or before, try a clean reinstall:
Download the latest version of avast http://www.avast.com/eng/download-avast-home.html (http://www.avast.com/eng/download-avast-home.html) and save it to your HDD, somewhere you can find it again. Use that when you reinstall. Ensure that you scroll down and select the avast direct download link for the English version and not Cnet as that is for an on-line installation (not what you want to do). - Direct download for avast Home, English version, http://files.avast.com/iavs4pro/setupeng.exe (http://files.avast.com/iavs4pro/setupeng.exe).

Download the avast! Uninstall Utility, find it here (http://www.avast.com/eng/avast-uninstall-utility.html) and save it to your HDD.
Title: Re: The AAVM subsystem detected an RPC error!
Post by: Alien1344 on January 17, 2010, 11:58:39 PM
Solution to this is pretty simple by the way. Right click my computer and hit manage. Go to services and applications (the +) then press services. Under services locate 'avast! Antivirus', double click it and press start. Also set the drop down box to automatic. Voila! Fixed :). Press ok and close services box.

Edit: Avast still won't be running on-screen protection so locate the avast icon in your task bar, right click it and hit "start on-screen protection".

If the icon is not there open my computer, locate alwil software and avast4 (C:\program files\alwil software\avast4 by default) and run 'ashDisp'. Then do the step above. :)
Title: Re: The AAVM subsystem detected an RPC error!
Post by: skniazi786 on February 26, 2013, 11:57:59 AM
hey i have the screen shot of this error i m getting
(http://img809.imageshack.us/img809/4668/errorios.png)
Title: Re: The AAVM subsystem detected an RPC error!
Post by: DavidR on February 26, 2013, 12:23:16 PM
Not good to tag along on a topic with three years since the latest post and the topic created almost nine years ago.

The avast versions will be completely different. So any suggestions offered here are unlikely to work. Outside of this error has been related to having another AV installed or remnants of you previous AV left behind.

So it would be best to create your own new topic, sans very large coloured text, not needed  to get help.

In that topic answer the following question - Have (or did) you another Anti-Virus installed in this system, if so what was it and how did you get rid of it ?
Title: Re: The AAVM subsystem detected an RPC error!
Post by: Lisandro on February 26, 2013, 12:29:58 PM
skniazi786, which is your avast! version number and type?
Which was your previous antivirus before avast! and how did you uninstall it?
Title: Re: The AAVM subsystem detected an RPC error!
Post by: DavidR on February 26, 2013, 12:40:34 PM
From his image it looks like avast 7, but this shouldn't continue in this nine year old topic.
Title: Re: The AAVM subsystem detected an RPC error!
Post by: Yngvarson on June 17, 2013, 12:59:52 PM
And the problem still exist.
--------------------
ver. 8.0.1489 avast! Free Antivirus

Previous AV's:
avast! Internet Security - un-installed and cleaned with avast un-installing tool
--------------------

After installing this free ver. I cannot register due to error and no engine updates are available.
avast! Antivirus service is not running and cannot start (starts and stops right away).
Only procces currently running is AvastUI.exe

-------------------

Please help
Title: Re: The AAVM subsystem detected an RPC error!
Post by: diwax on June 17, 2013, 11:03:27 PM
I've also had this happen twice in the last few days after updates have occurred. To finally restart (remove the red X circle in the orange icon) I had to reinstall  (as a restore didn't work). Not sure why this happening. FYI I'm using the attached (paid) version of internet security-is the version you are using?
Title: Re: The AAVM subsystem detected an RPC error!
Post by: Yngvarson on June 30, 2013, 06:41:45 AM
Hi,

So I found out what was wrong in my case.

What I did:


it is working now as it should be!

Regards
Title: Re:The AAVM subsystem detected an RPC error!
Post by: anshul_jaiswal@rediffmail on June 30, 2013, 05:55:13 PM
I had uninstalled, booted, reinstalled and booted but the problem remains the same. I had also successfully unistalled AVIRA anti virus before installing AVAST. Please help

Also check the Windows event log (Control Panel -> Administrative Tools -> Event Viewer), Antivirus category. Are there any "red" entries?

Thanks
Vlk
Title: Re: The AAVM subsystem detected an RPC error!
Post by: anshul_jaiswal@rediffmail on June 30, 2013, 05:56:29 PM
Hi everyone. I don't know why but for some reason I can't make the resident protector to work on my W2k pro.
I am getting this error message: "The AAVM subsystem detected an RPC error!"
I tried to stop the service and run it manually but still doesn't work.
Any ideas?

I am also having the same problem, Please somebody help
Title: Re: The AAVM subsystem detected an RPC error!
Post by: Lisandro on June 30, 2013, 09:07:43 PM
I had also successfully unistalled AVIRA anti virus before installing AVAST.
Please, after you use Add/Remove, you should use Avira Antivir RegistryCleaner as well as the appropiate "Uninstallation Package", both of which can be found at: http://www.avira.com/en/support/support_downloads.html
Title: Re: The AAVM subsystem detected an RPC error!
Post by: ROBERTO FRANÇA on July 01, 2013, 12:58:35 AM
Since I reformatted my computer, try to put the license out and the message "The AAVM subsystem detected a RPC error". It turns out that inadvertently the first time, read and turned the TXT file and now everytime I ask the file, it comes in txt and the message. I am repeating the message because it was sent in capital letter and people did not understand. Help me. I do not know what else to do. Using the tradutor google.
Title: Re:The AAVM subsystem detected an RPC error!
Post by: anshul_jaiswal@rediffmail on July 01, 2013, 07:05:34 AM
I had uninstalled, booted, reinstalled and booted but the problem remains the same. I had also successfully unistalled AVIRA anti virus before installing AVAST. Please help

Also check the Windows event log (Control Panel -> Administrative Tools -> Event Viewer), Antivirus category. Are there any "red" entries?

Thanks
Vlk

Yes there are 2 Red entries.
1st - The avast! Antivirus service depends on the aswMonFlt service which failed to start because of the following error: The specified procedure could not be found.
AND the 2nd - The aswMonFlt service failed to start due to the following error: The specified procedure could not be found.
In Services (Local) avast antivirus is stopped but when i try to start it manually it gives the message : "Could not start avast antivirus service on Local computer. Error 1068: The dependency service or group failed to start."
Title: Re: The AAVM subsystem detected an RPC error!
Post by: anshul_jaiswal@rediffmail on July 01, 2013, 07:07:16 AM
I had also successfully unistalled AVIRA anti virus before installing AVAST.
Please, after you use Add/Remove, you should use Avira Antivir RegistryCleaner as well as the appropiate "Uninstallation Package", both of which can be found at: http://www.avira.com/en/support/support_downloads.html
i had done the same but still the problem remains
Title: Re: The AAVM subsystem detected an RPC error!
Post by: anshul_jaiswal@rediffmail on July 02, 2013, 10:26:58 AM
I had successfully uninstalled AVira and used Avira RegistryCleaner as well but still the problem remains.
Also when i check the Windows event log (Control Panel -> Administrative Tools -> Event Viewer), Antivirus category. There are 2 "red" entries.
1st - The avast! Antivirus service depends on the aswMonFlt service which failed to start because of the following error: The specified procedure could not be found.
AND the 2nd - The aswMonFlt service failed to start due to the following error: The specified procedure could not be found.
In Services (Local) avast antivirus is stopped but when i try to start it manually it gives the message : "Could not start avast antivirus service on Local computer. Error 1068: The dependency service or group failed to start."
Title: Re: The AAVM subsystem detected an RPC error!
Post by: Warlord1981 on October 09, 2013, 09:09:44 AM
I am having the exact same problem with anshul. I uninstalled Symantec Endpoint Protection from a Windows XP SP3 machine and then installed Avast Free Antivirus. After installation the red X appears on the avast icon and I get the message "The AAVM subsystem detected an RPC error!" Also when i try to manually start the avast service i also get the error message "Could not start avast antivirus service on Local computer. Error 1068: The dependency service or group failed to start." Anshul did u solve it?
Title: Re: The AAVM subsystem detected an RPC error!
Post by: dbrisendine on October 10, 2013, 05:51:11 AM
I have found that this is most likely a File System / WMI error (most likely caused by a fault in WMI service and / or permission restoring when uninstalling security software).  Your best bet in solving this problem (on XP, Vista or Win7) is to repair Windows.  You can either 'over-install' Windows on top of your existing installation (this keeps all your personal settings and files intact but may have you re-install some third party programs after the 'over-install') or you can search the web for a repair tool.  One that I have used for years is from hxxp://www.tweaking.com and is called Windows Repair (All-in-One).  There is no voodoo or mystery programs run by this tool; it is just a tool that runs Windows CMD commands for the repairs you want done.

One note is to download this program first, then download aswClear, disconnect from the internet and remove Avast (via Uninstall and then running aswClear in Safe Mode).  After Avast is removed, run the repairs you want (follow the steps), reboot twice and then install Avast & connect to the internet.
Title: Re: The AAVM subsystem detected an RPC error!
Post by: Warlord1981 on October 14, 2013, 09:03:53 AM
Sorry but the Windows Repair tool mentioned above didnt help. I'm still getting the same results with Avast installation. Thx though. Any other suggestions please?
Title: Re: The AAVM subsystem detected an RPC error!
Post by: dbrisendine on October 14, 2013, 10:32:40 PM
How did you remove Symantec Endpoint Protection?  Did you use Symantec's removal tool after the uninstall?  SEP can be very stubborn to remove; what version did you have?  You may want to check out this web site: http://www.symantec.com/business/support/index?page=content&id=TECH164769&actp=search&viewlocale=en_US&searchid=1381782607220 .
Title: Re: The AAVM subsystem detected an RPC error!
Post by: faithtech on November 15, 2013, 03:13:19 AM
I too as the others have received this error msg when installing avast free 2014 on an XP PRO SP2 machine. I too have followed all the advise as listed above, uninstalling rebooting, using the avast uninstaller, going thru the registry to remove every trace of avast and so on. Here are the screen shots of the error msgs i received when trying to register and start avast services. Any help is greatly appreciated.
Title: Re: The AAVM subsystem detected an RPC error!
Post by: DavidR on November 15, 2013, 11:25:22 AM
This error (in earlier versions of avast) is often related to having another AV installed or remnants of another AV.
Have (or did) you another Anti-Virus installed in this system, if so what was it and how did you get rid of it ?
Title: Re: The AAVM subsystem detected an RPC error!
Post by: goodbye on November 17, 2013, 08:55:18 AM
My RPC error messages occured on 4 separate PC's running 4 separate Windows versions. All out of the blue with no other software activity going on. In fact one PC I left running while I was gone for a week. Fine when I left but when I returned it had what I'm now calling the 'red dot of death'. No one (users or Avast staff) have a solution. On this thread...for someone to suggest reinstalling Windows is ridiculous. 
Title: Re: The AAVM subsystem detected an RPC error!
Post by: faithtech on November 17, 2013, 05:01:40 PM
This error (in earlier versions of avast) is often related to having another AV installed or remnants of another AV.
Have (or did) you another Anti-Virus installed in this system, if so what was it and how did you get rid of it ?
I had previous Avast Free edition, used the avast uninstaller, prior to that had tried Avira, used their uninstaller also, went thru the registry confirming no reg entries of Avira or Avast were left behind. Rebooted, tried to reinstall 2014 and received the error msgs that i provided screen shots of above. For the most part, I have run Avast Free for years and had Avast free installed when out of nowhere the RED X showed up over the Avast tray icon. Researched and found several possibilities and tried them all to no avail. I run Avast free on my laptop, my wife and daughters laptops also. The only machine I having trouble with is this machine, my desktop.