Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: admkrk on November 21, 2008, 09:32:24 AM

Title: There was an error while completing the setup process
Post by: admkrk on November 21, 2008, 09:32:24 AM
ssia

can't install avast home. i now have a folder in my program directory for it, but avast doesn't show up anywhere else including add/remove programs. it gives a very long log file but i don't know what part would be relevant tho.

any ideas why the install fails or do i need to post the log?
Title: Re: There was an error while completing the setup process
Post by: Lisandro on November 21, 2008, 01:45:30 PM
I suggest an installation from the scratch:

1. Uninstall avast from Control Panel first.
2. Boot.
3. Download the latest version of Avast Uninstall (http://www.avast.com/eng/avast-uninstall-utility.html) and use it for complete uninstallation.
4. Boot.
5. Install again the latest avast! (http://www.avast.com/eng/programs.html) version.
6. Boot.
7. Check and post the results.
Title: Re: There was an error while completing the setup process
Post by: admkrk on November 22, 2008, 01:30:48 AM
thank you very much. the uninstaller did the trick. loaded up no problems after that.
Title: Re: There was an error while completing the setup process
Post by: Lisandro on November 22, 2008, 03:52:46 PM
thank you very much. the uninstaller did the trick. loaded up no problems after that.
Good to know. Come back any time you need help ;)
Title: Re: There was an error while completing the setup process
Post by: joychild13 on October 18, 2009, 05:47:58 AM
I am having the same issue. Avast did not appear on the Add/Remove Program list. I went on to use the AshClear prgram to uninstall Avast in order to reinstall the program. After this, I received the error while completing the setup process.

Does anyone have any suggestions on what I might do next in order to get Avast installed?

I could do a system restore in which Avast would appear to still be on the computer but it would not accept my license key that I received from Avast via email. I am certain that I entered it in correctly. But the blue ball does not appear in the taskbar beside the clock.

PLEASE HELP!
Title: Re: There was an error while completing the setup process
Post by: Tarq57 on October 18, 2009, 06:07:06 AM
Hi joychild, get the full Avast installer file (36.99Mb) from here, (http://www.avast.com/eng/download-avast-home.html) see how it goes installing that way.
What error did you get? (The above assumes an error in downloading the setup file.)
Title: Re: There was an error while completing the setup process
Post by: joychild13 on October 18, 2009, 02:50:12 PM
I did download it from the correct location (both from download.com and from the Avast site directly.) I started the setup; it asked what language, etc. Then upon trying to setup it read "There was an error while completing the setup process." (And it supplied an setup log.)
Title: Re: There was an error while completing the setup process
Post by: YoKenny on October 18, 2009, 03:00:49 PM
@joychild

I suggest an installation from scratch:
http://forum.avast.com/index.php?topic=40286.msg337250#msg337250
Title: Re: There was an error while completing the setup process
Post by: joychild13 on October 18, 2009, 03:04:23 PM
I've done that twice already.  ???
Title: Re: There was an error while completing the setup process
Post by: .: L' arc :. on October 18, 2009, 03:41:35 PM
 Using a different installer? Actually, if the installer asks for a language to use, that is the Universal installer but what we want you to download is the complete installer. Here is a direct download like for it: here (http://files.avast.com/iavs4pro/setupeng.exe)
Title: Re: There was an error while completing the setup process
Post by: joychild13 on October 18, 2009, 03:53:24 PM
Well, I feel stupid now. I totally forgot that there was a setup for English directly. I shall try this.
Title: Re: There was an error while completing the setup process
Post by: Tarq57 on October 18, 2009, 10:11:54 PM
I'm confident that will work. It was what I was trying to gt you to do, but I guess the BIG PRINT on that page kind of steers you away from the full installer packs, so don't feel stupid.
Lots of folk with similar problems with the installer from Cnet, this full installer usually solves it.
Title: Re: There was an error while completing the setup process
Post by: shaqtucker0071 on August 24, 2016, 10:46:18 PM
I downloaded the avast from another PC and put it on my USB and put it on my infected  PC and opened it and that messege poped up
Title: Re: There was an error while completing the setup process
Post by: Pondus on August 24, 2016, 11:12:11 PM
I downloaded the avast from another PC and put it on my USB and put it on my infected  PC and opened it and that messege poped up
you are posting in a topic from 2009

If you want help with malware, create a new post in Viruses and Worms forum section