Avast WEBforum

Business Products => Archive (Legacy) => Avast Business => Avast Server Protection => Topic started by: JadeWire on January 22, 2009, 06:04:17 AM

Title: Exchange 2007 and Internet Mail Scanner
Post by: JadeWire on January 22, 2009, 06:04:17 AM
Hello,

This post is more of an FYI. We just upgraded a client's Server 2003/Exchange 2003 server to Server 2008/Exchange 2007 and with the gracious help of Avast tech support's directions we were able to migrate and upgrade without any issues.

We did, however, notice something that was causing an issue after we were all done.

We had all On-Access scanners running and we had reports of undelivered emails. Looking at the email queues showed certain emails to certain domains would not be delivered. We narrowed it down to a handful of domains and we thought it was certainly an Exchange issue.I spent the past 3 days with little sleep trying to crack this one.

I *just* discovered the problem was that the Internet Mail scanner (v4.8-1005) was enabled and blocking certain emails from completing their SMTP send. Note: It only affected about 10%-20% of the domains and the other emails went out ok.

After disabling the Internet Mail scanner, we have had no emails stuck in queue.

This is not a big problem for us since no one actually uses the email server to send an email (e.g. from Outlook) and thus this particular scanner is not really needed on this server. It might be a good idea to look into why this happens though.

I can duplicate the errors and testing if anyone from Avast is interested in the details - just send me an email from my account I just registered and I might be able to arrange a log-me-in session or something. For now, we are operating OK.   

Thanks
Title: Re: Exchange 2007 and Internet Mail Scanner
Post by: jsbac on March 11, 2009, 07:52:14 PM
I am having the exact same problem.  I'm running Exchange 2003 on Windows 2003 though.  I have one domain that I can not send to when Avast is configured to scan outbound email.  If I disable outbound scanning, I have no problems sending to this domain.  Is there a solution to this?
Title: Re: Exchange 2007 and Internet Mail Scanner
Post by: ToM ™ on March 12, 2009, 05:18:43 PM
Hi,

solution is turn off or better uninstall Internet Mail Provider which should not running on mail server anyway  ;).