Avast WEBforum

Avast Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: husskii on April 14, 2009, 04:13:47 AM

Title: Avast Splash screen at keeps crashing
Post by: husskii on April 14, 2009, 04:13:47 AM
Hi I'm using Avast 4.8 pro on XP Vista & Win7. Avast works great on both XP and Win7, but everytime I try to start Avast! Antivirus in vista, the splash screen keeps crashing.. When it crashes, a windows (problem reporting center) screen pops up saying that avast splash screen has crashed and if I want to close app or close app and search for a solution.. If I dnt press anything and just wait till avast loads & then if I press close, avast will stay open and work but if I press close while its loading, then avast will just close.  I have tried updates from MS that are supposed to help with certain apps crashing, and it hasn't helped.. Has anyone come across this problem before, that can maybe give a little insight on whats going on or maybe how I can resolve?
I'm using an Acer Extensa 5220
Intel Celeron processor 540 (1.86 GHz, 533 MHz FSB, 1MB L2 cache)
1.5GB DDR2 ram,
Win Vista SP1
thanks :)
Title: Re: Avast Splash screen at keeps crashing
Post by: scythe944 on April 14, 2009, 06:36:47 AM
It's a possibility that you had a previous version of some type of A/V that was NOT avast and it's giving you an issue.  Can you please tell us if you have had anything else installed before you put avast on that machine?
Title: Re: Avast Splash screen at keeps crashing
Post by: husskii on April 14, 2009, 12:35:25 PM
My notebook came pre-installed with norton, but I still had to register then activate. As soon as i started windows, I went to programs & features, then removed norton and live updates, after that I installed Avast and went from there....
Title: Re: Avast Splash screen at keeps crashing
Post by: onlysomeone on April 14, 2009, 01:11:55 PM
Download and use the norton removal tool:
http://service1.symantec.com/Support/tsgeninfo.nsf/docid/2005033108162039

After this un- and reinstall avast or try a repair of the avast installation (via the control panel - add/remove programs)

Hopefully this helps - please post back the results :)

yours
onlysomeone
Title: Re: Avast Splash screen at keeps crashing
Post by: scythe944 on April 15, 2009, 03:42:22 AM
Thanks onlysomeone.  As he stated, the removal tool should help greatly.

As usual, Norton can be a "PITA" to remove, and the removal tool is about the only thing that can totally get rid of it.  I'm sure that as soon as you run the tool (and reboot), things will be running normally.

I can't wait until they (big hardware manufacturers) stop bundling this, well, "crap" that they call A/V programs on their computers.  It really is more of a nuisance than a benefit.
Title: Re: Avast Splash screen at keeps crashing
Post by: husskii on April 15, 2009, 05:15:00 AM

I can't wait until they (big hardware manufacturers) stop bundling this, well, "crap" that they call A/V programs on their computers.  It really is more of a nuisance than a benefit.
You said it m8, not only does it not detect infections properly, but it also uses up most of your CPU to run... Thats my theory anyways..

Back to topic, I ran the removal tool twice and after both restarts, I attempted to run Avast & Both time it crashed... I also went into regedit and looked for anything that had symantic or norton in the name, I found 1folder labeled symantic so I decided to delete it. I then ran the removal tool again, but still no luck.... :(
Title: Re: Avast Splash screen at keeps crashing
Post by: onlysomeone on April 15, 2009, 08:35:04 AM
did you reinstall avast after using the removal tool of norton?
Title: Re: Avast Splash screen at keeps crashing
Post by: husskii on April 15, 2009, 09:42:23 AM
**I just removed and reinstalled Avast, but still when I try to start Avast! Antivirus it crashes. This time when I start avast! Antivirus, the first time I try, it will crash & then the second time, it works. this will happen continuously, and every second attempt works...
strange  ???
Title: Re: Avast Splash screen at keeps crashing
Post by: onlysomeone on April 15, 2009, 10:23:31 AM
can you try running the Simple User Interface 2?
You can find it nomaly in the following direction:
C:\Program Files\Alwil Software\Avast4\ashSimp2.exe

yours
onlysomeone
Title: Re: Avast Splash screen at keeps crashing
Post by: husskii on April 15, 2009, 10:50:17 AM
You just wanted me to try open ashSimp2.exe didn't you... Anyways I tried running ashSimp2.exe, and it open up with no hiccups....
Title: Re: Avast Splash screen at keeps crashing
Post by: onlysomeone on April 15, 2009, 10:57:58 AM
You just wanted me to try open ashSimp2.exe didn't you... Anyways I tried running ashSimp2.exe, and it open up with no hiccups....

Yes, thats what i wanted :)

And you don't use any other security software besides Avast and windows firewall? (antivirus, firewall, antispyware,...)

have you already run a boottime scan?

you could try to run Malwarebytes Antimalware (http://www.malwarebytes.org/mbam.php) and/or Superantispyware (http://www.superantispyware.com/) to make sure you are not infected...
Title: Re: Avast Splash screen at keeps crashing
Post by: husskii on April 15, 2009, 11:35:20 AM
I do have sandboxie as well, nothing else... I havent done a boottime scan, since re-install... I'll do one now and see if it helps, as for infections I hope not, but I guess i'll try them options too....

thanks :)
Title: Re: Avast Splash screen at keeps crashing
Post by: scythe944 on April 15, 2009, 03:53:31 PM
You might have to remove avast with the avast removal tool as well.  Get back to a clean slate, you know?

Then, you can try installing avast again, and see if the problem has been fixed.

You can get the removal tool from here: http://avast.com/eng/avast-uninstall-utility.html
Title: Re: Avast Splash screen at keeps crashing
Post by: husskii on April 17, 2009, 07:32:40 PM
I tried using avast uninstall tool but avast still crashes. I also noticed that when I open my browser, I don't get the avast script blocker popup, I completed a scan with malwarebyts anti-malware and it came up clean, but Im not confident that my pc is fully protected.
Title: Re: Avast Splash screen at keeps crashing
Post by: Mjolnir07 on May 31, 2009, 01:53:23 AM
Same problem here, truly frustrating. Nothing fixes it, Avast won't issue a refund.
Title: Re: Avast Splash screen at keeps crashing
Post by: calcu007 on May 31, 2009, 02:20:56 AM
Try uninstalling it in Safe mode
Title: Re: Avast Splash screen at keeps crashing
Post by: Mjolnir07 on May 31, 2009, 07:36:59 PM
Uninstalling and Reinstalling has been no help, I'm afraid, nor has repairing it or removing all other fragments of Antivirus programs. I think it's just incompatible with some vista systems.
Title: Re: Avast Splash screen at keeps crashing
Post by: Lisandro on May 31, 2009, 09:01:02 PM
avast is fully compatible with Vista in any system...
I think remains of Norton (or whichever other antivirus you had) are messing the computer.
Title: Re: Avast Splash screen at keeps crashing
Post by: Mjolnir07 on June 01, 2009, 04:24:25 AM
Not to seem like an ingrate. but that's not it. There isn't even a thought floating about my computer over Norton or any other antivirus program. This is a serious bug. I wish Avast would either look into it or give those of us with this problem our money back.
Title: Re: Avast Splash screen at keeps crashing
Post by: mkis on June 01, 2009, 04:45:35 AM
Hi there Mjolnir07 and husskii

Neither of you have provided any kind of substantive data to shed more light on your problems.
Even a HiJackThis log would provide some indication of whether Avast engine sits proper with your operating system, devices and contributing software. What about MBAM scan and attach log to reply post? What is Avast telling you - right-clik 'a' icon in tray at bottom right-hand corner of screen, and choose 'avast! Log Viewer'. Check errors.

The replies you are recieving from the forum are only as much as you can expect. Please provide some solid information.  
Title: Re: Avast Splash screen at keeps crashing
Post by: Mjolnir07 on June 01, 2009, 07:21:37 PM
Please forgive my tenacity, I assure that my frustration is directed at Avast and not those of you attempting of your own accord to assist in finding a solution out of personal generosity. Avast themselves have instructed I and perhaps others to do the very same things that are detailed here by users of this forum, my tone has been less than pleasant as a result and I beg many pardons.

Logfile of Trend Micro HijackThis v2.0.2
Scan saved at 12:16:44 PM, on 6/1/2009
Platform: Windows Vista  (WinNT 6.00.1904)
MSIE: Internet Explorer v7.00 (7.00.6000.16830)
Boot mode: Normal

Running processes:
C:\Windows\system32\taskeng.exe
C:\Windows\Explorer.EXE
C:\hp\support\hpsysdrv.exe
C:\Program Files\Hewlett-Packard\On-Screen OSD Indicator\OSD.exe
C:\WINDOWS\RtHDVCpl.exe
C:\WINDOWS\System32\rundll32.exe
C:\Program Files\Snapfish Media Detector\SnapfishMediaDetector.exe
C:\Program Files\Alwil Software\Avast4\ashDisp.exe
C:\Program Files\Mozilla Firefox\firefox.exe
C:\Windows\system32\wuauclt.exe
C:\Program Files\Trend Micro\HijackThis\HijackThis.exe

R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant =
R0 - HKLM\Software\Microsoft\Internet Explorer\Search,CustomizeSearch =
O4 - HKLM\..\Run: [avast!] C:\PROGRA~1\ALWILS~1\Avast4\ashDisp.exe
O4 - HKLM\..\RunOnce: [Launcher] %WINDIR%\SMINST\launcher.exe
O4 - HKUS\S-1-5-20\..\Run: [WindowsWelcomeCenter] rundll32.exe oobefldr.dll,ShowWelcomeCenter (User 'NETWORK SERVICE')
O23 - Service: avast! iAVS4 Control Service (aswUpdSv) - ALWIL Software - C:\Program Files\Alwil Software\Avast4\aswUpdSv.exe
O23 - Service: avast! Antivirus - ALWIL Software - C:\Program Files\Alwil Software\Avast4\ashServ.exe
O23 - Service: InstallDriver Table Manager (IDriverT) - Macrovision Corporation - c:\Program Files\Common Files\InstallShield\Driver\1050\Intel 32\IDriverT.exe
O23 - Service: LightScribeService Direct Disc Labeling Service (LightScribeService) - Hewlett-Packard Company - c:\Program Files\Common Files\LightScribe\LSSrvc.exe

ashDisp.exe, ashServ.exe, aswUpdSv.exe are all running in the clear, the error occurs when attempting to "start avast!" from the 'a' icon in the task bar. Here's a picture: http://pics.livejournal.com/odin88/pic/00016ge3/s640x480
Title: Re: Avast Splash screen at keeps crashing
Post by: scythe944 on June 01, 2009, 08:56:48 PM
I hate to be a bother, but it really doesn't look like you posted an entire HJT log.  You can actually attach the log file in it's ".txt" format on the forum so that we can download and analyze it.

Just click, "Additional Options" when you are creating your next post, click the browse button and double-click on your HJT log.
Title: Re: Avast Splash screen at keeps crashing
Post by: Mjolnir07 on June 02, 2009, 03:26:58 AM
I hate to bother in return, but I have a scant few processes on the ignorelist and they have little or nothing to do with Avast. Are you trolling here just to try to make me out to be retarded man? I attached the whole unignored list to this message. You can keep your help though brother, the last thing I came to this message board for was another person to paint me into a whiny child. That's exactly what Avast support did.

I really don't mean to sound like an ingrate, but it seems like your purpose here is to stand around pretending to have some worthwhile knowledge on the subject just waiting for an opportunity to call me a fool. Forget this, forget avast, I'll bite the money I wasted on it and speak not another word about it.

Good evening.
 
Title: Re: Avast Splash screen at keeps crashing
Post by: mkis on June 02, 2009, 03:45:05 AM
He is trying to help you with your problem.
Title: Re: Avast Splash screen at keeps crashing
Post by: onlysomeone on June 02, 2009, 11:21:34 AM
Hi Mjolnir07!

Do you have a HP PC?

Did you already run Malwarebytes Antimalware (http://www.malwarebytes.org/mbam.php) and/or Superantispyware (http://www.superantispyware.com/)?

yours
onlysomeone
Title: Re: Avast Splash screen at keeps crashing
Post by: DavidR on June 02, 2009, 04:29:31 PM
I hate to bother in return, but I have a scant few processes on the ignorelist and they have little or nothing to do with Avast. Are you trolling here just to try to make me out to be retarded man? I attached the whole unignored list to this message. You can keep your help though brother, the last thing I came to this message board for was another person to paint me into a whiny child. That's exactly what Avast support did.
<snip>

Your HJT log is without doubt the shortest I have seen in these forums and that is I believe why scythe944 mentioned it in the first place, no other reason.

Whilst Vista HJT logs are smaller than XPs for instance, this is still very small, this could be as a result of an undetected/hidden process blocking much of HJTs digging.

So the suggestion to run the other programs is well worth the trouble, for peace of mind if nothing else. Though I have to say it is strange if it only presented itself in this way conflicting with the splash screen causing a crash.

I don't use the pro version, but can you not disable the splash screen (which I think is related to the Script Blocker) and see if that makes any difference.
Title: Re: Avast Splash screen at keeps crashing
Post by: scythe944 on June 02, 2009, 06:54:59 PM
Jeez... I was just trying to help.  I'm not trying to call anyone a fool, but seriously bro, that log is small!  I'll waste my time elsewhere I guess...
Title: Re: Avast Splash screen at keeps crashing
Post by: Wolfeen on June 22, 2009, 10:04:33 PM
Ok so I have the same. It started yesterday. While I was surfing in the net avast reported me some dangerous stuff on page and block it. After it my Vista report that gui crash and stop working.
I tried to reinstall Avast and now alway got Splash stop working while run gui from avast.
After crash in:

C:\Program Files\Alwil Software\Avast4\DATA\log

it's create files - for example:

unp79619576.tmp.mdmp

In log I found Splash screen crashes after reports this:

Code: [Select]
2009-06-22 21:58:11 SYSTEM 1608 Sign of "HTML:Iframe-inf" has been found in "http://pixhost.eu/avaxhome/avaxhome/2008-06-22/menue_lotr866.jpg\{gzip}" file. 
2009-06-22 21:58:13 SYSTEM 1608 Sign of "HTML:Iframe-inf" has been found in "http://pixhost.eu/avaxhome/avaxhome/2008-06-14/y1pA5_7nYF9X0Pr4EAHxa04aCmxPBJl1NPSM36TTSPLwNKUOnnCUYjk4CZ1_iVtqDl6iZVBEtDzf8o.jpg\{gzip}" file. 

I scan my PC with SpyBot and AVG and nothing was found. I wanna return to Avast but always got it spot working.

Anybody help?
Title: Re: Avast Splash screen at keeps crashing
Post by: Lisandro on June 22, 2009, 10:06:48 PM
Wolfeen, welcome to forums.
Why do you think the avast detection is wrong and AVG is correct?
Title: Re: Avast Splash screen at keeps crashing
Post by: Wolfeen on June 23, 2009, 06:54:45 AM
Hi,
I do not think that way but after crash as I wrote above I can not scan my PC with avast (so I installed AVG to test if my PC was infected).

Any comments about crashes?
I found also when I open My computer and use Scan drive C:\ I got dialog avast! Shell Extension Scanner stop working. The same as I am trying to run avast from tray.

BTW: I reinstall Windows Vista (SP2) and install Avast Home - updated defs and go to page with pictures as I mentioned above and Avast reported:

Sign of "HTML:Iframe-inf" has been found in "http://pixhost.eu/avaxhome/avaxhome/2008-06-22/menue_lotr866.jpg\{gzip}" file.  
Sign of "HTML:Iframe-inf" has been found in "http://pixhost.eu/avaxhome/avaxhome/2008-06-14/y1pA5_7nYF9X0Pr4EAHxa04aCmxPBJl1NPSM36TTSPLwNKUOnnCUYjk4CZ1_iVtqDl6iZVBEtDzf8o.jpg\{gzip}" file.  

and crash again. Nothing was done more only new copy of windows  and last version of avast.

Help please.

Title: Re: Avast Splash screen at keeps crashing
Post by: YoKenny on June 23, 2009, 07:49:36 AM
Woolfeen, the pixhost.eu site is infected with malware that its Webmaster needs to fix
Code: [Select]
6/23/2009 1:28:55 AM    SYSTEM  1192  Sign of "HTML:Iframe-inf" has been found in "http://pixhost.eu/\{gzip}" file.  
My Windows 7 system with avast! did not have a problem other than complaining that the site was infected.

Please read
Quote
gumblar.cn summary
June 3rd, 2009

In the previous month the World Wide Web was subject to one of the heaviest attacks since it first came into existence. Thousands of legitimate websites were attacked by the Trojan horses JS:Redirector-H and JS:Redirector-J, the aim of which was to infect millions of unsuspecting users.  avast! was the first antivirus program to detect the infection right at the start and all users of avast! were protected throughout the duration of the attack. Now, more than a month after the attack was first detected, it is possible to assess the attack.
http://blog.avast.com/2009/06/03/gumblarcn-summary

Make sure that AVG is completly removed as just disabling it stops avast! from working:
http://www.avg.com/download-tools
Title: Re: Avast Splash screen at keeps crashing
Post by: Wolfeen on June 23, 2009, 08:00:20 AM
Tnx for reply. But it does not explain why new clean installation of Vista and avast home crashes after reports (as I wrote above).

BTW: Later this day I will try English Windows 7 with avast in VirtualBox to test.

Anybody can visit:

http://pixhost.eu/avaxhome/avaxhome/2008-06-22/menue_lotr866.jpg

without harm avast (on Vista [PL])?

And why reinstall of avast does not help...
Title: Re: Avast Splash screen at keeps crashing
Post by: Wolfeen on June 24, 2009, 07:06:42 AM
OK. Again:
Windows 7 - reports Virus detection and I can abort connection.
Vista still the same.

How to find what's corrupted in my Vista?
Title: Re: Avast Splash screen at keeps crashing
Post by: Wolfeen on June 30, 2009, 08:04:26 AM
Some words after investigation:
Splash screen crashes on my Vista with SP2 (beta) - polish language - at links I mention above. But if Vista [PL] is not updated to SP2 - only SP1 everything works OK. No crash. So I think it's Vista SP2 bug.