Avast WEBforum

Consumer Products => Avast Mac Security => Topic started by: keithhmh on August 17, 2009, 11:41:04 AM

Title: Can't load it to turn off persistent application prior to temporary delete
Post by: keithhmh on August 17, 2009, 11:41:04 AM
I have a loan MacBook (from John Lewis's - how's that for service) while I my iMAC is being repaired. I have restored my latest Time Machine backup and was up and running within the hour with one exception and that was Avast. It is refusing to kick off scanning emails as they arrive and hanging the mail system so I decided to delete it and reinstal and therein is my problem.

I had already dragged the Avast application to trash when I remembered the business about turning off persistance before doing so. I reloaded the latest version and installed that. If I try to manually launch it now it says : Virus Engine cannot load, contact support so here I am. What should I do to get it all working again as the process of receiving emails is a real pain.

Title: Re: Can't load it to turn off persistent application prior to temporary delete
Post by: zilog on August 18, 2009, 12:54:13 PM
I have a loan MacBook (from John Lewis's - how's that for service) while I my iMAC is being repaired. I have restored my latest Time Machine backup and was up and running within the hour with one exception and that was Avast. It is refusing to kick off scanning emails as they arrive and hanging the mail system so I decided to delete it and reinstal and therein is my problem.

I had already dragged the Avast application to trash when I remembered the business about turning off persistance before doing so. I reloaded the latest version and installed that. If I try to manually launch it now it says : Virus Engine cannot load, contact support so here I am. What should I do to get it all working again as the process of receiving emails is a real pain.

Hallo,
1) you can just go to email preferences, rules, and disable avast rules - then, mails will be received directly and the problem might be gone.

2) persistence - something's still in your launchd's plist. install avast from the package, and turn persistent mode off, to get rid of those avast-related lrecords.

3) engine cannot run is strange - has nothing to do with launchd/plist/whatever, but with user-id. but also, re-ionstallation should restore your structure in your home directory, and avast will start.

regards,
pc
Title: Re: Can't load it to turn off persistent application prior to temporary delete
Post by: keithhmh on September 09, 2009, 11:27:02 PM
Hi Zilog

I got my iMAC back and I still have the same problem. Prior to every email that comes in I get a messsage window saying the 'virus engine won't load ' with a Terminate button. I press in this and the email then arrives. If I try to load Avast I get a very similar message - "Engine cannot launch - The virus scanner engine cannot launch: try please to re-install the application, or consult the support". Antivirus, the agent and preferences are all greyed out and as soon as I click on the terminate button it all disappears. I seem to be totally stuck as I can't deleteit properly and if I try to reload it it doesn't cure the problem. Any suggestions as to what to do next please

Keith
Title: Re: Can't load it to turn off persistent application prior to temporary delete
Post by: zilog on September 14, 2009, 06:12:53 PM
Hi Zilog

I got my iMAC back and I still have the same problem. Prior to every email that comes in I get a messsage window saying the 'virus engine won't load ' with a Terminate button. I press in this and the email then arrives. If I try to load Avast I get a very similar message - "Engine cannot launch - The virus scanner engine cannot launch: try please to re-install the application, or consult the support". Antivirus, the agent and preferences are all greyed out and as soon as I click on the terminate button it all disappears. I seem to be totally stuck as I can't deleteit properly and if I try to reload it it doesn't cure the problem. Any suggestions as to what to do next please

Keith

Hallo, first, make sure that 400.vps exists in your home directory, Library/Application Support/com.avast.MacAvast sub-directory. If not, one is in /Application/avast!.app (use ctrl-click), Show Package Contents, then go to Contents/Resources. Or, download latest one from http://files.avast.com/files/latest/400.vps .

regards,
pc
Title: Re: Can't load it to turn off persistent application prior to temporary delete
Post by: robowolf on November 11, 2009, 09:32:56 PM
Sorry to bump the topic, but I've got the same "Engine Cannot Launch". I tried to follow Zilog's instructions, but there is no Library/Application Support/com.avast.MacAvast sub-directory. I have Parallels, so I've been installing the Mac+PC trial version (http://www.avast.com/eng/avast-antivirus-mac-edition.html).

Should I create the com.avast.MacAvast folder? Is it already supposed to be there? I can't figure out what I'm doing wrong.
Title: Re: Can't load it to turn off persistent application prior to temporary delete
Post by: zilog on November 12, 2009, 06:21:22 PM
Sorry to bump the topic, but I've got the same "Engine Cannot Launch". I tried to follow Zilog's instructions, but there is no Library/Application Support/com.avast.MacAvast sub-directory. I have Parallels, so I've been installing the Mac+PC trial version (http://www.avast.com/eng/avast-antivirus-mac-edition.html).

Should I create the com.avast.MacAvast folder? Is it already supposed to be there? I can't figure out what I'm doing wrong.

Hallo,
Parallels = virtualiser. So, consider everything that runs under parallellised-windows as common windows application. Mac+PC means you'll get 2 licenses - one for windows avast antivirus, and one for mac. What matters is the innermost system, avast inside parallels doesn't (and mustn't) know about the outside world - macos, in this case. so, take it as tweo quite separate AV products, just bought bundled together.

more on this topic here: http://forum.avast.com/index.php?topic=47427.0

regards,
pc