Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: Amrynel on December 03, 2009, 12:45:19 PM

Title: Avast not updating from VPS 091203-0
Post by: Amrynel on December 03, 2009, 12:45:19 PM
Hi, well, I had an interesting day. Many phone calls to/from my customers re the bad update (I do tech support for a living). One pharmacy saw their network grind to a complete halt after the update chewed on their medical database software... fortunately they are back up and running, but Avast is gone from that business. :(

I digress. When I saw 091203-1 was out, I ran the iAVS update on my machine (Vista Ultimate, 64-bit). It tried to send a big file back to Alwil (1.6MB or so) which failed. So I ran the iAVS update again a while later, and the following is now happening:


I have also tried downloading the 091203-1 update from the website and running it myself, but it simply reports the definitions are already up to date.
Title: Re: Avast not updating from VPS 091203-0
Post by: nmb on December 03, 2009, 12:49:22 PM
Hello Amrynel,

sorry for what has happened.

if you are sure that the files which were infected before are successfully restored and they are not being flagged as virus, could you just do a fresh install of avast!

you can get the uninstall utility here : http://www.avast.com/eng/avast-uninstall-utility.html

make sure you install using the latest, updated setup version available on the home site.

thanks

nmb
Title: Re: Avast not updating from VPS 091203-0
Post by: Vlk on December 03, 2009, 01:37:28 PM
Please also see here: http://forum.avast.com/index.php?topic=51615.msg437093#msg437093
Title: Re: Avast not updating from VPS 091203-0
Post by: Amrynel on December 03, 2009, 01:47:59 PM
Thanks nmb, Vlk.

Since avast was no longer attempting to submit the file, but simply failing to update properly, I took the advice to clean and reinstall.
Title: Re: Avast not updating from VPS 091203-0
Post by: nmb on December 03, 2009, 01:48:52 PM
and the result is..

nmb
Title: Re: Avast not updating from VPS 091203-0
Post by: OliBls on December 03, 2009, 08:01:28 PM
Hi,

I've been up all night, trying to contain the infection to find out this morning (with only 2 hours sleep) that it was false positive! Ok, at least no harm to my pc and data I guess but the problem is not solved...

Indeed:
- I've transfered 100-ish files in the chest during the process
- Then I've updated to vps 091203-1 as soon as it's been released
- I've tried to restore the files from the chest (there are some errors so I guess not everything is restored)
- Yet, avast still displays vps version 091203-0 in the control panel and detects false positive Delf-MZG in the restored files mentioning vps version 091203-0
- Everytime I try to update, it tells me I have the latest version (091203-1)!

Conclusion: the update from vps 091203-0 to 091203-1 does not seem to work properly (at least for me) meaning that when checking the update server it says I have the latest version while avast clearly still runs the previous one.

A solution could be to uninstall avast and reinstall it properly but that would mean losing the files in the chest that could not be restored (errors)... which I'd rather not!

Do you guys plan on releasing a proper update from version 091203-0/1 and if yes when?

I've always been happy with avast and it's a shame this issue causes so massive trouble!

Thanks
Title: Re: Avast not updating from VPS 091203-0
Post by: spg SCOTT on December 03, 2009, 08:05:09 PM
Hi Olibls, welcome to the forum :)

Sorry to hear about this...

I would suggest to try:

1. A repair of avast!
Start-->control panel-->add/remove programs -->avast antivirus --> click remove --> scroll down and click repair

2. Try using the manual database updater:
http://www.avast.com/eng/updates.html

-Scott-
Title: Re: Avast not updating from VPS 091203-0
Post by: OliBls on December 03, 2009, 08:33:47 PM
Thanks Scott

I already tried the manual updater unsuccessfully :(
I'll try to repair avast from the control panel but if I do so will I loose the files in the chest?
I've tried the repair and it works fine (good version used and no more false positive)
I've re-scanned the files in the chest which "corrected" them so cool but still there are some 20 restore errors. Anyway as everything is working fine I deleted them. I guess I'll have to reinstall Spybot S&D for it to start at system start-up...

Everything back to normal (almost)

Cheers a lot!

Thanks
Title: Re: Avast not updating from VPS 091203-0
Post by: igor on December 03, 2009, 08:35:44 PM
No, repair shouldn't affect the files in Chest in any way.