Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: DaveyB on September 29, 2010, 06:15:27 PM

Title: Avast suddenly stops working - new possible cause!
Post by: DaveyB on September 29, 2010, 06:15:27 PM
If Avast suddenly stops working and complains of missing files, specifically MSVCR90.dll and MSVCP90.dll there is a possible cause! (Applies to some versions of Win XP, Win 2k)

OpenOffice.Org (OO.o) moved their offerings to a new program LibreOffice (LO) following the takeover of Sun by Oracle.  Long story, just take my word for it here!

In "upgrading" from OO.o to LO I found that OO.o does some naughty things in the uninstall! It removes files installed by MS C++ 2009 redistributable from the system32 folder!  On installing LO, it does replace the files, but not into system32, rather it puts them in its own folders!

Why is this posted here you may ask? Avast uses the same files, and Avast will fail to load or run without them!  The workaround is to reinstall the MS C++ redistributable package from Microsoft's site, reinstall Avast (which will install the same files) or if you have LO installed, find the files in their folders and copy them to the system32 folder!

I have already submitted bug reports to both OO.o and LO so that they can fix this.  Hope this helps someone here :)
Title: Re: Avast suddenly stops working - new possible cause!
Post by: Hermite15 on September 29, 2010, 06:59:54 PM
see my answer there:
http://forum.avast.com/index.php?topic=64479.msg545142#msg545142
Title: Re: Avast suddenly stops working - new possible cause!
Post by: DaveyB on September 29, 2010, 07:10:45 PM
Thanks Logos, however that information is already in my post above:
Quote
The workaround is to reinstall the MS C++ redistributable package from Microsoft's site, reinstall Avast (which will install the same files) or if you have LO installed, find the files in their folders and copy them to the system32 folder!

I posted this here for the information of others, once I found the problem thanks to reading your original post on the split-off of OpenOffice :)
Title: Re: Avast suddenly stops working - new possible cause!
Post by: Hermite15 on September 29, 2010, 07:55:31 PM
Thanks Logos, however that information is already in my post above:
Quote
The workaround is to reinstall the MS C++ redistributable package from Microsoft's site, reinstall Avast (which will install the same files) or if you have LO installed, find the files in their folders and copy them to the system32 folder!

I posted this here for the information of others, once I found the problem thanks to reading your original post on the split-off of OpenOffice :)

okay must have been thinking about something else and skipped this part of your post ;)