Avast WEBforum

Consumer Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: Waffles on October 16, 2010, 10:05:51 PM

Title: [Resolved] Avast 5 Free - web and mail shield not auto loading
Post by: Waffles on October 16, 2010, 10:05:51 PM
Hello everyone,

I have a problem here with the Avast 5 series Free on Windows XP
Version is the latest.
I don't have this problem on my own computer so I found it a bit odd.
Anyway when the computer boots and Avast launches the Web and Mail shield are not automatically loaded, in fact I have to manually click them on in Avast.
I scanned this computer for viruses with various programs I use, it isn't infected.
I tried in the add/remove programs list to Repair and Change Avast but it had no effect.
I looked into the programs list of my firewall and it isn't being blocked by anything.
I also checked and tried to upgrade but it is already the latest version.

How can I resolve this program?
Do I have to reinstall it?
Title: Re: Avast 5 Free - web and mail shield not auto loading
Post by: Lisandro on October 16, 2010, 10:14:47 PM
Both web and mail shield are manually started services, what I mean is that they're loaded when any program requires it. Generally, it occurs some seconds after logon.
Title: Re: Avast 5 Free - web and mail shield not auto loading
Post by: Waffles on October 16, 2010, 10:27:56 PM
What do you mean, they only activate if I start my internet browser or email client?
Because they do not load after I started up my windows and everything else is done loading.
There remains a "!" mark in my taskbar and when I click it, it tells me not all shields are active.
Title: Re: Avast 5 Free - web and mail shield not auto loading
Post by: Pondus on October 16, 2010, 10:29:18 PM
what AV did you have before avast! ?
have you uninstalled it ?
have you run a removal tool so all leftovers after the uninstall is gone ?
you can find it here, run and reboot http://uninstallers.blogspot.com/
Title: Re: Avast 5 Free - web and mail shield not auto loading
Post by: Lisandro on October 16, 2010, 11:16:33 PM
What do you mean, they only activate if I start my internet browser or email client?
To be precise, no, it's when http traffic is generated.

There remains a "!" mark in my taskbar and when I click it, it tells me not all shields are active.
Hmmm... Can you try to repair your installation?
Go to Control Panel > Add/Remove programs > avast! antivirus > Remove. Then choose Repair function in the popup window (Repair).
If this does not help, can you uninstall / boot / install / boot again?
Title: Re: Avast 5 Free - web and mail shield not auto loading
Post by: Waffles on October 17, 2010, 12:10:12 PM
What do you mean, they only activate if I start my internet browser or email client?
To be precise, no, it's when http traffic is generated.

There remains a "!" mark in my taskbar and when I click it, it tells me not all shields are active.
Hmmm... Can you try to repair your installation?
Go to Control Panel > Add/Remove programs > avast! antivirus > Remove. Then choose Repair function in the popup window (Repair).
If this does not help, can you uninstall / boot / install / boot again?

I already said that I tried doing that, both the repair option and the change option.
I also tried removing -> rebooting -> reinstalling -> rebooting but it didn't change anything

@Pondus and no I do not have multiple anti virus software, as I know that they can clash together.
Last time I had another anti virus it was about 2 years ago or so and since then it is 100% gone.
All this only seemed to happen since my father updated to Avast 5, the previous program which was 4 I believe didn't have this problem
The bad thing is however that on the main site you can only download version 5 or at least standardly download version 5
Title: Re: Avast 5 Free - web and mail shield not auto loading
Post by: SafeSurf on October 17, 2010, 12:18:51 PM
Waffles,

When did you upgrade from Avast 4 to 5?  Is this when your problems started?

Do you have any other security software on this machine?
Title: Re: Avast 5 Free - web and mail shield not auto loading
Post by: pk on October 17, 2010, 01:19:18 PM
@Waffles, it sounds like a known issue... if you start WinXP and wait for 1-2 mins, will those two shields start automatically?
Title: Re: Avast 5 Free - web and mail shield not auto loading
Post by: Waffles on October 18, 2010, 12:23:59 PM
@Waffles, it sounds like a known issue... if you start WinXP and wait for 1-2 mins, will those two shields start automatically?

I did what you said, waited patiently for about 3-4 minutes
seems like i is taking its sweet time to power up those shields, but they activated now
Still I find it strange because at my home system which uses the same OS and same AV they load up a lot faster
Perhaps it is to blame then for the age of this computer
Thank goodness no clean registry uninstall is needed after all.

And yes this only seemed to happen when my father updated to Avast 5 which is several weeks ago. This was not a known problem to me when they were using the older series
Title: Re: Avast 5 Free - web and mail shield not auto loading
Post by: SafeSurf on October 19, 2010, 01:36:56 AM
Check to see how many things are loading during boot up.  If there are items that can be disabled because they are not essential, go ahead and "disable" them to speed up booting up.

How often is the machine cleaned?  Something like CCleaner, is a freeware system optimization, privacy and cleaning tool.  There is a Slim version available as well at http://www.piriform.com/ccleaner/builds (http://www.piriform.com/ccleaner/builds) - 4th option down.  It removes unused files (cache, temporary Internet files, etc.) from your system - allowing Windows to run faster and freeing up valuable hard disk space.  It also cleans traces of your online activities such as your Internet history.  Additionally it contains a fully featured registry cleaner; I recommend making a back up in My Documents prior to doing a registry cleaner as a "just in case."

How often is the machine defragged?  There are many tools out there, but one that is free and easy to use is by Puran http://www.puransoftware.com/ (http://www.puransoftware.com/).

These items listed above will not speed up how quickly the Avast shields load, but they will speed up the machine.  However checking on what is loading on boot up may actually help speed Avast loading depending on what and how many things are competing at the same time.
Title: Re: Avast 5 Free - web and mail shield not auto loading
Post by: Waffles on October 19, 2010, 10:13:05 AM
CCleaner about every 2 weeks as well as a registry clean up. This computer doesn't have much software on it (AV, firewall, some decent cleaners), 1 game, office and that's about it. However it has been getting some complications so it will have to be replaced in the upcoming 6 months, it is 7 years old. My mom is planning on getting a new one. The fact that this old tart is rather slow is no real surprise
Title: Re: Avast 5 Free - web and mail shield not auto loading
Post by: SafeSurf on October 19, 2010, 10:17:11 AM
If you look at CCleaner > Tools > Start Up...are there any unnecessary things in there that you can disable (not delete)?

I would also use CCleaner after going online every time to clear the cache and temp. internet files, esp. for privacy issues and if any passwords were used.
Title: Re: Avast 5 Free - web and mail shield not auto loading
Post by: CraigB on October 19, 2010, 10:59:58 AM
CCleaner about every 2 weeks as well as a registry clean up. This computer doesn't have much software on it (AV, firewall, some decent cleaners), 1 game, office and that's about it. However it has been getting some complications so it will have to be replaced in the upcoming 6 months, it is 7 years old. My mom is planning on getting a new one. The fact that this old tart is rather slow is no real surprise
The fact that this old tart is rather slow is no real surprise
 Not a nice way to talk about your mother, only joking ;D thought i'd jump on that one before someone else did :)
Title: Re: Avast 5 Free - web and mail shield not auto loading
Post by: Waffles on October 19, 2010, 05:37:21 PM
If you look at CCleaner > Tools > Start Up...are there any unnecessary things in there that you can disable (not delete)?

I would also use CCleaner after going online every time to clear the cache and temp. internet files, esp. for privacy issues and if any passwords were used.

I never noticed a start up section, thumbs up for that one. A few useless things disabled there

@craigb
not my mum of course, this old tart of a computer that is. Some parts are getting rather out of date, 500mb ram, the video card and mother board those things need replacing nothing more. I think the vans are also giving it a go at some points
Title: Re: Avast 5 Free - web and mail shield not auto loading
Post by: SafeSurf on October 20, 2010, 12:27:13 AM
Did my suggestions help you?
Title: Re: Avast 5 Free - web and mail shield not auto loading
Post by: sandeep108 on October 20, 2010, 08:32:19 AM
The same issue also happens on my old single core CPU system. It just takes a little more time to load up (as also with some other programs). What I do now is just let it sit on the log on screen for a couple of minutes before logging on.
Title: Re: Avast 5 Free - web and mail shield not auto loading
Post by: Waffles on October 20, 2010, 01:06:40 PM
Did my suggestions help you?

Partly, a lot of the info was already known to me.
However I am glad that the problem has been resolved now, I am leaving it as it is
Title: [RESOLVED] Re: Avast 5 Free - web and mail shield not auto loading
Post by: SafeSurf on October 21, 2010, 02:20:15 AM
@ Waffles,

Now that you feel that your issue is resolved/fixed, please go back to the first open post in this topic, click the modify button in that Post and change the title/subject, add [Resolved] to the beginning of the title so this thread can be closed. 

Feel free to come back any time you need help, to learn something new, or just to ask questions.  We are here 24/7 for your convenience.  Thank you.  :)